.titleBar { margin-bottom: 5px!important; }

[gelöst] Failed to authenticate

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von kombjuder, 29 Dez. 2004.

  1. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Bei jedem externen Anruf sagt mein Asterisk userabhängig folgendes:

    chan_sip.c:6978 handle_request: Failed to authenticate user "Beyer" <sip:5550890@62.241.35.170>;tag=as343b98ec

    Soll das heissen, ich muß, bevor mich jemand anruft, diesen User erst auf dem Asterisk zulassen, oder habe ich da nur eine Funktion aus- bzw falsch eingeschaltet?

    Da ich überhaupt keine Idee habe, wo in der Konfiguration suchen soll und auch Google zwar die Fehlermeldung, aber keine Lösung bietet, frage ich mal hier im Forum.
     
  2. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Re: Failed to authenticate

    Wie ich zwischenzeitlich festgestellt habe, trifft das nur auf verschiedene Anrufe zu, die geroutet wurden, also z.B. PBX-Network auf sipgate oder Purtel. Purtelanruf nach sipgate geht aber.

    Hier ein Anruf auf sipgate:
    chan_sip.c:6978 handle_request: Failed to authenticate user "PBX-Network" <sip:31029@217.160.106.160>;tag=as4524079c

    Es fehlt also anscheinend etwas wie [guest] in der iax.conf


    Seltsam, seltsam
     
  3. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    In der sip.conf muss username=fromuser definiert sein sonst geht es nicht!
    Mit iax.conf hat das nichts zu tun, da iax ein properitäres Protokoll des * Herstellers Digium ist und du ja zu sipgate hin das sip-Protokoll verwendest!

    in der sip.conf daher:

    [general]

    register => 5550890:passw@sipgate.de/5550890

    [sipgate]
    type=friend
    username=5550890
    secret=passw
    host=sipgate.de
    fromuser=5550890
    fromdomain=sipgate.de
    context=default
    canreinvite=no
    qualify=no
    disallow=all
    allow=ulaw
    allow=alaw
    allow=ilbc
    allow=gsm
    ;allow=g729
    insecure=very
    nat=yes
    dtmfmode=info
    tos=0x18


    und in der extensions.conf:

    exten => 5550890,1,Dial(Capi/@37:40,60) z.B. Ruf von MSN 37 (Fritz-ISA) auf MSN 40
     
  4. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Ist so vorhanden.

    Ist mir klar darum habeich ja auch geschrieben wie [guest] ...

    Hier mal ein Teil meiner sip.conf:

    [general]
    port = 5060 ; Sipport
    bindaddr = 0.0.0.0 ; Addresse für den SIP Kanal
    externip=kombjuder.dyndns.org
    Localnet = 192.168.123.0/255.255.255.0
    context = default ; Hier wird den einzelnen Benutzern der Kontext default zugewiesen.
    srvlookup = yes ; Enable DNS SRV lookups on outbound calls
    tos=lowdelay ; hier durch wird das Routing verbessert und somit auch die Sprachqualität.

    disallow=all ; sperrt alle codecs
    allow=gsm
    allow=ulaw ; erlaubt alle codecs
    allow=alaw
    ;canreinvite=no
    insecure=very
    nat=no
    ;dtmfmode=info


    ;[sipprovider]
    register => 5555667:geheim@sipgate.de/in5555667
    register => 100331:geheim@pbx-network.de/in31029
    register => 502455:geheim@deu1.purtel.com/in502455

    register => kombjuder:geheim@sip.babble.net/kombjuder

    [5555667] ; Sipgate
    type=friend
    username=5555667
    fromuser=5555667
    secret=geheim
    context=default
    host=sipgate.de
    fromdomain=sipgate.de
    canreinvite=no
    qualify=no
    insecure=very
    nat=yes
    dtmfmode=info
    tos=0x18

    [31029] ; pbx-network.de

    ...

    [1234] ; SIP-Telefon
    type=friend ;
    username=1234 ;
    secret=geheim ;
    host=dynamic ;
    mailbox=1234 ;


    [1239]

    ....

    Irgendwelche Ideen?
     
  5. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Du hast unter [general] in der sip.conf 'nat=no' und dies wirkt sich auch auf die register-Einträge aus - dies sollte 'nat=yes' sein.

    Bei deinen Endgeräten z.B. [1234] musst du dann 'nat=no' explizit setzen.
     
  6. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Habe ich gemacht. Nun sagt er:

    chan_sip.c:6978 handle_request: Failed to authenticate user "PBX-Network" <sip:31029@217.160.106.160>;tag=as571abeee
     
  7. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Hi!

    Was hast du den hier in der sip.conf noch stehen (Eintrag ist unvollständig)?

    [31029] ; pbx-network.de

    ...
     
  8. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Kommando zurück, nach einem Asterisk-Neustart geht es.

    Besten Dank fürdie Hilfe!!!
     
  9. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    ok - viel Spass noch mit *!
     
  10. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Im Prinzip das selbe wie bei sipgate, nur halt mit den pbx Angaben
    und dann das ganze noch für purtel und babble.net