.titleBar { margin-bottom: 5px!important; }

(gelöst) Samba Fileserver Kennwort

Dieses Thema im Forum "Linux allgemein" wurde erstellt von ploieel, 19 März 2005.

  1. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Habe den Server installiert, der Windows-Client nennt mir nach "suchen" der IP-Adresse als Login <IP-Adresse/Gast> und will ein Kennwort. Ja welches denne? Habe alle möglichen und unmöglichen probiert, kein Erfolg. Kann mir bitte einer helfen?
     
  2. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Als User musst du einen User angeben, der auch auf dem Linux-System existiert. Der User muss vorher sein Passwort mit smbpasswd setzen. Evtl. musst du zuerst als root 'smbpasswd -a <username>' ausfuehren um den User in die smbpasswd Datei einzutragen.
     
  3. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Falls es sich um samba + fileserverpatch auf dem fli4l handelt darf das Passwort nicht gesetzt sein (blank)!
     
  4. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Genau darum handelt es sich, und blank lassen geht nicht. Der Windows-XP-Client will partout ein Passwort! :roll:
     
  5. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Installiert sind:

    Client für Microsoft-Netzwerke
    Datei- und Druckerfreigabe für Microsoftnetzwerke
    Unter Einstellungen/System/Computername/Ändern/Weitere/ ist der fqdn einetragen der in deiner Domain verwendet wird:

    Primärer DNS-Suffix des Systems:
    mydomian.de - muss auch in fli4l als Domain eingestellt sein!

    Auch stimmt dein Arbeitsgruppenname (identisch mit der samba-config des fli4l).

    Freigaben erfolgen wie folgt:
    Explorer starten, rechter Mausklick auf Laufwerk/Ordner / Freigabe und Sicherheit / Diesen Ordner im Netz freigeben (eine ander Freigabe geht nicht!!!!)
     
  6. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Installiert sind:

    Client für Microsoft-Netzwerke JA
    Datei- und Druckerfreigabe für Microsoftnetzwerke JA
    Unter Einstellungen/System/Computername/Ändern/Weitere/ ist der fqdn einetragen der in deiner Domain verwendet wird: benutze keine Domain, nur Arbeitsgruppe

    Primärer DNS-Suffix des Systems: kenne ich nicht
    mydomian.de - muss auch in fli4l als Domain eingestellt sein!

    Auch stimmt dein Arbeitsgruppenname (identisch mit der samba-config des fli4l). kontrolliert -> JA, auch in Großbuchstaben geschrieben; will trotzdem Passwort.

    Mir will zur Zeit überhaupt nichts mehr gelingen. :evil:
     
  7. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Was hast du im fli4l/base hier stehen?

    #------------------------------------------------------------------------------
    # Domain configuration:
    #------------------------------------------------------------------------------
    START_DNS='yes' # start dns server: 'yes' or 'no'

    DOMAIN_NAME='netview.de' # your domain name

    der muss auch als Primärer DNS-Suffix des Systems im Windows eingetragen sein!

    Wie gibst du Laufwerke/Ordner frei???

    so?

    Freigaben erfolgen wie folgt:
    Explorer starten, rechter Mausklick auf Laufwerk/Ordner / Freigabe und Sicherheit / Diesen Ordner im Netz freigeben (eine andere Freigabe geht nicht!!!!)
     
  8. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Domain configuration:
    #------------------------------------------------------------------------------
    START_DNS='yes' # start dns server: 'yes' or 'no' -->yes

    DOMAIN_NAME='netview.de' # your domain name -->lan.fli4l

    der muss auch als Primärer DNS-Suffix des Systems im Windows eingetragen sein! -->ist eingetragen

    Wie gibst du Laufwerke/Ordner frei???

    so?

    Freigaben erfolgen wie folgt:
    Explorer starten, rechter Mausklick auf Laufwerk/Ordner / Freigabe und Sicherheit / Diesen Ordner im Netz freigeben --> ja, und auch noch: Benutzer dürfen Dateien verändern angehakt

    Ich sehe da jetzt noch etwas:

    # new style packet filter config
    ...
    FORWARD_LIST_1='tmpl:samba DROP' # drop samba traffic if it tries
    # to leave the subnet
    ...
    Kann es etwas damit zu tun haben, dass samba ein Kennwort haben will?
     
  9. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Nein - der Filter soll ausgehende Daten blockieren!
     
  10. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Das Problem lässt mich einfach nicht los.
    Beim Booten von Fli4L rauschen folgende gelbe Zeilen durch:

    *** ERROR : cannot create directory /use/local/data/share1 for share1 on fli4l! ***
    *** ERROR : check OPT_MOUNT and SAMBA_SHARE_PATH! ***

    OPT_MOUNT habe ich auf yes und SAMBA_SHARE_PATH auf /usr/local/data; SAMBA_SHARE_1_NAME = 'share1'

    Was muss ich tun, um diese Fehler zu beseitigen?

    Grüße
    Günter
     
  11. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Du kannst die samba partition nur auf das /data Verzeichnis (HD) errichten da /usr/local read only ist!

    z.B:
    SAMBA_SHARE_1_NAME='share' # name of the 1st share
    SAMBA_SHARE_1_RW='yes' # should share writeable: yes or no
    SAMBA_SHARE_1_BROWSE='yes' # should share browseable: yes or no
    SAMBA_SHARE_1_PATH='/data' # path of the share, see MOUNT_x_POINT !
    SAMBA_SHARE_1_NET='' # allowed networks for 1st share,
    # if empty all internal nets

    Legt das Verzeichnis 'share' auf /data an und erlaubt Lese- und Schreibzugriff auf diese!
     
  12. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Problem gelöst, dank Netview.
    Kann in das share-Verzeichnis hineinsehen, ist aber noch leer. Jetzt muss ich von dort nach /etc/asterisk kommen, die .conf-files herunterziehen, mit Wordpad bearbeiten, wieder hinaufschieben und asterisk restarten. Bitte berichtigen, jede Einzelheit ist mir wichtig.

    Habe heute das opt 1588-opt_newmc_rc0 gefunden, ist erst ein paar Tage alt. Jetzt kann ich mir endlich das "Innenleben" meines fli4l mal richtig ansehen.
     
  13. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
  14. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Habe eben das erwähnte opt_newmc kurz getestet, scheint problemlos zu funktionieren.

    Nur mal so ganz nebenher für mich:
    Wäre es möglich, mittels putty auf dem fli und dem newmc die Konfigurationsdateien von asterisk zu öffnen, zu editieren, zu speichern; dann asterisk -restart und das wars dann? Ich möchte es gern fast glauben.

    Nichts gegen die Variante mit samba-file-server, aber ich bin schreibfaul und mit dem MC (als alter DOS-User bestens vertraut mit dem NC) käme ich weitaus besser zurecht.

    Grüße
    Günter
     
  15. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Ergänzung:
    Beachte jedoch bitte, dass meine Anleitung auf dem opt 1.1 aufsetzt!
    Es gibt zwischen * 1.2 und 1.1 nur den einzigen Unterschied, dass Jürgen in 1.2 aus der/config/asterisk.txt einige Parameter für die sip.conf etc. generiert, was es für newbies leichter macht das opt in Betrieb zu nehmen. Aus Sicht des fortgeschrittenen Anwenders macht dies jedoch keinen Sinn, da dieser gleich die .conf Dateien bearbeitet! Die vorgenommenen Änderungen betreffen daher die startup-scripte des * sonst nichts!

    Es macht daher durchaus Sinn statt 1.2 1.1 einzusetzen und gemäß meiner Anleitung vorzugehen. Spätere Migrationen bedeuten dann jedoch, dass nur die binaries und das /var Verzeichnis händisch getauscht werden müßen (genau wie du es bereits mit meinem package versucht hast!).
     
  16. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Wenn die .conf Dateien unter /opt liegen hast du das Problem, dass dieses Verzeichnis read-only ist. Mit dem Befehl 'mount -o remount,rw /dev/hda2 /opt' kann man dieses rw mounten und beschreiben.
    Ansonsten probieren - sollte gehen!
     
  17. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    Hat so wie beschrieben nicht funktioniert:

    fli4l 2.1.9 # mount -o remount,rw /dev/hda2/opt
    Can't find /dev/hda2/opt in /etc/fstab

    Könnte ich nicht einfach das Verzeichnis /etc/asterisk (oder eben das richtige Verzeichnis) mit dem MC (File --> cHmod) rw freigeben?
    Es gibt ein Verzeichnis /dev/+hda2 , aber darin kann man keinen opt-Ordner öffnen....
     
  18. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    O.K. hab das new_mc probiert. Scheint auch das Editieren zu funktionieren. Klar ist, das nur diejenigen Dateien editiert werden sollten, bei denen man sich wirklich sicher ist, was man tut. Oder eben immer ein Backup machen....

    Habe testweise unter /etc/asterisk die sip.conf editiert und einen "Fehler" eingebaut. Naja, nach einen asterisk -restart war es dann eben auch ein Fehler. Scheint also auch mittels mc direkt an der Konsole oder eben mittels putty als Client zu funktionieren. Weitere Tests werden aber folgen.
     
  19. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Gib mal ein 'df' ein dann siehst du wo /opt liegt.
     
  20. ploieel

    ploieel Aktives Mitglied

    Registriert seit:
    13 März 2005
    Beiträge:
    1,728
    Zustimmungen:
    1
    Punkte für Erfolge:
    36
    Ort:
    Vogtland
    fli4l 2.1.9 # df
    Filesystem 1k-blocks Used Available Use% Mounted on
    /dev/root 63744 2360 61384 4% /
    /dev/hda2 64420 32092 29002 53% /opt
    /dev/hda1 34156 14680 19476 43% /boot
    /dev/hda3 1930740 33248 1799416 2% /data
    fli4l 2.1.9 #