.titleBar { margin-bottom: 5px!important; }

HFC-8S + Bristuff: Keine Sprachdatenübertragung

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von TobiasUnsleber, 16 Jan. 2006.

  1. TobiasUnsleber

    TobiasUnsleber Neuer User

    Registriert seit:
    22 Juli 2005
    Beiträge:
    67
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 TobiasUnsleber, 16 Jan. 2006
    Zuletzt bearbeitet: 16 Jan. 2006
    Hallo,

    ich habe hier ein Problem mit einer HFC Karte und briStuff.

    Szenario:
    In meinem Asterisk-Server ist eine 8fach-HFC-Karte eingebaut und ein Port(Nr. 3) ist auf NT-Mode und einer(Port Nr. 1) auf TE-Mode. Der TE-Port haengt an einer HiCom Office Pro 150E und am NT-Port ein NTBA zur Stromversorgung und daran ein ISDN-Telefon, oder alternativ ein Rechner mit AVM-Fritzcard, oder AVM-B1.

    Fehler: Signalisierung klappt, aber es werden keine Sprachdaten übertragen. D. h. ich höre gar nix.

    System:
    Rechner, Celeron IV 2.0 GHz, 512 MB RAM
    Beronet BN8S0 mit Cologne HFC-8S Chipsatz
    Derzeit SuSE 10.0(Debian unstable bringt dieselben Symptome)
    Kernel 2.6.13-15
    Asterisk-1.2.1-bristuffed-0.3.0-PRE-1f
    libpri-1.2.1
    zaptel-1.2.1
    bristuffepatches fuer Beronetkarte angepasst.

    bisherige Maßnahmen:
    • Slot gewechselt
    • Betriebssystem gewechselt
    • Das System mit misdn getestet(Sprachdatenübertragung funktioniert!)
    • Jumper überprüft
    • Unter debian sowohl mit Debian-Paket als auch mit Junghanns-install-skript gearbeitet
    • NTBA-getauscht
    • Kabel getauscht
    • Interrupt Konflikte ausgeschlossen

    Habt Ihr in der aktuellen Version Probleme mit BRIStuff? Noch irgendwelche Ideen woran das liegen könnte?

    /etc/zaptel.conf
    Code:
    loadzone=de
    defaultzone=de
    # qozap span definitions
    # most of the values should be bogus because we are not really zaptel
    span=1,1,3,ccs,ami
    span=2,0,3,ccs,ami
    span=3,0,3,ccs,ami
    span=4,0,3,ccs,ami
    span=5,1,3,ccs,ami
    span=6,0,3,ccs,ami
    span=7,0,3,ccs,ami
    span=8,0,3,ccs,ami
    
    bchan=1,2
    dchan=3
    bchan=4,5
    dchan=6
    bchan=7,8
    dchan=9
    bchan=10,11
    dchan=12
    bchan=13,14
    dchan=15
    bchan=16,17
    dchan=18
    bchan=19,20
    dchan=21
    bchan=22,23
    dchan=24
    /etc/asterisk/zapata.conf:
    Code:
    ;
    ; Zapata telephony interface
    ;
    ; Configuration file
    
    [channels]
    context=wahlplan_test
    group = 2
    signalling = bri_cpe_ptmp
    ; S/T port 1
    channel => 1-2
    
    ; S/T port 2
    ; channel => 4-5
    
    signalling = bri_net_ptmp
    group = 1
    ; S/T port 3
    channel => 7-8
    
    ; signalling = bri_cpe_ptmp
    ; group = 1
    ; S/T port 4
    ; hannel => 10-11
    
    ; weiterer Test mit 2. NT Port
    group = 3
    
    signalling = bri_net_ptmp
    channel => 4-5
    
    group = 4
    
    channel => 10-11
    channel => 13-14
    channel => 16-17
    channel => 19-20
    channel => 22-23
    
    /etc/asterisk/extensions.ael:
    Code:
    context wahlplan_test {
            includes { parkedcalls;
                       hints;
                    };
            _0X.    =>      {
                            Set(CALLERID(number)=111);
                            Dial(ZAP/g2/${EXTEN:1});
                            //Dial(MISDN/g:extern/${EXTEN:1});
                            };
            68      =>      {
                            Dial(ZAP/g1/${EXTEN});
                            };
            69      =>      {
                            Dial(ZAP/g1/${EXTEN});
                            };
            111     =>      {
                            //Dial(ZAP/g1/500);
                            //Answer;
                            PlayBack(tt-monkeys);
                            //Dial(MISDN/g:intern/68);
                            };
            9067111 =>      {
                            //Dial(MISDN/g:intern/68);
                            Dial(ZAP/g1/68);
                            };
    
    
    
    
    };
    Laden der Zaptel-Treiber(Ports 2,3,6,7 im NT-Modus):
    Code:
    modprobe zaptel
    cd /lib/modules/$(uname -r)/misc
    insmod qozap.ko ports=102
    ztcfg -v
    
    Update 1:
    2. Test: Port 2 auch in den NT-Mode geschaltet, versucht mit Telefonen untereinander zu telefonieren -> geht nicht
    3. Test: Zwischen SIP-Telefonen und lokal angeschlossenen ISDN-Telefonen zu telefonieren -> geht nicht
    4. Test: Telefonie zwischen SIP-Telefonen geht

    Update 2:
    Das Treibermodul hat jetzt auch seinen eigenen Interrupt.