Hilfe für Music on Hold

Holg

Neuer User
Mitglied seit
17 Sep 2004
Beiträge
139
Punkte für Reaktionen
0
Punkte
0
Hi,
Habe das mpg123 Packet installiert und versuche mit

exten => *9,1,WaitMusicOnHold(30)

MusicOnHold zum Laufen zu bringen... klappt aber ned!

Es kommt immer folgende Meldung wenn ich *9 an meinem ISDN-Telefon wähle:

Code:
Unknown option: --mono
High Performance MPEG 1.0 Audio Player for Layer 1,2 and 3. ..
Version 0.54 (97/03/27). Written and copyrights by Michael Hipp.
Uses code from various people. See 'README' for more!
usage: mpg123 [-n <num>] [-f <scalefactor>] [-t|-s] [-c] [-v] inputBS
where:
 -t             testmode .. only decoding, no output.
 -s             write to stdout
 -c             check for filter range violations.
 -v             verbose.
 -q             quiet.
 -n <num>       decode only <num> frames.
 -skip <num>    skip first <num> frames.
 -f <factor>    Change scalefactor (default: 32768).
 -r <smplerate> Set samplerate (default: Automatic).
 -g <gain>      Set audio hardware output gain.
 -os,-oh,-ol    Set audio output line: speaker/headphone/line.
 -single0,-single1      for stereomodes: decode only channel No.0 or No.1.
 -singlemix     only Layer3: mix both channels
 inputBS  input bit stream of encoded audio
Vor allem die erste Zeile "Unknown option: --mono"...

Was mach ich falsch? Habe alles so wie es aus dem Archiev kam gelassen...

musiconhold.conf
Code:
[classes]
default => quietmp3:/var/lib/asterisk/mohmp3
loud => mp3:/var/lib/asterisk/mohmp3
random => quietmp3:/var/lib/asterisk/mohmp3,-z
;unbuffered => mp3nb:/var/lib/asterisk/mohmp3
;quietunbuf => quietmp3nb:/var/lib/asterisk/mohmp3
; Note that the custom mode cannot handle escaped parameters (specifically embedded spaces)
;manual => custom:/var/lib/asterisk/mohmp3,/usr/bin/mpg123 -q -r 8000 -f 8192 -b 2048 --mono -s

Muss dafür eine Soundkarte installiert sein???
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
Du mußt die Version 0.59r von mpg123 installieren. Dann läufts.

Raffi
 

Holg

Neuer User
Mitglied seit
17 Sep 2004
Beiträge
139
Punkte für Reaktionen
0
Punkte
0
Danke Raffi,

Ich hatte 0.59r lediglich kompiliert, aber dann nicht weiter installiert... :oops:

Holg
 

Raffi

Neuer User
Mitglied seit
25 Jul 2004
Beiträge
179
Punkte für Reaktionen
0
Punkte
16
Sowas passiert ;-)

Flotten Tach noch und viel Spaß beim Testen!

Raffi
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,160
Beiträge
2,030,798
Mitglieder
351,554
Neuestes Mitglied
TIMOC1983