Iaxtel fratze. Athentifizierung geht wohl nicht

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Hi,
Blackvel und ich haben gestern abend mal versucht uns uber IAXtel anzurufen. Hatte aber nicht gefunzt. Das lustige daran war, das bis zu mir eine Verbindung aufgebaut wurde, aber nicht an ein endgerät weitergeleitet wurde.
Nach einigem experimentieren habe ich jetzt den Fehler gefunden. Bei eingehenden Verbindungen über iaxtel scheit sich der IAX-Server erst zu authentifizieren. Die Methode nennt sich da wohl "rsa" und dafür wird auch ein schlüsel benötigt, der unter /var/lib/asterisk/keys zu finden ist und iaxtel.pub heißt (ist auch da). Der Schlüssel selbst wird mit dem bezeichner "inkeys" in der iax.conf definiert. Soweit ist auch alles richtig.
Wir hatten auch schonmal so telefoniert. Nur jetzt geht es eben nicht.
Wenn ich aber "auth=rsa" und "inkeys=iaxtel" kommentiere, geht es wieder. Nur leider ist es dann wohl unsicher, da sich ohne authentifizierung jeder als iaxtel ausgeben könnte.
Hat jemand dazu irgend welche Anregungen, Lösungsvorschläge usw.
("dann lass es einfach Kommentiert" zählt nicht!)
 

wrrdlbrrmpft

Mitglied
Mitglied seit
17 Jul 2004
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Hallo,

ist das Thema denn noch aktuell? Wenn ja, wie sieht die iax.conf aus?

Viele Grüße!
Benno
 

Hupe

Aktives Mitglied
Mitglied seit
8 Apr 2004
Beiträge
2,586
Punkte für Reaktionen
0
Punkte
0
Das Thema ist nichtmehr aktuell. War ein Fehler bei IAXtel. Dort hatte man nach dem neustart des Servers vergessen, die rsa-Keys neu zu laden. Die iax.conf kann man also wie in der mit asterisk mitgelieferten sample-Datei nutzen.
 

3CX PBX - GRATIS
Linux / Win / Cloud

Neueste Beiträge

Statistik des Forums

Themen
233,131
Beiträge
2,030,525
Mitglieder
351,490
Neuestes Mitglied
spaceMonster42