.titleBar { margin-bottom: 5px!important; }

Inalp Smartnode und Sipgate

Dieses Thema im Forum "Patton Inalp" wurde erstellt von muehle, 4 März 2005.

  1. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Guten Abend!

    Ich versuche nun seit einiger Zeit einen Inalp SmartNode 1200 mit Sipgate zum laufen zu bekommen...

    Könnte mir jemand mal eine komplette Beispiel-Konfiguration posten?
    Das währe echt nett! Denn bis jetzt konnte ich keine schöne Config basteln. Im Netz habe ich bis jetzt auch nichts komplettes gefunden.

    Ich verwende R3.10.

    Die Registrierung klappt scheinbar nur halb. Der SN sagt er sei registriert, aber auf der Sipgate-Page ist immer noch das Symbol "offline" zu sehen.
    Wenn ich einen Anruf auf die Testnummer 10000 tätige, bekomme ich eine Meldung "dieser Service ist nicht verfügbar" (oder so ähnlich).
    Im debug-Mode kann ich einen fehler beim authentifizieren erkennen, wenn ich einen call starte.

    Ich habe das Beispiel von Patton für Sipgate ausprobiert, aber da frisst er die Zeile:
    address-translation outgoing-call from-header user-part fix [Sipgate SIP-ID] host-part call
    schon nicht. (kennt address-translation nicht)

    Dann habe ich noch eine prinzipielle Frage zu den SmartNodes:
    Es soll ja mittlerweile möglich sein über eine grafische Oberfläche Konfigurationen vorzunehmen. (WEB-Oberfläche oder so) wie aktiviere ich die?

    Dankeschön!
     
  2. andreas

    andreas Mitglied

    Registriert seit:
    29 März 2004
    Beiträge:
    485
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Für was? Was ist wo angeschlossen? Welche Rufnummern sollen was machen? Wie ist der Zugang zum Internet?

    Wo ist denn deine jetzige Config?

    Welches Build?

    Was sagt er _genau_ ??
    #> show gateway sip wasauchimmerfüreinname status detail 9

    Ah ja, oder so ähnlich..... ;-) Wie kommt die Meldung? auf dem Display am Telefon? als Ansage von Sipgate? Wie lautet Sie genau?

    Welcher debug befehl genau?

    In deinem Release überhaupt nicht. Das geht erst ab 3.2x, die gab es mal auf der Patton-Seite, ich wollte Dir den Link raus suchen, aber scheinbar ist die dort verschwunden :gruebel:

    Wäre prima, wenn Du noch ein paar präzisere Fehlermeldungen geben könntest, ansonten sollte die Boardsuche, die eine oder andere Frage bereits beantworten. Ansonsten poste mal deine Config, dann sehen wir weiter (Passwörter raus nehmen nicht vergessen).

    Gruss,
    Andreas
     
  3. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hey, vielen Dank für Deine reaktion!
    Ja, preziese Fehlermeldungen das hab ich mir beim psoten auch schon gedacht, aber ich hab ja gehofft, dass jemand mal seine smartNode-Sipgate coinfig postet - zum verstehen und zweites um neue Ideen zu bekommen. Es ist ja sau viel möglich mit der SmartNode.

    Also, was ist wo angeschlossen:
    BRI0 : S0 vom isdn-Anschluss
    BRI1 : T Europa 09 (einfaches isdn Telefon)
    ETH0 : (Internetanschluss) (über Netgear Router ans Internet)
    ETH0 : irgendein PC

    Also, vielleicht muss ich erstmal etwas erklären. Mit dieser Config wollte ich zunächt einmal Sipgate testen. Daher ist diese config noch ohne irgend welche specials.
    Mit der Config sollte man über den normalen ISDN-Anschluss erreichbar sein. Alle abgehend Gespräche sollen über Sipgate laufen.

    R3.10 Build21262 SIP (ist momentan drauf)

    und hier mal was er beim register-status ausgibt:
    Code:
    show gateway sip status detail 5
    SIP Gateway: sip
    ================
     
     State:                                 Up
     User Agent:                            0xb77c90
     Local Address:                         192.168.0.99:5060
     Registrations
     
     SIP Registration: sip:555xxxx@sipgate.de
     ----------------------------------------
     
      State:                                Registered
      Registrar:                            sip:sipgate.de
      Default Server:                       (none)
      Logical Address:                      sip:555xxxx@sipgate.de
      Physical Address:                     sip:555xxxx@192.168.0.99:5060 (Current:
    sip:555xxxx@192.168.0.99:5060)
      Expiration Time:                      120ms
      Authenticated:                        yes
     
     Allocated Endpoints:                   0
     Allocated Sessions:                    0
     Allocated Audio Datapath Controllers:  0
    
    Wenn ich die Nummer 10000 von Sipgate vom telefon heraus anrufe kommt eine männliche Ansage von Sipgate: "Diese Funktion ist zur Zeit leider nicht verfügbar." Dannach bleibt die Verbindung bestehen, es wird nicht automatisch aufgelegt.

    Des weiteren sehe ich bei sipgate auf der Page nach jdem getätigten 10000er ausgehenden telfonat einen getätigten Anruf und einen verpassten anruf zur Nummer 10000 je Verbindung.

    Manchmal kam auch die weibliche Stimme, dass alles in Ordnung sein und mein Account funktionieren würde. Aber beim nächten test-anruf klappt wieder nicht. Ich habe den eindruck, dass irgendetwas mit der registrierung nicht stimmt.

    Die fehlermeldung die ich vor längerer Zeit mal im debug mode gesehen habe, kann ich mit der momentanen config nicht mehr finden.


    Noch eine zusätzliche schnelle frage (hab noch nichts nachgelsenen, aber...) ist es möglich in der Samrtnode die ausgehende MSN die das telefon sendet zu überschreiben? So dass ich am telefon irgendeinen MSn eingestellt haben kann und die smartnode automatisch die richtige ausgehende MSN für Sipgate wählt?

    hier meine aktuelle "bastel config":

    Code:
    cli version 3.00
    
    dns-client server 192.168.0.1
    dns-client cache 100
    webserver port 80 language en
    
    
    sntp-client server primary 129.132.2.21 port 123 version 4
    sntp-client operating-mode unicast
    sntp-client anycast-address 224.0.1.1 port 123
    sntp-client local-port 123
    
    system hostname voipGW
    
    profile napt test
    
    profile ppp default
    
    profile tone-set default
    
    profile voip default
      codec 1 g729 rx-length 20 tx-length 20
      codec 2 g711ulaw64k rx-length 20 tx-length 20
      codec 3 g711alaw64k rx-length 20 tx-length 20
    
    profile pstn default
    
    profile authentication default
      method 1 local
      method 2 none
    
    context ip router
    
      interface IF_WAN
        ipaddress 192.168.0.99 255.255.255.0
        icmp router-discovery
    
      interface IF_LAN
        ipaddress 192.168.1.1 255.255.255.0
        icmp router-discovery
    
    context ip router
      route 0.0.0.0 0.0.0.0 192.168.0.1 0
    
    context cs switch
    
      
    digit-collection timeout 3
    
      routing-table called-e164 CDPN_OUT
        route .T dest-interface IF_SIP_EPHONE
    
      interface isdn IF_SO_TERMINAL
        route call dest-table CDPN_OUT
    
      interface isdn IF_S0_PSTN
        route call dest-interface IF_SO_TERMINAL
        use profile pstn default
    
      interface sip IF_SIP_EPHONE
        bind gateway sip
        route call dest-interface IF_SO_TERMINAL
        address-translation outgoing-call from-header user-part fix 555xxxx host-part call
        use profile voip default
    
    context cs switch
      no shutdown
    
    
    gateway sip sip
    
    domain sipgate.de
    default-server sipgate.de loose-router
    registrar sipgate.de
    user 555xxxx
    authentication sipgate.de 555xxxx xxxxxxxxx default
    call-transfer-version 5
    session-timer-version 8
    
    
      registration-lifetime 120
    
      bind interface IF_WAN router
      no shutdown
    
    port ethernet 0 0
      medium 10 half
      encapsulation ip
      bind interface IF_WAN router
      no shutdown
    
    port ethernet 0 1
      medium 10 half
      encapsulation ip
      bind interface IF_LAN router
      no shutdown
    
    port bri 0 0
      clock auto
      encapsulation q921
    
      q921
        permanent-layer2
    
        protocol pmp
    
        uni-side user
        encapsulation q931
    
        q931
          protocol dss1
          uni-side user
          encapsulation cc-isdn
          bind interface IF_S0_PSTN switch
    
    port bri 0 0
      no shutdown
    
    port bri 0 1
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side net
          encapsulation cc-isdn
          bind interface IF_SO_TERMINAL switch
    
    port bri 0 1
      no shutdown
    
     
  4. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hat jemand eine Idee, wo man Hilfe zum Thema Sipgate und SmartNode bekommen kann?

    Der Sipgate Support macht keinen Support für diese Geräte
     
  5. andreas

    andreas Mitglied

    Registriert seit:
    29 März 2004
    Beiträge:
    485
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    upsa, hab dich glatt übersehen :) sorry...

    Du hast eine SN hinter einem Router, das wird dank der fehlenden STUN-Unterstützung mit der SN nicht funktionieren.

    Hast Du die Möglichkeit, die SN als Router direkt an das DSL anzuklemmen?

    Gruß,
    Andreas

    P.S. hast Du zufällig eine feste Internet-IP?
     
  6. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hm....

    Ich dachte SIP hinter nem Router sollte funktionieren, schade, ok, dann muss ich das mal versuchen.

    Leider habe ich keine fixe IP-Adresse :-(

    noch so ne prinzipielle Frage zu SN:
    Man kan doch Passwörter verschlüsselt in das CLI eingeben. Ich habe nur noch im Kopf dass das Kennwort über ein externes Progrmm verschlüsselt wird, weisst du mehr darüber? Oder nach welcher Form es verschlüsselt wird? crypt oder md5 oder...??
     
  7. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hallo!

    also, ich bin eigentlich keinen Meter weiter gekommen :-(
    Ich habe die SM jetzt mal direkt hinter das Modem geklemmt und habe so ein neues Problemm bekommen.

    Ich kann nicht "raus-pingen". Sobald ich eine externe IP oder Hostname anpinge, kommt eine Meldung, dass er keinen DNS gefunden hat. Ich kann noch nicht mal die IP des DNS-Servers anpingen!

    Die SN bekommt eine IP zugewiesen und erhälte auch die DNS-server adressen.

    Hier die config:
    Code:
    #----------------------------------------------------------------#
    #                                                                #
    # SN1200                                                         #
    # R3.10 BUILD21262 SIP                                           #
    # 2001-01-01T00:34:54                                            #
    # Generated configuration file                                   #
    #                                                                #
    #----------------------------------------------------------------#
    
    cli version 3.00
    banner "WELCOME\nPLEASE LOG ON"
    dns-client cache 30
    dns-relay
    snmp community public ro
    sntp-client
    sntp-client server primary 129.132.2.21 port 123 version 4
    sntp-client anycast-address 224.0.1.1 port 123
    sntp-client local-clock-offset
    sntp-client gmt-offset + 02:00:00
    system hostname voipGW
    
    
    profile acl ACL_WAN_IN
    
    profile napt NAPT
    
    profile ppp default
    	no local-address-autoconfig
    
    profile tone-set default
    
    profile voip default
      codec 1 g729 rx-length 20 tx-length 20
      codec 2 g711ulaw64k rx-length 20 tx-length 20
      codec 3 g711alaw64k rx-length 20 tx-length 20
    
    profile pstn default
    
    profile authentication default
      method 1 local
      method 2 none
      server-timeout 10
    
    profile dhcp-server DHCP_LAN
      network 192.168.2.0 255.255.255.0
      include 192.168.2.33 192.168.2.100
      lease 6 hours
      default-router 192.168.2.1
      domain-name-server 192.168.2.1
    
    
    context ip router
    
      interface IF_WAN
        ipaddress unnumbered
        mtu 580
        point-to-point
        use profile napt NAPT
        tcp adjust-mss rx mtu
        tcp adjust-mss tx mtu
    
      interface IF_LAN
    		ipaddress 192.168.2.1 255.255.255.0
        mtu 1500
    
    context ip router
      dhcp-server use DHCP_LAN
      route 0.0.0.0 0.0.0.0 IF_WAN 0
    
    subscriber ppp SUB_ADSL
      dial out
      authentication chap pap
    	identification outbound plapla password xyzxyz
      bind interface IF_WAN router
    
    context cs switch
      digit-collection timeout 3
    
      routing-table called-e164 CDPN_OUT
        route .T dest-interface IF_SIP_EPHONE
    
      interface isdn IF_SO_TERMINAL
        route call dest-table CDPN_OUT
    
      interface isdn IF_S0_PSTN
        route call dest-interface IF_SO_TERMINAL
        use profile pstn default
    
      interface sip IF_SIP_EPHONE
        bind gateway sip
        route call dest-interface IF_SO_TERMINAL
        use profile voip default
    
    context cs switch
      no shutdown
    
    gateway sip sip
      domain sipgate.de
      default-server sipgate.de loose-router
      registrar sipgate.de
      registration-lifetime 120
      user 55xxxxx
      authentication sipgate.de 55xxxxx xxxxxxxx default
      call-transfer-version 5
      session-timer-version 8
      bind interface IF_WAN router
      no shutdown
      use profile voip default
    
    port ethernet 0 0
      medium 10 half
      encapsulation pppoe
      no shutdown
    
      pppoe
    
        session SES_ADSL
          use profile ppp default
          bind subscriber SUB_ADSL
          no shutdown
    
    port ethernet 0 1
      medium 10 half
      encapsulation ip
      bind interface IF_LAN router
      no shutdown
    
    port bri 0 0
      clock auto
      encapsulation q921
    
      q921
        permanent-layer2
        protocol pmp
        uni-side user
        encapsulation q931
    
        q931
          protocol dss1
          uni-side user
          encapsulation cc-isdn
          bind interface IF_S0_PSTN switch
    
    port bri 0 0
      no shutdown
    
    port bri 0 1
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side net
          encapsulation cc-isdn
          bind interface IF_SO_TERMINAL switch
    
    port bri 0 1
      no shutdown
    
    
     
  8. andreas

    andreas Mitglied

    Registriert seit:
    29 März 2004
    Beiträge:
    485
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hey,

    bin gerade etwas im Stress, schicke Dir heute Abend eine funktionierende Konfig für Sipgate, wenn die SN als Router fungiert.

    btw.... ist die Routing Lizenz aktiv?

    #Show licenses

    was steht da?
     
  9. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    oh, ja, dann freu ich mich schon auf heute abend!

    jap, die routing lizens ist aktiv. Den "Fehler" hatte ich schon ein paar mal.
    aber die ist aktiv.

    gruss
    muehle
     
  10. andreas

    andreas Mitglied

    Registriert seit:
    29 März 2004
    Beiträge:
    485
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    So, damit sollte es funktionieren

    Code:
    cli version 3.00
    administrator administrator password 1234
    banner "#\n# Smartnode\n#\n# Config by Andreas ;-)\n#"
    dns-client server 194.8.194.70
    dns-client cache 30
    dns-relay
    snmp community public ro
    snmp target snmp.domain.de security-name public
    snmp host snmp.domain.de security-name public
    sntp-client
    sntp-client server primary ptbtim1.ptb.de port 123 version 4
    sntp-client server secondary ntp0.fau.de port 123 version 4
    sntp-client anycast-address 224.0.1.1 port 123
    sntp-client poll-interval 6000
    sntp-client gmt-offset + 02:00:00
    system location germany,cologne
    system contact andreas
    system supplier VOIP-Spezialist
    system provider diverse
    
    profile service-policy qos
      rate-limit 192
    
      source traffic-class local-default
        priority
    
      source traffic-class default
    
      source traffic-class local-voice
        priority
    
    profile napt NAPT
    
    profile ppp default
    
    profile tone-set default
    
    profile voip default
      codec 1 g729 rx-length 20 tx-length 20
      codec 2 g723-6k3 rx-length 30 tx-length 30
      codec 3 g711ulaw64k rx-length 30 tx-length 30
      codec 4 g711alaw64k rx-length 30 tx-length 30
    
    profile pstn default
    
    profile dhcp-server dhcp-lan
      network 192.168.10.0 255.255.255.0
      include 192.168.10.1 192.168.10.20
      lease 5 hours
      default-router 192.168.10.250
      domain-name-server 194.8.194.70
    
    profile authentication default
      method 1 local
      method 2 none
      server-timeout 10
    
    context ip router
    
      interface eth0
        ipaddress unnumbered
        mtu 1492
        point-to-point
        use profile service-policy qos out
        use profile napt NAPT
        tcp adjust-mss rx mtu
        tcp adjust-mss tx mtu
    
      interface eth1
        ipaddress 192.168.10.250 255.255.255.0
        mtu 1492
        icmp router-discovery
    
      dyndns
        hostname test.dyndns.org
        authentication test password
        service dynamic
        observe eth0
    
    context ip router
      dhcp-server use dhcp-lan
      route 0.0.0.0 0.0.0.0 eth0 1
    
    subscriber ppp provider
      dial out
      authentication pap
      identification outbound [email]xyz@provider.de[/email] password geheim
      timeout idle 6000
      bind interface eth0 router
    
    context cs switch
    
      routing-table called-e164 from-phone
        route default dest-interface sip-sipgate sip-sipgate-mapping
    
      mapping-table called-e164 to called-e164 remove1
        map .(.%) to \1
    
      mapping-table calling-e164 to calling-e164 sip-sipgate-mapping
        map 1000 to 654321
        map (.%) to 654321
    
      complex-function sip-sipgate-gehend
        execute 1 sip-sipgate-mapping
        execute 2 remove1
    
      interface isdn telefon
        route call dest-table from-phone
    
      interface sip sip-sipgate
        bind gateway sip-sipgate
        route call dest-interface telefon
    
    context cs switch
      no shutdown
    
    gateway sip sip-sipgate
      domain sipgate.de
      call-signaling-port 5060
      default-server sipgate.de loose-router
      registrar sipgate.de 5060
      user 654321 display-name " "
      authentication sipgate.de geheim
      call-transfer-version 5
      session-timer-version 8
      bind interface eth0 router
      no shutdown
      use profile voip default
    
    
    port ethernet 0 0
      medium 10 half
      encapsulation pppoe
      no shutdown
    
      pppoe
    
        session provider
          bind subscriber provider
          no shutdown
    
    port ethernet 0 1
      medium 10 half
      encapsulation ip
      bind interface eth1 router
      no shutdown
    
    port bri 0 0
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side user
          encapsulation cc-isdn
          bind interface amt switch
    
    port bri 0 0
      no shutdown
    
    port bri 0 1
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side net
          encapsulation cc-isdn
          bind interface telefon switch
    
    port bri 0 1
      no shutdown
    
    
    
     
  11. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hey! Vielen Dank!

    Jetzt funzt es! - Danke!!!!!!
    Ich musste zwar noch ein wenig in der Config spielen, aber die Verbindung steht!

    Jetzt kommt noch das fine-tuning dran.
    Der DHCP-Server geht noch nicht richtig hab ich den Eindruck. Und eine ACL kommt noch rein und digit-collection und so ein paar sachen :)

    Wenn ich noch ein paar Feinheiten drin habe, poste ich meine Config nocheinmal hier.

    Danke!
     
  12. andreas

    andreas Mitglied

    Registriert seit:
    29 März 2004
    Beiträge:
    485
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Na, prima :) Ist eben etwas schwierig eine "funktionierende" Konfig zu posten. Dazu ist die SN einfach zu flexibel. Mit dem DHCP-Server stehe ich auch etwas auf Kriegsfuß, im Prinzip funktioniert er einwandfrei.... Aber auf ein iponfig -renew bekomme ich auch ums verrecken keine neue IP, bei einem Rechnerneustart dagegen ohne Probleme. Auf der Patton-Seite ist übrigens seit gestern die neuste 3.20 er Firmware, einspielen lohnt sich, sind ein paar elementare Bugs gefixt, auch das Web-Interface wird immer besser. Aber ich mags trotzdem noch nicht ;-)

    Viele Grüße,
    Andreas
     
  13. hedgeschredder

    hedgeschredder Neuer User

    Registriert seit:
    6 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    könnet Ihr beiden mir mal einen Gefallen tun und mir sagen welcher codec bei gehenden bzw. kommenden Gesprächen verwendet wird ?

    Bei mir ist es aktuell so, daß er bei kommenden Gesprächen G729 verwendet und bei gehenden G711alaw. Beschränke ich den SN auf G729 only wird keine Sprache übertragen. Die Sip/SDP messages sind korrekt und auch die gelisteten codecs.

    Danke

    Thomas
     
  14. andreas

    andreas Mitglied

    Registriert seit:
    29 März 2004
    Beiträge:
    485
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Sipgate versucht immer den G711 zu nehmen, auch wenn andere zur Verfügung stehen. Das Gerät das angerufen wird bestimmt den Codec.
     
  15. hedgeschredder

    hedgeschredder Neuer User

    Registriert seit:
    6 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    In der "Invite message" die der SN sendet sind die codecs alle aufgelistet die er beherrscht. Bis jetzt war mein Wissenstand so, daß sich die beiden Partner auf einen Codec einigen.
    Wenn ich nun hingehe und auf g729 alleine konfiguriere, schickt Sipgate RTP im G729 Format, die der SN mit einem ICMP Destination unreachable (Port unreachable) beantwortet, dies spricht meiner Meinung nach dafür, das Sipgate auch G729 unterstützt.

    Nehme ich ein Cisco phone mit G729 funktioniert das auch, nur der SN scheint ein Problem damit zuhaben.
     
  16. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Da ich eben per Privat-Nachricht gefragt wurde, ob ich eine beispiel config zur Verfügung stellen könnte, poste ich jetzt mal eine weitere funktionierende.

    Hinweis:
    Wenn man ganz normal eine Nummer wählt, geht er über das normale Festnetz raus.
    Um über Sipgate zu telefonieren muss man 999 wählen und dan die nummer, also: 999089123456 für die nummer 089123456 mit sipgate.

    ich hoffe das kann jemandem helfen.

    Code:
    cli version 3.00
    administrator admin password [geheim]
    dns-client cache 30
    dns-relay
    snmp community public ro
    sntp-client
    sntp-client server primary ptbtim1.ptb.de port 123 version 4
    sntp-client server secondary ntp0.fau.de port 123 version 4
    sntp-client anycast-address 224.0.1.1 port 123
    sntp-client poll-interval 6000
    sntp-client gmt-offset + 02:00:00
    
    
    
    profile acl ACL_WAN_IN
      deny icmp any any name echo
      permit icmp any any
      permit tcp any any gt 1023
      permit udp any any gt 1023
      permit udp any any eq 123
      deny ip any any
    
    profile service-policy qos
      rate-limit 192
    
      source traffic-class local-default
        priority
    
      source traffic-class default
    
      source traffic-class local-voice
        priority
    
    profile napt NAPT
    
    
    profile ppp default
    
    profile tone-set default
    
    profile voip default
      codec 1 g729 rx-length 20 tx-length 20
      codec 2 g723-6k3 rx-length 30 tx-length 30
      codec 3 g711ulaw64k rx-length 30 tx-length 30
      codec 4 g711alaw64k rx-length 30 tx-length 30
    
    profile pstn default
    
    profile dhcp-server dhcp-lan
      network 192.168.1.0 255.255.255.0
      include 192.168.1.2 192.168.1.32
      lease 5 hours
      default-router 192.168.1.1
      domain-name-server 192.168.1.1
    
    profile authentication default
      method 1 local
      method 2 none
      server-timeout 10
    
    context ip router
    
      interface eth0
        ipaddress unnumbered
        mtu 1492
        point-to-point
        use profile acl ACL_WAN_IN in
        use profile service-policy qos out
        use profile napt NAPT
        tcp adjust-mss rx mtu
        tcp adjust-mss tx mtu
    
      interface eth1
        ipaddress 192.168.1.1 255.255.255.0
        mtu 1492
        icmp router-discovery
    
      dyndns
        hostname [geheim].dyndns.org
        authentication [geheim] [geheim]
        service dynamic
        observe eth0
    
    context ip router
      dhcp-server use dhcp-lan
      route 0.0.0.0 0.0.0.0 eth0 1
    
    subscriber ppp provider
      dial out
      authentication pap
      identification outbound [geheim] password [geheim]
      bind interface eth0 router
    
    context cs switch
      digit-collection timeout 3
    
      routing-table called-e164 from-phone
        route 999T dest-interface sip-sipgate sip-sipgate-gehend
        route .T dest-interface amt
    
      mapping-table called-e164 to called-e164 remove1
        map .(.%) to \1
    
      mapping-table calling-e164 to calling-e164 sip-sipgate-mapping
        map 1000 to 5552711
        map (.%) to 5552711
    
      mapping-table called-e164 to called-e164 REM-PFX
        map 999(.%) to \1
    
      complex-function sip-sipgate-gehend
        execute 1 sip-sipgate-mapping
        execute 2 REM-PFX
    
      interface isdn telefon
        route call dest-table from-phone
    
      interface isdn amt
        route call dest-interface telefon
        use profile pstn default
    
      interface sip sip-sipgate
        bind gateway sip-sipgate
        route call dest-interface telefon
    
    context cs switch
      no shutdown
    
    gateway sip sip-sipgate
      domain sipgate.de
      default-server sipgate.de loose-router
      registrar sipgate.de 5060
      user [geheim]
      authentication sipgate.de [geheim] [geheim] default
      call-transfer-version 5
      session-timer-version 8
      bind interface eth0 router
      no shutdown
      use profile voip default
    
    port ethernet 0 0
      medium 10 half
      encapsulation pppoe
      no shutdown
    
      pppoe
    
        session provider
          bind subscriber provider
          no shutdown
    
    port ethernet 0 1
      medium 10 half
      encapsulation ip
      bind interface eth1 router
      no shutdown
    
    port bri 0 0
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side user
          encapsulation cc-isdn
          bind interface amt switch
    
    port bri 0 0
      no shutdown
    
    port bri 0 1
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side net
          encapsulation cc-isdn
          bind interface telefon switch
    
    port bri 0 1
      no shutdown
    
    
     
  17. mastapuffy

    mastapuffy Neuer User

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    brauche ebenfalls hilfe

    HI,
    ich habe einige der Konfigurationen getestet aber komme leider zu keinem erfolgergebnis.Es ist schon ein Sip telefon vorhanden deswegen benutze ich den port 5061. Dieser ist auch in der Firewall geforwarded. Im webserver des smartnode ist bei sip unter statur entweder Registering oder Idle vorhanden. Ich möchte von einem angeschlossnene IDSN tele per sip telefoniernen.
    Code:
    #----------------------------------------------------------------#
    #                                                                #
    # SN1200                                                         #
    # R3.20 BUILD21318 SIP                                           #
    # 1970-01-03T19:53:49                                            #
    # Generated configuration file                                   #
    #                                                                #
    #----------------------------------------------------------------#
    
    cli version 3.20
    administrator administrator password hidden
    dns-client server 192.168.0.3
    dns-client server 194.25.2.129
    webserver port 80 language en
    system location germany,vaihingen
    
    system
    
      ic voice 0
    
    profile service-policy qos
      rate-limit 192 header-length 18 voice-margin 0
    
      source traffic-class local-default
        priority
    
      source traffic-class default
    
      source traffic-class local-voice
        priority
    
    profile napt NAPT
    
    profile ppp default
    
    profile tone-set default
    
    profile voip default
      codec 1 g729 rx-length 20 tx-length 20
      codec 2 g723-6k3 rx-length 30 tx-length 30
      codec 3 g711ulaw64k rx-length 30 tx-length 30
      codec 4 g711alaw64k rx-length 30 tx-length 30
    
    profile pstn default
    
    profile sip default
    
    profile authentication default
      method 1 local
      method 2 none
    
    context ip router
    
      interface eth0
        ipaddress unnumbered
    
      interface eth1
        ipaddress 192.168.0.99 255.255.255.0
        mtu 1492
        icmp router-discovery
    
    context ip router
      route 0.0.0.0 0.0.0.0 192.168.0.3 12
    
    context cs switch
    
      routing-table called-e164 from-phone
        route default dest-interface sip-sipgate sip-sipgate-mapping
    
      mapping-table called-e164 to called-e164 remove1
        map .(.%) to \1
    
      mapping-table calling-e164 to calling-e164 sip-sipgate-mapping
        map 1000 to 654321
        map (.%) to 654321
    
      complex-function sip-sipgate-gehend
        execute 1 sip-sipgate-mapping
        execute 2 remove1
    
      interface isdn telefon
        route call dest-table from-phone
    
      interface sip sip-sipgate
        bind gateway sip-sipgate
        route call dest-interface telefon
    
    context cs switch
      no shutdown
    
    gateway sip sip-sipgate
      domain sipgate.de
      call-signaling-port 5061
      default-server sipgate.de loose-router
      registrar sipgate.de 5061
      user 18xxxxx display-name "" phone-context ""
      authentication sipgate.de 18xxxxx password default
      bind interface eth1 router
      no shutdown
    
    port ethernet 0 0
      medium 10 half
      encapsulation pppoe
      no shutdown
    
    port ethernet 0 1
      medium 10 half
      encapsulation ip
      bind interface eth1 router
      no shutdown
    
    port bri 0 0
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side user
          encapsulation cc-isdn
    
    port bri 0 0
      no shutdown
    
    port bri 0 1
      clock auto
      encapsulation q921
    
      q921
        protocol pmp
        uni-side auto
        encapsulation q931
    
        q931
          protocol dss1
          uni-side net
          encapsulation cc-isdn
          bind interface telefon switch
    
    port bri 0 1
      no shutdown
    
     
  18. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!

    Was für eine Umgebung hast du denn?
    Du hast einen Router, an dem ein SIP-Fon angeschlossen ist und ein SmartNode?

    Du bist nicht richtig am Sip-Server angemeldet. Dafür müsste REGISTERED im Status stehen.

    Ich hab mir Deine Config noch nicht richtig angeschaut, aber ich meine, dass Du dich unbedingt am Port 5060 anmelden musst. Weil der Service am SIP-Server nur an diesem Port zur Verfügung steht.
     
  19. mastapuffy

    mastapuffy Neuer User

    Registriert seit:
    1 Aug. 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ja ich habe einen Router an dem ist ein SIP phone von allnet angeschlossen. dieses läuft auf den port 5060. Da ja der port 5060 scho an das phone geroutet wird muss ich ja einen anderen ans smartnode routen. dazu habe ich den port 5061 genutzt.
     
  20. muehle

    muehle Neuer User

    Registriert seit:
    3 März 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich kenne das SIP-Protokoll nicht so gut...
    aber stelle mal den " registrar"-Port auf 5060
    Lass nur mal den call-signaling-port auf 5061
    vielleicht hilft das schon.

    Übernimm auch mal die Einstellungen
    call-transfer-version 5
    session-timer-version 8


    Um das QOS nutzen zu können soltest du aber mindestens deinen PC hinter den Smart-Node hängen.
    Besser ist es den SmartNode als PPPoE-Router einzusetzen.
    Du kanst dir das SIP-Fon ausch sparen, denn du kannst im SmartNode mehrere SIP-Gateways einrichten.