.titleBar { margin-bottom: 5px!important; }

Info: Übermittlung der eigenen Telefonnummer mit Asterisk

Dieses Thema im Forum "Dellmont (vormals Betamax.com/Finarea)" wurde erstellt von arnysch, 26 Nov. 2008.

  1. arnysch

    arnysch Neuer User

    Registriert seit:
    28 Sep. 2007
    Beiträge:
    103
    Zustimmungen:
    1
    Punkte für Erfolge:
    18
    #1 arnysch, 26 Nov. 2008
    Zuletzt bearbeitet: 26 Nov. 2008
    Siehe bitte die nachträgliche Korrektur unten
    -----


    Weil ichs auch nach längerem Suchen im Forum nicht gefunden habe, und es auch im Hauptthread dazu (geschlossen) doppeldeutig drinsteht:

    Bei mir funktioniert die Übermittlung einer Telefonnummer überhaupt nicht via Setzen mit CALLERID(num) oder ähnlich in der extension.conf.

    Die Übertragung der Caller-ID über Intervoip (und vermutlich auch anderen Betamax-Ablegern) geht aber mit dem richtigen Eintrag fromuser= in der sip.conf:
    Code:
    [intervoip]
    type=peer
    host=sip.intervoip.com
    ;;; Parameter fuer Incoming-Verbindungen 
    ; ... nix, da bei mir nicht verwendet
    ;;; Parameter fuer Outgoing-Verbindungen
    username=MeinIntervoipUsername
    fromuser=49711997654321
    secret=MeinIntervoipPasswort
    
    Natürlich muss die Rufnummer 49711997654321 vorher bei Betamax/Intervoip als Eigene registriert und verifiziert sein.


    Korrektur:
    Die Beschreibung im Hauptthread ist doch richtig.

    Dort ist beschrieben, dass man auch CALLERID(number) verwenden kann. Allerdings finde ich CALLERID(number) bei keiner Asterisk-Dokumentation, sondern immer nur CALLERID(num), und nur damit hatte ich es - vergeblich -probiert.

    Aber grad getestet: Setzen von CALLERID(number) zusammen mit einem nichtleeren CALLERID(name) in der extension.conf funktioniert tatsächlich.

    Es scheint wohl unterschiedliche Asterisk-Versionen zu geben: Manche (neuere?) verstehen CALLERID(num), andere wie meine Version 1.2.18 verstehen CALLERID(number).
     
  2. bbob

    bbob Neuer User

    Registriert seit:
    18 Jan. 2006
    Beiträge:
    71
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    habe is pbxes folgendes gemacht.

    username: die caller id nummer die auch gecheckt worden ist:
    password: password:username vergesse das : zeichen nicht.

    das sollte es gehen.