.titleBar { margin-bottom: 5px!important; }

Installation einer AVM B1 ISA

Dieses Thema im Forum "Asterisk ISDN mit CAPI (chan_capi, chan_capi_cm)" wurde erstellt von ankes, 5 Juni 2005.

  1. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Jetzt lese ich schon fast 5 Stunden hier im Forum, verfolge diverse Links zum Thema und bin nun am Ende:
    Ich hab bis jetzt keine funktionierende Anleitung gefunden, wie ich die B1 unter A@H installieren soll.
    Das folgende Script funktioniert dahingehend nicht, daß bei der Installation von A@H (CentOS 3.4) die genannten rpm nicht dabei sind. Dann hab ich mir ähnlich klingende heruntergeladen (kernel-unsupported-2.4.21-20.EL.i686.rpm und kernel-smp-unsupported-2.4.21-20.EL.i686.rpm), aber capi läuft einfach nicht, denn der Aufruf "capiinit start" bringt die Fehlermeldungen:

    modprobe: Can't locate module kernelcapi
    ERROR: cannot load module kernelcapi

    Ich weiß nun überhaupt nicht, wo ich anfangen soll zu suchen....


    Code:
    #!/bin/sh
    
    echo -------------------------------------------
    echo installing chan_capi.so
    echo -------------------------------------------
    
    yum install isdn4k-utils-devel
    rpm -i /var/build_aah/disk1/RedHat/RPMS/kernel-unsupported-2.4.21-20.EL.c0.i686.rpm
    rpm -i /var/build_aah/disk1/RedHat/RPMS/kernel-smp-unsupported-2.4.21-20.EL.c0.i686.rpm
    
    wget http://www.junghanns.net/asterisk/downloads/chan_capi.0.3.5.tar.gz
    tar xvfz chan_capi.0.3.5.tar.gz
    cd chan_capi-0.3.5
    
    make
    make config
    make install
    cd ..
    
    echo "b1pci b1.t4 DSS1 - - - - P2P" > /etc/capi.conf
    
    wget ftp://ftp.in-berlin.de/pub/capi4linux/firmware/b1/3-11-03/b1.t4
    cp b1.t4 /usr/lib/isdn
    
    echo "capiinit start" >> /etc/rc.d/rc.local
    echo "chan_capi.so=yes" >> /etc/asterisk/modules.conf
    
     
  2. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    Hi ankes!

    Einfach das script mit

    nohup sh -x script.sh

    starten und die Ergebnisdatei "nohup.out"
    hier posten.

    Gruß
    britzelfix
     
  3. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vielen Dank schon jetzt für Deine Mühe!
    Grüße, Andreas.

    Code:
    + echo -------------------------------------------
    -------------------------------------------
    + echo installing chan_capi.so
    installing chan_capi.so
    + echo -------------------------------------------
    -------------------------------------------
    + yum install isdn4k-utils-devel
    isdn4k-utils-devel is installed and is the latest version.
    Gathering header information file(s) from server(s)
    Server: CentOS-3 - Addons
    Server: CentOS-3 - Base
    Server: CentOS-3 - Extras
    Server: CentOS-3 - Updates
    Finding updated packages
    Downloading needed headers
    No actions to take
    + rpm -i /var/build_aah/disk1/RedHat/RPMS/kernel-unsupported-2.4.21-20.EL.c0.i686.rpm
    	package kernel-unsupported-2.4.21-32.EL (which is newer than kernel-unsupported-2.4.21-20.EL.c0) is already installed
    + rpm -i /var/build_aah/disk1/RedHat/RPMS/kernel-smp-unsupported-2.4.21-20.EL.c0.i686.rpm
    	package kernel-smp-unsupported-2.4.21-32.EL (which is newer than kernel-smp-unsupported-2.4.21-20.EL.c0) is already installed
    + wget http://www.junghanns.net/asterisk/downloads/chan_capi.0.3.5.tar.gz
    --22:16:36--  http://www.junghanns.net/asterisk/downloads/chan_capi.0.3.5.tar.gz
               => `chan_capi.0.3.5.tar.gz.1'
    Resolving [url]www.junghanns.net[/url]... done.
    Connecting to [url]www.junghanns.net[192.67.198.55]:80[/url]... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 40,825 [application/x-gzip]
    
        0K .......... .......... .......... .........            100%  101.70 KB/s
    
    22:16:37 (101.70 KB/s) - `chan_capi.0.3.5.tar.gz.1' saved [40825/40825]
    
    + tar xvfz chan_capi.0.3.5.tar.gz
    chan_capi-0.3.5/
    chan_capi-0.3.5/app_capiCD.c
    chan_capi-0.3.5/INSTALL
    chan_capi-0.3.5/LICENSE
    chan_capi-0.3.5/Makefile
    chan_capi-0.3.5/README
    chan_capi-0.3.5/app_capiRETRIEVE.c
    chan_capi-0.3.5/app_capiNoES.c
    chan_capi-0.3.5/app_capiECT.c
    chan_capi-0.3.5/app_capiHOLD.c
    chan_capi-0.3.5/app_capiMCID.c
    chan_capi-0.3.5/capi.conf
    chan_capi-0.3.5/chan_capi.c
    chan_capi-0.3.5/chan_capi_app.h
    chan_capi-0.3.5/chan_capi_pvt.h
    chan_capi-0.3.5/xlaw.h
    + cd chan_capi-0.3.5
    + make
    make: Nothing to be done for `all'.
    + make config
    cp capi.conf /etc/asterisk/
    + make install
    for x in chan_capi.so app_capiCD.so app_capiHOLD.so app_capiRETRIEVE.so app_capiECT.so app_capiMCID.so app_capiNoES.so; do install -m 755 $x /usr/lib/asterisk/modules ; done
    + cd ..
    + echo 'b1pci b1.t4 DSS1 - - - - P2P'
    + wget ftp://ftp.in-berlin.de/pub/capi4linux/firmware/b1/3-11-03/b1.t4
    --22:16:40--  ftp://ftp.in-berlin.de/pub/capi4linux/firmware/b1/3-11-03/b1.t4
               => `b1.t4.1'
    Resolving ftp.in-berlin.de... done.
    Connecting to ftp.in-berlin.de[192.109.42.66]:21... connected.
    Logging in as anonymous ... Logged in!
    ==> SYST ... done.    ==> PWD ... done.
    ==> TYPE I ... done.  ==> CWD /pub/capi4linux/firmware/b1/3-11-03 ... done.
    ==> PASV ... done.    ==> RETR b1.t4 ... done.
    Length: 254,657 (unauthoritative)
    
        0K .......... .......... .......... .......... .......... 20%   98.04 KB/s
       50K .......... .......... .......... .......... .......... 40%  120.19 KB/s
      100K .......... .......... .......... .......... .......... 60%  123.46 KB/s
      150K .......... .......... .......... .......... .......... 80%  119.90 KB/s
      200K .......... .......... .......... .......... ........  100%  123.26 KB/s
    
    22:16:44 (116.05 KB/s) - `b1.t4.1' saved [254657]
    
    + cp b1.t4 /usr/lib/isdn
    + echo 'capiinit start'
    + echo chan_capi.so=yes
    
    
     
  4. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    Das script ist ohne Fehler durchgelaufen.
    Möglicherweise fehlt nur ein:

    depmod -a
    oder
    depmod -a -v|grep kernelcapi

    Wenn kernelcapi zu sehen ist, dann ist
    evtl. kein "Kerne module loader" installiert.
    Dann hilft ein "insmod kernelcapi".

    Wenn das nicht klappt, dann den richtigen!
    Kernel-Source installieren. Welcher Kernel
    grade arbeitet überprüft man mit "uname -r".

    Dann die benötigten Module selbst compilieren mit:

    cd /usr/src/linux
    make menuconfig
    # im submenu isdn/aktive/avm-b1-isa (M) einschalten
    # anschließend
    make modules modules_install

    und nochmal "capiinit start" versuchen.

    Gruß
    britzelfix
     
  5. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hab nun alles entsprechend Deiner Empfehlung gemacht:
    die ersten Punkte klappten nicht, mußte bis zu make menuconfig gehen
    der Eintrag im submenu isdn/aktive/avm-b1-isa (M) war bereits angeschalten
    aber auch dieses klappte nicht

    nun hab ich mich entschlossen, doch noch mal von vorn anzufangen (mit dem iso-image), vielleicht liegt das ganze ja an mir, daß ich mir irgendwann mal was versaut habe

    ich melde mich nach meinem nächsten Versuch wieder

    Gruß, Andreas.
     
  6. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    nun hab ich das ganze noch mal gemacht
    es sieht so aus, als ob jetzt das make von chan_capi schief geht...
    es folgt die Ausgabe des Scripts (siehe angehängte Datei):
     

    Anhänge:

  7. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    sieht so aus, als ob yum unterbrochen wurde
    "Exiting on user command."

    Wurden die Pakete isdn4k-utils und kernel-source auch entpackt?
    Danach kann es nicht weitergehen wegen:

    "chan_capi.c:36:20: capi20.h: No such file or directory"

    und capi20.h befindet sich im isdn4k-utils Paket.

    Gruß
    britzelfix
     
  8. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    bei isdn4k-utils war nichts nötig zu tun
    bei kernel-source wurde ein Update installiert

    Das make von chan_capi läuft aber trotzdem nicht ("chan_capi.c:36:20: capi20.h: No such file or directory")
    Wird denn chan_capi unbedingt gebraucht?

    capiinit start läuft jetzt, nachdem ich (siehe script vom Anfang der Beiträge) die Zeile
    echo "b1pci b1.t4 DSS1 - - - - P2P" > /etc/capi.conf
    in
    echo "b1isa b1.t4 DSS1 - - - - P2P" > /etc/capi.conf
    geändert habe
     
  9. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    jetzt hab ich noch mal
    yum install isdn4k-utils-devel
    aufgerufen und jetzt wurde ich gefragt, ob es installiert werden soll...
    seltsam
    ...
    dafür startet jetzt asterisk nicht mehr...
    Code:
    Jun 7 18:05:25 VERBOSE[1451]: [chan_capi.so]Jun 7 18:05:26 VERBOSE[1451]: [chan_capi.so] => (Common ISDN API for Asterisk)
    Jun 7 18:05:26 VERBOSE[1451]: == Parsing '/etc/asterisk/capi.conf': Jun 7 18:05:26 VERBOSE[1451]: == Parsing '/etc/asterisk/capi.conf': Found
    Jun 7 18:05:26 NOTICE[1451]: CAPI not installed!
    Jun 7 18:05:26 WARNING[1451]: chan_capi.so: load_module failed, returning -1
    Jun 7 18:05:26 WARNING[1451]: Unable to unregister from CAPI!
    Jun 7 18:05:26 VERBOSE[1451]: == Unregistered channel type 'CAPI'
    Jun 7 18:05:26 WARNING[1451]: Loading module chan_capi.so failed!
    Jun 7 18:05:26 WARNING[1451]: Loading module chan_capi.so failed!
    
    Was ist denn das für'n Mist: jetzt läuft die capi wohl doch nicht
    capiinit show gibt aber aus:

    driver firmware proto io irq mem cardnr options
    b1isa b1.t4 DSS1 - - - - P2P
     
  10. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    ich tippe mal, daß libcapi20 nicht installiert ist.
    was sagt denn

    ldd /usr/lib/asterisk/modules/chan_capi.so

    ??

    [Nachtrag]

    ich frage mich allerdings, ob der ISA-Bus schnell
    genug ist um die Sprache von und zu Karte so
    schnell übertragen kann, daß keine deutlichen
    Störungen entstehen.

    Gruß
    britzelfix
     
  11. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Naja, ich weiss auch von einigen, die ne FritzCard mit ISA-Bus erfolgreich nutzen. Ich vermute einfach mal, dass bei ner aktiven Karte eher weniger, aber aif keinen Fall mehr Informationen über den ISA_Bus laufen.
     
  12. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    ldd /usr/lib/asterisk/modules/chan_capi.so
    gibt das folgende aus:

    libcapi20.so.2 => /usr/lib/libcapi20.so.2 (0x00921000)
    libc.so.6 => /lib/tls/libc.so.6 (0x00c72000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x00fc4000)

    ich hab mir jetzt noch ne PCI-Version der B1 besorgt, aber auch damit hab ich die gleichen Probleme...
     
  13. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    ok, ich war vorhin falsch.

    "CAPI not installed" sagt schon chan_capi, also
    wurde sie ordnungsgemäß geladen.

    capi20.c verlangt aber die devices:

    /dev/capi20 oder /dev/isdn/capi20

    Diese werden afaik durch capiinit erzeugt.
    Möglich ist auch, daß die Treiber nicht geladen
    wurden.


    Gibt es dafür nicht eine kleine HOWTO?

    Gruß
    britzelfix
     
  14. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wenn Du "capiinfo" in die Konsole von linux eingiebst, was ist dann das resultat?
    Wie ist die Ausgabe von "lsmod"?
    Wenn Du ne b1-Karte (pci) hast, dann sollte da wenigstens:
    capi, capifs, kernelcapi und b1pci stehen (aber dafür nix von hisax, oder so).
    enn das nicht der Fall ist, dann gieb mal "capiinit" ein. Dann sollte er eigentlich das b1pci-Modul laden. Sonst mal nachsehen, ob die capi.conf von Linux (nicht von Asterisk) ok ist in /etc oder /etc/isde. Da sollte dann b1pci auskommentiert sein.
     
  15. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    capiinfo gibt aus:
    Code:
    Controller 1:
    Manufacturer: AVM GmbH
    CAPI Version: 2.0
    Manufacturer Version: 3.17-03  (49.19)
    Serial Number: 4008356
    BChannels: 2
    Global Options: 0x00000039
       internal controller supported
       DTMF supported
       Supplementary Services supported
       channel allocation supported (leased lines)
    B1 protocols support: 0x4000001f
       64 kbit/s with HDLC framing
       64 kbit/s bit-transparent operation
       V.110 asynconous operation with start/stop byte framing
       V.110 synconous operation with HDLC framing
       T.30 modem for fax group 3
    B2 protocols support: 0x00000b1b
       ISO 7776 (X.75 SLP)
       Transparent
       LAPD with Q.921 for D channel X.25 (SAPI 16)
       T.30 fro fax group 3
       ISO 7776 (X.75 SLP) with V.42bis compression
       V.120 asyncronous mode
       V.120 bit-transparent mode
    B3 protocols support: 0x8000003f
       Transparent
       T.90NL, T.70NL, T.90
       ISO 8208 (X.25 DTE-DTE)
       X.25 DCE
       T.30 for fax group 3
    
      0100
      0200
      39000000
      1f000040
      1b0b0000
      3f000080
      00000000 00000000 00000000 00000000 00000000 00000000
      01000001 00010000 00000000 00000000 00000000
    
    Supplementary services support: 0x000003ff
       Hold / Retrieve
       Terminal Portability
       ECT
       3PTY
       Call Forwarding
       Call Deflection
       MCID
       CCBS
    
    
    lsmod gibt aus:
    Code:
    Module                  Size  Used by    Not tainted
    capi                   20672   0
    capifs                  5360   1  [capi]
    autofs4                15928   0  (autoclean) (unused)
    audit                  89816   3
    3c59x                  28944   1
    ztdummy                 2464   0  (unused)
    zaptel                178560   0  [ztdummy]
    b1pci                   7684   1
    b1dma                  13460   0  [b1pci]
    b1                     17408   0  [b1pci b1dma]
    kernelcapi             33536   3  [capi b1pci]
    capiutil               23840   0  [kernelcapi]
    floppy                 56656   0  (autoclean)
    sg                     36204   0  (autoclean) (unused)
    scsi_mod              106408   1  (autoclean) [sg]
    microcode               5688   0  (autoclean)
    keybdev                 2944   0  (unused)
    mousedev                5524   0  (unused)
    hid                    22116   0  (unused)
    input                   5888   0  [keybdev mousedev hid]
    usb-uhci               25740   0  [ztdummy]
    usbcore                77376   1  [hid usb-uhci]
    ext3                   85736   2
    jbd                    50604   2  [ext3]
    
    die capi.conf ist in /etc und dort steht drin:
    b1pci b1.t4 DSS1 - - - - P2P

    soll das wirklich auskommentiert werden?
     
  16. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Sieht eigentlich alles Ok aus. Die nötige Module scheinen geladen worden zu sein. capiinfo giebt das richtige ergebnis. Das einzige, was bei mir anders ist, ist das "capiutil" bei mir nicht als modul geladen wurde. Hast du es schonmal ohne probiert? Sonst mal "rmmod capiutil", und dan Asterisk neu starten. Wo kommt das Modul überhaupt her? Ist für Asterisk auf jeden Fall unnötig.
     
  17. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mir scheint, ich bin jetzt am Ende einer Sackgasse gelandet
    Trotzdem: Vielen Dank für Eure Unterstützung!
     
  18. lo4dro

    lo4dro Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    656
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    bei mir werden für capi folgende Module geladen:

    b1isa 5648 2
    b1 15168 1 b1isa
    capi 8960 8
    kernelcapi 27072 3 b1isa,b1,capi
    capifs 1576 2 capi

    entlade mal das capiutil
     
  19. ankes

    ankes Neuer User

    Registriert seit:
    5 Juni 2005
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    rmmod capiutil gibt aus:
    capiutil: Device or resource busy

    ich hab auch leider die Stelle nicht ausfindig machen können, an der capiutil gestartet wird

    capiinit gibt aus:
    1 b1pci running b1pci-1080 B1 3.11-03 0x1080 10 r2
     
  20. old-dad

    old-dad Neuer User

    Registriert seit:
    19 Juni 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    HI

    vielleicht mal folgender gedanke dazu.

    ich erinnere mich dunkel, daß zumindest capi4linux nicht mit 'nem smp-kernel funktioniert.

    also, wenn dein rechner vielleicht keine mehreren CPU's hat (beim P4 wird mitunter ein smp-kernel als standart *z.bsp. susi* installiert) dann installiere einen normalen und probiers noch mal.
    immerhin wird doch deine b1-karte korrekt geladen, oder?

    gruß dad