.titleBar { margin-bottom: 5px!important; }

Installation ISDN

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von wpfundstein, 4 Feb. 2006.

  1. wpfundstein

    wpfundstein Mitglied

    Registriert seit:
    24 Nov. 2005
    Beiträge:
    267
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    #1 wpfundstein, 4 Feb. 2006
    Zuletzt bearbeitet: 5 Feb. 2006
    Hallo zusammen,

    Habe bisher meinen Asterisk auf einem Scenic PIII 500 laufen.

    Jetzt habe ich mir mir 2 HFC Karten und eine 40 GB Festplatte für eine Neuinstallation besorgt, so dass ich die alte nicht verliere.

    für den Start nur eine HFC Karte eingebaut

    zuerste habe ich es mit mISDN probiert.

    1. Installation Debian 2.4.47
    2. Kernel auf 2.6.8-2-386 upgedatet
    3. Kernel Headers installiert
    5. Kernel Sources installiert
    6. libncurses5-dev,libssl-dev, zlib1g-dev und patch nachinstalliert
    7. die symbolischen Links:
    ln -s /usr/src/kernel-source-2.6.8 /usr/src/linux
    ln -s /usr/src/kernel-source-2.6.8 /usr/src/linux-2.6
    angelegt

    Jetzt die Installation an sich

    von digium asterisk 1.2.4 downgeloadet
    von beronet install-misdn downgeloadet

    zuerst asterisk
    make
    make install
    make samples

    danach misdn

    make && make install

    das kompilieren und installieren verlief ohne Probleme

    /etc/init.d/misdn-init scan
    /etc/init.d/misdn-init config

    die /etc/misdn-init.conf angepasst und mit

    /etc/init.d/misdn-init start

    misdn gestartet

    nun meine asterisk conf Dateien angepasst und asterisk gestartet.

    Habe zum Testen 2 SIP Telefone und ein ISDN Telefon mit eigener Stromversorgung

    SIP zu SIP wunderbar

    SIP zu ISDN !? ISDN Telefon klingelt 2 bis 2 mal und Schluss. Auf der Console erhalte ich einen dev_timer???, oder so ähnlich, Fehler. Auf alle Fälle läuft es nicht.

    Ok, dachte ich mir. Nimmst halt nicht mISDN sondern Bristuff.

    Kiste neu installiert.

    1. Installation Debian 2.4.47
    2. Kernel auf 2.6.8-2-386 upgedatet
    3. Kernel Headers installiert
    5. Kernel Sources installiert
    6. libncurses5-dev,libssl-dev, zlib1g-dev und patch nachinstalliert
    7. die symbolischen Links:
    ln -s /usr/src/kernel-source-2.6.8 /usr/src/linux
    ln -s /usr/src/kernel-source-2.6.8 /usr/src/linux-2.6
    angelegt

    Jetzt die Installation an sich

    von junghanns die letzte Version PRE-1k downgeloadet

    zuerst ./download ausgeführt, ohne Probleme
    dann ./compile.sh ausgeführt, auch ohne Probleme

    ABER, ich kriegt den zaphfc nicht zum laufen.

    make load nt bringt Fehler, dateie oder verzeichnis nicht gefunden

    Habe schon diverse Anleitungen durchforstet und bin der Meinung alles richtig gemacht zu haben.

    Gruß, Werner
     
  2. wpfundstein

    wpfundstein Mitglied

    Registriert seit:
    24 Nov. 2005
    Beiträge:
    267
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    ich noch mal.

    Habs jetzt mit mISDN hingekriegt.

    hab allerdings immer noch den

    dev_del_timer: timer(xxxx) not running

    Gruß, Werner
     
  3. mabo

    mabo Neuer User

    Registriert seit:
    23 Juni 2005
    Beiträge:
    105
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Oldenburg bei Bremen
    Hallo,
    bei deiner Bristuff Instrallation vermute ich mal dieses:

    "zaphfc und die anderen Treiber sind nicht im compile.sh Skripte enthalten."

    Das heißt Du musst das zaphfc Modul selber kompilieren und installieren.

    cd zaphfc
    make
    make install
    depmod -a


    Bei der mISDN Installation und dem Wort "timer" würde ich auf ztdummy tippen.
    Das heißt zaptel und ztdummy muss geladen sein.

    Gruß Mabo
     
  4. wpfundstein

    wpfundstein Mitglied

    Registriert seit:
    24 Nov. 2005
    Beiträge:
    267
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi Mabo,

    danke für die Antwort.


    das mit bristuff werde ich nochmals testen.

    zu mISDN und Timer

    nach dem Start von Linux:

    modprobe zaptel
    modprobe ztdummy
    /etc/init.d/misdn-init start
    asterisk
    asterisk -r

    Hab aber immer noch den dev_del_timer fehler.

    Kann auch mit dem ISDN Telefon telefonieren.

    dabei habe ich noch folgende Probleme:

    möchte ich ein Gespräch vermitteln, dann bekomme ich auf der Console:

    Hold not allowed on port 1:

    ich kann dann zwar eine andere Nebenstelle anrufen und zwischen den beiden Gesprächen makeln. Es wird aber kein music on hold abgespielt.

    Mit meinen SIP Telefonen funktioniert das wunderbar.


    Frage: Sind solche Probleme mit Bristuff weg?

    Gruß, Werner
     
  5. wpfundstein

    wpfundstein Mitglied

    Registriert seit:
    24 Nov. 2005
    Beiträge:
    267
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi Mabo,

    hab jetzt neues Debian 2.6.8-2-686 aufgesetzt.

    Dann bristuff PRE-1k download und compile durchgeführt.

    Du hattest Recht. zaphfc wird zwar kompiliert aber fehler. Also nach der Installation in das zaphfc Verzeichnis und make aufgerufen

    krieg aber sofort nen Fehler bei:

    make -C SUBDIRS=/usr/src/bristuff-0.3.0-PRE-1k/zaphfc ZAP=I/usr/src/bristuff-0.3.0-PRE-1k/zaptel-1.2.3 modules
    make: ***SUBDIRS=/usr/src/bristuff-0.3.0-PRE-1k/zaphfc. Datei oder Verzeichnis nicht gefunden. Schluss.
    make: *** [linux26] Fehler 2

    Kann irgendwie nichts damit anfangen.

    Gruß, Werner
     
  6. crich

    crich Mitglied

    Registriert seit:
    1 Sep. 2005
    Beiträge:
    529
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    die dev_timer outputs sind nur loggings, sind keine Fehler.

    Christian
    (crich)
     
  7. mabo

    mabo Neuer User

    Registriert seit:
    23 Juni 2005
    Beiträge:
    105
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Oldenburg bei Bremen
    @ crich

    Danke, wieder was gelernt :)

    @ wpfundstein

    was da jetzt genau bei dir klemmt weiß ich auch nicht. Ich hab bei mir heut noch mal
    Bristuff raufgeschmissen und folgenden weg benutzt.

    Installtion AVM FritzCard PCI und 1mal HFC

    Code:
    apt-get install kernel-headers-`uname -r`
    apt-get update
    apt-get upgrade
    
    #hisax entfernen
    rm -r /lib/modules/2.6.8-2-k7/kernel/drivers/isdn/hisax/
    shutdown -r now 
    
    apt-get install mc
    apt-get install cvs
    apt-get install subversion
    apt-get install libspeex-dev
    apt-get install libssl-dev
    apt-get install libz-dev
    apt-get install libncurses-dev
    apt-get install libmysqlclient12-dev
    apt-get install capiutils
    apt-get install libcapi20-dev
    
    ln -s kernel-headers-2.6.8-2-k7/ linux-2.6
    ln -s linux-2.6 linux
    ln -s /usr/src/linux-2.6 /lib/modules/2.6.8-2-k7/build
    cd /usr/src/linux
    cp /boot/config-2.6.8-2-k7 ./.config
    make oldconfig
    echo -2-k7 > .extraversion
    
    #AVM Treiber besorgen 
    tar -xvzf fcpci-suse9.1-3.11-02.tar.gz -C /usr/src/avm/
    ./install
    
    cat /etc/isdn/capi.conf
    # card          file    proto   io      irq     mem     cardnr  options
    #b1isa          b1.t4   DSS1    0x150   7       -       -       P2P
    #b1pci          b1.t4   DSS1    -       -       -       -
    #c4             c4.bin  DSS1    -       -       -       -
    #c4             -       DSS1    -       -       -       -
    #c4             -       DSS1    -       -       -       -       P2P
    #c4             -       DSS1    -       -       -       -       P2P
    #c2             c2.bin  DSS1    -       -       -       -
    #c2             -       DSS1    -       -       -       -
    #t1isa          t1.t4   DSS1    0x340   9       -       0
    #t1pci          t1.t4   DSS1    -       -       -       -
    fcpci           -       -       -       -       -       -
    #fcclassic      -       -       0x150   10      -       -
    
    capiinit start
    
    wget http://www.junghanns.net/downloads/bristuff-0.3.0-PRE-1k.tar.gz
    tar -xvzf bristuff-0.3.0-PRE-1k.tar.gz -C /usr/src/bristuff
    
    cd /usr/src/bristuff/bristuff-0.3.0-PRE-1k/
    
    ./install.sh 
    cd asterisk-1.2.4
    make samples 
    
    cd ..
    cd zaphfc/
    
    make
    make install
    depmod -a
    
    make loadNT
    
    Ich hoffe ich konnte helfen

    Gruß Mabo
     
  8. wpfundstein

    wpfundstein Mitglied

    Registriert seit:
    24 Nov. 2005
    Beiträge:
    267
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hallo crich

    danke für die info

    Hallo mabo

    ich habs jetzt bristuff zum laufen gebracht. Muss sagen es funktioniert bisher ganz gut.

    Hab da eine Frage zum florz patch.

    Ich habe 2 HFC Karten eingebaut. Eine für Intern und eine für Extern. Die Interne läuft schon produktiv mit einem Sinus ISDN Schnurlos Telefon.

    Wie erkenne ich ob der Patch richtig installiert ist. bzw. wie wirkt sich das aus wenn er nicht installiert ist?

    Gruß, Werner
     
  9. mabo

    mabo Neuer User

    Registriert seit:
    23 Juni 2005
    Beiträge:
    105
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Oldenburg bei Bremen
    Da ich nur eine HFC Karte habe und ich glaube dann braucht man den Patch nicht.
    Habe ich leider keine Ahnung im Umgang mit dem Patch.

    Gruß Mabo
     
  10. greenhornXXL

    greenhornXXL Neuer User

    Registriert seit:
    6 Feb. 2006
    Beiträge:
    85
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    zaphfc Fehler bei make

    Hallo zusammen

    Nach einigen Fehlanläufen um * mit ISDN zum laufen zu bringen habe ich den Rechner komplett neu aufgesetzt und mich dabei an die Anleitung von "mabo" gehalt.
    Die ich auch sehr hilfreich finde.

    Mein Problem ist das ich nun beim letzten Schritt zur zaphfc Fehler bekomme sobald ich make ausführe:

    make[1]: Entering directory `/usr/src/kernel-headers-2.6.8-2-386'
    Building modules, stage 2.
    MODPOST
    *** Warning: "zt_register" [/usr/src/bristuff-0.3.0-PRE-1k/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_transmit" [/usr/src/bristuff-0.3.0-PRE-1k/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_receive" [/usr/src/bristuff-0.3.0-PRE-1k/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_ec_chunk" [/usr/src/bristuff-0.3.0-PRE-1k/zaphfc/zaphfc.ko] undefined!
    *** Warning: "zt_unregister" [/usr/src/bristuff-0.3.0-PRE-1k/zaphfc/zaphfc.ko] undefined!
    make[1]: Leaving directory `/usr/src/kernel-headers-2.6.8-2-386'


    Für eine kleine Info wäre ich sehr dankbar.

    grennhornXXL
     
  11. crich

    crich Mitglied

    Registriert seit:
    1 Sep. 2005
    Beiträge:
    529
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Diese Warnings sind nicht weiter bedenklich.
     
  12. greenhornXXL

    greenhornXXL Neuer User

    Registriert seit:
    6 Feb. 2006
    Beiträge:
    85
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo crich

    erstmal Vielen Dank für Deine schnelle Antwort.

    Wenn ich die Fehlermeldung vernachlässige und anschliessend ein
    make loadNT
    eingebe bekomme ich wieder diese Meldungen und

    Zaptel Configuration
    ======================


    0 channels configured.

    --------------

    Soll mich das nicht beunruhigen?
    Dann konfiguriere ich jetzt mal den * und schau das alles fkt.
    Ich wollte nur vermeiden das ich später nach Konfig Fehlern suche die bei der Installation schon aufgetreten sind.

    gruß

    greenhornXXL
     
  13. crich

    crich Mitglied

    Registriert seit:
    1 Sep. 2005
    Beiträge:
    529
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also 0 Channels configured, ist irgendwie falsch. du musst eine zaptel.conf erstellen und ztcfg -v sollte 2 channels anzeigen.