.titleBar { margin-bottom: 5px!important; }

Installation von Asterisk Beta auf Linux Debian

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Nostraddi, 20 Sep. 2005.

  1. Nostraddi

    Nostraddi Neuer User

    Registriert seit:
    12 Aug. 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    ich bin Linux Neueinsteiger, darf mich aber als alten DOS und Windows Fortgeschrittener bezeichnen, Asterisk ist mein Ziel, ich möchte gerne bis zum 1.1.06 eine TK Anlage aufstellen können.

    Folgendes Problem habe ich zZt und ich HOFFE das mir jemand hier ein wenig helfen kann, also los - ich hab eine Abhakliste gemacht :

    ---------------------------

    3 Files wie im Handbuch beschrieben von CVS downloaden lassen.

    - Zaptel installiert (1 Fehler)

    make -C SUBDIRS=/usr/src/zaptel modules
    make: *** SUBDIRS=/usr/src/zaptel: Datei oder Verzeichnis nicht gefunden. Schluss.
    make: *** [linux26] Fehler 2


    - libpri installiert OK
    - Asterisk installiert OK

    configure: error: termcap support not found
    make: *** [editline/libedit.a] Fehler 1


    - Pwlib installiert (Bibliotheksfehler, ungravierend) NOK

    /usr/bin/install -c -m 444 lib/libpt_linux_x86_r.so.1.8.7 /usr/local/lib
    /usr/bin/install: Aufruf von stat für ,,lib/libpt_linux_x86_r.so.1.8.7" nicht möglich: Datei oder Verzeichnis nicht gefunden
    make: *** [install] Fehler 1


    - Open H323 gedownloaded und installiert (Abbruch! Bibliothek fehlt) NOK

    /usr/bin/install -c -m 444 lib/*_r.so /usr/local//lib
    /usr/bin/install: Aufruf von stat für ,,lib/*_r.so" nicht möglich: Datei oder Verzeichnis nicht gefunden
    make: *** [install] Fehler 1


    - Asterisk OH323 via Debian-Paketinstallation installiert.. OK
    - Sicherheitshalber nochmals von inaccessnetworks.com installiert
    Er beschwert sich über ein fehlendes "pwlib" Verzeichnis (existiert) NOK

    ERROR: No PWLIB library found!
    make[1]: *** [chan_oh323.so] Fehler 1
    make[1]: Leaving directory `/usr/src/asterisk-oh323/asterisk-driver'
    make: *** [subdirs_build] Fehler 1


    ------------------------------------------

    Reichlich viele Fehler wie man sehen kann, aber alles bezieht sich immer wieder auf dasselbe Hauptproblem, das pwlib.

    Ich habe folgenden Rechner :
    AMD A 3GHZ, noch KEINE Isdn Karten installiert
    Debian, als Paketinstallation bereits Asterisk installiert (via Paketmanager)
    habe es allerdings nochmals separat installiert, da ich die Debian-Version nicht auffinden konnte.

    Meine CLI gibt zZt folgendes aus (wie gesagt - noch keine ISDN Karten installiert)

    [ Booting......Sep 20 21:59:59 WARNING[29651]: res_musiconhold.c:565 moh_register: Unable to open pseudo channel for timing... Sound may be choppy.
    ..Sep 20 21:59:59 WARNING[29651]: res_musiconhold.c:205 spawn_mp3: Found no files in '/usr/share/asterisk/mohmp3'
    Sep 20 21:59:59 WARNING[29651]: res_musiconhold.c:278 monmp3thread: unable to spawn mp3player
    .....Sep 20 21:59:59 NOTICE[29651]: res_odbc.c:133 load_odbc_config: registered database handle 'mysql1' dsn->[MySQL-asterisk]
    Sep 20 21:59:59 NOTICE[29651]: res_odbc.c:133 load_odbc_config: registered database handle 'mysql2' dsn->[MySQL-asterisk]
    Sep 20 21:59:59 NOTICE[29651]: res_odbc.c:415 load_module: res_odbc loaded.
    .Sep 20 21:59:59 NOTICE[29651]: config.c:888 ast_config_register: Registered Config Engine odbc
    Sep 20 21:59:59 NOTICE[29651]: res_config_odbc.c:190 load_module: res_config_odbc loaded.
    .......Sep 20 21:59:59 WARNING[29651]: chan_iax2.c:7491 load_module: Unable to open IAX timing interface: No such file or directory
    ..Sep 20 21:59:59 WARNING[29651]: chan_skinny.c:2587 reload_config: Unable to get our IP address, Skinny disabled
    .Sep 20 21:59:59 WARNING[29651]: loader.c:258 ast_load_resource: /usr/lib/asterisk/modules/chan_zap.so: undefined symbol: pri_suspend_acknowledge
    Sep 20 21:59:59 WARNING[29651]: loader.c:440 load_modules: Loading module chan_zap.so failed!


    Jede Menge Infos -- ich hoffe es gibt jemanden der sich dessen ein wenig annehmen kann, ich würde sehr dankbar sein !

    Soweit, Grüsse , Nos!
     
  2. Boardercrime

    Boardercrime Neuer User

    Registriert seit:
    18 Aug. 2005
    Beiträge:
    26
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  3. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Termcap installieren
    prüfen ob die jeweiligen devel-Pakete installiert sind
    Zu den Fehlern auf dem cli:
    Da helfen ein paar noload= in der modules.conf.
    Ein Teil sind da fehlende Hardwarechan_zao, skinny ...
     
  4. Nostraddi

    Nostraddi Neuer User

    Registriert seit:
    12 Aug. 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für den Tipp, diesen Patch hatte ich bereits im Einsatz, hab ihn trotzdem nochmals gesaugt und compiliert (./configure, make clean ; make install)...

    Leider mit selbigem Ergebnis wie vorher , er vermisst irgendeine Datei .. :

    /usr/bin/install -c -m 444 lib/libpt_linux_x86_r.so.1.8.7 /usr/local/lib
    /usr/bin/install: Aufruf von stat für ,,lib/libpt_linux_x86_r.so.1.8.7" nicht möglich: Datei oder Verzeichnis nicht gefunden
    make: *** [install] Fehler 1


    Die Suche nach der Datei ergibt das diese beim Paket beiliegen müsste...wie gesagt : müsste...

    EDIT : Ich habe nochmals Google und die Pakete nach dieser Datei durchsucht "libpt_linux_x86_r.so.1.8.7" ... leider alles erfolglos. Bei Google wird man zwar fündig, weiterhelfen tut es allerdings nicht :-(

    Hat jemand sowas schonmal erlebt ?
     
  5. Nostraddi

    Nostraddi Neuer User

    Registriert seit:
    12 Aug. 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Vorweg : Ich habe erwähnt das ich den aktuellen Kernel 2.6 nutze ?
    Und das ich nach der Anleitung zu einer Studienarbeit vorgegangen bin :

    http://archiv.tu-chemnitz.de/pub/2004/0008/data/asterisk.pdf

    So, nun zum eigentlichen Thema .. :

    [/quote]
    Termcap installieren
    prüfen ob die jeweiligen devel-Pakete installiert sind
    Zu den Fehlern auf dem cli:
    Da helfen ein paar noload= in der modules.conf.
    Ein Teil sind da fehlende Hardwarechan_zao, skinny ...[/quote]

    Termcap --> installiert als Debian-compet

    Devel's --> alle notwendigen sind meines Wissens und Recherche installiert.

    CLI --> diese Fehler würden ja herausfallen sobald die Karten eingebaut sind, ich hoffe das ich bas dahin aber alles soweit problemlos wieder aufbauen kann..

    make -C SUBDIRS=/usr/src/zaptel modules
    make: *** SUBDIRS=/usr/src/zaptel: Datei oder Verzeichnis nicht gefunden. Schluss.
    make: *** [linux26] Fehler 2


    Das Problem hier in der Zaptel Konfiguration besteht ebenso noch - werde dabei genausowenig schlau, das Verzeichnis existiert, da ich daraus installiere.

    Jedoch - das pwlib problem besteht weiterhin...

    Grüsse und DANKE für eure Hilfe ! Nos!
     
  6. kperas

    kperas Neuer User

    Registriert seit:
    17 Jan. 2005
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  7. Nostraddi

    Nostraddi Neuer User

    Registriert seit:
    12 Aug. 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hey,

    danke erstmal,

    ich werds in meine Projektlinkseite mit aufnehmen.

    Projektforum von Stefan

    Ich bin erst einmal auf A@H umgestiegen da ich die zahlreichen Problemfelder nicht alle lösen konnte...

    Danke aber trotzdem!