.titleBar { margin-bottom: 5px!important; }

Kann externen SIP Teilnehmer nicht mehr erreichen

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von ktronic, 8 Nov. 2005.

  1. ktronic

    ktronic Neuer User

    Registriert seit:
    8 Nov. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    HAllo,
    Betreibe an einem ASTERISK eine externe SIP Nebenstelle.
    Also der ASTERISK steht bei mir und ein Freund meldet sich mit seinem SIP Phone auf dem ASTERISK von mir an.
    Klappte eine ganze Zeit wunderbar. Doch jetzt, kann er zwar immer noch telefonieren und andere Teilnehmer (auch über CAPI) erreichen. Allerdings, wenn man nun ihn (die externe Nebenstelle) versucht zu erreichen, klingelt diese, wird abgehoben wird die Verbindung allerdings sofort unterbrochen.

    SIP Nebenstelle: ZYXEL 2000W

    ASTERISK sagt folgendes
    Code:
    -- creating pipe for PLCI=0x101 msn = 45
           > sent ALERT_REQ PLCI = 0x101
        -- started pbx on channel (callgroup=0)!
        -- Executing Goto("CAPI[contr1/45]/73", "menu2|s|1") in new stack
        -- Goto (menu2,s,1)
        -- Executing BackGround("CAPI[contr1/45]/73", "vmpublic") in new stack
        -- CAPI Answering for MSN 45
        -- Playing 'vmpublic' (language 'en')
      == CDR updated on CAPI[contr1/45]/73
        -- Executing Dial("CAPI[contr1/45]/73", "sip/72") in new stack
        -- Called 72
        -- SIP/72-36b4 is ringing
        -- SIP/72-36b4 answered CAPI[contr1/45]/73
        -- Got SIP response 400 "Bad Request" back from xxx.xxx.xxx.xxx
      == Spawn extension (menu2, 72, 1) exited non-zero on 'CAPI[contr1/45]/73'
        -- CAPI Hangingup
           > sent DISCONNECT_B3_REQ NCCI=0x10101
           > sent DISCONNECT_REQ PLCI=0x101
        -- removed pipe for PLCI = 0x101
        -- Got SIP response 400 "Bad Request" back from xxx.xxx.xxx.xxx
        -- Got SIP response 400 "Bad Request" back from xxx.xxx.xxx.xxx
    
    Wobeo xxx.xxx.xxx.xxx die öffentliche IP des Routers meines Freundes ist.

    Wer weiß was..........

    Haben gerade festgestellt, dass es mit einem XLIGHT Client funktioniert!!

    Vielen DANK
    Thomas
     
  2. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    hast Du mal ein SIP DEBUG gemacht, um zu sehen, was da genau schiefgeht ?
     
  3. ktronic

    ktronic Neuer User

    Registriert seit:
    8 Nov. 2005
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Anbei ein Tarce nach SIP DEBUG,

    Kann allerdings auser der gleichen Fehlermeldung nichts mehr entdecken,
    aber vieleicht jemand anderes.

    Code:
     (no NAT) to 84.165.234.55:19870
    idefix*CLI>
    
    Sip read:
    SIP/2.0 400 Bad Request
    Via:SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK5a9f3f1e;rport
    From:01713664184<sip:72@onlineaccess.no-ip.com>;tag=as4918e533
    To:<sip:72@84.165.234.55>;tag=84351D743A54557FB36D
    Call-ID:4383ab0015e7416b0d5a7da117633a63@192.168.1.5
    CSeq:102 ACK
    User-Agent: ZyXEL P2000W VoIP Wi-Fi Phone
    
    7 headers, 0 lines
        -- Got SIP response 400 "Bad Request" back from 84.165.234.55
      == Spawn extension (menu2, 72, 1) exited non-zero on 'CAPI[contr1/45]/12'
        -- CAPI Hangingup
           > sent DISCONNECT_B3_REQ NCCI=0x10101
           > sent DISCONNECT_REQ PLCI=0x101
    Destroying call '4383ab0015e7416b0d5a7da117633a63@192.168.1.5'
    idefix*CLI>
    
    Sip read:
    SIP/2.0 400 Bad Request
    Via:SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK616ad1d4
    From:asterisk<sip:asterisk@onlineaccess.no-ip.com>;tag=as75368db8
    To:<sip:84.165.234.55>
    Call-ID:6f99f7a2527e34fa076fdeb145fb709e@192.168.1.5
    CSeq:102 OPTIONS
    User-Agent: ZyXEL P2000W VoIP Wi-Fi Phone
    
    7 headers, 0 lines
    Destroying call '6f99f7a2527e34fa076fdeb145fb709e@192.168.1.5'
        -- removed pipe for PLCI = 0x101
    idefix*CLI>
    
    Sip read:
    SIP/2.0 200 OK
    Via:SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK4f5b2a98;rport
    From: "01713664184" <sip:72@192.168.1.5>;tag=as4918e533
    To: <sip:72@84.165.234.55:19870>;tag=84351D743A54557FB36D
    Call-ID:4383ab0015e7416b0d5a7da117633a63@192.168.1.5
    CSeq:102 INVITE
    Contact: <sip:72@84.165.234.55:19870;transport=udp>
    Allow: INVITE,OPTIONS,BYE,CANCEL,ACK,SUBSCRIBE,NOTIFY,INFO,REFER
    User-Agent: ZyXEL P2000W VoIP Wi-Fi Phone
    Content-Type: application/sdp
    Content-Length: 154
    
    v=0
    o=TelogyUnknown0000 1571470 1571470 IN IP4 84.165.234.55
    s=RTP Audio
    c=IN IP4 84.165.234.55
    t=0 0
    m=audio 20626 RTP/AVP 8
    a=rtpmap:8 PCMA/8000
    
    11 headers, 7 lines
    Destroying call '4383ab0015e7416b0d5a7da117633a63@192.168.1.5'
    idefix*CLI>
    
    Sip read:
    SIP/2.0 200 OK
    Via:SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK4f5b2a98;rport
    From: "01713664184" <sip:72@192.168.1.5>;tag=as4918e533
    To: <sip:72@84.165.234.55:19870>;tag=84351D743A54557FB36D
    Call-ID:4383ab0015e7416b0d5a7da117633a63@192.168.1.5
    CSeq:102 INVITE
    Contact: <sip:72@84.165.234.55:19870;transport=udp>
    Allow: INVITE,OPTIONS,BYE,CANCEL,ACK,SUBSCRIBE,NOTIFY,INFO,REFER
    User-Agent: ZyXEL P2000W VoIP Wi-Fi Phone
    Content-Type: application/sdp
    Content-Length: 154
    
    v=0
    o=TelogyUnknown0000 1571470 1571470 IN IP4 84.165.234.55
    s=RTP Audio
    c=IN IP4 84.165.234.55
    t=0 0
    m=audio 20626 RTP/AVP 8
    a=rtpmap:8 PCMA/8000
    
    11 headers, 7 lines
    Destroying call '4383ab0015e7416b0d5a7da117633a63@192.168.1.5'
    idefix*CLI>
    
    
    Manchmal funktioniert es auch, aber nur sehr selten!!

    Danke