.titleBar { margin-bottom: 5px!important; }

Kein Anruf möglich cp-7960 und cisco 1750

Dieses Thema im Forum "Cisco" wurde erstellt von ShiningStar, 11 Aug. 2005.

  1. ShiningStar

    ShiningStar Neuer User

    Registriert seit:
    23 Juli 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich hab oben genannte Hardware. Ich hab auch die DNS von t-online ins telefon eingetragen, und dann stand oben plötzlich korrektes datum und Uhrzeit. Soweit ok. Dann wollte ich das in EU format ändern, da war es plötzlich weg. Viel schlimmer jedoch ist, das ich nun weder angerufen werden kann, noch anrufen kann. Meine konfig sieht wie folgt aus:

    DialIn_LTB_01#sh conf
    Using 2726 out of 29688 bytes
    !
    version 12.2
    service config
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname DialIn_LTB_01
    !
    enable secret 5 xxx
    enable password xxx
    !
    ip subnet-zero
    !
    !
    !
    ip audit notify log
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    ip mtu adjust
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    description T-DSL Hello World
    no ip address
    ip access-group 100 in
    ip mtu 1492
    ip nat outside
    no ip mroute-cache
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 21
    no cdp enable
    !
    interface FastEthernet0
    description inside lan
    ip address 192.168.0.2 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip tcp adjust-mss 1452
    no ip mroute-cache
    speed auto
    full-duplex
    no cdp enable
    !
    interface Dialer21
    ip address negotiated
    ip access-group 100 in
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 21
    dialer-group 2
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxx@t-online.de password 0 xxx
    ppp ipcp dns request
    !
    ip nat inside source list 101 interface Dialer21 overload
    ip nat inside source static tcp 192.168.0.5 5060 interface Dialer1 5060
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer21
    no ip http server
    !
    !
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any packet-too-big
    access-list 100 permit icmp any any echo
    access-list 100 permit icmp any any ttl-exceeded
    access-list 100 permit tcp any any established
    access-list 100 permit udp any eq domain any
    access-list 100 permit udp any eq ntp any
    access-list 101 permit udp any any eq ntp
    access-list 101 permit udp any any eq domain
    access-list 101 permit tcp any any eq smtp
    access-list 101 permit tcp any any eq pop3
    access-list 101 permit tcp any any eq 143
    access-list 101 permit tcp any any eq www
    access-list 101 permit tcp any any eq 443
    access-list 102 deny udp any eq netbios-dgm any
    access-list 102 deny udp any eq netbios-ns any
    access-list 102 deny udp any eq netbios-ss any
    access-list 102 deny udp any range snmp snmptrap any
    access-list 102 deny udp any range bootps bootpc any
    access-list 102 deny tcp any eq 137 any
    access-list 102 deny tcp any eq 138 any
    access-list 102 deny tcp any eq 139 any
    access-list 102 permit ip any any
    dialer-list 2 protocol ip list 101
    no cdp run
    !
    snmp-server community LTB1 RW
    snmp-server enable traps tty
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    no login
    !
    ntp server 192.53.103.104
    ntp server 129.69.1.153
    ntp server 130.149.17.8
    ntp server 131.188.3.220
    end

    Ich weiss echt nicht mehr weiter, helft mir mal bitte. Danke schon eimal im vorraus.
     
  2. hedgeschredder

    hedgeschredder Neuer User

    Registriert seit:
    6 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    Du musst natürlich noch die Ports für den RTP stream (analog zu dem SIP 5060) weiterleiten. In der config des phones ist auch irgendwo die port range zu finden:

    start_media_port: 16384 ; Start RTP range for media (default - 16384)
    end_media_port: 16387 ; End RTP range for media (default - 32766)


    In der access-list 100 ist dann noch die entsprechenden Ports freizuschalten.

    Cisco SIP phones verwenden UDP port 5060, also in der Portweiterleitung das Protokoll von tcp auf udp ändern.

    In der config des Phones:
    voip_control_port: 5060 ; UDP port used for SIP messages (default - 5060)

    ip nat inside source static udp 192.168.0.5 5060 interface Dialer21 5060

    Für das inteface ethernet 0 reicht die folgende config:

    interface Ethernet0/0
    no ip address
    no ip mroute-cache
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 21
    no cdp enable

    Probier das dochmal aus, später kann man noch ppp multilink implementieren um bei hoher Auslastung noch problemlos telefonieren zu können.

    Ich schlage vor das diese config dir Grundlage für alles weitere ist.
     
  3. hedgeschredder

    hedgeschredder Neuer User

    Registriert seit:
    6 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    P.S.

    kommst Du mit dem Teil ins Internet ? Folgendes müsste noch geändert werden:

    access-list 1 permit 192.168.0.0 0.0.0.255
    ip nat inside source list 1 interface Dialer21 overload
    dialer-list 2 protocol ip permit
     
  4. ShiningStar

    ShiningStar Neuer User

    Registriert seit:
    23 Juli 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    sicherlich komme ich mit dem teil ins inet, sonst könnte ich hier nicht schreiben, warum fragst du ?
     
  5. ShiningStar

    ShiningStar Neuer User

    Registriert seit:
    23 Juli 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wie meinst du das mit auf udp ändern und wie muss ich denn die konfig machen um ein port range frei zu geben und weiter zu leiten?
     
  6. hedgeschredder

    hedgeschredder Neuer User

    Registriert seit:
    6 Jan. 2005
    Beiträge:
    25
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    ip nat inside source static udp 192.168.0.5 5060 interface Dialer21 5060

    Port ranges gehen nicht, aber man kann die 4 ports analog eintragen:

    ip nat inside source static udp 192.168.0.5 16384 interface Dialer21 16384
    ip nat inside source static udp 192.168.0.5 16385 interface Dialer21 16385
    ip nat inside source static udp 192.168.0.5 16386 interface Dialer21 16386
    ip nat inside source static udp 192.168.0.5 16387 interface Dialer21 16387
     
  7. ShiningStar

    ShiningStar Neuer User

    Registriert seit:
    23 Juli 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    also meine config sieht nun wie folgt aus. Ins i net komme ich, telefonieren oder angerufen werden geht noch immer nicht:

    sh conf
    Using 2598 out of 29688 bytes
    !
    ! Last configuration change at 22:44:20 UTC Thu Aug 11 2005
    ! NVRAM config last updated at 22:44:22 UTC Thu Aug 11 2005
    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 xxx
    enable password xxx
    !
    ip subnet-zero
    !
    !
    !
    ip audit notify log
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    ip mtu adjust
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    description T-DSL Hello world
    no ip address
    ip access-group 100 in
    ip mtu 1492
    ip nat outside
    no ip mroute-cache
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 21
    no cdp enable
    !
    interface FastEthernet0
    description inside Lan
    ip address 192.168.0.1 255.255.255.0
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip tcp adjust-mss 1452
    no ip mroute-cache
    speed auto
    full-duplex
    no cdp enable
    !
    interface Dialer21
    description Dialerinterface dsl
    ip address negotiated
    ip access-group 100 in
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 21
    dialer-group 2
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxx#0001@t-online.de password 0 xxx
    ppp ipcp dns request
    !
    ip nat inside source list 101 interface Dialer21 overload
    ip nat inside source static tcp 192.168.0.5 5060 interface Dialer21 5060
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer21
    ip http server
    !
    !
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any packet-too-big
    access-list 100 permit icmp any any echo
    access-list 100 permit icmp any any ttl-exceeded
    access-list 100 permit tcp any any established
    access-list 100 permit udp any eq domain any
    access-list 100 permit udp any eq ntp any
    access-list 101 permit udp any any eq ntp
    access-list 101 permit udp any any eq domain
    access-list 101 permit tcp any any eq smtp
    access-list 101 permit tcp any any eq pop3
    access-list 101 permit tcp any any eq 143
    access-list 101 permit tcp any any eq www
    access-list 101 permit tcp any any eq 443
    access-list 101 permit udp any any eq 5060
    access-list 101 permit udp any any range 16384 32766
    access-list 101 permit tcp any any range 16384 32766
    dialer-list 2 protocol ip list 101
    no cdp run
    !
    snmp-server community xxx
    snmp-server enable traps tty
    !
    line con 0
    line aux 0
    line vty 0 4
    password xxx
    login
    !
    ntp clock-period 17179790
    ntp server 192.53.103.104
    ntp server 129.69.1.153
    ntp server 130.149.17.8
    ntp server 131.188.3.220
    end

    Ich weiss nich wie ich den rtp stream weiter leiten soll, oder was schief geht... irgendwie geht das mit dem telefon nicht. Helft mir bitte
     
  8. ShiningStar

    ShiningStar Neuer User

    Registriert seit:
    23 Juli 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    problem ist auch das mein telefon immer nur die standart media ports nimmt und ich daran leider nichts ändern kann... ich kann doch keine 1000 nat einträge nur für das tele machen... das is n höllen act....
     
  9. ShiningStar

    ShiningStar Neuer User

    Registriert seit:
    23 Juli 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    sodele, config update gemacht... siehe da, nun kann ich zwar anrufen, er verbindet, aber hören tue ich nichts, auch zeigt das telefon mir kein datum und uhrzeit mehr an und angerufen werden kann ich auch nicht. Mein router hat folgende config:

    sh conf
    Using 3269 out of 29688 bytes
    !
    ! Last configuration change at 03:03:43 UTC Fri Aug 12 2005
    ! NVRAM config last updated at 03:03:45 UTC Fri Aug 12 2005
    !
    version 12.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 xxx
    enable password xxx
    !
    ip subnet-zero
    !
    !
    !
    ip audit notify log
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group 1
    request-dialin
    protocol pppoe
    ip mtu adjust
    !
    !
    !
    !
    !
    !
    interface Ethernet0
    description T-DSL Hello world
    no ip address
    ip access-group 100 in
    ip mtu 1492
    ip nat outside
    no ip mroute-cache
    half-duplex
    pppoe enable
    pppoe-client dial-pool-number 21
    no cdp enable
    !
    interface FastEthernet0
    description inside Lan
    ip address 192.168.0.1 255.255.255.0
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip tcp adjust-mss 1452
    no ip mroute-cache
    speed auto
    full-duplex
    no cdp enable
    !
    interface Dialer21
    description Dialerinterface dsl
    ip address negotiated
    ip access-group 100 in
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    no ip mroute-cache
    dialer pool 21
    dialer-group 2
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxx#0001@t-online.de password 0 xxx
    ppp ipcp dns request
    !
    ip nat inside source list 101 interface Dialer21 overload
    ip nat inside source static udp 192.168.0.5 5005 interface Dialer21 5005
    ip nat inside source static udp 192.168.0.5 5004 interface Dialer21 5004
    ip nat inside source static udp 192.168.0.5 5060 interface Dialer21 5060
    ip nat inside source static udp 192.168.0.5 16387 interface Dialer21 16387
    ip nat inside source static udp 192.168.0.5 16386 interface Dialer21 16386
    ip nat inside source static udp 192.168.0.5 16385 interface Dialer21 16385
    ip nat inside source static udp 192.168.0.5 16384 interface Dialer21 16384
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer21
    ip http server
    !
    !
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any packet-too-big
    access-list 100 permit icmp any any echo
    access-list 100 permit icmp any any ttl-exceeded
    access-list 100 permit tcp any any established
    access-list 100 permit udp any eq domain any
    access-list 100 permit udp any eq ntp any
    access-list 100 permit udp any any range 16384 32766
    access-list 100 permit udp any any range 16384 16387
    access-list 100 permit udp any any eq 5004
    access-list 100 permit udp any any eq 5005
    access-list 100 permit udp any any eq 5060
    access-list 100 permit udp any eq 5060 any
    access-list 101 permit udp any any eq ntp
    access-list 101 permit udp any any eq domain
    access-list 101 permit tcp any any eq smtp
    access-list 101 permit tcp any any eq pop3
    access-list 101 permit tcp any any eq 143
    access-list 101 permit tcp any any eq www
    access-list 101 permit tcp any any eq 443
    access-list 101 permit udp any any eq 5060
    access-list 101 permit udp any any range 16384 16387
    dialer-list 2 protocol ip list 101
    no cdp run
    !
    snmp-server community Router
    snmp-server enable traps tty
    !
    line con 0
    line aux 0
    line vty 0 4
    password xxx
    login
    !
    ntp clock-period 17179785
    ntp server 192.53.103.104
    ntp server 129.69.1.153
    ntp server 130.149.17.8
    ntp server 131.188.3.220
    end


    Die config meines cp-7960, sipstandart.cnf:

    # SIP Default Generic Configuration File
    ########################################
    # Image Version
    # Je nachdem welche Image Version Verwendung findet,
    # den Eintrag entsprechend abaendern...
    image_version: P0S3-07-4-00

    # Proxy Server
    proxy1_address: "sipgate.de" ; Can be dotted IP or FQDN
    proxy2_address: "sipsnip.com" ; Can be dotted IP or FQDN
    proxy3_address: "sipgate.de" ; Can be dotted IP or FQDN
    proxy4_address: "" ; Can be dotted IP or FQDN
    proxy5_address: "" ; Can be dotted IP or FQDN
    proxy6_address: "" ; Can be dotted IP or FQDN

    # Proxy Server Port (default - 5060)
    proxy1_port: 5060
    proxy2_port: 5060
    proxy3_port: 5060
    proxy4_port: 5060
    proxy5_port: 5060
    proxy6_port: 5060

    # Proxy Registration (0-disable (default), 1-enable)
    proxy_register: 1

    # Phone Registration Expiration [1-3932100 sec] (Default - 3600)
    timer_register_expires: 500

    # Codec for media stream (g711ulaw (default), g711alaw, g729a)
    preferred_codec: g711ulaw

    # TOS bits in media stream [0-5] (Default - 5)
    tos_media: 5

    # Inband DTMF Settings (0-disable, 1-enable (default))
    dtmf_inband: 1

    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt )
    dtmf_outofband: avt

    # DTMF dB Level Settings (1-6dB down, 2-3db down, 3-nominal (default), 4-3db up, 5-6dB up)
    dtmf_db_level: 3

    # SIP Timers
    timer_t1: 500 ; Default 500 msec
    timer_t2: 4000 ; Default 4 sec
    sip_retx: 10 ; Default 10
    sip_invite_retx: 6 ; Default 6
    timer_invite_expires: 180 ; Default 180 sec

    ####### New Parameters added in Release 2.0 #######

    # Dialplan template (.xml format file relative to the TFTP root directory)
    dial_template: dialplan

    # TFTP Phone Specific Configuration File Directory
    tftp_cfg_dir: "" ; Example: ./sip_phone/

    # Time Server (There are multiple values and configurations refer to Admin Guide for Specifics)
    sntp_server: "ntp.sipgate.net" ; SNTP Server IP Address
    sntp_mode: directedbroadcast ; unicast, multicast, anycast, or directedbroadcast (default)
    time_zone: CET ; Time Zone Phone is in
    dst_offset: 1 ; Offset from Phone's time when DST is in effect
    dst_start_month: April ; Month in which DST starts
    dst_start_day: "" ; Day of month in which DST starts
    dst_start_day_of_week: Sun ; Day of week in which DST starts
    dst_start_week_of_month: 1 ; Week of month in which DST starts
    dst_start_time: 02 ; Time of day in which DST starts
    dst_stop_month: Oct ; Month in which DST stops
    dst_stop_day: "" ; Day of month in which DST stops
    dst_stop_day_of_week: Sunday ; Day of week in which DST stops
    dst_stop_week_of_month: 8 ; Week of month in which DST stops 8=last week of month
    dst_stop_time: 2 ; Time of day in which DST stops
    dst_auto_adjust: 1 ; Enable(1-Default)/Disable(0) DST automatic adjustment
    time_format_24hr: 1 ; Enable(1 - 24Hr Default)/Disable(0 - 12Hr)
    date_format: D-M-YY ; Dateformat Day, month, year

    # Do Not Disturb Control (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    dnd_control: 0 ; Default 0 (Do Not Disturb feature is off)

    # Caller ID Blocking (0-disbaled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    callerid_blocking: 0 ; Default 0 (Disable sending all calls as anonymous)

    # Anonymous Call Blocking (0-disabled, 1-enabled, 2-disabled no user control, 3-enabled no user control)
    anonymous_call_block: 0 ; Default 0 (Disable blocking of anonymous calls)

    # DTMF AVT Payload (Dynamic payload range for AVT tones - 96-127)
    dtmf_avt_payload: 101 ; Default 101

    # Sync value of the phone used for remote reset
    sync: 1 ; Default 1
    ####### New Parameters added in Release 2.1 #######

    # Backup Proxy Support
    proxy_backup: "" ; Dotted IP of Backup Proxy
    proxy_backup_port: 5060 ; Backup Proxy port (default is 5060)

    # Emergency Proxy Support
    proxy_emergency: "" ; Dotted IP of Emergency Proxy
    proxy_emergency_port: 5060 ; Emergency Proxy port (default is 5060)

    # Configurable VAD option
    enable_vad: 0 ; VAD setting 0-disable (Default), 1-enable

    ####### New Parameters added in Release 2.2 ######
    # NAT/Firewall Traversal
    nat_enable: 1 ; 0-Disabled (default), 1-Enabled
    nat_address: "192.168.0.1" ; WAN IP address of NAT box (dotted IP or DNS A record only)
    voip_control_port: 5060 ; UDP port used for SIP messages (default - 5060)
    start_media_port: 16384 ; Start RTP range for media (default - 16384)
    end_media_port: 16387 ; End RTP range for media (default - 32766)
    nat_received_processing: 1 ; 0-Disabled (default), 1-Enabled

    # Outbound Proxy Support
    outbound_proxy: "" ; restricted to dotted IP or DNS A record only
    outbound_proxy_port: 5060 ; default is 5060
    ####### New Parameter added in Release 3.0 #######

    # Allow for the bridge on a 3way call to join remaining parties upon hangup
    cnf_join_enable : 1 ; 0-Disabled, 1-Enabled (default)

    ####### New Parameters added in Release 3.1 #######

    # Allow Transfer to be completed while target phone is still ringing
    semi_attended_transfer: 1 ; 0-Disabled, 1-Enabled (default)

    # Telnet Level (enable or disable the ability to telnet into the phone)
    telnet_level: 1 ; 0-Disabled (default), 1-Enabled, 2-Privileged

    ####### New Parameters added in Release 4.0 #######
    # XML URLs
    services_url: "http://www.fo-pa.de/cgi-bin/rss2cisco.pl" ; URL for external Phone Services
    directory_url: "//niels/tftp-root/directory.xml" ; URL for external Directory location
    logo_url: "" ; URL for branding logo to be used on phone display

    # HTTP Proxy Support
    http_proxy_addr: "" ; Address of HTTP Proxy server
    http_proxy_port: 80 ; Port of HTTP Proxy Server (80-default)

    # Dynamic DNS/TFTP Support
    dyn_dns_addr_1: "" ; restricted to dotted IP
    dyn_dns_addr_2: "" ; restricted to dotted IP
    dyn_tftp_addr: "" ; restricted to dotted IP

    # Remote Party ID
    remote_party_id: 0 ; 0-Disabled (default), 1-Enabled

    ####### New Parameters added in Release 4.4 #######

    # Call Hold Ringback (0-off, 1-on, 2-off with no user control, 3-on with no user control)
    call_hold_ringback: 0 ; Default 0 (Call Hold Ringback feature is off)

    ####### New Parameters added in Release 6.0 #######

    # Dialtone Stutter for MWI (Message Waiting Indicator)
    #**** 0-abgeschaltet
    #**** 1-eingeschaltet
    stutter_msg_waiting: 1 ; 0-Disabled (default), 1-Enabled

    # RTP Call Statistics (SIP BYE/200 OK message exchange)
    #**** 0-abgeschaltet
    #**** 1-eingeschaltet
    call_stats: 1 ; 0-Disabled (default), 1-Enabled

    # Telefonnummern automatisch vervollstaendigen (macht bei mir Probleme, also aus)
    #**** 0-abgeschaltet
    #**** 1-eingeschaltet


    Ein problem ist es auch, das start media und end media port nicht so wie in der config auch im telefon stehen, weil der partut nicht belehren lassen will, doch meine vorgaben zu verwenden, lieber benutzt er da seine standartports... ich hoffe nicht, das ich 1600 einzelne ports freischalten muss, das mein telefon geht.

    Helft mir bitte, so langsam bin ich am verzweifeln....