.titleBar { margin-bottom: 5px!important; }

Kein Freizeichen am Analog-Telefon

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von jcrocholl, 9 Feb. 2005.

  1. jcrocholl

    jcrocholl Neuer User

    Registriert seit:
    8 Feb. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Guten Abend,

    ich versuche bisher erfolglos, ein Analog-Telefon am Asterisk mit HFC-Karte im NT-Modus zu benutzen. Ich habe keinen öffentlichen ISDN- oder Telefonanschluss, sondern telefoniere bisher über VoIP mit einem SoftPhone auf einem anderen Rechner. Der Internetzugang bei uns im Studentenwohnheim wird vom BelWue zur Verfügung gestellt und ist super schnell und breit.

    Bisher kriege ich an den Analogtelefonen kein Freizeichen (Wählton). Auch das Anrufen vom Asterisk zum Analogtelefon funktioniert nicht.

    Allerdings: wenn ich ein Analogtelefon abhebe, erscheint auf der Asterik-Console folgende Meldung 3 mal im Abstand von einer Sekunde. Diese Meldungen kommen auch, wenn der Asterisk gar nicht läuft.

    zaphfc card 0 rx 8 bytes: [ 0xab 0xcd hexadezimale Bytes ... ]
    zaphfc card 0 rx 2 bytes: [ 0xab 0xcd ]

    Was muss ich tun, um an der ISDN-Anlage ein Freizeichen zu kriegen?

    Bisher sieht das bei mir so aus:
    800 MHz Serverkiste mit Debian Sarge
    Asterisk 1.0.3 (siehe Signatur)
    HFC-Karte von Sitecom (PCI-Anschluss)
    NTBA mit fest verdrahtetem Crosskabel und Stromversorgung
    ISDN-Anlage TA33 von DeTeWe
    1. Analog-Telefon: W38 von RFT (altes schwarzes Bakelit-Telefon mit Wählscheibe)
    2. Analog-Telefon: Philips Aloris (schnurlos aber kein DECT)

    /etc/asterisk/zapata.conf:
    Code:
    [channels]
    switchtype = euroisdn
    signalling = bri_net_ptmp
    pridialplan = local
    prilocaldialplan = local
    echocancel = yes
    overlapdial = no
    immediate = no
    usecallerid = yes
    group = 1
    context = voipout
    channel => 1-2
    
    /etc/asterisk/extensions.conf:
    Code:
    [general]
    static=yes
    writeprotect=yes
    
    [macro-callwithmsn]
    exten => s,1,SetCallerID(${ARG2})
    exten => s,2,SetCIDName(${ARG3})
    exten => s,3,Dial(${ELMEG}/0${ARG1},60,Ttr)
    exten => s,104,Playtones(busy);
    exten => s,105,Busy
    
    [macro-callwithvoip]
    exten => s,1,SetCallerID(${ARG2})
    exten => s,2,SetCIDName(${ARG3})
    exten => s,3,Dial(SIP/${ARG1}@sipgate,60,Ttr)
    exten => s,104,Playtones(busy);
    exten => s,105,Busy
    
    [voipout-1111]
    exten => _.,1,Macro(callwithmsn,${EXTEN},11,name1)
    exten => _1*.,1,Macro(callwithvoip,${EXTEN},11,name1)
    
    [voipout-2222]
    exten => _.,1,Macro(callwithmsn,${EXTEN},22,name2)
    exten => _1*.,1,Macro(callwithvoip,${EXTEN},22,name2)
    
    [voipout]
    exten => s,1,NoOP
    exten => _X.,1,Goto(voipout-${CALLERIDNUM},${EXTEN},1)
    
    [local]
    import => voipout
    
    /etc/zaptel.conf:
    Code:
    defaultzone=nl
    loadzone=nl
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    
    Für alle sachdienlichen Hinweise vielen Dank im Voraus!
    Johann