.titleBar { margin-bottom: 5px!important; }

Kein Wählton/Freizeichen an HFC-S mit NTBA und ISDN-Fon

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von *-tuxi, 16 Okt. 2005.

  1. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hallo Leute,

    ich habe jetzt meine Versuche erstmal aufgegeben, Asterisk und den ganzen Kram selber zu kompilieren. Haut nicht hin mit SUSE 10 und gcc 4.x.
    Ich habe also nun den mitglieferten asterisk-Kram von der SUSE 10-DVD genommen. Dort ist natürlich kein florz-Patch drin, aber was solls... wenn's dann überhaupt mal ein bissl funktioniert, kann man ja immer noch weitersehen...

    Mein Problem: Ich bekomme kein Freizeichen/keinen Wählton, wenn ich das ISDN-Telefon abhebe, welches am NTBA (zwecks Speisespannung) angeschlossen ist, dieser wiederum mit ISDN-cross zur HFC Karte (2x Conrad HFC (Asuscom/Billion) im Rechner).

    Ich habe genau so angeschlossen, wie man hier sieht:
    http://www.pro-linux.de/work/asterisk/jpgs/setup.png
    Das Bild ist aus dem Pro-Linux Artikel:
    http://www.pro-linux.de/work/asterisk/asterisk-1.html

    Das Cross-Kabel habe ich zwei Mal hergestellt, einmal nach Schema in der c't 12/2005 (Mai) und nach dem Artikel auf pro-linux.de.
    Skizze in der c't ist halt sehr auslegungsfähig, pro-linux.de ist da deutlicher.
    Ich habe also 3-4 unter einander gekreuzt und 5-6 unter einander gekreuzt. (nach pro-linux.de)
    Das Kabel benutze ich zur Zeit zwischen NTBA und HFC card 1 (card0 -> T-Com-NTBA)

    Nun, wie gesagt, ich höre nichts und kann auch nichts anwählen.
    Der zaphfc-Treiber ist geladen (ebenso zaptel), ztcfg wurde ausgeführt und 6 Kanäle sind konfiguriert, /dev/zap/1 und /dev/zap/2 spucken nur Müll aus, wenn Asterisk läuft, bringt ein cat auf den beiden devices nur, dass ebensolche "busy" sind - asterisk hat sie sich ja auch geholt...

    Hier meine aktuellen configs:

    Code:
    sip:/etc #
    sip:/etc #
    sip:/etc # cat zaptel.conf
    #
    # Zaptel Configuration File
    #
    # This file is parsed by the Zaptel Configurator, ztcfg
    #
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    
    span=2,1,3,ccs,ami
    bchan=4-5
    dchan=6
    
    #loadzone=nl
    #loadzone = us
    #loadzone = us-old
    #loadzone=gr
    #loadzone=it
    #loadzone=fr
    #loadzone=de
    #loadzone=uk
    #loadzone=fi
    #loadzone=jp
    #loadzone=sp
    #loadzone=no
    defaultzone=nl
    sip:/etc #
    sip:/etc #
    sip:/etc #
    

    Code:
    sip:/etc/asterisk #
    sip:/etc/asterisk #
    sip:/etc/asterisk # cat zapata.conf
    ;
    ; Zapata telephony interface
    ;
    ; Configuration file
    
    [trunkgroups]
    
    [channels]
    
    ; 1. Karte
    signalling=bri_cpe_ptmp ;muss mit der durch modes in Makefile gemachten Einstellung ereistimmen.
    pridialplan=national
    prilocaldialplan=national
    echocancel=yes
    immediate=yes
    usecallingpres=yes
    overlapdial=yes
    group=1
    context=default
    channel => 1-2
    
    ; 2. Karte
    switchtype=euroisdn
    signalling=bri_net_ptmp
    pridialplan=national
    prilocaldialplan=national
    echocancel=yes
    immediate=yes
    usecallingpres=yes
    overlapdial=yes
    group=2
    context=default
    channel => 4-5
    sip:/etc/asterisk #
    sip:/etc/asterisk #
    

    Code:
    sip:/etc/asterisk # cat modules.conf
    ;
    ; Asterisk configuration file
    ;
    ; Module Loader configuration file
    ;
    
    [modules]
    autoload=yes
    ;
    ; If you want, load the GTK console right away.
    ; Don't load the KDE console since
    ; it's not as sophisticated right now.
    ;
    noload => pbx_gtkconsole.so
    ;load => pbx_gtkconsole.so
    noload => pbx_kdeconsole.so
    ;
    ; Intercom application is obsoleted by
    ; chan_oss.  Don't load it.
    ;
    noload => app_intercom.so
    ;
    ; Explicitly load the chan_modem.so early on to be sure
    ; it loads before any of the chan_modem_* 's afte rit
    ;
    load => res_features.so
    load => res_musiconhold.so
    load => chan_modem.so
    load => chan_zap.so
    ;
    ; Load either OSS or ALSA, not both
    ; By default, load OSS only (automatically) and do not load ALSA
    ;
    noload => chan_alsa.so
    ;noload => chan_oss.so
    ;
    ; Module names listed in "global" section will have symbols globally
    ; exported to modules loaded after them.
    ;
    [global]
    res_features.so=yes
    chan_modem.so=yes
    chan_zap.so=yes
    ;chan_capi.so=yessip:/etc/asterisk #
    sip:/etc/asterisk #
    sip:/etc/asterisk #
    

    Code:
    *CLI>
    *CLI> pri show span 1
    Primary D-channel: 3
    Status: Provisioned, Down, Active
    Switchtype: National ISDN
    Type: CPE (PtMP)
    Window Length: 0/7
    Sentrej: 0
    SolicitFbit: 0
    Retrans: 0
    Busy: 0
    Overlap Dial: -1
    
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI> pri show span 2
    Primary D-channel: 6
    Status: Provisioned, Up, Active
    Switchtype: EuroISDN
    Type: Network (PtMP)
    Overlap Dial: -1
    
    *CLI>
    *CLI>
    *CLI> zap show channels
       Chan Extension  Context         Language   MusicOnHold
     pseudo            default
          1            default
          2            default
          4            default
          5            default
    *CLI>
    *CLI>
    *CLI> zap show channel 1
    Channel: 1
    File Descriptor: 8
    Span: 1
    Extension:
    Dialing: no
    Context: default
    Caller ID string:
    Destroy: 0
    InAlarm: 1
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    Echo Cancellation: 128 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    *CLI>
    *CLI>
    *CLI>
    *CLI> zap show channel 2
    Channel: 2
    File Descriptor: 9
    Span: 1
    Extension:
    Dialing: no
    Context: default
    Caller ID string:
    Destroy: 0
    InAlarm: 1
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    Echo Cancellation: 128 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI> zap show channel 4
    Channel: 4
    File Descriptor: 10
    Span: 2
    Extension:
    Dialing: no
    Context: default
    Caller ID string:
    Destroy: 0
    InAlarm: 0
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    Echo Cancellation: 128 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI> zap show channel 5
    Channel: 5
    File Descriptor: 11
    Span: 2
    Extension:
    Dialing: no
    Context: default
    Caller ID string:
    Destroy: 0
    InAlarm: 0
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    Echo Cancellation: 128 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI> zap show channel 4
    Channel: 4
    File Descriptor: 10
    Span: 2
    Extension:
    Dialing: no
    Context: default
    Caller ID string:
    Destroy: 0
    InAlarm: 0
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    Echo Cancellation: 128 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI> zap show channel 5
    Channel: 5
    File Descriptor: 11
    Span: 2
    Extension:
    Dialing: no
    Context: default
    Caller ID string:
    Destroy: 0
    InAlarm: 0
    Signalling Type: PRI Signalling
    Owner: <None>
    Real: <None>
    Callwait: <None>
    Threeway: <None>
    Confno: -1
    Propagated Conference: -1
    Real in conference: 0
    DSP: no
    Relax DTMF: no
    Dialing/CallwaitCAS: 0/0
    Default law: alaw
    Fax Handled: no
    Pulse phone: no
    Echo Cancellation: 128 taps unless TDM bridged, currently OFF
    PRI Flags:
    PRI Logical Span: Implicit
    Actual Hookstate: Onhook
    *CLI>
    *CLI>
    *CLI>
    

    /etc/asterisk/extensions.conf habe ich so gelassen, also Original-SUSE/Asterisk-config.

    Brauche Eure Hilfe! Echt, komme nicht weiter, was ist zu tun? Wo ist der Fehler/sind die Fehler??? Heeelp! :shock: :shock: :shock: :shock: :shock: :?: :?: :?: :?: :cry: :cry: :cry: :cry: :cry: :cry: :evil: :evil: :evil: :evil: :evil: :evil:

    Michael
     
  2. DeepBlueGermany

    DeepBlueGermany Neuer User

    Registriert seit:
    9 Okt. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    intern kein Freizeichen & zaphfc: empty HDLC frame or ba

    Hallo!

    Ich habe hier ein ähnliches Problem und weiß absolut nicht, wie ich das in Griff bekommen soll.
    Ich habe nur eine HFC-S Karte in meinem Rechner und will die externen Gespräche über eine AVM Fritz abwickeln.
    Ich habe hier eine SuSE 9.3 installiert und nutze das mitgelieferte Asterisk.
    zaptel.conf und zapata.conf sind ähnlich wie beim Vorgänger und die capi.conf ist zusätzlich erstellt.
    Wenn ich asterisk mit dem Sample für die extensions.conf starte und mit dem Handy extern anrufe erhalte ich die Begrüßung. Also extern alles IO.
    Hebe ich mein ISDN Telefon intern ab, habe ich wie mein Vorgänger auch kein Freizeichen und nach einer gewissen Zeit Störung auf dem Display stehen.

    Nutze ich meine eigene extensions.conf, versucht Asterisk meinen externen Anruf intern zu vermitteln. Dabei erhalte ich folgende Fehlermeldung:
    -- Called g1/12345
    -- Channel 0/1, span 1 got hangup
    -- Zap/1-1 is circuit-busy
    -- Hungup 'Zap/1-1'

    dmesg zeigt mir folgende Fehlermeldung:
    zaphfc: empty HDLC frame or bad CRC received (....).

    Wo liegt der Fehler?
    Vielen Dank für eure Hilfe!!!

    Grüße DeepBlue
     
  3. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ich habe nun * ein wenig laufen gelassen und bekomme alle paar Stunden unperiodisch diesen Fehler auf dem * CLI:

    Code:
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
    Oct 16 19:28:31 NOTICE[6050]: chan_zap.c:7819 pri_dchannel: PRI got event: HDLC Abort (6) on Primary D-channel of span 1
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
        -- parse_srv: SRV mapped to host sipgate.de, port 5060
    
    Was hat das zu bedeuten?

    Trotzdessen bin ich bei meinem Problem immer noch kein Stück weitergekommen...
    Weiss denn niemand etwas dazu zu schreiben?

    Michael
     
  4. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi,

    ich bin's nochmal... ;-)
    Hat wirklich nieeeemand eine Idee, warum ich kein Freizeichen kriege?
    Was läuft bei mir anders als bei anderen, wieso krieg ich das alles nicht hin??

    Bin wirklich für jeden Tip dankbar!!

    Michael
     
  5. uweh

    uweh Neuer User

    Registriert seit:
    7 Aug. 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @Michael

    Ist die HFC Karte sicher im NT mode?

    insmod /usr/src/junghanns/bristuff/zaphfc/zaphfc.o modes=1

    In diesem thread ist das alles ausführlichst erklärt.

    http://www.ip-phone-forum.de/forum/viewtopic.php?t=26177&highlight=hfc+nt

    Wenn's dann immer noch nicht klappt müsste man mal die zaptel.conf und die zapata.conf vergleichen.

    Bei mir laufen 3 HFC Karten - 1 im NT Modus.

    -Uwe
     
  6. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    @uweh:

    Ja, Karte ist sicher im NT-Modus, mit folgender Anweisung geladen:

    Code:
    modprobe zaptel
    modprobe zaphfc modes=2 debug=1
    ztcfg
    
    zttool sagt ebenfalls, dass card0=TE hat, card1=NT.
    card0 geht zum T-Com-NTBA (CAT5-Kabel, 1:1 beschaltet), card1 geht mit ISDN-cross-Kabel zum 2. NTBA, der am Stromnetz hängt. An diesem 2. NTBA hängt das ISDN-Fon (T-Europa 11a) dran. Strom bekommt das Telefon korrekt, nur kein Freizeichen/Wählton, wie man es auch immer nennen möchte...

    Hilfe hilfe hilfe!!! ;-)

    Michael
     
  7. uweh

    uweh Neuer User

    Registriert seit:
    7 Aug. 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @*-tuxi

    Leg' doch bitte mal die zapata.conf hier rein. dann kann ich die mit meiner vergleichen wenn ich zu Hause bin.

    Das muss doch hinzukriegen sein :bluescre:

    edit: hier ist das Wichtigste aus meiner zapata.conf zum Vergleichen
    Code:
    ;
    ; Zapata telephony interface
    ;
    ; Configuration file
    
    [trunkgroups]
    
    [channels]
    
    language=de
    switchtype = euroisdn
    
    pridialplan = dynamic
    prilocaldialplan = local
    nationalprefix = 0
    internationalprefix = 00
    
    overlapdial=yes
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=no
    echotraining=no
    rxgain=0.0
    txgain=0.0
    immediate=no
    callerid=asreceived
    
    ;-------------------------------
    ; ptmp NT mode
    ;-------------------------------
    
    signalling = bri_net_ptmp
    context = from-internal
    
    group = 0
    channel => 1-2
    
    ;-------------------------------------------
    ; p2mp TE
    ;-------------------------------------------
    signalling = bri_cpe_ptmp
    context = from-pstn
    group = 1
    channel => 4-5 
    
    -Uwe
     
  8. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi Uwe,

    danke für Deine Antwort, meine zapata.conf ist in meinem ersten Posting (ganz oben) mit drin, es ist der zweite CODE-Kasten...
    Weiss sonst niemand etwas??
    Hier sind doch wirklich sooo viele Leute unterwegs, die Asterisk-cracks sind... Wo seid ihr alle??? ;-) Hiiiiilfe!! ;-)

    Michael
     
  9. uweh

    uweh Neuer User

    Registriert seit:
    7 Aug. 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Michael,

    hast Du schon mal einen bri intense debug span 2 probiert? Bei mir ist der NT Span auf der Nummer 1. Wenn ich den Debug einschalte und den Hörer an der ISDN Extension 47 abnehme kommt so was.

    Code:
    Verbosity is at least 3
    asterisk*CLI> bri intense debug span 1
    Enabled EXTENSIVE debugging on span 1
    asterisk*CLI>
    < [ 00 83 b8 56 08 01 01 05 04 03 80 90 a3 6c 04 00 80 34 37 7d 02 91 81 ]
    
    < Informational frame:
    < SAPI: 00  C/R: 0 EA: 0
    <  TEI: 065        EA: 1
    < N(S): 092   0: 0
    < N(R): 043   P: 0
    < 19 bytes of data
    -- ACKing all packets from 42 to (but not including) 43
    -- Since there was nothing left, stopping T200 counter
    -- Stopping T203 counter since we got an ACK
    -- Nothing left, starting T203 counter
    < Protocol Discriminator: Q.931 (8)  len=19
    < Call Ref: len= 1 (reference 1/0x1) (Originator)
    < Message type: SETUP (5)
    < [04 03 80 90 a3]
    < Bearer Capability (len= 5) [ Ext: 1  Q.931 Std: 0  Info transfer capability: Speech (0)
    <                              Ext: 1  Trans mode/rate: 64kbps, circuit-mode (16)
    <                              Ext: 1  User information layer 1: A-Law (35)
    < [6c 04 00 80 34 37]
    < Calling Number (len= 6) [ Ext: 0  TON: Unknown Number Type (0)  NPI: Unknown Number Plan (0)
    <                           Presentation: Presentation permitted, user number not screened (0) '47' ]
    < [7d 02 91 81]
    < IE: High-layer Compatibility (len = 4)
    Sending Receiver Ready (93)
    
    > [ 00 83 01 ba ]
    
    > Supervisory frame:
    > SAPI: 00  C/R: 0 EA: 0
    >  TEI: 065        EA: 1
    > Zero: 0     S: 0 01: 1  [ RR (receive ready) ]
    > N(R): 093 P/F: 0
    > 0 bytes of data
    -- Restarting T203 counter
    -- Restarting T203 counter
    
    > [ 02 83 56 ba 08 01 81 0d 18 01 8a 1e 02 81 88 ]
    
    > Informational frame:
    > SAPI: 00  C/R: 1 EA: 0
    >  TEI: 065        EA: 1
    > N(S): 043   0: 0
    > N(R): 093   P: 0
    > 11 bytes of data
    -- Restarting T203 counter
    Stopping T_203 timer
    Starting T_200 timer
    > Protocol Discriminator: Q.931 (8)  len=11
    > Call Ref: len= 1 (reference 129/0x81) (Terminator)
    > Message type: SETUP ACKNOWLEDGE (13)
    > [18 01 8a]
    > Channel ID (len= 3) [ Ext: 1  IntID: Implicit, Other Spare: 0, Exclusive Dchan: 0
    >                        ChanSel: B2 channel
                             ]
    > [1e 02 81 88]
    > Progress Indicator (len= 4) [ Ext: 1  Coding: CCITT (ITU) standard (0) 0: 0   Location: Private network serving the local user (1)
    >                               Ext: 1  Progress Description: Inband information or appropriate pattern now available. (8) ]
        -- Starting simple switch on 'Zap/2-1'
        -- Accepting overlap voice call from '47' to '<unspecified>' on channel 0/2, span 1
    asterisk*CLI>
    
    Danach höre ich den Wählton. Was wird bei Dir angezeigt? Ich hoffe mal auf eine Meldung, mit der man was anfangen kann.

    Mir fällt noch etwas ein: während meiner Spielphase habe ich den * öfters neu gestartet und hatte hin und wieder auch keinen Wählton auf dem internen ISDN. Ich musste dann das Telefon booten (power off/on). Hast Du das Telefon schon mal bei laufendem * neu gestartet?

    -Uwe
     
  10. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hi Uwe,

    das ging ja schnell! ;-)
    Habe nun das debug mal eingeschaltet.
    Erst auf span=1 dann auf span=2.
    Danach jeweils den Hörer abgenommen.
    Kein Ton, kein gar nichts...

    Code:
    *CLI> bri intense debug span 1
    Enabled EXTENSIVE debugging on span 1
    *CLI>
    *CLI>
    *CLI>
    Sending TEI Request ri=26352
    
    > [ fc ff 03 0f 66 f0 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=38731
    
    > [ fc ff 03 0f 97 4b 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=50294
    
    > [ fc ff 03 0f c4 76 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=300
    
    > [ fc ff 03 0f 01 2c 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=42000
    
    > [ fc ff 03 0f a4 10 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=48164
    
    > [ fc ff 03 0f bc 24 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=2414
    
    > [ fc ff 03 0f 09 6e 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=36906
    
    > [ fc ff 03 0f 90 2a 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=26736
    
    > [ fc ff 03 0f 68 70 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=41651
    
    > [ fc ff 03 0f a2 b3 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=8923
    
    > [ fc ff 03 0f 22 db 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=51436
    
    > [ fc ff 03 0f c8 ec 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    bri intense nSending TEI Request ri=732
    
    > [ fc ff 03 0f 02 dc 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=56650
    
    > [ fc ff 03 0f dd 4a 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=5004
    
    > [ fc ff 03 0f 13 8c 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    Sending TEI Request ri=33023
    
    > [ fc ff 03 0f 80 ff 01 ff ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 0 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    1
    Disabled debugging on span 1
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    
    Code:
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI>
    *CLI> bri intense debug span 2
    Enabled EXTENSIVE debugging on span 2
    *CLI>
    *CLI>
    *CLI>
    
    Auf span 2 passiert also gar nichts... Nix versteh... :-?

    Sagt Dir das etwas?? Mir nicht wirklich... ;-)

    Michael
     
  11. udosw

    udosw Aktives Mitglied

    Registriert seit:
    20 März 2004
    Beiträge:
    1,114
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Hannover
    @*-tux: Mit gcc4 geht es nicht, wurde hier auch schon gepostet. Versuch es mit gcc3 zu kompilieren.

    Zur HFC-Karte: Wie sieht bei dir die Ausgabe von ztcfg -vv aus ?

    Udo
     
  12. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    @udosw:

    Weiss ich, mit gcc4 habe ich ja das grosse Problem... Shit ist das...
    Habe aber zur Zeit die SUSE-Original-Pakete am laufen, die dabei waren (ist halt asterisk-1.0.9 & bristuff 0.2.0-RC8n natürlich ohne florz :-((( ).
    Die SUSE-Leute müssen dass Ding ja irgendwie gepatcht haben, sodass es unter gcc4 zu kompilieren ging...
    Vielleicht ist der SUSE-asterisk einfach nur broken??
    Ich habe sowieso jetzt vor, gcc3 in ein Verzeichnis zu installieren und den asterisk-Kram dagegen zu compilen... Meinst Du, das wird's bringen??

    Code:
    sip:/dev/zap #
    sip:/dev/zap #
    sip:/dev/zap # ztcfg -vv
    
    Zaptel Configuration
    ======================
    
    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 2: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    
    Channel map:
    
    Channel 01: Individual Clear channel (Default) (Slaves: 01)
    Channel 02: Individual Clear channel (Default) (Slaves: 02)
    Channel 03: D-channel (Default) (Slaves: 03)
    Channel 04: Individual Clear channel (Default) (Slaves: 04)
    Channel 05: Individual Clear channel (Default) (Slaves: 05)
    Channel 06: D-channel (Default) (Slaves: 06)
    
    6 channels configured.
    
    sip:/dev/zap #
    sip:/dev/zap #
    sip:/dev/zap #
    
    das sagt ztcfg -vv
    Was hältst Du davon?

    Michael
     
  13. turboj

    turboj Neuer User

    Registriert seit:
    14 Okt. 2005
    Beiträge:
    8
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, und die Patches sind im src-rpm von asterisk.

    Negativ. Ich habe hier * auf SuSE 10.0 und konnte sowohl rein- als auch raustelefonieren, mit 2* HFCS-PCI.
     
  14. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    @turboj:
    dann schieb doch mal bitte deine /etc/zaptel.conf und deine /etc/asterisk/zapata.conf und /etc/asterisk/modules.conf rüber.
    Was mich noch interessiert: Wie lädst Du über das SUSE-Skript "rczaptel" den zaphfc-Treiber mit der Angabe "modes=1" bzw. bei mir wäre es "modes=2" ???

    Ich komme hier nämlich absolut nicht mehr weiter, mein Telefon schweigt mich nur an (obwohl die Ruhe manchmal ja ganz erträglich ist *g*) und trete den sche*ss bald in die Tonne - wenn's nicht geht, geht's halt nicht - ich kann mich nicht vier Wochen lang von morgens bis in die Nacht hinein mit sowas beschäftigen - scheinbar ist das alles doch überhaupt nicht so ausgereift wie ich anfangs dachte...

    Michael
     
  15. uweh

    uweh Neuer User

    Registriert seit:
    7 Aug. 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das sagt mir, dass auf der Leitung rein gar nichts läuft. Bist Du sicher, daß das mit dem Kabel alles richtig ist :?:
     
  16. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
  17. uweh

    uweh Neuer User

    Registriert seit:
    7 Aug. 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Und hinter dem Fon noch ein Abschlusswiederstand?

    Hast Du ein Messgerät um die Spannungen zu messen?

    Unter Sicherheit im internet habe ich als Abbildung 12 eine Darstellung der richtigen Spannungen gefunden. Wenn da was falsch gepolt ist ...

    -Uwe
     
  18. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Hallo Uwe,

    wie kann ich so etwas (Abschlusswiderstand) realisieren? Wie gesagt, die HFC-Karte, die im NT-Modus läuft, ist über ein ISDN-cross-Kabel mit dem Zweit-NTBA verbunden. Das ISDN-Telefon habe ich mit einem normalen ISDN-Kabel an die zweite S0-Buchse vom NTBA gehängt.
    Der NTBA ist ans Stromnetz angeschlossen.

    Das Telefon bekommt Strom, nur nix Ton... Aber wie ich oben schon angedeutet hatte, einen Abschlusswiderstand habe ich nirgendwo eingebaut, ich wüsste auch nicht, wie.
    Zudem ist es doch so, dass der NTBA den Anschluss terminiert. (?)
    Diese Terminierung kann ja auch über die DIP-Schalter (DIL?) ausgeschaltet werden...

    Michael
     
  19. uweh

    uweh Neuer User

    Registriert seit:
    7 Aug. 2005
    Beiträge:
    14
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Solche Abschlußwiederständ müssten an beiden Enden des Busses sein. Das sind jeweils 100Ohm zwischen den Pins 3 und wie sowie zwsichen 5 und 6. Man kann auch was zum Stecken im Baumarkt kaufen. Der NTBA kann das eine Ende des Busses sein. Dann müsste eine Abscluß auf die andere Seite.

    Auf der Seite aus meinem vorherigen Posting kannst Du unter der Abbildungen 7 bzw. 9 Details sehen.

    Wenn der Abschluß nicht dran ist, führt das aber "nur" zu Störungen. bei Dir kommt aber gar nichts an. :?:
     
  20. *-tuxi

    *-tuxi Neuer User

    Registriert seit:
    28 Sep. 2005
    Beiträge:
    126
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Naja, die Frage, die sich mir da stellt, ist ganz einfach:
    Wie soll ich an die ZWEI Anschlüsse des NTBA's die 1.) HFC-Karte vom *, 2.) das ISDN-Telefon und 3.) einen (steckbaren) Abschlusswiderstand anbringen??

    Auch: Wieso überhaupt? Der NTBA terminiert doch... Oder doch nicht?
    Ausgeschaltet habe ich die Teriminierung mittels der DIP-Schalter jedenfalls nicht.

    Ich werde mal mein Kabel fotografieren und es hier reinstellen...

    Michael