.titleBar { margin-bottom: 5px!important; }

Kein Wählton mit ISDN-Telefon an NTBA mit HFC-Karte

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von iHawk, 1 Mai 2005.

  1. iHawk

    iHawk Neuer User

    Registriert seit:
    1 Mai 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe einen Asterisk auf einem Eisfair-Server am Laufen, allerdings mit einem dicken Problem:

    Ankommende Anrufe über SIP und CAPI funktionieren einwandfrei, aber ich kann mit dem an der HFC-Karte hängen ISDN-Telefon nicht raustelefonieren. Es kommt kein Freizeichen und das Telefon nimmt keine Tastendrücke an.
    Asterisk sagt dabei folgendes:

    == Primary D-Channel on span 1 up for TEI 64

    und nach kurzer Zeit bzw. nach dem Auflegen:

    Primary D-Channel on span 1 down for TEI 64

    und das wars. In dieser Zeit kommt in Syslog dies:

    kernel: zaphfc[0]: card TX [ 0x0 0x83 0x73 ] 3 bytes
    kernel: zaphfc[0]: received d channel frame with bad CRC.
    kernel: zaphfc[0]: received d channel frame with bad CRC.
    kernel: zaphfc[0]: card TX [ 0xfe 0xff 0x3 0xf 0x71 0x5b 0x6 0x81 ] 8 bytes
    kernel: zaphfc[0]: received d channel frame with bad CRC.

    Ein Intense Debug auf Span 1 bringt unter anderem noch dieses Ergebnis:

    Code:
    *CLI> pri intense debug span 1
    Enabled EXTENSIVE debugging on span 1
    *CLI>
    < [ fc ff 03 0f fb 10 01 ff ]
    
    < Unnumbered frame:
    < SAPI: 63  C/R: 0 EA: 0
    <  TEI: 127        EA: 1
    <   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    < 5 bytes of data
    Sending TEI assign ri=64272 tei=64
    
    > [ fe ff 03 0f fb 10 02 81 ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 1 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
    
    < [ 00 81 7f ]
    
    < Unnumbered frame:
    < SAPI: 00  C/R: 0 EA: 0
    <  TEI: 064        EA: 1
    <   M3: 3   P/F: 1 M2: 3 11: 3  [ SABME (set asynchronous balanced mode extended) ]
    < 0 bytes of data
    -- Got SABME from cpe peer.
    Sending Unnumbered Acknowledgement
    
    > [ 00 81 73 ]
    
    > Unnumbered frame:
    > SAPI: 00  C/R: 0 EA: 0
    >  TEI: 064        EA: 1
    >   M3: 3   P/F: 1 M2: 0 11: 3  [ UA (unnumbered acknowledgement) ]
    > 0 bytes of data
    -- Restarting T203 counter
      == Primary D-Channel on span 1 up for TEI 64
    T203 counter expired, sending RR and scheduling T203 again
    Sending Receiver Ready (0)
    
    > [ 02 81 01 01 ]
    
    > Supervisory frame:
    > SAPI: 00  C/R: 1 EA: 0
    >  TEI: 064        EA: 1
    > Zero: 0     S: 0 01: 1  [ RR (receive ready) ]
    > N(R): 000 P/F: 1
    > 0 bytes of data
    -- Restarting T203 counter
    -- Retrying poll with f-bit
    Sending Receiver Ready (0)
    
    > [ 02 81 01 01 ]
    
    > Supervisory frame:
    > SAPI: 00  C/R: 1 EA: 0
    >  TEI: 064        EA: 1
    > Zero: 0     S: 0 01: 1  [ RR (receive ready) ]
    > N(R): 000 P/F: 1
    > 0 bytes of data
    -- Restarting T203 counter
    -- Retrying poll with f-bit
    Sending Receiver Ready (0)
    
    > [ 02 81 01 01 ]
    
    > Supervisory frame:
    > SAPI: 00  C/R: 1 EA: 0
    >  TEI: 064        EA: 1
    > Zero: 0     S: 0 01: 1  [ RR (receive ready) ]
    > N(R): 000 P/F: 1
    > 0 bytes of data
    -- Restarting T203 counter
    -- Retrying poll with f-bit
    -- Timeout occured, restarting PRI
    Sending TEI remove tei=64
    
    > [ fe ff 03 0f cc 5d 06 81 ]
    
    > Unnumbered frame:
    > SAPI: 63  C/R: 1 EA: 0
    >  TEI: 127        EA: 1
    >   M3: 0   P/F: 0 M2: 0 11: 3  [ UI (unnumbered information) ]
    > 5 bytes of data
      == Primary D-Channel on span 1 down for TEI 64
    T203 counter expired in weird state 0 
    
    Hat irgendjemand eine Idee, was das verursachen könnte? Falls Konfigurationsdateien benötigt werden, kann ich die natürlich gerne noch posten.

    Vielen Dank schon einmal,

    iHawk
     
  2. iHawk

    iHawk Neuer User

    Registriert seit:
    1 Mai 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hat sich erledigt! Die HFC-Karte war kaputt....