Keine abgehenden Gespräche über web.de

dora71

Neuer User
Mitglied seit
25 Sep 2004
Beiträge
50
Punkte für Reaktionen
0
Punkte
0
Hallo Forum,

da ich diese Konfiguration noch nirgendwo hier gefunden habe, möchte ich folgendes Problem posten:

Habe mir Asterisk für ein Softphone (X-Lite) konfiguriert und möchte mit Vorwahlziffer "9" über Sipgate und mit der "8" über web.de telefonieren.

Ankommende Gespräche funktionieren einwandfrei, abgehend über Sipgate funktioniert es mittlerweile auch.

Nur über web.de habe ich keine Chance, sowohl ins "web.de-Netz" als auch weiter ins Festnetz.

Hat einer von Euch das Problem in den Griff bekommen?

Im CLI von Asterisk erscheint bei Anwahl über web.de immer folgende Fehlermeldung:

chan_sip.c:6576 handle_response: Failed to authenticate on INVITE to '"USERNAME" <sip:[email protected]>;tag=as2147015a'
wobei USERNAME für meinen Benutzernamen bei web.de steht.

Die sip.conf und die extensions.conf poste ich gerne hier einmal mit.

sip.conf:

Code:
[general]
port = 5060
bindaddr = 0.0.0.0
context = default
disallow=all
allow=gsm
allow=ulaw
allow=alaw
register => USERNAME:[email protected]/USERNAME
register => USERNAME:[email protected]/USERNAME

[sipgate]
type=friend
username=SIPGATENUMMER
host=sipgate.de
fromuser=SIPGATENUMMER
fromdomain=sipgate.de
nat=yes
context=default
canreinvite=no

[webde]
type=friend
username=USERNAME
host=sip.web.de
fromuser=USERNAME
fromdomain=sip.web.de
nat=yes
context=default
canreinvite=no

[3355]
type=friend
username=3355
secret=meinpasswort
host=dynamic
disallow=all
allow=ulaw
allow=alaw
dtmfmode=rfc2833
language=de
context=outgoing
Und dann noch die extensions.conf:

Code:
[general]

static=yes
writeprotected=yes

[default]
exten => 3355,1,Dial(SIP/${EXTEN},60)
exten => 3355,2,Congestion
exten => 3355,102,Busy

[outgoing]
include => default
exten => _9.,1,Dial(SIP/${EXTEN:1}@sipgate,60)
exten => _9.,2,Congestion
exten => _9.,102,Busy
exten => _8.,1,Dial(SIP/${EXTEN:1}@webde,60)
exten => _8.,2,Congestion
exten => _8.,102,Busy
Für Hilfen jeder Art wäre ich dankbar.

Viele Grüsse.

Dora71
 

wrrdlbrrmpft

Mitglied
Mitglied seit
17 Jul 2004
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Also ich habe in sip.conf:
fromdomain=web.de
Mit
fromdomain=sip.web.de
funktioniert es bei mir nicht.

Wenn das nicht hilft, bitte nochmal melden!
wrrdlbrrmpft
 

dora71

Neuer User
Mitglied seit
25 Sep 2004
Beiträge
50
Punkte für Reaktionen
0
Punkte
0
So klappt's!

Hallo zusammen,

habe mich mit einem Kollegen nochmals zusammengesetzt und bin die ganzen Config-Files durchgegangen, jetzt klappt alles.

Für alle, die damit noch Probleme haben, poste ich hier nochmal meine (funktionierende) sip.conf, mit der man über sipgate und web.de Gespräche abwickeln kann. :wink:

Code:
general]
port = 5060
bindaddr = 0.0.0.0
context = default
srvlookup=yes
disallow=all
allow=gsm
allow=ulaw
allow=alaw
insecure=very
register => sipgatenr:[email protected]/sipgatenr
register => benutzername:[email protected]/benutzername

[sipgate]
type=friend
username=sipgatenummer
host=sipgate.de
secret=passwort_sipgate
fromuser=sipgatenummer
fromdomain=sipgate.de
nat=no
context=default
canreinvite=no
qualify=yes
insecure=very

[webde]
type=friend
username=benutzername
secret=passwort_web.de
host=sip.web.de
fromuser=raidoh71
fromdomain=sip.web.de
nat=no
context=default
canreinvite=no
qualify=yes
insecure=very
Hierbei nur noch die Benutzernamen bzw. Sipgate-Rufnummer und die Passwörter abändern, dann sind die Voraussetzungen geschaffen, über web.de und sipgate.de telefonieren zu können.

Danke für Eure Hilfe.

Grüsse,

Dora71
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,364
Beiträge
2,033,278
Mitglieder
351,956
Neuestes Mitglied
einfachluk