.titleBar { margin-bottom: 5px!important; }

kleine Probleme mit Asterisk und 2 Sipgate-Accounts

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von iXware, 2 Dez. 2005.

  1. iXware

    iXware Neuer User

    Registriert seit:
    21 Juni 2004
    Beiträge:
    49
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo zusammen,

    nachdem ich Asterisk jetzt so halbwegs zum laufen bekommen habe und das Grandstram GXP-2000 auch funktioniert. muß ich noch einige Probleme lösen. Also ich habe eine Asterisk auf meinem Server installiert, der ist über einen Router ans Internet angeschlossen. das GXP-2000 hängt am internen Netz. Der Router macht NAT, hat aber eine feste externe IP-Adresse. die benötigten Ports sind offen. Ich hoffe mal, daß meine Configs so halbwegs richtig sind, aber ich habe noch folgende Probleme:

    1.) wenn ich mit dem GXP-2000 nach draußen eine Festnetznummer anwähle funktioniert alles recht gut (SPrache in beide Richtungen) - naja die Sprachqualität könnte etwas besser sein, wenn ich aber vom Festnetztelefon die Sip-gatnummer anrufe, dann geht die Sprach nur von Innen (GXP) nach draußen. Spreche ich am Festnetztelefon kommt beim GXP nichts an.

    2.) wie kann ich Asterisk anweisen, daß ein interner User immer nur mit seinem eigenen Sipgate-Account rauswählen kann. Es soll aber immer für Sipgate als vorwahl die 9 gewählt werden. Ich habe also 2 interne Telefone (50, 51) der 50 ist der Sipgateaccount 7777777 zugeordnet und der 51 ist die 9999999 zugeordnet. wenn jetzt der Nutzer an Telefon 50 die Nummer 9-030-1234567 wählt, dann soll der sipgate-account 777777 genutzt werden. Wenn jetzt der Nutzer an Telefon 51 die Nummer 9-030-1234567 wählt, dann muß er den sipgate-account 9999999 nutzen.

    3.) das dritte sind die Mailboxen -irgend bekomme ich die nicht daz zu funktionieren

    Könnte mir bitte jemand bei der Lösung dieser 3 Probleme helfen????


    extensions.conf
    Code:
    [general]
    static=yes
    writeprotect=no
    
    [default]
    exten => 600,1,Playback(demo-echotest)
    exten => 600,2,Echo
    exten => 600,3,Playback(demo-echodone)
    exten => 600,4,Goto(s,6)
    
    
    exten => _9.,1,NoOP(Call via Sipgate)
    exten => _9.,2,SetCallerID(7777777)
    exten => _9.,3,Dial(SIP/${EXTEN:1}@7777777,60)
    
    
    exten => _8.,1,NoOP(Call via Sipgate)
    exten => _8.,2,SetCallerID(9999999)
    exten => _8.,3,Dial(SIP/${EXTEN:1}@9999999,60)
    
    
    [ankommend_7777777]
    exten => 7777777,1,Dial(SIP/50)
    
    
    [ankommend_9999999]
    exten => 9999999,1,Dial(SIP/51)
    
    
    [mailbox]
    exten=> 88/_[1-9].,1,Answer
    exten=> 88/_[1-9].,2,Wait(1)
    exten=> 88/_[1-9].,3,VoicemailMain2(s${CALLERIDNUM})
    exten=> 88/_[1-9].,4,Hangup
    
    
    [50]
    ; User1 Sip-Telefon-Konfiguration
    exten => 50,1,Dial(SIP/50,20)
    exten => 50,2,Voicemail(500)
    exten => 50,3,Congestion
    exten => 50,102,Busy
    
    
    [51]
    ; User2 Sip-Telefon-Konfiguration
    exten => 51,1,Dial(SIP/51,20)
    exten => 51,2,Voicemail(510)
    exten => 51,3,Hangup
    

    sip.conf
    Code:
    ;
    ; SIP Configuration for Asterisk
    ;
    
    [general]
    context=default
    port=5060
    bindaddr=192.168.1.2
    nat=yes
    externip = 999.222.222.999
    localnet=192.168.1.0/255.255.255.0
    
    register => 7777777:GEHEIM@sipgate.de/7777777
    register => 9999999:GEHEIM@sipgate.de/9999999
    
    
    [7777777]
    type=peer
    username=7777777
    fromuser=7777777
    secret=GEHEIM
    host=sipgate.de
    fromdomain=sipgate.de
    contex=7777777
    canreinvite=no
    qualify=yes
    nat=yes
    
    
    [9999999]
    type=peer
    username=9999999
    fromuser=9999999
    secret=GEHEIM
    host=sipgate.de
    fromdomain=sipgate.de
    contex=9999999
    canreinvite=no
    qualify=yes
    nat=yes
    
    
    [sipgate_7777777]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    context=ankommend_7777777
    
    [sipgate_9999999]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    context=ankommend_9999999
    
    
    [50]
    type=friend
    username=50
    secret=geheim
    host=dynamic
    dtmfmod=rfc2833
    mailbox=500
    
    [51]
    type=friend
    username=51
    secret=geheim
    host=dynamic
    dtmfmod=rfc2833
    mailbox=510
    
    und zu guter letzt noch die voicemail.conf
    Code:
    ;
    ; Voicemail Configuration
    ;
    [general]
    format=wav
    serveremail=asterisk
    attach=yes
    maxmessage=180
    minmessage=3
    maxgreet=60
    skipms=3000
    maxsilence=10
    silencethreshold=128
    maxlogins=3
    charset=ISO-8859-1
    fromstring=The Asterisk PBX
    pagerfromstring=The Asterisk PBX
    emailsubject=New VM (${VM_MSGNUM}) - ${VM_DUR} long in mailbox ${VM_MAILBOX} from ${VM_CALLERID} 
    emailbody=Dear ${VM_NAME}:\n\n\tjust wanted to let you know you were just left a ${VM_DUR} long message (number ${VM_MSGNUM})\nin mailbox ${VM_MAILBOX} from ${VM_CALLERID}, on ${VM_DATE} so you might\nwant to check it when you get a chance.  Thanks!\n\n\t\t\t\t--Asterisk\n
    mailcmd=/usr/sbin/sendmail -t
    
    [zonemessages]
    eastern=America/New_York|'vm-received' Q 'digits/at' IMp
    central=America/Chicago|'vm-received' Q 'digits/at' IMp
    central24=America/Chicago|'vm-received' q 'digits/at' H 'digits/hundred' M 'hours'
    
    [default]
    500 => 50,User1,user1@domain.de
    510 => 51,User2,user2@domain.de
    
     
  2. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Das ist ein Routerproblem.
    [hr:24b9f7b6e2]
    Gib jedem SIP-Client einen eigenen Context, als in sip.conf

    [50]
    context=context50

    und in extensions.conf dann

    [context50]
    exten => _9.,1,Dial(SIP/Account_für_50@sipgate)

    Parallel das gleiche natürlich auch für 51
    [hr:24b9f7b6e2]

    Dazu bin ich jetzt zu müde - falls niemand anderes das löst, schau ich mir das morgen mal an. Auf Anhieb würde ich mal sagen, daß in Deinem Context [default] das include fehlt, um den Mailbox-Context überhaupt verfügbar zu haben

    include => mailbox

    Außerdem würde ich es mal so probieren:

    Code:
    [mailbox]
    exten=> 88,1,Answer
    exten=> 88,2,Wait(1)
    exten=> 88,3,VoicemailMain2(s${CALLERIDNUM})
    exten=> 88,4,Hangup
    
     
  3. iXware

    iXware Neuer User

    Registriert seit:
    21 Juni 2004
    Beiträge:
    49
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    was kann das für ein Problem sein?

    ok, danke, das funktioniert jetzt, langsam scheine ich die Zusammenhänge zu begreifen :)

    das geht leider auch nicht, ich bekomme im IP-Telefon die Fehlermeldung:

    "404 NOT FOUND, Wrong number or remote party not online"

    MfG, Frank.
     
  4. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Poste bitte nochmal Deine aktuelle extensions.conf

    Wenn Du Deinen beiden Endgeräte jetzt eigene Kontexte zugewiesen hast, mußt Du natürlich auch dafür sorgen, daß die [mailbox] auch in diesen Kontexten verfügbar ist.

    Also muß das

    include => mailbox

    jetzt nicht mehr in [default] stehen, sondern in [context50] und [context51]
     
  5. iXware

    iXware Neuer User

    Registriert seit:
    21 Juni 2004
    Beiträge:
    49
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    Hallo

    also wenn ich jetzt vom Festnetztelefon aus meine SIP-Nummer anrufe, dann hört nach 60 Sekunden das Sip-Telefon auf zu klingeln, aber im Ferstnetztelefon höre ich noch ca. weitere 20 Sekunden das Rufzeichen. Im Logfile von Asterisk ist aber nichts von der Mailbiox zu sehen..., obwohl ich den Loglevel auf debug gestellt habe.

    die extentensions.conf sieht jetzt so aus:
    Code:
    [general]
    static=yes
    writeprotect=no
    
    [default]
    exten => 600,1,Playback(demo-echotest)
    exten => 600,2,Echo
    exten => 600,3,Playback(demo-echodone)
    exten => 600,4,Goto(s,6)
    
    
    [abgehend_50]
    exten => _9.,1,NoOP(Call via Sipgate)
    exten => _9.,2,SetCallerID(7777777)
    exten => _9.,3,Dial(SIP/${EXTEN:1}@7777777,60)
    
    [abgehend_51]
    exten => _9.,1,NoOP(Call via Sipgate)
    exten => _9.,2,SetCallerID(9999999)
    exten => _9.,3,Dial(SIP/${EXTEN:1}@9999999,60)
    
    [ankommend_7777777]
    exten => 7777777,1,Dial(SIP/50)
    include => mailbox
    
    [ankommend_9999999]
    exten => 9999999,1,Dial(SIP/51)
    include => mailbox
    
    [mailbox]
    exten=> 88,1,Answer
    exten=> 88,2,Wait(1)
    exten=> 88,3,VoicemailMain2(s${CALLERIDNUM})
    exten=> 88,4,Hangup
    
    
    [50]
    ; User1 Sip-Telefon-Konfiguration
    exten => 50,1,Dial(SIP/50,20)
    exten => 50,2,Voicemail,u500
    exten => 50,102,Voicemail,b500
    exten => 50,3,Congestion
    exten => 50,103,Hangup
    
    
    [51]
    ; User2 Sip-Telefon-Konfiguration
    exten => 51,1,Dial(SIP/51,20)
    exten => 51,2,Voicemail,u510
    exten => 51,102,Voicemail,b510
    exten => 51,103,Hangup
    
    
    und das ist die Sip.conf:
    Code:
    ;
    ; SIP Configuration for Asterisk
    ;
    
    [general]
    context=default
    port=5060
    bindaddr=192.168.1.2
    nat=yes
    externip = 999.222.222.999
    localnet=192.168.1.0/255.255.255.0
    
    register => 7777777:GEHEIM@sipgate.de/7777777
    register => 9999999:GEHEIM@sipgate.de/9999999
    
    
    [7777777]
    type=peer
    username=7777777
    fromuser=7777777
    secret=GEHEIM
    host=sipgate.de
    fromdomain=sipgate.de
    contex=7777777
    canreinvite=no
    qualify=yes
    nat=yes
    
    
    [9999999]
    type=peer
    username=9999999
    fromuser=9999999
    secret=GEHEIM
    host=sipgate.de
    fromdomain=sipgate.de
    contex=9999999
    canreinvite=no
    qualify=yes
    nat=yes
    
    
    [sipgate_7777777]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    context=ankommend_7777777
    
    [sipgate_9999999]
    type=peer
    fromdomain=sipgate.de
    host=sipgate.de
    context=ankommend_9999999
    
    [50]
    type=friend
    username=50
    secret=geheim
    host=dynamic
    dtmfmod=rfc2833
    mailbox=500
    context=abgehend_50
    
    [51]
    type=friend
    username=51
    secret=geheim
    host=dynamic
    dtmfmod=rfc2833
    mailbox=510
    context=abgehend_51
    
     
  6. HaaP

    HaaP Neuer User

    Registriert seit:
    16 Apr. 2007
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Software & Systementwickler
    Hallo!

    Ich habe folgendes Problem: Ich verwende auf meiner Asterisk TK-Anlage zwei sipgate Accounts.

    Wenn jetzt einer der beiden von extern angerufen wird - funktioniert das Gespräch einwandfrei, versucht aber paralell dazu der zweite sipgate Benutzer nach extern zu telefonieren, wird der erste aus der Leitung geworfen!?

    Ich habe jetzt herausgefunden wenn ich in der sip.conf bei jedem sipgate User den Parameter fromdomain=sipgate.at auskommentiere funktioniert es wieder einwandfrei!

    Könnte ich dadurch aber in andere Probleme geraten, wenn ich diesen Parameter nicht verwende?? Ich werde nicht wirklich schlau, für was dieser steht!

    greez, patrick