.titleBar { margin-bottom: 5px!important; }

Knacken, wenn niemand spricht

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von psuter, 7 Juni 2005.

  1. psuter

    psuter Neuer User

    Registriert seit:
    7 Juni 2005
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi
    ich habe kürzlich mal endlich einen eigenen asterisk server aufgesetzt und bisher alles einigermassen zum laufen gebracht. doch habe ich ein problem:

    wenn ich ein gespräch habe, bei dem ein an meinen asterisk server angemoldenes telefon beteiligt ist, dann hört die andere seite jeweils ein knacken in der leitung (in gewissen fällen sogar irgendwelche töne) sobald der teilnehmer am sip telefon aufhört zu sprechen. wenn er weiter spricht, hört auch das knacken auf.

    zeitgleich mit jedem knacks sehe ich auf der asterisk konsole folgende meldung (die beiden zahlen variieren jeweils ein wenig)
    Code:
    RFC3389: 5 bytes, level 2...
    das passiert sowohl wenn der sip client ein x-lite ist, wie auch wenn es ein Leadtek BVA8051 (sip <-> analog adapter) ist.

    interessanterweise habe ich dieses problem aber nur mit sip clients. wenn jemand per isdn anruft und via die hfc karte rein kommt, gibts von ihm kein knacken, jedoch von den sip telefonen und softphones schon.

    meine vermutung: offensichtlich senden sip clients ein rtp päckchen an den server, sobald niemand mehr spricht, damit dieser den client stummschalten kann oder so. dummerweise scheint das mein asterisk aber nur mit knacken bwerkstelligen zu können

    hat jemand eine idee, woran das liegen könnte? respektive was ich dagegen unternehmen kann?

    hier noch ein paar infos zu meinem setup:
    Pentium 4 mit Debian Sarge und den Asterisk binary-paketen (per apt installiert), HFC karte mit zaphfc treibern.

    grüsse
    pascal
     
  2. voipalex

    voipalex Mitglied

    Registriert seit:
    18 Okt. 2004
    Beiträge:
    319
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Probier mal bei X-Lite die Silence Compression / VAD auszuschalten. Das geht mit der Option "Transmit silence".
     
  3. psuter

    psuter Neuer User

    Registriert seit:
    7 Juni 2005
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hmm, transmit silence ist bei mir schon ausgeschaltet
     
  4. Honk

    Honk Neuer User

    Registriert seit:
    3 Okt. 2004
    Beiträge:
    108
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Hamburg
    @psuter

    Du sollst sie ja auch EINSCHALTEN :)
    Also Transmit Silence = YES

    Gruß,
     
  5. psuter

    psuter Neuer User

    Registriert seit:
    7 Juni 2005
    Beiträge:
    36
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hoppala.. zuwenig bis garnicht mitgedacht ;)

    sieht so aus, als ob das mein problem lösen würde. nun ist es aber so, dass ich das x-lite nur installiert habe, um ein bisschen rum zu pröbeln. kann ich das auch asterisk seitig ausschalten, so dass dieser einfach gar nicht mehr auf diese päckchen hört? (zudem weiss ich nicht, wo ich das beim leadtek adapter ausschalten könnte)

    grüsse
    pascal
     
  6. voipalex

    voipalex Mitglied

    Registriert seit:
    18 Okt. 2004
    Beiträge:
    319
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Stand der Dinge ist, dass Asterisk nicht mit VAD zurecht kommt. D.h. du mußt an den Clients was ändern.