.titleBar { margin-bottom: 5px!important; }

MusicOnHold (MoH) in SlowMotion

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von konqi, 10 März 2005.

  1. konqi

    konqi Guest

    Hi!

    erst mal Ausgangslage:
    -SuSE 9.2
    mit Asterisk 0.1.0-RC4a
    &
    mpg321 (-V) Version 0.2.10 mit ln auf mpg123 (-v spricht alledings von Version 0.59q)
    ^^ welche Versionnummer ist denn nun Richtig?
    - ISDN-Anlagenanschluss -> AVM C2 -> Asterisk -> Snom190 SIP-Phones

    Problem:
    Wenn die Warteschleifenmusik spielt scheint diese in Zeitlupe abgespielt zu werden. Dementsprechend hört es sich auf jeden fall an!

    und nein: kein SMP, keine ID3-Tags und eigentlich NUR die Standartfiles aus dem /var/lib/asterisk/mohmp3
    habe auch schon das Streaming ausprobiert, hört sich genauso besch...eiden an!
    Die CPU-Last steigt auch nicht ungewöhnlich! Der Load bleibt bei <0.02 und die CPU-Last auf < 1%

    Hat dafür irgendwer eine erklärung? Ich dreh hier gleich am Zahn!
    Ich bin um jeden Tip dankbar

    MfG
    Marcel

    P.S: warum stolper ich denn immer über solch komische Sachen?!

    P.P.S:
    Code:
    ; Music on hold class definitions
    ;
    [classes]
    default => quietmp3:/var/lib/asterisk/mohmp3,-z
    manual => custom:/var/lib/asterisk/mohmp3,/usr/bin/mpg123 -q -r 8000 -f 8192 -b 2048 --mono -s
    stream => mp3:/var/lib/asterisk/mohmp3/empty,http://sb.mthn.net:8000/
    
    was ist hier überhaupt der unterschied zwischen "mp3:" , "quietmp3:" und/oder "custom:" ??
     
  2. konqi

    konqi Guest

    mpg321 != mpg123

    *stöhnz*
    diese dämlichen SuSE Packages!!

    Lösung:
    mpg123 in v0.59r von hand compilen, dann gehts! *grmbl

    MfG
    Marcel