[Gelöst] NAT im Heimnetzwerk mit UniFi USG

m_angel

Neuer User
Mitglied seit
31 Mrz 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Hallo zusammen. Ich bin noch recht neu in der Thematik und habe ein grundsätzliches Problem.

Und zwar habe ich eine Fritzbox 6490Cabel daran als Exposed Host angeschlossen eine Unifi USG fon Ubiquiti welche mir drei Netzwerke incl WLANs zur Verfügung stellt.
Ein Gästenetzwerk ein Normales Netzwerk für alle normalen Clients und ein Haustechnik Netzwerk an dem die Haussteuerung mit allen Komponenten hängt.
Ich habe mir jetzt eine Türsprechanlage auf Basis Raspberry Pi mit Linphone gebaut. Die Verbindung zur Fritzbox als Nebenstelle funktioniert.
Wenn ich jetzt am Raspberry Linphone aus dem Haustechnik Netz einen Anruf auslöse klingelt die Gegenstelle zwar aber es kommt kein Ton. Wenn ich den Raspberry direkt an die Fritzbox anschließe funktioniert es problemlos.
Nach ein wenig suche habe ich dann gefunden das die UDP Pakete nicht NAT fähig sind und somit nie durch meine USG an meiner Fritzbox ankommen. Jetzt gibt es ja diese tollen STUN Server.
Meine Frage kann ich mein Problem damit beheben und wenn ja wie. Also wo muss der STUN Server sitzen direkt an der Fritzbox oder im Haustechnik Netz oder in beiden und woher weiß der wo jetzt die entsprechenden Geräte stecken.
Diese Debian derivat https://www.stefanux.de/wiki/doku.php/server/stun habe ich zwar mal installiert aber ohne erfolg...

Danke fürs lesen und eure Antworten
 

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,096
Punkte für Reaktionen
97
Punkte
48
Du müsstest Linphone dazu bekommen, eine IP-Adresse aus dem FRITZ!Box-Netz (= die IP-Adresse des UniFi Security Gateway) zu senden, siehe diesen Post … selbst noch nicht probiert, ob das überhaupt geht, aber daher müsste der STUN-Server im Netz der FRITZ!Box stehen. Dann kann der STUN-Server mit der IP-Adresse antworten, die er sieht = die IP-Adresse des UniFi Security Gateway.
 

m_angel

Neuer User
Mitglied seit
31 Mrz 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Danke für die Antrort. Ich habe jetzt bei meiner USG so was drehen können das die SIP Telegramme durchgeroutet werden. Jetzt funktioniert es.
 

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
24,015
Punkte für Reaktionen
252
Punkte
83

sonyKatze

Aktives Mitglied
Mitglied seit
6 Aug 2009
Beiträge
1,096
Punkte für Reaktionen
97
Punkte
48
KunterBunter meint – hätte man anstatt öffentlich auch ganz lieb über eine private Unterhaltung danach bitten können –, dass Du Deine Schritte bzw. die Funktion nennst, also wie Du dieses „Routen“ eingestellt hast. Entweder den Menüpunkt oder sogar die Menü-Abfolge in den Einstellungen der USG. Das könnte anderen, zukünftigen, passiven Lesern dieses Threads dann direkter helfen. Würde auch mich interessieren, zum Einen weil hier viele mit USG aufschlagen. Zum Anderen, weil ich jetzt auf Anhieb nicht wüsste, wie man das mittels der USG retten kann.
 

m_angel

Neuer User
Mitglied seit
31 Mrz 2020
Beiträge
3
Punkte für Reaktionen
0
Punkte
1
Sorry Ihr habt recht das wäre besser und im sinne eines Forum wenn es etwas ausführlicher ist.
Da ich nicht wirklich etwas passendes zur lösung meines Problems gefunden hatte kam mir die Idee ein Porf forwarding in der USG einzurichten und den Port 5060 einfach direkt vom Linphone an die Fritzbox und umgekehr zu leiten. Nachteil es würde so nur ein Endgerät im Netzwerk funktionieren. Kurz um hat nicht funktioniert. Aber die Idee das man an der USG was machen kann fand ich garnicht so falsch und in diversen Foren habe ich Einträge gefunden, dass die USG tatzächlich probleme mit SIP Geräten hat. In einem Eintrag von 2017 bin ich auf den hinweiß gestoßen das man SIP unter Routing & Firewall -> Firewall -> Settings -> CONNTRACK MODULES deaktivieren soll und zusätzlich noch über SSH auf der USG direkt noch SIP in einer Configdatei abschalten. Naja immerhin mal was gefundne gehabt. Bei meiner USG mal nachgeschaut und SIP war bereits ab werk deaktiviert. Ich habs dan mal eingeschaltet um zu schauen was passiert. Nach dem die Einstellung übernommen war einen Anruf gestartet und wunderwas es kam Ton in beide Richtungen. Es scheint so als hätte da UniFi nachgebessert und den Punkt bereits so eingerichtet das es ohne STUN oder sonstwas funktioniert entsprechende Telegramme weiterzuleiten.
 
3CX

Statistik des Forums

Themen
234,940
Beiträge
2,053,544
Mitglieder
355,275
Neuestes Mitglied
odoakar