.titleBar { margin-bottom: 5px!important; }

[nearly solved] ZT_SPANCONFIG failed on span 1:

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von schorsch, 6 Jan. 2005.

  1. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!
    Ich versuche gerade auf Suse 9.2 asterisk mit genau einer HFC-Karte im NT-Modus zum Laufen zu bringen. Ich nutze den aktuellen Bristuff und bin gemäß der Anleitung von jui vorgegangen. Asterisk scheint sauber kompiliert worden zu sein, lspci liefert nichts Abnormes und in den /var/log/messages sieht eigentlich auch alles soweit gut aus, denke ich.

    Trotzdem liefert make loadNT nachdem "3 channels configured" steht als letzt Zeile die Ausgabe:

    ZT_SPANCONFIG failed on span 1: Invalid argument (22)

    und asterisk startet nicht. Diese Ausgabe stammt übrigens vom ausgeführten ztcfg -v. Wenn ich wiederholt ztcfg -v eingebe erhalte ich immer wieder diese Ausgabe. Meine /etc/zaptel.conf ist die fünfzeilige Standarddatei. Da habe ich auch schon versucht, einige Werte zu verändern, hat alles nichts gebracht.
    Falls jemand dieses Problem kennt oder Ideen hat, würde mich das sehr freuen.
    Viele Grüße
    schorsch
     
  2. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @schorsch

    Schon weitergekommen mit der Sache? Offenbar weiss hier auch keiner so recht Rat ... Wie gesagt hatte ich das auch mal, weiss aber nicht mehr wie ich dieses Problem losgeworden bin.

    Viel Erfolg! Ggf. einfach auch mal in einem anderen Rechner testen.
     
  3. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke der Nachfrage!
    Weitergekommen bin ich noch nicht, aber ich wollt' es in der Tat mit einem anderen Rechner und dann auch gleich mit einer anderen Karte versuchen... Wird aber wohl erst nächste Woche etwas werden.
    Viele Grüße
    schorsch
     
  4. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe gerade in einem anderen Beitrag hier folgendes von "mover" gefunden:

    Kann es sein, dass Du noch ein asterisk-rpm irgendwo im system aktiv hast? Probier mal den "rmmod zaptel" bevor Du den "make loadNT" machst und schau ob Du noch ein rpm vom asterisk auf der SuSI hast.

    Viel Glück!

    Gruß,

    Jui
     
  5. mover

    mover Neuer User

    Registriert seit:
    8 Jan. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    zaptel ist nicht von asterisk. Das ist eine generelle pri/bri unterstützung bei suse. Ich habe auch kein einzige rpm von * installiert.

    Gruß

    mover
     
  6. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke, dass ihr euch immer noch bemüht...
    rmmod zaptel bringt einen Error, da zaptel gar nicht da ist. Das sollte also der Fehler nicht sein, bei make loadNT ändert sich auch nichts. Leider!
    Ich hatte übrigens ein frisches Suse 9.2 installiert und dann gleich während der Installation das Online-Update ausgeführt. Nur den Kernel habe ich dann nochmal extra nachinstalliert. Asterisk rpms oder sonst irgendwelche nicht benötigten Dinge sollten also nicht vorhanden sein (habe ich zumindest nicht bewusst installiert).

    [Ist es denn nicht eigentlich so, dass zaptel von zaphfc benötigt wird? Wenn ich nämlich (nachdem ich make loadNT aufgerufen habe) rmmod zaptel eingebe, erhalte ich eine Fehlermeldung:

    ERROR: Module zaptel is in use by zaphfc

    ...das nur am Rande]

    Ich glaube, die Idee es mal mit anderer Hardware auszuprobieren, ist immer noch am vielversprechendsten, irgendwie habe ich den Eindruck, dass in meinem System in Verbindung mit Suse 9.2 von Anfang der Wurm drinsteckte. Wobei eigentlich ein Pentium IV mit 2.4 GHz, 512 MB RAM und MSI-Board mit 845PE Chipsatz nichts so Außergewöhnliches sein sollte.

    Viele Grüße, schorsch
     
  7. mover

    mover Neuer User

    Registriert seit:
    8 Jan. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi nochmal,

    ein letzer Versuch. mach im verzeichnis zaphfc mal
    Code:
    make unload && make loadNT
     
  8. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Leider, leider...
    Ich poste vorsichtshalber nochmal die komplette Ausgabe. Vielleicht hat dieses Warning ja doch eine Bedeutung oder ihr erkennt doch irgendetwas, was falsch sein könnte.

    Code:
    asterisk:/usr/src/asterisk/bristuff-0.2.0-RC3/zaphfc # make unload && make loadNT
    rmmod zaphfc zaptel
    ERROR: Module zaphfc does not exist in /proc/modules
    ERROR: Module zaptel does not exist in /proc/modules
    make: [unload] Fehler 1 (ignoriert)
    make -C /usr/src/linux-2.6 SUBDIRS=/usr/src/asterisk/bristuff-0.2.0-RC3/zaphfc modules
    make[1]: Entering directory `/usr/src/linux-2.6.8-24.10'
    
    WARNING: Symbol version dump /usr/src/linux-2.6.8-24.10/Module.symvers is  missing, modules will have CONFIG_MODVERSIONS disabled.
    
      Building modules, stage 2.
      MODPOST
    make[1]: Leaving directory `/usr/src/linux-2.6.8-24.10'
    modprobe zaptel
    insmod ./zaphfc.ko modes=1
    ztcfg -v
    
    Zaptel Configuration
    ======================
    
    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    
    3 channels configured.
    
    ZT_CHANCONFIG failed on channel 2: Invalid argument (22)
    Did you forget that FXS interfaces are configured with FXO signalling
    and that FXO interfaces use FXS signalling?
    make: *** [loadlinux26NT] Fehler 1
    
    
    Danke, Schorsch
     
  9. mover

    mover Neuer User

    Registriert seit:
    8 Jan. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi Schorsch.

    das problem ist anscheinen deine /etc/zaptel.conf. Post diese bitte mal und eine ausgabe von ztcfg -vv

    danke

    Gruß

    ein ausgeschlafener mover :)
     
  10. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    OK, das ist meine /etc/zaptel.conf:
    Code:
    loadzone=nl
    defaultzone=nl
    span=1,1,3,ccs,ami
    bchan = 1-2
    dchan = 3
    
    ...an sich ja wohl nichts besonderes, oder?

    Und ztcfg -vv liefert folgendes (wobei ich vorher erst einmal make loadNT ausgeführt habe und dann anschließend ztcfg -vv):
    Code:
     asterisk:/usr/src/asterisk/bristuff-0.2.0-RC3/zaphfc # ztcfg -vv
    
    Zaptel Configuration
    ======================
    
    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    
    Channel map:
    
    Channel 01: Individual Clear channel (Default) (Slaves: 01)
    Channel 02: Individual Clear channel (Default) (Slaves: 02)
    Channel 03: D-channel (Default) (Slaves: 03)
    
    3 channels configured.
    
    ZT_CHANCONFIG failed on channel 2: Invalid argument (22)
    Did you forget that FXS interfaces are configured with FXO signalling
    and that FXO interfaces use FXS signalling?
    
    Danke, viele Grüße
    Schorsch
     
  11. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Tut mir leid, aus Versehen zweimal geklickt. Schorsch.
     
  12. mover

    mover Neuer User

    Registriert seit:
    8 Jan. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hast du ein ISDN Kabel an der hfc karte? Wenn ja was für eines gekreuzt oder nicht? und wo steckt es drin?

    Poste bitte auch mal deine zapata.conf

    Danke
     
  13. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @mover

    Soso, ausgeschlafen :)

    Das Kabel kann mit der Fehlermeldung nichts zu tun haben. Auch die zaptel.conf ist ja ok und an der zapata.conf sollte es auch nicht liegen, das wurde von schorsch ja auch schon geprüft. ISt wirklich etwas eigenartig dass dieser Fehler nicht verschwindet.
     
  14. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @mover

    Soso, ausgeschlafen :)

    Das Kabel kann mit der Fehlermeldung nichts zu tun haben. Auch die zaptel.conf ist ja ok und an der zapata.conf sollte es auch nicht liegen, das wurde von schorsch ja auch schon geprüft. ISt wirklich etwas eigenartig dass dieser Fehler nicht verschwindet.
     
  15. rajo

    rajo Admin-Team

    Registriert seit:
    31 März 2004
    Beiträge:
    1,958
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    evtl. das hier?

    http://www.voip-info.org/wiki-Asterisk+zaphfc+install
     
  16. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @rajo
    Danke auf alle Fälle; das hatte ich aber schon mit als erstes ausprobiert als der Fehler auftauchte. Hatte ich auch in obiger Quelle gefunden.

    @mover
    Ich kann mir auch nicht vorstellen, wie das Kabel diesen Fehler produzieren sollte. Alles ist bei mir ganz standardmäßig:
    ISDN-Karte <--> gekreuztes ISDN-Kabel <--> NTBA <--> normales ISDN-Kabel <--> Telefon.
    Als zapata.conf verwende ich entweder das Standardbeispiel von Christopher Bach oder die zapata.conf von jui als Test. Macht aber keinen Unterschied.

    Gruß, Schorsch
     
  17. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mir ist da gerade noch etwas eingefallen:
    Und zwar habe ich im Zusammenhang mit der Suche nach der Beseitigung des Fehlers als Tip gesehen, sich folgende /etc/modules.conf einzurichten:
    Code:
    pre-install zaphfc /sbin/modprobe zaptel
    post-install zaphfc /sbin/ztcfg
    
    Diese Idee war für Mandrake gedacht. Ich glaube sie stammt irgendwo von voip-info.org. Gebracht hatte es leider nichts und bringt auch jetzt nichts, aber vielleicht weiß einer von euch etwas damit anzufangen.

    Viele Grüße, Schorsch
     
  18. jui

    jui Mitglied

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    229
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @schorsch

    Ich habe das auch nicht in der modules.conf stehen. Scheint also nicht wirklich wichtig zu sein.
     
  19. mover

    mover Neuer User

    Registriert seit:
    8 Jan. 2005
    Beiträge:
    21
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi schorsch,

    ich könnte was drauf verwetten dass bei dir irgend eine Lib von SuSE überlebt hat nachdem du den bristuff installiert hast. Eine letzte Möglichkeit ist folgende. Mach mal genau das was ich hier gemacht habe, packe es in eben solche Dateien und lass einen diff drüber rutschen.

    strace modprobe zaptel

    Code:
    execve("/sbin/modprobe", ["modprobe", "zaptel"], [/* 58 vars */]) = 0
    uname({sys="Linux", node="fe0-noc", ...}) = 0
    brk(0)                                  = 0x805b000
    access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
    open("/etc/ld.so.cache", O_RDONLY)      = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=63529, ...}) = 0
    old_mmap(NULL, 63529, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40018000
    close(3)                                = 0
    open("/lib/tls/libc.so.6", O_RDONLY)    = 3
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0L\1\000"..., 512) = 512
    fstat64(3, {st_mode=S_IFREG|0755, st_size=1359489, ...}) = 0
    old_mmap(NULL, 1137708, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x40028000
    madvise(0x40028000, 1137708, MADV_SEQUENTIAL|0x1) = 0
    mprotect(0x40137000, 27692, PROT_NONE)  = 0
    old_mmap(0x40138000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x10f000) = 0x40138000
    old_mmap(0x4013c000, 7212, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x4013c000
    close(3)                                = 0
    old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x4013e000
    mprotect(0x40138000, 4096, PROT_READ)   = 0
    set_thread_area({entry_number:-1 -> 6, base_addr:0x4013e300, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
    munmap(0x40018000, 63529)               = 0
    create_module(umovestr: Input/output error
    0, 0)                     = -1 ENOSYS (Function not implemented)
    uname({sys="Linux", node="fe0-noc", ...}) = 0
    fstat64(2, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 3), ...}) = 0
    brk(0)                                  = 0x805b000
    brk(0x807c000)                          = 0x807c000
    open("/etc/modprobe.conf", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOTDIR (Not a directory)
    open("/etc/modprobe.conf", O_RDONLY)    = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=13666, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    read(3, "#\n# Copyright (c) 1996-2002 SuSE"..., 4096) = 4096
    read(3, "  io=0x2a0 irq=10\n# options fmv1"..., 4096) = 4096
    read(3, "#\n# USB\n########################"..., 4096) = 4096
    read(3, " for modprobe.conf\n\nalias char-m"..., 4096) = 1378
    open("/etc/modprobe.d", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 4
    fstat64(4, {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    fcntl64(4, F_SETFD, FD_CLOEXEC)         = 0
    getdents(4, /* 6 entries */, 4096)      = 112
    open("/etc/modprobe.d/tv", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOTDIR (Not a directory)
    open("/etc/modprobe.d/tv", O_RDONLY)    = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40019000
    read(5, "", 4096)                       = 0
    close(5)                                = 0
    munmap(0x40019000, 4096)                = 0
    open("/etc/modprobe.d/zaptel", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOTDIR (Not a directory)
    open("/etc/modprobe.d/zaptel", O_RDONLY) = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=752, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40019000
    read(5, "options torisa base=0xd0000\nalia"..., 4096) = 752
    read(5, "", 4096)                       = 0
    close(5)                                = 0
    munmap(0x40019000, 4096)                = 0
    open("/etc/modprobe.d/sound", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOTDIR (Not a directory)
    open("/etc/modprobe.d/sound", O_RDONLY) = 5
    fstat64(5, {st_mode=S_IFREG|0644, st_size=124, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40019000
    read(5, "options snd-via82xx enable=1 ind"..., 4096) = 124
    read(5, "", 4096)                       = 0
    close(5)                                = 0
    munmap(0x40019000, 4096)                = 0
    getdents(4, /* 0 entries */, 4096)      = 0
    close(4)                                = 0
    open("/etc/modprobe.conf.local", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = -1 ENOTDIR (Not a directory)
    open("/etc/modprobe.conf.local", O_RDONLY) = 4
    fstat64(4, {st_mode=S_IFREG|0644, st_size=47, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40019000
    read(4, "#\n# please add local extensions "..., 4096) = 47
    read(4, "", 4096)                       = 0
    close(4)                                = 0
    munmap(0x40019000, 4096)                = 0
    read(3, "", 4096)                       = 0
    close(3)                                = 0
    munmap(0x40018000, 4096)                = 0
    open("/lib/modules/2.6.8-24.10-default/modules.dep", O_RDONLY) = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=287266, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    read(3, "/lib/modules/2.6.8-24.10-default"..., 4096) = 4096
    close(3)                                = 0
    munmap(0x40018000, 4096)                = 0
    open("/lib/modules/2.6.8-24.10-default/kernel/lib/crc-ccitt.ko", O_RDWR) = 3
    fcntl64(3, F_SETLKW, {type=F_WRLCK, whence=SEEK_SET, start=0, len=1}) = 0
    open("/proc/modules", O_RDONLY)         = 4
    fstat64(4, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    read(4, "crc_ccitt 2176 0 - Live 0xf91300"..., 1024) = 1024
    close(4)                                = 0
    munmap(0x40018000, 4096)                = 0
    close(3)                                = 0
    open("/lib/modules/2.6.8-24.10-default/misc/zaptel.ko", O_RDWR) = 3
    fcntl64(3, F_SETLKW, {type=F_WRLCK, whence=SEEK_SET, start=0, len=1}) = 0
    open("/proc/modules", O_RDONLY)         = 4
    fstat64(4, {st_mode=S_IFREG|0444, st_size=0, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    read(4, "crc_ccitt 2176 0 - Live 0xf91300"..., 1024) = 1024
    read(4, "0xf9385000\ngameport 4608 1 snd_v"..., 1024) = 1024
    read(4, "0xf9146000\niptable_nat 23980 3 i"..., 1024) = 1024
    read(4, "1 - Live 0xf9035000\njbd 61348 1 "..., 1024) = 224
    read(4, "", 1024)                       = 0
    close(4)                                = 0
    munmap(0x40018000, 4096)                = 0
    fcntl64(3, F_GETFL)                     = 0x2 (flags O_RDWR)
    fstat64(3, {st_mode=S_IFREG|0644, st_size=553517, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    _llseek(3, 0, [0], SEEK_CUR)            = 0
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\1\0\3\0\1\0\0\0\0\0\0\0"..., 16384) = 16384
    read(3, "1\333\353\23\272\377\177\0\0f\211\24_C\203\373\7\17\217"..., 16384) = 16384
    read(3, "\213F\10\211\223,\5\0\0\211F\4\213\17\17\257\310\301\371"..., 32768) = 32768
    mmap2(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x4013f000
    read(3, "\236@\10\0\0\307\206D\10\0\0\310\0\0\0C\211\321\211\236"..., 65536) = 65536
    mremap(0x4013f000, 135168, 266240, MREMAP_MAYMOVE) = 0x4013f000
    read(3, "\244]\0\0\1C<\0\0\4\354>\0\0\0\7\4\224]\0\0\3\273]\0\0"..., 131072) = 131072
    mremap(0x4013f000, 266240, 528384, MREMAP_MAYMOVE) = 0x4013f000
    read(3, "ym\0array\0fxsave\0MODULE_STATE_GOI"..., 262144) = 262144
    mremap(0x4013f000, 528384, 1052672, MREMAP_MAYMOVE) = 0x4013f000
    read(3, "\1\1\0\0\354)\1\0\1\1\0\0\360)\1\0\1\1\0\0\367)\1\0\1\1"..., 524288) = 29229
    read(3, "", 491520)                     = 0
    read(3, "", 491520)                     = 0
    init_module(ELF", 0x8722d)         = 0
    munmap(0x4013f000, 1052672)             = 0
    close(3)                                = 0
    exit_group(0) 
    Dann noch strace insmod ./zaphfc.ko modes=1

    Code:
    execve("/sbin/insmod", ["insmod", "./zaphfc.ko", "modes=1"], [/* 58 vars */]) = 0
    uname({sys="Linux", node="fe0-noc", ...}) = 0
    brk(0)                                  = 0x8057000
    access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
    open("/etc/ld.so.cache", O_RDONLY)      = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=63529, ...}) = 0
    old_mmap(NULL, 63529, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40018000
    close(3)                                = 0
    open("/lib/tls/libc.so.6", O_RDONLY)    = 3
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0L\1\000"..., 512) = 512
    fstat64(3, {st_mode=S_IFREG|0755, st_size=1359489, ...}) = 0
    old_mmap(NULL, 1137708, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x40028000
    madvise(0x40028000, 1137708, MADV_SEQUENTIAL|0x1) = 0
    mprotect(0x40137000, 27692, PROT_NONE)  = 0
    old_mmap(0x40138000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x10f000) = 0x40138000
    old_mmap(0x4013c000, 7212, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x4013c000
    close(3)                                = 0
    old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x4013e000
    mprotect(0x40138000, 4096, PROT_READ)   = 0
    set_thread_area({entry_number:-1 -> 6, base_addr:0x4013e300, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
    munmap(0x40018000, 63529)               = 0
    brk(0)                                  = 0x8057000
    brk(0x8078000)                          = 0x8078000
    create_module(umovestr: Input/output error
    0, 0)                     = -1 ENOSYS (Function not implemented)
    open("./zaphfc.ko", O_RDONLY)           = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=104760, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\1\0\3\0\1\0\0\0\0\0\0\0"..., 16384) = 16384
    _llseek(3, 0, [16384], SEEK_CUR)        = 0
    read(3, "M\26\0\0\2#\30\22uid\0\36`\1\337\1\0\0\2# \0\7\4\377\33"..., 16384) = 16384
    read(3, "\0\0(g\1M\26\0\0\2#,\23_\r\0\0(h\1\350\24\0\0\2#4\23\336"..., 32768) = 32768
    mmap2(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x4013f000
    read(3, "s\0mmap_base\0rootmnt\0pageset\0popu"..., 65536) = 39224
    read(3, "", 24576)                      = 0
    read(3, "", 24576)                      = 0
    close(3)                                = 0
    munmap(0x40018000, 4096)                = 0
    init_module(ELF", 0x19938)         = 0
    exit_group(0)
    und zu guter letzt strace ztcfg -v

    Code:
    execve("/sbin/ztcfg", ["ztcfg", "-v"], [/* 58 vars */]) = 0
    uname({sys="Linux", node="fe0-noc", ...}) = 0
    brk(0)                                  = 0x8086000
    access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
    open("/etc/ld.so.cache", O_RDONLY)      = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=63529, ...}) = 0
    old_mmap(NULL, 63529, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40018000
    close(3)                                = 0
    open("/lib/tls/libm.so.6", O_RDONLY)    = 3
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P3\0\000"..., 512) = 512
    fstat64(3, {st_mode=S_IFREG|0755, st_size=174623, ...}) = 0
    old_mmap(NULL, 139424, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x40028000
    madvise(0x40028000, 139424, MADV_SEQUENTIAL|0x1) = 0
    old_mmap(0x40049000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x20000) = 0x40049000
    close(3)                                = 0
    open("/lib/tls/libc.so.6", O_RDONLY)    = 3
    read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0L\1\000"..., 512) = 512
    fstat64(3, {st_mode=S_IFREG|0755, st_size=1359489, ...}) = 0
    old_mmap(NULL, 1137708, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x4004b000
    madvise(0x4004b000, 1137708, MADV_SEQUENTIAL|0x1) = 0
    mprotect(0x4015a000, 27692, PROT_NONE)  = 0
    old_mmap(0x4015b000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x10f000) = 0x4015b000
    old_mmap(0x4015f000, 7212, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x4015f000
    close(3)                                = 0
    old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40161000
    mprotect(0x4015b000, 4096, PROT_READ)   = 0
    set_thread_area({entry_number:-1 -> 6, base_addr:0x401615e0, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
    munmap(0x40018000, 63529)               = 0
    brk(0)                                  = 0x8086000
    brk(0x80a7000)                          = 0x80a7000
    open("/etc/zaptel.conf", O_RDONLY)      = 3
    fstat64(3, {st_mode=S_IFREG|0644, st_size=211, ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    read(3, "\n# zaphfc and qozap span definit"..., 4096) = 211
    read(3, "", 4096)                       = 0
    close(3)                                = 0
    munmap(0x40018000, 4096)                = 0
    fstat64(1, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 3), ...}) = 0
    mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40018000
    write(1, "\n", 1
    )                       = 1
    write(1, "Zaptel Configuration\n", 21Zaptel Configuration
    )  = 21
    write(1, "======================\n", 23======================
    ) = 23
    write(1, "\n", 1
    )                       = 1
    write(1, "SPAN 1: CCS/ AMI Build-out: 399-"..., 49SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    ) = 49
    write(1, "\n", 1
    )                       = 1
    write(1, "3 channels configured.\n\n", 243 channels configured.
    
    ) = 24
    open("/dev/zap/ctl", O_RDWR)            = 3
    ioctl(3, 0x40244a12, 0x8061280)         = 0
    ioctl(3, 0x403c4a13, 0x80624bc)         = 0
    ioctl(3, 0x403c4a13, 0x80624f8)         = 0
    ioctl(3, 0x403c4a13, 0x8062534)         = 0
    open("/dev/zap/ctl", O_RDWR)            = 4
    ioctl(4, 0x40044a1a, 0xbfffb3e8)        = 0
    ioctl(4, 0x40704a19, 0xbfffb400)        = 0
    close(4)                                = 0
    ioctl(3, 0x40044a18, 0x804d1a0)         = 0
    ioctl(3, 0x40044a63, 0x8061280)         = 0
    close(3)                                = 0
    munmap(0x40018000, 4096)                = 0
    exit_group(0)                           = ?
    Wenn du kein 64bit Linux verwendest solltest du dich nicht über die eventuell differierenden Funktionsnamen wundern. Achte hauptsächlich auf die returncodes am ende einer jeden Zeile.

    Lass mich wissen was er rausgeworfen hat.

    Gruß
     
  20. schorsch

    schorsch Neuer User

    Registriert seit:
    29 Dez. 2004
    Beiträge:
    31
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke! Ich weiß nicht, ob ich heute noch zu dem Test komme und melde mich erstmal für ein paar Tage (bis Freitag) ab, da ich geschäftlich unterwegs bin. Aber dann....
    Viele Grüße
    Schorsch