.titleBar { margin-bottom: 5px!important; }

Netzwerkeinstellungen Ubuntu8.04 und VM-Ware

Dieses Thema im Forum "Telekom" wurde erstellt von Bolle01, 3 Okt. 2008.

  1. Bolle01

    Bolle01 Mitglied

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    260
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Berlin
    #1 Bolle01, 3 Okt. 2008
    Zuletzt bearbeitet: 3 Okt. 2008
    Hallo, ich habe bis vor einiger Zeit das Flashen der Speedports immer mit einer Knoppix Live CD unter VM-Ware Server gebootet durchgeführt.
    Seit meiner Ubuntu 8.04 Installation auf einem VM-Ware Server (Jars) habe ich Probleme beim Flashen der Image Datei unter Ubuntu.
    Die Internetverbindung allerdings funktioniert, alle Dateien werden heruntergeladen.
    Netzwerkeinstellungen unter Ubuntu ist DHCP
    Netzwerkkarte unter VMWare NAT (Used to share the Host´s IP-Adress)
    Netzwerkeinstellungen des VM-Ware-Server (Rechners) diverse IP-s Manuell vergeben
    unter Anderem 192.168.2.15; ...178.15, .....100.15
    Da ich bei Knoppix keine Probleme hatte, jetzt meine Frage?
    Was ist bei Ubuntu anders, oder was habe ich falsch gemacht? Alle Updates sind übrigens gemacht
     
  2. Ernest015

    Ernest015 IPPF-Promi

    Registriert seit:
    12 Jan. 2007
    Beiträge:
    3,136
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Probier hier mal, die Einstellung auf "Bridged" zu setzen.

    mfg
     
  3. Bolle01

    Bolle01 Mitglied

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    260
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Berlin
    Hat leider nicht geholfen, ich denke ich habe das Problem beim setzen der IP-Adresse auf 192.168.178.x. Meine Standart IP ist 192.168.100.x, damit komme ich inś Internet, aber komme nicht auf die 192.168.178.1. Von der Windowsoberfläche des Rechners, auf dem VM-Ware läuft klappt das problemlos.
    Gibt es eine Möglichkeit unter Ubuntu einer Netzwerkkarte mehrere IP-Adressen zuzuteilen?
     
  4. werwohl

    werwohl Neuer User

    Registriert seit:
    20 Mai 2008
    Beiträge:
    67
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Irgendwie schaff ich es mit Ubuntu auch nicht mehr die IP auf 192.168.178.x zu setzen. Ich behelfe mir damit, die image-Datei per mail auf den PC zu verfrachten und dann per Web-Interface upzugraden.
    Ggfls. gingen auch noch irgendwelche gemeinsamen Ordner, hat auch mal funktioniert.

    Cu,
    Robert
     
  5. Bolle01

    Bolle01 Mitglied

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    260
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Berlin
    So mach ich das auch, kann aber nicht die Lösung sein auf Dauer. Zumal es mit neuen "jungfräulichen" Speedports nur über den Umweg "Recoverdatei" geht. Heute hatte ich eine Kiste die schon einer zu Schrott geflashed hatte, da muste Knoppix wieder mal herhalten, um den Kasten wieder zum Laufen zu bekommen. Da kam mir das IP-Problem mit Ubuntu wieder zu Bewusstsein
     
  6. Ernest015

    Ernest015 IPPF-Promi

    Registriert seit:
    12 Jan. 2007
    Beiträge:
    3,136
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Hallo, ich verstehe das Problem noch nicht so ganz. Es gibt doch unter Ubuntu die Möglichkeit, das Netzwerk manuell mit einer statischen IP-Adresse einzurichten. Oder war das automatische Uploaden der Firmware per Push gemeint? Im Optionsmenü des Scriptes kann unter dem letzten Menüpunkt (Setup a fixed FTP IP Address) zwischen 192.168.178.1 oder 192.168.2.1 ausgewählt werden, siehe auch hier. Im Menüpunkt darüber ist bei mehreren vorhandenen Netzwerkkarten auch eine Auswahl der richtigen Karte möglich.

    mfg
     
  7. Bolle01

    Bolle01 Mitglied

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    260
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Berlin
    Hallo Ernest, vielen Dank für die Geduld, aber es klappt nicht. Möglicherweise liegt das an meiner Einstellung statt Bill Gates lieber die Pinguine im Zoo zu bewundern.
    Es ist natürlich der automatische Upload per Push gemeint.
    Mein "normales" Netzwerk liegt im 192.168.100.x Bereich, die IP-Adressen werden via DHCP zugeteilt, die IP-Adresse des VM-Ware (Host) Server ist fest eingetragen (um auch in die anderen IP-Bereiche.2.x 178.x etc zu kommen. Das klappt unter Knoppix und Microsoft auch wunderbar.
    Ich habe jetzt auf der Virtuellen Ubuntu Maschine 2 Netzwerkkarten eingerichtet und fest 192.168.100.215 sowie 192.168.178.215 vergeben, im Script die Nutzung der 2. Karte und FTP 178.1 eingetragen, leider erfolglos. Mit dem Explorer (Firefox) komme ich zwar auf www.avm.de aber nicht auf 192.168.178.1.
    Wo habe ich den Pinguin verärgert?
     
  8. Ernest015

    Ernest015 IPPF-Promi

    Registriert seit:
    12 Jan. 2007
    Beiträge:
    3,136
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Man muss zwischen der Zugangsadresse für FTP und der "normalen" IP-Adresse der Weboberfläche unterscheiden. Für die Weboberfläche gilt, dass sie mit der originalen oder auch mit der gefritzten AVM-Firmware auf 192.168.178.1 liegt, in der Regel jedoch erst nach einem Werksreset. Die FTP-Adresse, also damit auch der Zugang für die Push-Option kann dagegen alles mögliche sein. Normalerweise ist sie ebenfalls auf 192.168.178.1, werden jedoch beispielsweise mal mtd3 und mtd4 gelöscht, so ändert sich die FTP-Adresse auf 192.168.2.1. Ich hatte aber auch schon mal den Effekt, dass die FTP-Adresse aus irgendwelchen Gründen anders war, in dem Fall 192.168.2.3.
    Um nun herauszufinden, welches die aktuelle FTP-IP-Adresse der Box ist, kann man es am einfachsten mit Telnet probieren. Zunächst muss es in der Box per Telefontastatur aktiviert werden:
    #96*7* schaltet Telnet an
    Dann unter Windows ein DOS-Fenster öffnen (Start - Ausführen und dann cmd eingeben)

    In diesem DOS-Fenster dann telnet 192.168.178.1 eintippen, falls ein Webpasswort gesetzt wurde, jetzt dieses eingeben. Der Bildschirm sieht dann so aus:
    Telnet01.jpg

    Nun kommt folgender Befehl: cat /proc/sys/urlader/environment | grep my_ipaddress

    Ergebnis:
    Telnet02.jpg

    Die hier angezeigte IP-Adresse ist die FTP-Adresse der Box, nicht die der Weboberfläche. Anschliessend kann man das DOS-Fenster wieder schliessen und mit:
    #96*8* das Telnet in der Box wieder ausschalten.

    mfg
     
  9. Bolle01

    Bolle01 Mitglied

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    260
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Berlin
    Hallo Ernest, eine wirklich tolle Erklärung. Allerdings ohne neue Erkenntnisse. Die IP ist definitiv 192.168.178.1 und das Pushen der Imagedatei klappt nicht mit der Ubuntu Installation. Es brennt ja jetzt nicht unbedingt, aber ich will es doch wissen, wo ich den Pinguin geärgert habe und probiere weiter