.titleBar { margin-bottom: 5px!important; }

[Frage] NHIPT IPv6 Portfreigabe?

Dieses Thema im Forum "Freetz" wurde erstellt von Crunk_Bass, 20 Nov. 2011.

  1. Crunk_Bass

    Crunk_Bass Neuer User

    Registriert seit:
    13 Juni 2007
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #1 Crunk_Bass, 20 Nov. 2011
    Zuletzt bearbeitet: 20 Nov. 2011
    Ich würde gerne im NHIPT Webinterface Ports für verschiedene PCs freigeben.

    Momentan sieht meine Konfiguration so aus:
    NHIPT.png

    Die PCs sind also nur innerhalb des LAN über ihre IPv6 Adressen erriechbar. Jetzt hatte ich versucht bei RULES FOR CHAIN FORWARD [ filter ] [ IPv6 ] im Feld Dest IP die IP Adresse anzugeben, was in meinem Fall 2001:4dd0:ff00:8b37:8d66:d84c:d7f6:d12 ist und bei D-Port den Port 25573.

    Wenn ich aber auf Insert drücke kommt folgende Fehlermeldung:
    Code:
    ip6tables v1.4.11.1: unknown option "--dport"
    Try `ip6tables -h' or 'ip6tables --help' for more information.
    Exit Code 2 - ip6tables -t filter -A FORWARD -d 2001:4dd0:ff00:8b37:8d66:d84c:d7 --dport 25573 -j ACCEPT
    Nun meine Fragen:
    - Welches Modul muss ich fest in den Kernel einkompilieren um --dport verwenden zu können? (module loading funktioniert auf meiner 7240 nicht bzw. die Module werden nicht ins Image gepackt)
    - Ist meine bisherige Konfiguration sicher oder kann man da was besser machen?
    - Warum wird die IP Adresse nach 32 Feldern abgeschnitten?
     
  2. HabNeFritzbox

    HabNeFritzbox IPPF-Urgestein
    Forum-Mitarbeiter

    Registriert seit:
    12 Dez. 2017
    Beiträge:
    14,507
    Zustimmungen:
    136
    Punkte für Erfolge:
    63
    Ort:
    fd00:HAM:BURG::/64
    Portweiterleitung gibts bei NAT, also nur bei IPv4.

    Bei IPv6 kannst nur Portfreigabe machen, das die Fritzbox den Port nicht blockiert. Kannst direkt in der Fritzbox IPv6 Freigaben setzen für deinen PC.
     
  3. Crunk_Bass

    Crunk_Bass Neuer User

    Registriert seit:
    13 Juni 2007
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    #3 Crunk_Bass, 20 Nov. 2011
    Zuletzt bearbeitet: 20 Nov. 2011
    Okay Port Forwarding ist der falsche Ausdruck. Ich meinte natürlich Portfreigabe. Hab das wegen der Forward Chain irgendwie so zusammengewürfelt.

    Ich verwende die 7240 nur als IPv6 Gateway (Internetzugang über LAN1) und diese hängt an meiner 7390. Mit der AVM Firmware kann ich keine Verbindung zu SixXS aufbauen. Deswegen habe ich IPv6 im AVM Interface gar nicht aktiviert sondern nur über Freetz aiccu und radvd am laufen. Über das AVM Webinterface kann ich also keine Ports öffnen.

    Oder sehe ich das falsch?
     
  4. Beetlejuice

    Beetlejuice Mitglied

    Registriert seit:
    2 Feb. 2007
    Beiträge:
    251
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Niederrhein
    Das Problem mit dem 'unknown option "--dport" ' hatte ich auf meiner 7270v1 auch und habe es bisher auch nicht lösen können. Ich nutze stattdessen den Parameter 'multiport':
    Code:
    modprobe xt_multiport
    Code:
    ip6tables -t filter -A FORWARD -i sixxs -p tcp -m multiport --dports 1234,5678 -j ACCEPT
    NHIPT benutze ich allerdings nicht zur Eingabe der Regeln, ich mache das über die rc.custom.
     
  5. Crunk_Bass

    Crunk_Bass Neuer User

    Registriert seit:
    13 Juni 2007
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mit dem Befehl auf der Konsole wurde jetzt ein Eintrag erstellt und der Port ist auch von aussen erreichbar.
    Code:
    ip6tables -t filter -A FORWARD -d 2001:4dd0:ff00:8b37:8d66:d84c:d7f6:d12 -i sixxs -p tcp -m multiport --dports 25573 -j ACCEPT
    Danke schon mal für diese vorrübergehende Lösung.

    Das Problem ist jetzt dass der Eintrag zwar in NHIPT auftaucht aber ich den Eintrag nicht über NHIPT erstellen kann. Bei dem Feld Module habe ich multiport nicht zur Auswahl. Hoffentlich meldet sich hier noch jemand der sich mit NHIPT auskennt.
     
  6. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Dir ist aber aufgefallen, dass im ersten Beitrag das "-p tcp" fehlt und daher --dport nicht funktioniert?
     
  7. Crunk_Bass

    Crunk_Bass Neuer User

    Registriert seit:
    13 Juni 2007
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmm das kommt dabei raus wenn man im Halbschlaf immer noch an der Konfiguration rumbastelt. Ich hatte wirklich vergessen das Protokoll anzugeben.

    Wenn ich das Protokoll mit angebe bekomme ich folgende Fehlermeldung:
    Code:
    ip6tables v1.4.11.1: host/network `2001:4dd0:ff00:8b37:8d66:d84c:d7' not found
    Try `ip6tables -h' or 'ip6tables --help' for more information.
    Exit Code 2 - ip6tables -t filter -A FORWARD -d 2001:4dd0:ff00:8b37:8d66:d84c:d7 -i sixxs -p tcp --dport 25573 -j ACCEPT
    Der Eintrag würde also funktionieren aber kann nicht eingetragen werden weil ja die IP Adresse nach 32 Stellen abgeschnitten wird. Ich wundere mich gerade warum das sonst noch keinem aufgefallen ist. Dieses Problem müsste sich doch schnell lösen lassen oder?
     
  8. RalfFriedl

    RalfFriedl IPPF-Urgestein

    Registriert seit:
    22 Apr. 2007
    Beiträge:
    12,343
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Funktioniert das Kommando denn von der Kommandozeile aus, mit vollem Hostnamen?
    Was, wenn Du den Hostnamen in die hosts Datei einträgst und den Namen verwendest?
     
  9. Crunk_Bass

    Crunk_Bass Neuer User

    Registriert seit:
    13 Juni 2007
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Von der Kommandozeile aus mit kompletter IP Adresse funktioniert der Befehl. Die Freigabe taucht dann auch im NHIPT Webinterface auf.

    IP in hosts Datei eintragen und dann den Namen verwenden funktioniert nicht. Hier bekomme ich folgenden Fehler angezeigt:
    Code:
    ip6tables v1.4.11.1: host/network `testpc' not found
    Try `ip6tables -h' or 'ip6tables --help' for more information.
    Exit Code 2 - ip6tables -t filter -A FORWARD -d testpc -i sixxs -p tcp --dport 25573 -j ACCEPT
    @HabNeFritzbox: Das AVM Webinterface weiß nicht mal dass die Fritzbox als IPv6 Router läuft. Siehe meinen zweiten Post in diesem Thread.