.titleBar { margin-bottom: 5px!important; }

Outbound Proxy oder STUN oder beides?

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von klimeck, 19 Aug. 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. klimeck

    klimeck Neuer User

    Registriert seit:
    14 Apr. 2005
    Beiträge:
    41
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Utrecht
    Hallo,

    leider werde ich aus den vielen Berichten hier im Forum nicht ganz schlau...

    Ich benutze als Line 1 einen Sipgate-Account und habe regelmaessig Probleme, bedeutet, dass ich nicht angerufen werden kann. Anrufer erhalten kein Freizeichen, es klingelt nicht etc.

    Wenn ich die SPA-3000 kurz vom Strom nehme, dann funktioniert alles fuer einen Zeitraum x.

    Auf sipgate.de ist beschrieben, dass STUN und Outbound Proxy verwendet werden. Die Eintargungen habe ich so uebernommen.

    Weiterhin habe ich die entsprechenden Port der Firewall (Zyxel Prestige 2602H, symmetric NAT) auf die SPA-3000 weiterleite.

    Kann mir jemand einen Tipp geben? Danke!

    Tom
     
  2. exim

    exim Admin a.D.

    Registriert seit:
    27 Apr. 2004
    Beiträge:
    1,013
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Versuche mal den NAT-Keepalive, das Feld "NAT Keep Alive Msg" leer lassen. Läuft es damit?
     
  3. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe so ziemlich das gleiche Problem: Anfang September habe ich mit VoIP über Sipgate angefangen. Zwei Wochen lang lief es mit einem ZyXEL 2002L alles perfekt. Doch nach diesen zwei Wochen ist es jetzt eigentlich immer so, dass ich ab ca. 17 Uhr nicht mehr erreichbar bin (manchmal ist auch das Phänomen, wie es klimek beschrieben hat, zu beobachten). Anrufer erhalten ein Besetztzeichen. Raustelefonieren geht problemlos. Bis dahin habe ich auch rein gar nichts an der Konfiguration geändert! Das Problem kam wirklich (auch wenn es schwer zu glauben ist) aus dem Nichts.

    Darauf habe ich mit dem Sipgate-Support gesprochen, aber die konnten mir auch nur Tipps wie Portweiterleitung, Stun usw. geben, was alles nichts brachte. Zudem haben die mir sogar eine zweite Rufnummer gegeben, die sich aber wie die Erste verhält.

    Nun habe ich den ZyXEL 2002L gegen ein Sipura 2000 getauscht und das Problem besteht weiterhin - ich habe sogar den Eindruck, dass es nach dem Umstieg noch schlimmer geworden ist.

    Ein zusätzlich angelegter web.de Account funktioniert mit der gleichen Hardware immer problemlos.

    Ich hoffe, dass mir hier vielleicht jemand weiterhelfen kann. Ich bin echt am Verzweifeln :(


    Router: AVM Fritz!Box WLAN 3030 (Firmware 21.03.87)
    VoIP-Adapter: Sipura SPA 2000 (Firmware 2.0.7(f))
    VoIP Provider: Sipgate
    DSL: 2000 GMX


    MfG
    zwelch
     
  4. exim

    exim Admin a.D.

    Registriert seit:
    27 Apr. 2004
    Beiträge:
    1,013
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Auch hier Test:
    - Stun aktivieren, also nicht nur eintragen sondern auch die STUN-Tests einschalten
    - versuchsweise den outbound proxy abschalten: Use Outbound Proxy = No, Use OB Proxy In Dialog = No
    - im Tab "SIP" ganz unten NAT Keep Alive Intvl auf 15
    - im Tab der entsprechenden Leitung "NAT Keep Alive Enable" auf "yes" und das Feld "NAT Keep Alive Msg" leer lassen

    Läuft es damit?

    Die 2.0.7f für den SPA-1000/2000 war übrigens eine Beta-Version, die es nie zum Download gab, die darauf folgende 2.0.8 hat ziemlich gesponnen. Ein Update auf zumindest 2.0.9d oder besser noch 2.0.13g wäre nicht verkehrt ...
     
  5. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Die Firmware habe ich bereits gestern auf 2.0.13(g) aktualisiert.
    Hatte ich schonmal erfolglos getestet.
    Steht bereits darauf.
    Ist auch bereits so und hilft nicht.

    Den Outbound Proxy werde ich heute noch testen.

    //edit
    Update auf Firmware 3.1.5

    MfG
    zwelch
     
  6. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hilft nicht. Dadurch tauchte jetzt nur noch ein Problem mehr auf, nämlich dass das Telefon (nach dem Auflegen der Gegenstelle) weiter klingelt, bis man abnimmt.
     
  7. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @zwelch:
    Hast Du die Möglichkeit die Ports am Router zu mappen, dann mach das?!

    Gruß
    C
     
  8. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    In der Fritz Box kann ich Ports freigeben (was ich auch mache - UDP: 10000, 5004-5005, 5060-5061, 16384-16482, 16483-16500). Ich weiß jedoch nicht wirklich, was Port Mapping ist. Des weiteren kann ich IP Routen anlegen, wo ich aber überhaupt nicht weiter weiß.
     
  9. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ok, die Mappings die Du wirklich brauchst sind:
    5060 + 5061 (TCP/UDP) und
    16384 bis 16482 (UDP)
    Die anderen Ports werden vom SPA nicht genutzt.

    Portmapping öffnet Ports bestimmter Dienste/Geräte für die Außenwelt (macht sie erreichbar und das wollen wir ja beim SPA). Die IP-Routen kannst Du ignorieren.

    Such mal in der Konfiguration der FBF nach Portmapping, -forwarding oder -weiterleitung. Dort gibts Du dann die o.g. Ports an mit der IP des SPA als Ziel (Du solltest dafür dem SPA eine feste IP geben falls noch nicht geschehen).

    Ggf. überprüfe mal, ob Du die STUN-Settings (unter SIP) wie auf der Seite in meiner Signatur hast.

    Gruß
    C
     
  10. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe das Port-Mapping für 5060-5061 TCP auch noch aktiviert. Die anderen sind ja bereits drin.

    Der SPA hat eine feste IP. DHCP ist deaktiviert.

    STUN-Settings sind jetzt genauso wie bei deiner Config. Sowieso habe ich schon einen Großteil nach deiner Config eingerichtet.

    Hat aber alles nichts gebracht. :(

    MfG
    zwelch
     
  11. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Du willst uns also ärgern... ;)

    Hast Du irgend welche Firewall-Regeln definiert, mit denen Du Dich selbst blockierst? Hast Du noch ein anderes SIP-Gerät im Netz? Setze mal den "NAT Keep Alive Intervall" (übergangsweise) auf 3 herab und berichte.
    Danach poste mal bitte die Einstellungen der FBF und dem SPA (oder schick sie mir per pn oder Mail).

    Gruß
    C
     
  12. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Jup :lol:
    Aber tröste dich, der Sipgate-Support ist auch mit seinem Latein am Ende (Nicht, dass du denkst, ich würde nur euch nerven :wink: )

    Nicht, dass ich wüsste.

    Nein.

    Hilft nichts.

    SPA-Conf: http://www.die-firma.ws/sipura/info.htm
    FritzBox Portfreigabe: http://www.die-firma.ws/sipura/fritzbox_portfreigabe.jpg

    MfG
    zwelch
     
  13. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Fein, sieht alles wie erwartet ok aus. Die Mappings greifen auch, das Problem muss also ein anderes sein.
    Dein Router hat auch definitiv die 172.16.0.254?

    Setz mal (wie besprochen) noch den "Register Expires"-Wert auf 60 oder weniger und danach bleibt nur noch Sipgate.

    Gruß
    C
     
  14. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Jup

    Habe ich bereits während unseres Gespräches gemacht. Eben hat es nicht funktioniert, momentan geht es :arrow: ich werde das noch etwas testen und rückmeldung machen.
     
  15. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wie nicht anders zu erwarten, hat das Ändern von "Register Expires" auch nichts gebracht.
    Ich gebs auf...
    ...und versuchs mit einem Becher-Schnur-Telefon :roll:
     
  16. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    na dann...
     
  17. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe heute eine Antwort von Sipgate bekommen. Demnach ist nicht Sipgate sondern "definitiv" der Carrier Telefonica schuld. Die würden meine Telefonnummer nicht richtig weiterleiten und würden auf Anfragen von Sipgate bezüglich dieses Problems nicht reagieren.
     
  18. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Und eine Lösung (außer den Anbieter zu wechseln) gab's nicht?

    Gruß
    C
     
  19. zwelch

    zwelch Neuer User

    Registriert seit:
    16 Okt. 2005
    Beiträge:
    63
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe erstmal noch eine andere Telefonnummer bekommen (ohne Ortsvorwahl) und mit der funktioniert es bis jetzt. Mal zwei Tage testen und weiter sehen...

    Das Problem ist ja, dass ich eigentlich einen Provider brauche, der mir meine Ortsvorwahl bietet oder zumindest eine Nummer zum Ortstarif (-> keiner ist bereit für ein Ortsgespräch wie für ein Ferngespräch zu zahlen). Und da Sipgate bis jetzt der einzige Provider ist, der mir das zu akzeptablen Preisen ohne 100 Euro Einrichtugnsgebühr bietet, tue ich mich mit dem Wechsel ncoh etwas schwer.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.