.titleBar { margin-bottom: 5px!important; }

peer-Registrierung auf vServer (NAT)

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von Holg, 2 Feb. 2006.

  1. Holg

    Holg Neuer User

    Registriert seit:
    17 Sep. 2004
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    Ich habe mir gerade mal auf meinem vServer (Server im Internet), ein sip show peer 200 auf meiner Anlage angeschaut. Der peer ist mir nat=yes eingebunden.

    folgendes kam dabei raus:

    Sollte unter Reg. Contact nicht die public IP meines DSL-Zugangs stehen???
    Und wie darf ich
    Defaddr->IP : 0.0.0.0 Port 5060
    verstehen? Kommt das von asterisk oder vom ip-Phone. Auf dem IP-Phone habe ich nämlich port 50200 angegeben?

    Ich habe das Problem, das meine 3 IP-Telefone nach einer paar Stunden unreachable werden.

    Gruß
    Holg
     
  2. betateilchen

    betateilchen Grandstream-Guru

    Registriert seit:
    30 Juni 2004
    Beiträge:
    12,882
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    am Letzenberg
    Das ist einzig und alleine ein Problem Deines lokalen Routers - und nicht der Asterisk-Konfiguration oder des vServers.
     
  3. Holg

    Holg Neuer User

    Registriert seit:
    17 Sep. 2004
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also ich habe gerade herausgefunden, dass man die Variable port und defaultip bei den peer Einstellungen in der sip.conf setzen kann (für defaultip ist auch ein dyndns Eintrag möglich)

    Wenn ich das mache stimmt der Eintrag Defaddr->IP:
    Der ist im übrigen dafür da, dass ein Telefon, welches sich noch nicht oder nicht mehr registriert ist trozdem angesprochen werden kann. (war mir neu)

    Sicher nicht, da ich 3 weitere Telefone habe bei denen das Phänomen nicht auftritt. (Sorry hätte ich erwähnen sollen)

    Also:
    2x GS GXP 2000, 1 x BT 101 -> keine Probleme
    3 x BT 101 -> irgendwann unreachable, wobei eines davon sogar status unknown bekommt.

    Ich tippe mittlerweile auf ein Konfigurationsproblem der BTs. Ich habe jetzt mal den Eintrag "NAT Traversal" auf yes gesetzt und das Feld dahinter leer gelassen.
    Diese Einstellung ist die Einzige, die sich zwischen dem funktionierenden und den nicht funktionierenden BTs unterscheidet. Sendet dann das BT dauernd irgendwelche Anfragen?

    Gruß
    Holg

    Router ist übrigens ein IPCop 1.4.10 mit Portfowarding auf die Telefone. (Das muß auf diese Weise sogar so funktionieren, dass wenn die Firewall die Verbindung auf dem Port nicht offen hält, die Anfrage trotzdem beim Telefon landet). Ich denke vorallem, dass hier der Port- und Defaultip Eintrag auf Seiten des Asterisk weiterhelfen.
     
  4. Holg

    Holg Neuer User

    Registriert seit:
    17 Sep. 2004
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So... jetzt ist es mal wieder soweit. Drei der 6 Telefone haben unter show peers den status unknown, obwohl alle in deren Status registered anzeigen.

    Dank der defaultip sind sie aber noch erreichbar - klingeln. Ich habe bei allen mal ein Firmwareuupgrade gemacht keine Änderung.

    Gibt es noch eine Einstellung auf den BTs, die man machen kann, damit sie unter show peers als registriert erscheinen? Was ist mit der NAT Einstellung?

    [eidt]
    Kann das auch etwas mit der Zwangstrennung zu tun haben?

    Gruß
    Holg