.titleBar { margin-bottom: 5px!important; }

Port Forwarding wirklich nötig?

Dieses Thema im Forum "Gigaset" wurde erstellt von rob, 19 März 2005.

  1. rob

    rob Mitglied

    Registriert seit:
    15 Feb. 2005
    Beiträge:
    399
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hab bei mir ein wirklich seltsames Phänomen entdeckt - vielleicht kann das jn. von Euch auch noch mal nachstellen. Hab auch schon mal im allgemeinen Teil von VoIP versucht, den Hintergrund zu erfragen, aber bislang keine wirkliche Antwort dazu!

    Ich hab in meinem privaten Netz ein Softphone (freephone oder Freenetiphone, ... irgendwas SIPpiges) installiert. Um diese zu verwenden, hatte ich bislang die für den jeweiligen Provider einschlägigen Ports gePATted/geforwarded). Mehr aus Versehen hab ich das Portforwarding mal ausgeschaltet und konnte trotzdem angerufen werden.
    Nur um ganz sicher zu sein, hab ich auch mal folgendes gemacht:
    - Portscan auf das Gigaset - nichts ungewöhnliches
    TCP
    PORT STATE SERVICE
    139/tcp open netbios-ssn
    1720/tcp filtered H.323/Q.931
    6667/tcp filtered irc
    8081/tcp open blackice-icecap
    UDP
    137/udp open|filtered netbios-ns
    138/udp open|filtered netbios-dgm
    161/udp open|filtered snmp
    162/udp open|filtered snmptrap
    520/udp open|filtered route
    1434/udp open|filtered ms-sql-m
    1900/udp open|filtered UPnP
    32768/udp open|filtered omad
    ==> nichts ungewöhnliches (RTP ...)
    (na ja, 137-139 und 1434 hätten sie sich auf dem WAN auch sparen können)
    - der Pakettrace ergab gehäuft Zugriffe auf die Proxy-Server

    Jetzt hätt ich nur noch gerne ne Erklärung dazu. Vielleicht ist mir da bislang was durch die Lappen gegangen?
    Meine Erklärung wäre die, daß das unter bestimmten Voraussetzungen (z.B. kein symetrisches NAT, sondern Full Cone NAT), STUN-Server ... wirklich funktionieren kann.
    Irgendjemand einen Hint?
    Würde einigen auch die Arbeit ersparen, immer die PATs einzurichten (es sei denn, es gibt keinen Proxy ...)

    Gruß,

    rob
     
  2. karpe

    karpe Mitglied

    Registriert seit:
    22 Dez. 2004
    Beiträge:
    574
    Zustimmungen:
    1
    Punkte für Erfolge:
    18
    Beruf:
    Dipl.-Ing. Spezialität Rechnernetze
    Ort:
    Hamburg
    Hallo Rob,

    ich denke, du hast einen STUN Server eingetragen. Nach meinem bisherigen Verständnis ist es sein Zweck, die NAT zu öffnen für eingehende Anrufe.

    Hast du den Portscan auf der WAN Seite gemacht ?

    Eigentlich gehören die Microsoft Ports da wirklich gesperrt, wenngleich es sich dabei sicherlich nur um den internen Fileserver handelt ;-(

    Klaus
     
  3. rob

    rob Mitglied

    Registriert seit:
    15 Feb. 2005
    Beiträge:
    399
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Karpe,

    ja - STUN-Server ist eingetragen (s.o.) - ich vermute auch, daß es daran liegt (in Verbindung mit bestimmten NATs), aber erklären kann ich's mir nicht ganz genau. Würde bedeuten, daß Port Forwarding gar nicht nötig ist (wenn eben gewisse Voraussetzungen passen).
    Die Ports sind auf der WAN-Seite - wo die NetBIOS-Ports definitiv nicht hingehören.

    Gruß,

    Rob