[Gelöst] PPTPD seltsamer Fehler im Log

han-solo

Mitglied
Mitglied seit
28 Jul 2005
Beiträge
451
Punkte für Reaktionen
0
Punkte
0
Hallo zusammen,

ich habe freetz-devel-11903 auf meiner 7390 und bekomme beim Connect meines iPhone zur Box folgenden merkwürdigen Fehler (IP ausge-X-ed):

Code:
Mar 28 09:34:59 fritz daemon.info pptpd[16425]: MGR: Maximum of 100 connections reduced to 11, not enough IP addresses given
Mar 28 09:34:59 fritz daemon.info pptpd[16426]: MGR: Manager process started
Mar 28 09:34:59 fritz daemon.info pptpd[16426]: MGR: Maximum of 11 connections available
Mar 28 09:35:01 fritz daemon.info pptpd[16704]: CTRL: Client xx.xx.xx.xx control connection started
Mar 28 09:35:01 fritz daemon.info pptpd[16704]: CTRL: Starting call (launching pppd, opening GRE)
Mar 28 09:35:02 fritz daemon.err pppd[16706]: unrecognized option ÿÿÿÿÿÿþÿÿÿÿÿÿÿÿ2.168.179.52'
Mar 28 09:35:02 fritz daemon.err pptpd[16704]: GRE: read(fd=6,buffer=415ca8,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Mar 28 09:35:02 fritz daemon.err pptpd[16704]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Mar 28 09:35:02 fritz daemon.info pptpd[16704]: CTRL: Client xx.xx.xx.xx control connection finished
Mar 28 09:35:02 fritz daemon.err pptpd[16704]: CTRL: Couldn't write packet to client.
Mar 28 09:35:02 fritz daemon.err pptpd[16704]: CTRL: Couldn't write packet to client.

Dazu meine Configs:

options.pptpd
Code:
name fritzbox
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
mppe required
mppe stateless
nodeflate
ms-dns 192.168.179.1
proxyarp
lock
nobsdcomp
novj
novjccomp

pptpd.conf
Code:
ppp /usr/sbin/pppd
option /etc/ppp/options.pptpd
localip 192.168.179.1
remoteip 192.168.179.52-62

secret:
Code:
# client	server	secret			IP addresses
username fritzbox password *
EOF

Mein iPhone gibt aus:
Code:
Die Verbindung wurde vom Kommunikationsgerät getrennt.....

Jemand ne Idee was dieses "unrecognized option ÿÿÿÿÿÿþÿÿÿÿÿÿÿÿ2.168.179.52'" zu bedeuten hat?

Gruß
HS
 
Zuletzt bearbeitet:
Hallo RalfFriedl, hab ich bereits schon getan aber ich bekomme leider nicht mehr Meldungen im LOG als vorher.
Ich habe einen ähnlichen Fall im web gefunden: https://bbs.archlinux.org/viewtopic.php?id=140838

In meiner Freetz-Compile-Umgebung unter ./source/target-mipsel_gcc-4.6.4_uClibc-0.9.29/pptpd-1.3.4/pptpctrl.c ist der selbe Eintrag zu finden.
Vielleicht handelt sich tatsächlich um einen Bug in den Sourcen.

Allerdings habe ich gestern ein Image für eine 7170 kompiliert und dort funktioniert es einwandfrei.

Gruß
HS
 
Hab gerade ein Freetz Ticket mit dem selben Problem gefunden: http://freetz.org/ticket/2244
Ist aber von cuma auf fixed gesetzt worden. Allerdings im kernel BusyBox v1.21.1

Aktuell ist aber BusyBox v1.22.1.

Habe Ticket 2244 reopend.
Neues Ticket: http://freetz.org/ticket/2427

Kann da einer von den Entwicklern bitte den Fix durchführen?
Vielen Dank schonmal!

Gruß
HS
 
Zuletzt bearbeitet:
Moin

Idee!

Vielleicht hat dies etwas mit dem komischen Fehler zu tun, der auftritt bei Geräten mit statischer IP.
Siehe Screenshot.
 

Anhänge

  • festvergebene_ip_fehler_01.jpg
    festvergebene_ip_fehler_01.jpg
    47.5 KB · Aufrufe: 12
Hab gerade ein Freetz Ticket mit dem selben Problem gefunden: http://freetz.org/ticket/2244
Ist aber von cuma auf fixed gesetzt worden. Allerdings im kernel BusyBox v1.21.1
Im Ticket geht es um AVM OS6, der Fehler mit pptpd wird nur am Rande erwähnt.
Und Busybox ist kein Kernel.

Wenn debug nichts zusätzliches bringt, gehen die Meldungen wohl irgendwo unter. Nimm dann mal
Code:
nolog debug logfile /tmp/pppd.log
und schau nach, ob in /tmp/pppd.log etwas steht.
 
Zuletzt bearbeitet:
Negativ. Die Datei wird zwar angelegt, aber ist leer.

Code:
root@fritz:/var/mod/root# cat /tmp/pppd.log
root@fritz:/var/mod/root# ls -l /tmp/pppd.log
-rw-r--r--    1 root     root             0 Mar 28 14:40 /tmp/pppd.log
 
cat /etc/ppp/options.pptpd

Code:
name fritzbox
refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
mppe required
mppe stateless
nodeflate
ms-dns 192.168.179.1
proxyarp
debug logfile /tmp/pppd.log
lock
nobsdcomp
novj
novjccomp
 
Da ist nichts dabei, das meiner Meinung nach das Protokoll verhindern sollte.

Der Link, den Du als Freetz Ticket gehängt hast, könnte der Grund für den Fehler enthalten.
 
Ja, aber macht das wirklich Sinn, wenn es bei meiner 7170 funktioniert? Die Sourcen sind doch die selben.
Wie auch immer, habe die Scripte verändert und kompiliere gerade neu. Mal sehen was dabei rauskommt.
 
Haha, das war wirklich das Problem. Jetzt funktioniert es!
Und jetzt wird auich das Logfile geschrieben.

Code:
using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/pts/0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0xbd96bdfc> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x18f13f56> <pcomp> <accomp>]
sent [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x18f13f56> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth chap MS-v2> <magic 0xbd96bdfc> <pcomp> <accomp>]
sent [CHAP Challenge id=0x1d <71a06d552d6f96719f04b3f735639233>, name = "fritzbox"]
rcvd [LCP EchoReq id=0x0 magic=0x18f13f56]
sent [LCP EchoRep id=0x0 magic=0xbd96bdfc]
rcvd [CHAP Response id=0x1d <7754db56cc4ca5ce746a9259bd5939700000000000000000debf02b2e83724767fcbe1a441191f1a1dc93ee07c9d102901>, name = "username"]
sent [CHAP Success id=0x1d "S=089C72EEEF5CA56E15B645C800F0BEC1197F0B67 M=Access granted"]
sent [CCP ConfReq id=0x1 <mppe +H +M +S +L -D +C>]
sent [IPCP ConfReq id=0x1 <addr 192.168.179.1>]
rcvd [CCP ConfReq id=0x1 <mppe +H -M +S +L -D -C>]
sent [CCP ConfNak id=0x1 <mppe +H -M +S -L -D -C>]
rcvd [CCP ConfNak id=0x1 <mppe +H -M +S -L -D -C>]
sent [CCP ConfReq id=0x2 <mppe +H -M +S -L -D -C>]
rcvd [IPCP TermAck id=0x1]
rcvd [CCP ConfReq id=0x2 <mppe +H -M +S -L -D -C>]
sent [CCP ConfAck id=0x2 <mppe +H -M +S -L -D -C>]
rcvd [CCP ConfAck id=0x2 <mppe +H -M +S -L -D -C>]
MPPE 128-bit stateless compression enabled
rcvd [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
sent [IPCP ConfNak id=0x1 <addr 192.168.179.52> <ms-dns1 192.168.179.1> <ms-dns2 192.168.179.1>]
rcvd [IPV6CP ConfReq id=0x1 <addr ff81::3ce0:785e:0ab4:4f0f>]
Unsupported protocol 'IPv6 Control Protocol' (0x8057) received
sent [LCP ProtRej id=0x2 80 57 01 01 00 0e 01 0a 3c d0 78 6e 0a b4 4e 0f]
rcvd [IPCP ConfReq id=0x2 <addr 192.168.179.52> <ms-dns1 192.168.179.1> <ms-dns2 192.168.179.1>]
sent [IPCP ConfAck id=0x2 <addr 192.168.179.52> <ms-dns1 192.168.179.1> <ms-dns2 192.168.179.1>]
sent [IPCP ConfReq id=0x1 <addr 192.168.179.1>]
rcvd [IPCP ConfAck id=0x1 <addr 192.168.179.1>]
found interface tap0 for proxy arp
local  IP address 192.168.179.1
remote IP address 192.168.179.52
Script /etc/ppp/ip-up started (pid 4654)
Script /etc/ppp/ip-up finished (pid 4654), status = 0x0


Lösung:

Scripte geändert in:

./source/target-mips_gcc-4.7.3_uClibc-0.9.33.2-nptl/pptpd-1.3.4/pptpctrl.c
./source/target-mipsel_gcc-4.6.4_uClibc-0.9.29/pptpd-1.3.4/pptpctrl.c

Code:
...
        char pppInterfaceIPs[33];
        if (*pppaddrs[0] || *pppaddrs[1]) {
                sprintf(pppInterfaceIPs, "%s:%s", pppaddrs[0], pppaddrs[1]);
                pppd_argv[an++] = pppInterfaceIPs;
        }
...

Danach neu compiliert:
Code:
[freetz@asmodina freetz-trunk]$ make clean
[freetz@asmodina freetz-trunk]$ make
 
Kostenlos!

Statistik des Forums

Themen
248,917
Beiträge
2,305,038
Mitglieder
378,638
Neuestes Mitglied
Patrick89