.titleBar { margin-bottom: 5px!important; }

Problem mit misdn + A@H 2.1 (Centos 4.2) mit HFC Karte

Dieses Thema im Forum "Asterisk ISDN mit mISDN" wurde erstellt von rubinho, 7 Dez. 2005.

  1. rubinho

    rubinho Mitglied

    Registriert seit:
    3 Aug. 2004
    Beiträge:
    206
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Beruf:
    Netz Admin
    Ort:
    Saarland
    Hallo

    Ich bin seit 4 Tagen dran eine lauffähige A@H 2.x Version zu installieren mit eingebundener HFC-Karte.

    3 Tage hab ich mit Bristuff probiert und jetzt wollte ich es mit misdn ausprobieren.

    Leider bekomme ich wärend der Installation die Fehlermeldung "DEBUG_Spinlock in Kernel enabled"

    Wie bekomme ich unter Centos den Debug_Spinlock deaktiviert.

    Gruß
    Rubinho
     
  2. LateRunner

    LateRunner Mitglied

    Registriert seit:
    24 Mai 2004
    Beiträge:
    253
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    spinlock

    Hallo,
    die Fehlermeldung ist doch eindeutig. Es wird dort eine conf Datei angegeben. Diese mit dem midnight commander (mc) suchen und editieren Die entsprechede zeile ... spinlock .. suchen und von y auf n setzen. Übrigens kommt dann noch eine Fehlermeldung die sich auf die nächste Zeile (ebenfalls spinlock ...) bezieht auch hier statt y n eingeben. speichern nicht vergessen (F2) und es noch einmal versuchen. Dann läuft das script durch.

    VG

    Laterunner
     
  3. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @late

    Spinlock ist eine Debugging-Art für SMP Kernel.
    Da mISDN nicht mit SMP läuft, sollte man eher
    den Kernel austauschen. Meinst Du nicht?

    Im Übrigen würde ich von HFC mit mISDN abraten,
    aber das soll auch jeder selbst ausprobieren.

    Gruß
    britzelfix
     
  4. rubinho

    rubinho Mitglied

    Registriert seit:
    3 Aug. 2004
    Beiträge:
    206
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Beruf:
    Netz Admin
    Ort:
    Saarland
    Ich würde ja gerne den Bristuff benutzen aber ich bekomme es nicht auf die Reihe

    Bristuff lässt sich zwar fehlerfrei installieren aber nach dem Reboot läuft Asterisk nicht mehr hoch und der Treiber wird nicht geladen .
     
  5. LateRunner

    LateRunner Mitglied

    Registriert seit:
    24 Mai 2004
    Beiträge:
    253
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @britzelfix

    interessant - abraten ok aber warum?

    ich kämpfe gerade mit dem chan_istdn,

    sieht alles ganz gut aus aber, wenn ich "misdn-init start" eingebe erhalte ich ich neben anderen Meldungen eine Fehlermeldung:

    Badness in interruptable_sleep_on at kernel/sched.c:2975

    im log steht:
    ...
    HFC-PCI: IRQ 5 count 24
    mISDN: HFC-PCI driver Rev. 1.38
    HFC no more cards found
    HFC 1 cards installed

    amportal startet nicht

    woran kann das liegen?

    VG

    Laterunner
     
  6. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @late

    lies mal den code, dann wirst Du's wissen.

    Gruß
    britzelfix
     
  7. LateRunner

    LateRunner Mitglied

    Registriert seit:
    24 Mai 2004
    Beiträge:
    253
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @ britzelfix

    was soll ich denn damit anfangen, - also mal ehrlich, das hilft nicht weiter.

    Der momentane Stand scheint wohl so zu sein:

    AAH und Bristuff geht nicht richtig

    AAH und misdn geht wohl auch nicht

    AAH und visdn geht wohl auch noch nicht.

    Da hilft wohl nur warten und bei den alten Versionen bleiben und den code lesen :(

    VG

    Laterunner
     
  8. britzelfix

    britzelfix Gesperrt

    Registriert seit:
    28 Mai 2004
    Beiträge:
    1,099
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Braunschweig
    @late

    *g*, wobei bristuff schon mal ging und es CAPI auch noch gibt.
    Ich glaube das File heißt hfc_pci.c, fang mal damit an.
    mISDN lief mal bei mir 12 Stunden, danach nichts mehr. Leider
    äußern sich die Entwickler nicht zum aktuellem Stand.
    Was dort in den Readme's steht, das stimmt garnicht. Das blöde
    ist, daß viele es glauben und versuchen wie bekloppt es zum laufen
    zu bringen. In der isdn4linux-ml will man aber auch nicht helfen.
    Beronet hat schon lauffähige Treiber, Winbond läuft garnicht,
    HFC zu 50%. Fritz k.a.

    Gruß
    britzelfix