.titleBar { margin-bottom: 5px!important; }

Problem mit STUN beim F1000 und freenet.de

Dieses Thema im Forum "Andere VoIP-Hardware" wurde erstellt von RealNexus, 7 Sep. 2005.

  1. RealNexus

    RealNexus Neuer User

    Registriert seit:
    7 Sep. 2005
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    ITler
    Ort:
    Erfurt, Düsseldorf, Frankfurt
    Hallo,
    ich gehöre sicherlich zu den VoIP-Neulingen und bin froh ein passendes Forum gefunden zu haben ;-)

    Ich habe mir einen F1000 zugelegt - nach der ersten Eingabe der freenet-iphone-Daten konnte sich das Telefon anmelden, ich konnte jedoch keine Gespräche führen - egal ob mit STUN oder nicht. Nach dem Softwareupdate auf 3.10st war es mir dann möglich die ausgehenden Gespräche in Spitzenqualität(!!!) zu führen. Nur leider konnte ich keine Gespräche annehmen. Bei STUN habe ich alles mögliche versucht... iphone-stun.freenet.de und Port 10000. Aber hier bucht er sich gar nicht ein - auch nach einer halben Stunde nicht... Ich habe versucht die Ports von 5060 auf 5069 oder ähnl. umzustellen - das gleiche Ergebnis - ich kann raustelefonieren - andere Richtung geht nicht.

    Man muss auch dazu sagen, dass ich keinen Zugriff auf die Router habe - ich bin oft unterwegs und nutze die WLAN-Infrastrukturen von Unterwegs (Hotel, Kunden-WLAN etc) mit STUN sollte es eigentlich keine Probleme geben.. oder irre ich mich da?
    Woran könnte es denn liegen? veralteter Router? oder ein Router mit "zu scharfen" Regeln für eingehende UDP Verbindungen?

    Für ein paar Tips wäre ich euch sehr dankbar...
    Alex
     
  2. RealNexus

    RealNexus Neuer User

    Registriert seit:
    7 Sep. 2005
    Beiträge:
    139
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    ITler
    Ort:
    Erfurt, Düsseldorf, Frankfurt
    Selbst ist der Mann... ;-)

    Problem gelöst.. es lag an mehreren Dingen...

    zum einen, war die Portnummer für den STUN-Server von freenet falsch. Nach langem Suchen, habe ich auf einer recht aktuellen Seite den Port 3478 (statt 10000) gefunden.
    Trotzdem wollte er sich nicht anmelden...
    Dann war schluss mit Lustig... Da ich immer eine WLAN-Alternative dabei habe (Neben der PCMCIA-WLAN-Karte auch einen USB-WLAN-Stick) habe ich schnell mein Notebook zum AP "umgenbaut" (also für das Phone und die eine WLAN-Karte eigenes WLAN-Netz aufgebaut) und somit den gesamten Verkehr zwischen dem WLAN-Handy und dem Netz abgelauscht und die Datenpakete an das WLAN-Netz weitergeleitet. Aus Gründen wie auch immer, hat der Router entweder die Pakete nicht an den Stun-Server übertragen oder sich strickt geweigert Datenpakete anzunehmen. Da ich keinen Zugriff auf den Router habe, ist es also nur eine Vermutung...

    OK... kein Problem, über einen VPN-Tunnel habe ich sämtliche Kommunikation über meinen Server umgeleitet und siehe da - es klappt.... wunderbar! Anrufe gehen raus... und mich kann auch jeder erreichen.. super ;-)