.titleBar { margin-bottom: 5px!important; }

Probleme mit der SIP Firmware Version 7.5 auf 7960

Dieses Thema im Forum "Cisco" wurde erstellt von TheBinary, 27 Juli 2005.

  1. TheBinary

    TheBinary Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Ich habe zwei Cisco 7960 auf dehnen bisher die Cisco SIP Firmware in der Version 7.4 installiert war. Mit dieser Version lief auch alles wunderbar. :)

    Nachdem ich nun die 7.5 Version installiert habe, höre ich bei allen
    Anrufen nichts mehr. Geht man auf RTP Infos währen des Telefonats,
    so sieht man das nur Pakete geschickt, jedoch keine Pakete empfangen werden (zahl bei Rxc bleibt 0000, währen bei Txc die Anzhal der empfangenen Pakete immer steigt).

    Beide Phones sind "anpingbar" und man kann per telnet auf sie zugreifen.

    In den Firwalleinstellungen hat sich nichts geändert (UDP & TCP):

    Ports 5060 und 16384-16394 auf IP Phone 1
    Ports 5061 und 17384-17394 auf IP Phone 2

    Als ich auf den beiden IP-Phones wieder die 7.4 installiert habe, läuft wieder alles wunderbar.

    Hier die Configs:

    SIPDefault
    Code:
    # SIP Default Generic Configuration File 
    ######################################## 
    
    # Image Version 
    image_version: P0S3-07-5-00
    
    # Proxy Registration (0-disable (default), 1-enable) 
    proxy_register: 1
    
    # URI fuer die Taste "messages"
    messages_uri: 50000             ; Fuer Sipgate
    
    # Phone Registration Expiration [1-3932100 sec] (Default - 3600) 
    timer_register_expires: 500 
    
    # Codec for media stream (g711ulaw (default), g711alaw, g729a) 
    preferred_codec: g711alaw 
    
    # TOS bits in media stream [0-5] (Default - 5) 
    tos_media: 5 
    
    # Inband DTMF Settings (0-disable, 1-enable (default)) 
    dtmf_inband: 1 
    
    # Out of band DTMF Settings (none-disable, avt-avt enable (default), avt_always - always avt ) 
    dtmf_outofband: avt 
    
    # DTMF dB Level Settings (1-6dB down, 2-3db down, 3-nominal (default), 4-3db up, 5-6dB up) 
    dtmf_db_level: 3 
    
    # SIP Timers 
    timer_t1: 500             ; Default 500 msec 
    timer_t2: 4000            ; Default 4 sec 
    sip_retx: 10              ; Default 10 
    sip_invite_retx: 6        ; Default 6 
    timer_invite_expires: 180 ; Default 180 sec 
    
    ####### New Parameters added in Release 2.0 ####### 
    # Dialplan template (.xml format file relative to the TFTP root directory) 
    dial_template: "dialplan"
    
    # TFTP Phone Specific Configuration File Directory 
    tftp_cfg_dir: ""         ; Example:  ./sip_phone/ 
      
    # Time Server (There are multiple values and configurations refer to Admin Guide for Specifics) 
    sntp_server: "ntp.sipgate.net" ; SNTP Server IP Address 
    sntp_mode: unicast             ; unicast, multicast, anycast, or directedbroadcast (default) 
    time_zone: CET                 ; Time Zone Phone is in 
    dst_offset: 1                  ; Offset from Phone's time when DST is in effect 
    dst_start_month: March         ; Month in which DST starts 
    dst_start_day: "22"            ; Day of month in which DST starts 
    dst_start_day_of_week: Sun     ; Day of week in which DST starts 
    dst_start_week_of_month: 1     ; Week of month in which DST starts 
    dst_start_time: 02             ; Time of day in which DST starts 
    dst_stop_month: Oct            ; Month in which DST stops 
    dst_stop_day: ""               ; Day of month in which DST stops 
    dst_stop_day_of_week: Sunday   ; Day of week in which DST stops 
    dst_stop_week_of_month: 8      ; Week of month in which DST stops 8=last week of month 
    dst_stop_time: 2               ; Time of day in which DST stops 
    dst_auto_adjust: 1             ; Enable(1-Default)/Disable(0) DST automatic adjustment 
    time_format_24hr: 1            ; Enable(1 - 24Hr Default)/Disable(0 - 12Hr) 
    date_format: D-M-YY            ; Dateformat Day, month, year 
    
    # Do Not Disturb Control (0-off, 1-on, 2-off with no user control, 3-on with no user control) 
    dnd_control: 0         ; Default 0 (Do Not Disturb feature is off) 
    
    # Caller ID Blocking (0-disbaled, 1-enabled, 2-disabled no user control, 3-enabled no user control) 
    callerid_blocking: 0      ; Default 0 (Disable sending all calls as anonymous) 
    
    # Anonymous Call Blocking (0-disabled, 1-enabled, 2-disabled no user control, 3-enabled no user control) 
    anonymous_call_block: 0      ; Default 0 (Disable blocking of anonymous calls) 
    
    # DTMF AVT Payload (Dynamic payload range for AVT tones - 96-127) 
    dtmf_avt_payload: 101      ; Default 101 
    
    # Sync value of the phone used for remote reset 
    sync: 1            ; Default 1 
    
    ####### New Parameters added in Release 2.1 ####### 
    
    # Backup Proxy Support 
    proxy_backup: ""   ; Dotted IP of Backup Proxy 
    proxy_backup_port: 5060      ; Backup Proxy port (default is 5060) 
    
    # Emergency Proxy Support 
    proxy_emergency: ""       ; Dotted IP of Emergency Proxy 
    proxy_emergency_port: 5060   ; Emergency Proxy port (default is 5060) 
    
    # Configurable VAD option 
    enable_vad: 0         ; VAD setting 0-disable (Default), 1-enable 
    
    ####### New Parameter added in Release 3.0 ####### 
    
    # Allow for the bridge on a 3way call to join remaining parties upon hangup 
    cnf_join_enable : 1      ; 0-Disabled, 1-Enabled (default) 
    
    ####### New Parameters added in Release 3.1 ####### 
    
    # Allow Transfer to be completed while target phone is still ringing 
    semi_attended_transfer: 1   ; 0-Disabled, 1-Enabled (default) 
    
    # Telnet Level (enable or disable the ability to telnet into the phone) 
    telnet_level: 2         ; 0-Disabled (default), 1-Enabled, 2-Privileged 
    
    ####### New Parameters added in Release 4.0 ####### 
    
    # XML URLs 
    services_url: ""      ; URL for external Phone Services 
    directory_url: ""      ; URL for external Directory location 
    logo_url: ""         ; URL for branding logo to be used on phone display 
    
    # HTTP Proxy Support 
    http_proxy_addr: ""      ; Address of HTTP Proxy server 
    http_proxy_port: 80      ; Port of HTTP Proxy Server (80-default) 
    
    # Dynamic DNS/TFTP Support 
    dyn_dns_addr_1: ""              ; restricted to dotted IP 
    dyn_dns_addr_2: ""              ; restricted to dotted IP 
    dyn_tftp_addr: ""               ; restricted to dotted IP 
    
    # Remote Party ID 
    remote_party_id: 0      ; 0-Disabled (default), 1-Enabled 
    
    ####### New Parameters added in Release 4.4 ####### 
    
    # Call Hold Ringback (0-off, 1-on, 2-off with no user control, 3-on with no user control) 
    call_hold_ringback: 0      ; Default 0 (Call Hold Ringback feature is off) 
    
    ####### New Parameters added in Release 6.0 ####### 
    
    # Dialtone Stutter for MWI (Message Waiting Indicator) 
    #**** 0-abgeschaltet 
    #**** 1-eingeschaltet 
    stutter_msg_waiting: 1          ; 0-Disabled (default), 1-Enabled 
    
    # RTP Call Statistics (SIP BYE/200 OK message exchange) 
    #**** 0-abgeschaltet 
    #**** 1-eingeschaltet 
    call_stats: 1                   ; 0-Disabled (default), 1-Enabled 
    
    # Telefonnummern automatisch vervollstaendigen (macht bei mir Probleme, also aus) 
    #**** 0-abgeschaltet 
    #**** 1-eingeschaltet 
    autocomplete: 0                 ; 0-Disabled, 1-Enabled (default)
    
    ####### New Parameters added in Release 6.1 #######
    
    local_cfwd_enable: 1            ; 0 - off, 1 - on; the default value is 1.
    timer_register_delta: 5         ; Time interval in seconds; the default is 5 seconds. (range 0-32767)
    
    ####### New Parameters added in Release 7.5 #######
    
    sip_max_forwards: "10"
    rfc_2543_hold: "1"
    


    CONFIG PHONE 2
    Code:
    # SIP Configuration Generic File 
    
    phone_label: "CISCO 7960-2" 
    
    ######################################### Line 1 - Sipgate
    
    proxy1_address: "xxxxxxxxx" 
    proxy1_port: 5061
    line1_name: "xxxxxxxxx" 
    line1_authname: "xxxxxxxxx"
    line1_password: "xxxxxxxxx" 
    line1_displayname: "xxxxxxxxx" 
    line1_shortname: "SipGate" 
    
    ######################################### Line 2 - Freenet.de
    
    proxy2_address: "xxxxxxxxx" 
    proxy2_port: 5061
    line2_name: "xxxxxxxxx" 
    line2_authname: "xxxxxxxxx" 
    line2_password: "xxxxxxxxx" 
    line2_displayname: "xxxxxxxxx" 
    line2_shortname: "Freenet" 
    
    ######################################### Line 3 - Purtel
    
    proxy3_address: ""
    proxy3_port: 5061
    line3_name: ""
    line3_authname: ""
    line3_password: ""
    line3_displayname: ""
    line3_shortname: "" 
    
    
    ######################################### Line 4 - Sipsnip 
    
    proxy4_address: "" 
    proxy4_port: 5061
    line4_name: "" 
    line4_authname: ""
    line4_password: "" 
    line4_displayname: "" 
    line4_shortname: "" 
    
    ######################################### Line 5 - web.de
    
    proxy5_address: ""
    proxy5_port: 5061 
    line5_name: ""
    line5_authname: ""
    line5_password: ""
    line5_displayname: ""
    line5_shortname: ""
    
    ######################################### Line 6 - test
    proxy6_address: "" 
    proxy6_port: 5061 
    line6_name: "" 
    line6_authname: "" 
    line6_password: "" 
    line6_displayname: "" 
    line6_shortname: "" 
    
    ####### New Parameters added in Release 2.0 ####### 
    
    # All user_parameters have been removed 
    
    # Phone Label (Text desired to be displayed in upper right corner) 
    phone_label: " "   ; Has no effect on SIP messaging 
    
    # Line 1 Display Name (Display name to use for SIP messaging) 
    line1_displayname: "xxxx xxxxxxx" 
    
    # Line 2 Display Name (Display name to use for SIP messaging) 
    line2_displayname: "" 
    
    ####### New Parameters added in Release 3.0 ###### 
    
    # Phone Prompt (The prompt that will be displayed on console and telnet) 
    phone_prompt:   "Cisco7960-2"      ; Limited to 15 characters (Default - SIP Phone) 
    
    # Phone Password (Password to be used for console or telnet login) 
    phone_password: "xxxxxxxxx" ; Limited to 31 characters (Default - cisco) 
    
    # User classifcation used when Registering [ none(default), phone, ip ] 
    user_info: none
    
    ####### New Parameters added in Release 2.2 ###### 
    
    # NAT/Firewall Traversal 
    nat_enable: 1                ; 0-Disabled (default), 1-Enabled 
    nat_address: "xxxxx.dyndns.org"   ; WAN IP address of NAT box (dotted IP or DNS A record only) 
    voip_control_port: 5061      ; UDP port used for SIP messages (default - 5060) 
    start_media_port: 17384      ; Start RTP range for media (default - 16384) 
    end_media_port: 17394        ; End RTP range for media (default - 32766) 
    nat_received_processing: 1   ; 0-Disabled (default), 1-Enabled 
    
    # Outbound Proxy Support 
    outbound_proxy: ""       ; restricted to dotted IP or DNS A record only 
    outbound_proxy_port: 5061    ; default is 5060 
    

    CONFIG PHONE 1
    Code:
    # SIP Configuration Generic File 
    
    phone_label: "CISCO 7960"
    
    ######################################### Line 1 - Sipgate
    
    proxy1_address: "sipgate.de" 
    proxy1_port: 5060
    line1_name: "xxxxxxx" 
    line1_authname: "xxxxxxx"
    line1_password: "xxxxxxx" 
    line1_displayname: "xxxx xxxxx" 
    line1_shortname: "SipGate" 
    
    ######################################### Line 2 - Freenet.de
    
    proxy2_address: "freenet.de" 
    proxy2_port: 5060
    line2_name: "xxxxxxx" 
    line2_authname: "xxxxxxx" 
    line2_password: "xxxxxxx" 
    line2_displayname: "xxx xxxxx" 
    line2_shortname: "Freenet" 
    
    ######################################### Line 3 - Purtel
    
    proxy3_address: ""
    proxy3_port: 5060
    line3_name: ""
    line3_authname: ""
    line3_password: ""
    line3_displayname: ""
    line3_shortname: "" 
    
    
    ######################################### Line 4 - Sipsnip 
    
    proxy4_address: "" 
    proxy4_port: 5060
    line4_name: "" 
    line4_authname: ""
    line4_password: "" 
    line4_displayname: "" 
    line4_shortname: "" 
    
    ######################################### Line 5 - web.de
    
    proxy5_address: ""
    proxy5_port: 5060
    line5_name: ""
    line5_authname: ""
    line5_password: ""
    line5_displayname: ""
    line5_shortname: ""
    
    ######################################### Line 6 - test
    proxy6_address: "" 
    proxy6_port: 5060
    line6_name: "" 
    line6_authname: "" 
    line6_password: "" 
    line6_displayname: "" 
    line6_shortname: "" 
    
    ####### New Parameters added in Release 2.0 ####### 
    
    # All user_parameters have been removed 
    
    # Phone Label (Text desired to be displayed in upper right corner) 
    phone_label: " "   ; Has no effect on SIP messaging 
    
    # Line 1 Display Name (Display name to use for SIP messaging) 
    line1_displayname: "xxxxxx xxxxx" 
    
    # Line 2 Display Name (Display name to use for SIP messaging) 
    line2_displayname: "" 
    
    ####### New Parameters added in Release 3.0 ###### 
    
    # Phone Prompt (The prompt that will be displayed on console and telnet) 
    phone_prompt:   "Cisco7960"      ; Limited to 15 characters (Default - SIP Phone) 
    
    # Phone Password (Password to be used for console or telnet login) 
    phone_password: "xxxxxxxx" ; Limited to 31 characters (Default - cisco) 
    
    # User classifcation used when Registering [ none(default), phone, ip ] 
    user_info: none
    
    ####### New Parameters added in Release 2.2 ###### 
    
    # NAT/Firewall Traversal 
    nat_enable: 1                ; 0-Disabled (default), 1-Enabled 
    nat_address: "xxxxxx.dyndns.org"   ; WAN IP address of NAT box (dotted IP or DNS A record only) 
    voip_control_port: 5060      ; UDP port used for SIP messages (default - 5060) 
    start_media_port: 16384      ; Start RTP range for media (default - 16384) 
    end_media_port: 16394        ; End RTP range for media (default - 32766) 
    nat_received_processing: 1   ; 0-Disabled (default), 1-Enabled 
    
    # Outbound Proxy Support 
    outbound_proxy: ""       ; restricted to dotted IP or DNS A record only 
    outbound_proxy_port: 5060    ; default is 5060 
    
    Warum kommen keine Pakete mehr zu meinen IP Phones???
    Und warum klappts mit der 7.4 und mit der 7.5 nicht?? :)

    Gruss,

    TheBinary
     
  2. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Liest sich sehr merkwürdig. Kann ich aber mangels Testmöglichkeit (habe die 7.5 noch nicht) leider nicht nachvollziehen.

    Mach doch mal einen Debug-Mitschnitt vom Telefon (per TELNET). Da kann man anhand der REGISTERs und INVITEs sehen, ob die richtige externe IP-Adresse und/oder Ports mitgeschickt werden. Das wäre nämlich meine Vermutung, daß sich dort irgendwas geändert hat. Die Versionsinfo hat ja so einige Anmerkungen in der Richtung auf irgendwelche RFCs gehabt...
     
  3. zmoho

    zmoho Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    ich kann das Problem mit der 7.5 nur bestätigen.
    Sprechen geht, Hören geht nicht.
    Nach den Downgrade auf die 7.4 lief alles wieder prima.

    gruss
    thomas

    Router: Linksys WRT54g
    VoIP-Hardware: Cisco 7960 - FW 7.4
    VoIP-Dienste: Sipgate
    Anbindung: versanet
     
  4. TheBinary

    TheBinary Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Habe mit Ethereal mal die ganze Sache mitgesnifft.

    Die Ports sowie die IP Adressen stimmen sowohl bei:

    - den INVITE bzw. bei
    - den REGISTER Befehlen

    des SIP Protokolls. Daher bin ich ja so verwundert, das ich nix höre.
     
  5. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    Das ist ärgerlich! Wenn ich die neue Firmware irgendwo auftreibe, mache ich mal selber ein paar Tests. Evtl sagt das Telefon ja irgendwas im Debug-Modus. Kann ja irgendwelche Bauchschmerzen haben...

    Really wild guess: Mal versucht, zwischen Freisprechen und Hörer zu wechseln? Vielleicht ist da was faul. Oder irgendeine Kombination von Codec und Provider ist nicht so bekömmlich. Habt ihr mal verschiedene Kombinationen probiert? Auch mal Handy und Festnetz?
     
  6. TheBinary

    TheBinary Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ja, habe zwischen Headset, Freisprecher und normalem Hörer alles ausprobiert. Kein Unterschied. Alles still.

    Habe insg. 6 verschiedene SIP-Provider im Phone drinn.
    Und mit allen tritt das Problem auf. Denke nicht, das es daran liegt.

    Kenne mich mit dem Debug modus nicht so gut aus.
    Kannst du mir sagen, was ich genau in Telnet eintippen soll,
    damit du da evtl. was analysieren kannst!?
     
  7. zmoho

    zmoho Neuer User

    Registriert seit:
    15 Juli 2005
    Beiträge:
    17
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,
    ich habe mal ein 7960 mit 7.5 und das Andere 7.4 mit installiert.
    Interne Gespräche klappen einwandfrei. Sobald ich mit der 7.5 bei SIPGATE die 10000 anrufe rauschen die Verbindungsaufbauten nur so vorbei, somit scheint es hier keine Antwortpakete zu geben. Leider habe ich auf meinem WRT54G kein tcpdump laufen, um das näher zu analysieren.

    Cisco mit 7.5
    Aug 8 19:49:46 xxxxxxx kernel: ACCEPT IN=br0 OUT=ppp0
    SRC=xxx.xxx.xxx.xxx DST=217.10.79.30 LEN=200 TOS=0x18 PREC=0xA0 TTL=63 ID=4360 PROTO=UDP SPT=16388 DPT=18936 LEN=180
    Aug 8 19:49:46 xxxxxxx kernel: ACCEPT IN=br0 OUT=ppp0 SRC=xxx.xxx.xxx.xxx DST=217.10.79.30 LEN=200 TOS=0x18 PREC=0xA0 TTL=63 ID=4361 PROTO=UDP SPT=16388 DPT=18936 LEN=180
    ......

    Cisco mit 7.4
    Aug 8 19:50:16 xxxxxxx kernel: ACCEPT IN=br0 OUT=ppp0 SRC=xxx.xxx.xxx.xxx DST=217.10.79.30 LEN=200 TOS=0x18 PREC=0xA0 TTL=63 ID=49425 PROTO=UDP SPT=16388 DPT=12784 LEN=180


    gruss
    thomas
     
  8. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    @TheBinary
    Auf der Kommandozeile des Telefons gibt es den Befehl "debug", mit dem Du ein Debug-Log auf einem beliebigen Level der nach oben offenen Geschwätzigkeitsskala auslösen kannst. Mit "debug ?" kann man sich einen Überblick verschaffen, welche Teilbereiche man überwachen kann.

    Egal, was man für Debugs einschaltet, mit "undebug all" kann man das wieder abstellen. Man muß das nur ganz beherzt tippen, auch wenn man vor lauter Debug-Ausgaben gar nicht mehr lesen kann, was man selbst gerade schreibt...

    Ich denke, für einen ersten Test sollte ein "debug sip-messages" ausreichen. Wenn Du Putty verwendest, kannst Du das ganze auch sehr schön in eine Datei mitschreiben lassen. Das können ganz nette Datenmengen werden!

    @zmoho
    Was ich da sehe, sind wohl alles nur RTP-Pakete, die vom Telefon an irgendeine Zieladresse geschickt werden. Gibt es keine Antwortpakete? Wichtig wäre auch der Inhalt von REGISTER und INVITE und ihren Quittungstelegrammen. Damit könnte man z.B. feststellen, ob evtl die IP-Adresse oder die Port-Nummer einfach falsch ausgehandelt werden.
     
  9. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin zusammen!

    Habe endlich(?) auch mal die 7.5 besorgen können und gerade ein paar Tests gemacht.

    Dabei hat sich folgendes herausgestellt:
    • Sipgate --------- Fehler ankommende und abgehende Telefonate
    • Nikotel --------- OK ankommend und abgehend
    • pbx-network - OK ankommend und abgehend
    • gmx ------------ OK abgehend (ankommend nicht getestet)
    • PURtel --------- OK ankommend (abgehend nicht getestet)
    Ich konnte also lediglich im Falle von Sipgate den beschriebenen Fehler feststellen (Audio nur ankommend, nicht abgehend). Alle anderen Provider haben keine Probleme gezeigt :?

    Meine Beobachtung am Router war: keine! Soll heißen, daß mein Router sich nicht beschwert hat, daß irgendwelche RTP-Pakete auf nicht dafür vorgesehenen Ports angekommen wären. Aller Voraussicht nach wird also seitens Sipgate gar kein RTP an meine IP-Adresse geschickt. Mein Router ist nämlich ausgesprochen geschwätzig eingestellt - meldet jeden ankommenden Fliegenschiss :wink:

    Allerdings hat die Firmware-Version noch einen weiteren kleinen Bug, wie ich feststellen musste: Sie hat ein Problem mit meiner HTTP-Proxy-Einstellung. Ich habe im Netz einen lokalen HTTP-Proxy (squid), über den alles läuft. Und da klappt gar nix mehr mit 7.5! Er kann weder mein Logo laden, noch das External Directory oder die Services-URL.
    Die Fehlermeldung, die ich bei einer Telnet-Session gesehen habe :
    Was immer das bedeutet :shock:
    Mein squid hat die Standard-Einstellung (Port 3128/tcp) und hat auch in den vorherigen Versionen funktioniert.

    Jetzt fragt sich natürlich: Liegt das Problem bei Sipgate oder hat das Telefon (resp. die Firmware) eine Macke, die alle anderen nur geschickt umschiffen?

    Mit welchen Providern habt ihr probiert?
     
  10. TheBinary

    TheBinary Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @RB:

    Ich habe folgende SIP Provider getestet:

    [php:1:be5626578a]

    LINE REGISTRATION TABLE

    Proxy Registration: ENABLED, state: REGISTERED
    line APR state timer expires proxy:port
    ---- --- ------------- ---------- ---------- ----------------------------
    1 111 REGISTERED 495 246 sipgate.de:5060
    2 111 REGISTERED 495 161 sip.web.de:5060
    3 111 REGISTERED 495 293 deu1.purtel.com:5060
    4 111 REGISTERED 495 161 sipsnip.com:5060
    5 111 REGISTERED 495 231 sip-gmx.net:5060
    6 111 REGISTERED 495 161 freenet.de:5060
    1-BU .1x NONE 0 0 undefined:0

    [/php:1:be5626578a]

    Bei allen das gleiche Problem, nämlich das keine Pakete ankommen.

    Das "debug" per telnet werde ich heute Abend mal ausprobieren, da ich zwar per ssh und telnet
    im moment von der arbeit aus an mein telefon dran komme, jedoch von hier aus
    schlecht den hörer abnehmen und tippen kann.

    Obwohl ich dafür auch mal irgendwo die cisco telnet Kommandos gelesen habe.

    Gruss,

    TheBinary
     
  11. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Das ist ja jetzt wieder mal verblüffend, daß bei mir PURtel und GMX anstandslos funktionieren und bei Dir nicht :shock:

    For the Record: Ich habe übrigens auch mal mittels debug timestamp sip-messages die Signalisierung mitgeschnitten und konnte erstmal auf Anhieb keine Unregelmäßigkeiten feststellen (wobei ich aber auch nicht behaupten will, daß ich die SIP-RFCs auswendig kann oder völlig durchschaut habe)...

    EDIT: Ich habe gerade der Vollständigkeit halber nochmal versucht die Sipgate-Testnummer anzurufen. Es trat der Effekt auf, daß die Verbindung augenscheinlich im Wahlversuch abgebrochen wurde, aber das Telefonsysmbol (an der Line-Taste) noch eine offene Verbindung anzeigte und die Statuszeile auch noch "proceeding" meldete.

    Mittels Speaker an- und wieder ausschalten war der Effekt weg. Allerdings ließ sich von jetzt an (vielleicht auch schon früher?) nicht mehr mit den Menütasten des Telefons arbeiten. Bei Druck auf <settings> kam ein leeres Display mit der Überschrift "Settings". Das gleiche bei der Taste <directories>!

    Der Telnet-Zugang funktionierte nach wie vor und zeigte keine Auffälligkeiten. Ein erase protflash brachte keine Verbesserung des Zustandes. Erst ein Warmstart mittels Affengriff hat dann wieder den Normalzustand hervorgezaubert.

    Das muß ich noch ein wenig beobachten. Aber erstmal hinterläßt diese Firmware den Eindruck eher Alpha- als Beta-Status zu haben :evil:
     
  12. TheBinary

    TheBinary Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das Phänomen hatte ich bissher noch nicht. Aber das unterstreich den Gesamteindruck von der 7.5er FW, den ich bis jetzt habe.

    Welchen Flash-speicher lösche ich denn mit diesem Befehl? Wofür steht "prot" ? Und was bringt das löschen?

    In der Tat...ich verstehe nicht, wie der weltweit grösste Netzwerkausrüster so eine Firmware ausliefern kann. Warscheinlich, weil die SIP FW eh nur hauptsächlich Privatleute benutzen und diese nicht in Firmen eingesetzt wird. Ich jedenfalls bleibe zwangsweise bei der 7.4er Version.

    Werde heute Abend das debuggen per telnet nachholen.
     
  13. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Damit macht man eine Art "Teil-Warmstart". Das Telefon lädt seine Konfigurationsdateien aus dem TFTP neu und auch z.B. das Logo.

    Was das "protflash" genau bedeutet, weiß ich auch nicht. Naheliegend wäre aber die Vermutung, daß es sich um den Flash-Speicher für die Protokoll-Einstellungen handelt. Wenn man den löscht, muß er sich halt die Konfiguration neu laden.

    Ich habe übrigens per Google mal ein wenig nach Fehlermeldungen für diese Firmware gesucht - und nichts weiter gefunden! Das einzige war in irgendeiner Mailing-Liste, wo sich jemand über Probleme mit Sipgate beschwert hat. Andere Provider würden funktionieren. Ein Downgrade auf 7.4 hat geholfen. Also erstmal wie bei mir.

    Ich wüsste zu gerne, warum das mit den Providern bei Dir anders ist?!
     
  14. bluelion

    bluelion Neuer User

    Registriert seit:
    23 Okt. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo erstmal, ist mein erster Eintrag!

    Habe das gleiche Problem, nur nach einem Downgrade auf 7.4 bleibt das Problem bestehen, bei sipgate höre ich nichts, werde aber gehört.

    Auf der ersten Leitung mit Web.de Freephone klappt es aber einwandfrei. Dumm, denn mir wäre sipgate mit der Ortsvorwahl eigentlich lieber, als die 01212-Vorwahl, die aus diversen Netzen garnicht erst erreichbar ist.

    Hat jemand bei dem Problem schon eine Lösung gefunden?

    cu
     
  15. TheBinary

    TheBinary Neuer User

    Registriert seit:
    18 Dez. 2004
    Beiträge:
    11
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Habe es nach langer Zeit endlich geschafft mal den Debug Modus auf den Cisco 7960er laufen zu lassen.
    Jeweils mit einer anderen Firmware Version, also einmal 7.4 und einmal 7.5.
    Und ich habe endlich den Fehler bzw. die Ursache für die Probleme gefunden, weiss aber nicht wie man ihn korrigieren kann.

    Cisco 7960 - Firmware V. 7.4
    Code:
    CSeq: 102 INVITE
    Content-Length: 0
    
    >, length=331
    [11:57:10] sipSPICheckResponse: Response match: callid=0011bbae-348e0036-5ec75d2
    b-4134347d@213.168.110.74, cseq=102, cseq_method=INVITE
    [11:57:13] SIPProcessUDPMessage: recv UDP message from <217.72.200.89>:<50195>:
    <>, length=4
    [11:57:14] SIPProcessUDPMessage: recv UDP message from <194.97.54.97>:<50195>:
    <SIP/2.0 183 Session Progress
    Via: SIP/2.0/UDP 213.168.110.74:5060;branch=z9hG4bK2be7fc3d
    From: "Thomas Stein" <sip:halrd2@freenet.de>;tag=0011bbae348e2b111aa5c76c-59514f
    f7
    To: <sip:02217167036@freenet.de>;tag=AC42B624-14FB
    Date: Mon, 31 Oct 2005 10:57:10 GMT
    Call-ID: 0011bbae-348e0036-5ec75d2b-4134347d@213.168.110.74
    Server: Cisco-SIPGateway/IOS-12.x
    
    CSeq: 102 INVITE
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY
    , INFO, UPDATE, REGISTER
    Allow-Events: telephone-event
    Contact: <sip:00492217167036@62.104.216.135:5060>
    Record-Route: <sip:194.97.52.47;ftag=0011bbae348e2b111aa5c76c-59514ff7;lr=on>,<s
    ip:194.97.54.97;ftag=0011bbae348e2b111aa5c76c-59514ff7;lr=on>
    Content-Disposition: session;handling=required
    Content-Type: application/sdp
    Content-Length: 206
    
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 8370 9531 IN IP4 62.104.216.135
    s=SIP Call
    c=IN IP4 62.104.216.135
    t=0 0
    m=audio 16906 RTP/AVP 8
    c=IN IP4 62.104.216.135
    a=rtpmap:8 PCMA/8000
    a=direction:passive
    >, length=1017
    
    Cisco 7960 - Firmware V. 7.5
    Code:
    [11:53:56] INVITE sip:02217167036@freenet.de SIP/2.0
    Via: SIP/2.0/UDP 213.168.110.74:5061;branch=z9hG4bK2215d9bb
    From: "herselb" <sip:herselb@freenet.de>;tag=00075043569f000c21542b4f-2a1cf4cd
    To: <sip:02217167036@freenet.de>
    Call-ID: 00075043-569f000a-230fe965-51c015b4@213.168.110.74
    Max-Forwards: 10
    Date: Mon, 31 Oct 2005 10:53:48 GMT
    CSeq: 101 INVITE
    User-Agent: Cisco-CP7960G/7.5
    Contact: <sip:herselb@213.168.110.74:5061>
    Expires: 180
    Accept: application/sdp
    Allow: ACK,BYE,CANCEL,INVITE,NOTIFY,OPTIONS,REFER,REGISTER,UPDATE
    Supported: replaces
    Content-Length: 255
    Content-Type: application/sdp
    Content-Disposition: session;handling=optional
    
    v=0
    o=Cisco-SIPUA 22923 0 IN IP4 192.168.1.24
    s=SIP Call
    t=0 0
    m=audio 17386 RTP/AVP 8 0 18 101
    c=IN IP4 192.168.1.24
    a=rtpmap:8 PCMA/8000
    a=rtpmap:0 PCMU/8000
    a=rtpmap:18 G729/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-15
    a=sendrecv
    
    
    Und zwar ist der Unterschied zwischen den Firmware Versionen, neben einigen kosmetischen Änderungen an der Ausgabe der Dubuginformation, folgende Zeile welche den Fehler verursacht:


    Version 7.4
    o=CiscoSystemsSIP-GW-UserAgent 8370 9531 IN IP4 [highlight=red:102a7b874a]62.104.216.135[/highlight:102a7b874a]

    Version 7.5
    o=Cisco-SIPUA 22923 0 IN IP4 [highlight=red:102a7b874a]192.168.1.24[/highlight:102a7b874a]


    Und zwar wird hier, wie man sehr schön sehen kann wird:
    - bei V. 7.5 die intere lokale IP (192.168.1.24) mitgeschickt , welche ja bekanntlich nicht gerne im Internet geroutet wird.
    - In der Version 7.4 wird die hierfür korrekte externe IP (62.104.216.135) genommen.
     
  16. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    @bluelion
    Willkommen im Forum!

    Ich denke mal, daß Dein Problem nicht unbedingt (nur) mit der Firmware des Cisco-Telefons zu tun hat. Da können durchaus auch Eigenheiten Deines Routers und von Sipgate selbst mitspielen.

    Dummerweise entwickelt sich das immer mehr zu einer Wissenschaft für sich. Immer dann, wenn ein Router mit NAT im Spiele ist, der nicht selber als VoIP-Proxy oder -Client fungiert, kann es problematisch werden. Die genaue Geschmacksrichtung der Probleme hängt dann sehr von den beteiligten Hard- und Software-Komponenten ab.

    Ich würde vorschlagen, daraus einen eigenen Thread zu machen.

    @TheBinary
    Ich bin mir bei Deinen Debugs gar nicht so sicher, ob das wirklich so das Problem ist. Die Mitschnitte zeigen ja zwei verschiedene Stadien eines Gesprächsaufbaus. Vermute ich zumindest. Das ganze sieht doch recht unterschiedlich aus...

    Kannst Du mal die beiden kompletten Anrufeinleitungen posten? Eventuell wird mir das dann etwas klarer.

    Aber abgesehen davon würde ich aus den anderen Gründen (Einfrieren des Telefons, Verlust der Menüfähigkeit, ...) in jedem Falle die Finger von der Firmware 7.5 lassen, selbst wenn man dieses spezielle Problem gelöst bekäme!
     
  17. gr650

    gr650 Neuer User

    Registriert seit:
    6 Dez. 2005
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Cisco 7940 mit SIP-Firmware 7.5

    Leitung 1, Sipgate, werde gehört, aber höre vom Angerufenen/Anrufenden nichts
    Leitung 2, QSC IPfonie, funktioniert einwandfrei

    Diese Firmware ist jedenfalls nicht zu empfehlen, aber das Telefon mag ich trotzdem, weil man dabei was über die zugrundeliegende Technik lernt :)
     
  18. RB

    RB Aktives Mitglied

    Registriert seit:
    22 Juni 2004
    Beiträge:
    1,311
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    Selbständiger Bitbeißer
    Ort:
    40883 Ratingen
    Moin!

    Damit, daß man da was über die Technik lernt, hast Du allerdings recht! Allerdings u.U. mehr, als einem lieb ist ;-)
     
  19. alex-911

    alex-911 Mitglied

    Registriert seit:
    6 Aug. 2005
    Beiträge:
    261
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    inschenjöhr
    Ort:
    Schweiz

    hi

    und mit 7.4 hast du dieses problem nicht....? ;)

    ich mag dieses hässliche fisher price teil eigentlich gar nicht :p

    gruss
    /alex
     
  20. gr650

    gr650 Neuer User

    Registriert seit:
    6 Dez. 2005
    Beiträge:
    6
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nein. Dieselben Einstellungen, nur andere Firmware (7.4 statt 7.5) und es funktioniert prima (bis auf die DTMF-Problematik mit sipgate).