.titleBar { margin-bottom: 5px!important; }

probleme mit TDM400P und TE110P

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von calippo, 15 Okt. 2005.

  1. calippo

    calippo Neuer User

    Registriert seit:
    12 Mai 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi!

    Vielleicht kann mir einer von euch einen Tipp geben.

    Ich habe auf einem System mit CentOS3 eine TDM400P laufen mit einem FXS und 2 FXO Modulen da läuft die ganze sache prime.

    zaptel.conf

    Code:
        
    fxsks=1
    fxoks=2
    loadzone = nl
    defaultzone=nl
    
    zapata.conf

    Code:
    context=incoming
    signalling=fxs_ks
    channel=1
    
    context=default
    signalling=fxo_ks
    channel=2
    
    Jetzt habe ich auf einem anderen System eine TE110P und eine TMD400P eingebaut verwende auch wieder CentOs3. Nur dass hier zwei FXO Module auf der TMD400P sind.
    Beide Karten einzeln laufen nur zusammen laufen sie nicht. Und an wenn ich an die TMP400P ein Gerät anschließe bekomme ich ein belegt und am Fax wird ZB. Telefon extern signalisiert.

    zaptel.conf

    Code:
    span=1,1,0,ccs,hdb3,crc4
    bchan=1-15,17-31
    dchan=16
    
    fxoks=32-33
    
    loadzone = nl
    defaultzone=nl
    
    zapata.conf

    Code:
    language=de
    context=default
    switchtype=euroisdn
    signalling=pri_cpe
    rxwink=300		;
    
    
    callerid=asreceived
    usecallerid=yes
    hidecallerid=no
    callwaiting=yes
    
    pridialplan=unknown
    
    internationalprefix = 00
    nationalprefix = 0
    
    usecallingpres=yes
    callwaitingcallerid=yes
    threewaycalling=yes
    transfer=yes
    cancallforward=yes
    callreturn=yes
    echocancel=yes
    echocancelwhenbridged=yes
    echotraining=5000
    rxgain=0.0
    txgain=0.0
    group=1
    callgroup=1
    pickupgroup=1
    immediate=no
    overlapdial=yes
    
    ;faxdetect=both
    faxdetect=incoming
    ;faxdetect=outgoing
    ;faxdetect=no
    
    channel => 1-15,17-31
    
    
    signalling=fxo_ks
    context=default
    channel => 32-33
    
    ztcfg -vvv

    Code:
    Zaptel Configuration
    ======================
    
    SPAN 1: CCS/HDB3 Build-out: 0 db (CSU)/0-133 feet (DSX-1)
    
    Channel map:
    
    Channel 01: Individual Clear channel (Default) (Slaves: 01)
    Channel 02: Individual Clear channel (Default) (Slaves: 02)
    Channel 03: Individual Clear channel (Default) (Slaves: 03)
    Channel 04: Individual Clear channel (Default) (Slaves: 04)
    Channel 05: Individual Clear channel (Default) (Slaves: 05)
    Channel 06: Individual Clear channel (Default) (Slaves: 06)
    Channel 07: Individual Clear channel (Default) (Slaves: 07)
    Channel 08: Individual Clear channel (Default) (Slaves: 08)
    Channel 09: Individual Clear channel (Default) (Slaves: 09)
    Channel 10: Individual Clear channel (Default) (Slaves: 10)
    Channel 11: Individual Clear channel (Default) (Slaves: 11)
    Channel 12: Individual Clear channel (Default) (Slaves: 12)
    Channel 13: Individual Clear channel (Default) (Slaves: 13)
    Channel 14: Individual Clear channel (Default) (Slaves: 14)
    Channel 15: Individual Clear channel (Default) (Slaves: 15)
    Channel 16: D-channel (Default) (Slaves: 16)
    Channel 17: Individual Clear channel (Default) (Slaves: 17)
    Channel 18: Individual Clear channel (Default) (Slaves: 18)
    Channel 19: Individual Clear channel (Default) (Slaves: 19)
    Channel 20: Individual Clear channel (Default) (Slaves: 20)
    Channel 21: Individual Clear channel (Default) (Slaves: 21)
    Channel 22: Individual Clear channel (Default) (Slaves: 22)
    Channel 23: Individual Clear channel (Default) (Slaves: 23)
    Channel 24: Individual Clear channel (Default) (Slaves: 24)
    Channel 25: Individual Clear channel (Default) (Slaves: 25)
    Channel 26: Individual Clear channel (Default) (Slaves: 26)
    Channel 27: Individual Clear channel (Default) (Slaves: 27)
    Channel 28: Individual Clear channel (Default) (Slaves: 28)
    Channel 29: Individual Clear channel (Default) (Slaves: 29)
    Channel 30: Individual Clear channel (Default) (Slaves: 30)
    Channel 31: Individual Clear channel (Default) (Slaves: 31)
    Channel 32: FXO Kewlstart (Default) (Slaves: 32)
    Channel 33: FXO Kewlstart (Default) (Slaves: 33)
    
    33 channels configured.
    
    


    asterisk -vvvgc

    Code:
     [chan_zap.so] => (Zapata Telephony w/PRI)
      == Parsing '/etc/asterisk/zapata.conf': Found
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:9651 setup_zap: Ignoring internationalprefix
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:9651 setup_zap: Ignoring nationalprefix
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:9651 setup_zap: Ignoring localprefix
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:9651 setup_zap: Ignoring privateprefix
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:9651 setup_zap: Ignoring unknownprefix
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:9287 setup_zap: Echo training time must be within the range of 10 to 2000 ms at line 61
        -- Registered channel 1, PRI Signalling signalling
        -- Registered channel 2, PRI Signalling signalling
    Oct 15 20:36:20 WARNING[2106]: chan_zap.c:778 zt_open: Unable to specify channel 3: No such device
    Oct 15 20:36:20 ERROR[2106]: chan_zap.c:6239 mkintf: Unable to open channel 3: No such device
    here = 0, tmp->channel = 3, channel = 3
    Oct 15 20:36:20 ERROR[2106]: chan_zap.c:9191 setup_zap: Unable to register channel '1-15'
    Oct 15 20:36:20 WARNING[2106]: loader.c:345 ast_load_resource: chan_zap.so: load_module failed, returning -1
      == Unregistered channel type 'Tor'
      == Unregistered channel type 'Zap'
        -- Unregistered channel 1
        -- Unregistered channel 2
    Oct 15 20:36:20 WARNING[2106]: loader.c:440 load_modules: Loading module chan_zap.so failed!
    
    
    es scheint hier irgendwas nicht ganz richtig geladen zu werden.
    Hatte es aber mit genau der selben Koniguration schon mal auf einem System laufen da hatte ich nur das Problem wenn ich an die TDM400P eine Gerät angeschlossen habe dass dieses sofort belegt wurde. Dieses Problem habe ich übriges jetzt auch wieder.

    wäre schön wenn mir wer weiterhelfen könnte!

    SG. Calippo