Rückkanal fehlt, AVM-VPN & Wireguard

DPRec

Neuer User
Mitglied seit
15 Jul 2013
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Hallo,

habe eine Route gesetzt, trotzdem Probleme.
104034
FB: 192.168.1.1
Raspi: 192.168.1.75
Wireguard: 192.168.42.0/24 (und als IPv6-Netz fd00:42::/64. IPv6 ist z.Zt. nicht aktiviert).
Als lokaler DNS-Server: 192.168.1.75 ist der Raspi in der FB eingetragen
(Heimnetz => Netzwerkeinstellungen => IPv4-Adressen => Lokaler DNS-Server).

Mit Fritz!App Fon, Samsung Galaxy Note 3 VPN App über die FB 7490 mit AVM-VPN funktioniert die Telefonie.
Aber nicht wirklich gut!
Samsung Galaxy Note 3 mit Wireguard, da fehlt mir der Rückkanal. Ich höre kein Klingeln und keine AB-Ansage der FB.

Auf dem Notebook habe ich Phoner 3.22 (Win8.1) installiert.
Voriges Jahr im Urlaub ging noch alles.
Inzwischen habe ich einen Raspi mit Wireguard und PiHole und fhem.
Phoner geht gar nicht mehr, nicht mit AVM-VPN und nicht mit Wireguard (Rückkanal fehlt).
 

Limer

Neuer User
Mitglied seit
8 Nov 2006
Beiträge
32
Punkte für Reaktionen
4
Punkte
8
Aus deinen dürftigen Angaben kann ich mir höchsten ein verschwommenes Bild zusammenträumen wie genau dein Netz Logisch, Topologisch usw. aussieht, geschweige denn was genau welche Komponente tun soll.
Was hat das alles mit Wireguard zu tun?
Bitte mach deutlicher wie genau dein Netz aussieht (ASCII Grafik kann auch helfen).

Dein Routen Screenshot scheint zu bedeutend das alle geräte im HeimNetz deiner FB wissen wie sie nach .42.0/24 kommen.
Wissen auch alle Geräte in .42.0/24 wie sie nach .1.0/24 kommen?
Routet der Router zwischen den beiden Netzen mit NAT, oder vollständig in beide Richtungen?

Was hast du schon versucht um das Problem einzugrenzen?
 

DPRec

Neuer User
Mitglied seit
15 Jul 2013
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
Hallo Limer,

ich habe eine FB mit der Adresse 192.168.1.1
Auf der lief fhem bis AVM das nicht mehr unterstützt hat.
Dann kam der Raspi dazu, Adresse 192.168.1.75, auf dem läuft seitdem fhem.

Bis dahin lief alles.

Dann habe ich PiHole und zuletzt Wireguard (alles nach c´t Anleitung) installiert das ein anderes Netz benötigt, 192.168.42.0/24
Mehr ist bei mir nicht.
Ich kann auf die FB und den Raspi über AVM-VPN & Wireguard zugreifen.
Alles läuft bis auf die Telefonie über VPN.

Wissen auch alle Geräte in .42.0/24 wie sie nach .1.0/24 kommen?
Routet der Router zwischen den beiden Netzen mit NAT, oder vollständig in beide Richtungen?
Gute Frage, heißt das man müsste eine 2. Route nach .1.0/24 setzen?
Mit NAT habe ich nichts gemacht, jedenfalls nicht bewusst, sagt mir nichts.
 

Ohrenschmalz

Mitglied
Mitglied seit
19 Apr 2006
Beiträge
781
Punkte für Reaktionen
22
Punkte
18
Dann habe ich PiHole und zuletzt Wireguard (alles nach c´t Anleitung) installiert das ein anderes Netz benötigt, 192.168.42.0/24
Warum?

Trag doch mal testweise 255.255.0.0 als Subnetzmaske ein. Dann sehen wir weiter...
 

DPRec

Neuer User
Mitglied seit
15 Jul 2013
Beiträge
5
Punkte für Reaktionen
0
Punkte
1

3-Finger-Harry

Neuer User
Mitglied seit
13 Jan 2020
Beiträge
28
Punkte für Reaktionen
0
Punkte
1
Funktioniert bei Deinem Galaxy Note 3 die Kamera noch? - Dann könntest Du Deinen Ausführungen mal zu Papier bringen und ablichten - siehe Posting #2.
 

Theo Tintensich

Aktives Mitglied
Mitglied seit
10 Mrz 2008
Beiträge
1,640
Punkte für Reaktionen
37
Punkte
48
Trag doch mal testweise 255.255.0.0 als Subnetzmaske ein. Dann sehen wir weiter...
Das wäre mehr als Kontraproduktiv.
Wissen auch alle Geräte in .42.0/24 wie sie nach .1.0/24 kommen?
Wenn die Geräte im Netz 192.168.42.0/24 nur einen Gateway haben, wissen sie es.

Etwas anderes wäre wichtig, denn der Wireguard-Tunnel ist ja nochmals ein Netz, das wohl im Netz 192.168.42.0/24 endet. Und hierzu muss das F!B-Netz wissen, wie dieses Netz, also der VPN-Endpunkt erreichbar ist.
Wenn der andere Wireguard-Endpunkt nicht nur ein Gerät, sondern ein gesamten Netz umfasst, muss zusätzlich dieses Netz als Ziel genannt werden, nicht das Wireguard-Netz.
(Dessen Gateway muss der PI kennen, auch muss der so eingestellt sein, dass er routen kann. In der default-Netzeinstellung macht er das nicht)

Beispiel:auf der F!B, jeweils mit der .75, dem PI, als Ziel.
Route ins PI-Netz 192.168.40/24. siehe oben
Route zum Wireguard Endpunkt: 10.0.8.0/228 (wenn dass das Netz ist, aus dem die IP des per Wireguard angeschlossenem Gerät ist)
Route zum externen Netz: 192.168.43.0/24 (wenn dass das externe per Wireguard angeschlossene Netz ist)

Diese Netze müssten in der Routingtabelle der F!B eingetragen werden.
Beim PI müsste für jeden Gateway die entsprechenden Netze eingetragen werden, auch müssten die sich im PI-Netz befindenden Geräte die passenden Gateways genannt bekommen.
 

DPRec

Neuer User
Mitglied seit
15 Jul 2013
Beiträge
5
Punkte für Reaktionen
0
Punkte
1
könntest Du Deinen Ausführungen mal zu Papier bringen
Hier mein Versuch.
Grafik IP..jpg

Route ins PI-Netz 192.168.40/24. siehe oben
Ist als einzige Route angelegt.

Route zum Wireguard Endpunkt: 10.0.8.0/228 (wenn dass das Netz ist, aus dem die IP des per Wireguard angeschlossenem Gerät ist)
Das wäre dann Client 1, Endpoint 87.122.116.124 oder ?

Route zum externen Netz: 192.168.43.0/24 (wenn dass das externe per Wireguard angeschlossene Netz ist)
Interface: Client 1, 192.168.42.110
Stimmt das so?

Bild geschrumpft by stoney
 
Zuletzt bearbeitet von einem Moderator:

KunterBunter

IPPF-Urgestein
Mitglied seit
12 Okt 2005
Beiträge
23,354
Punkte für Reaktionen
185
Punkte
63
Ich kann auf die FB und den Raspi über AVM-VPN & Wireguard zugreifen.
Alles läuft bis auf die Telefonie über VPN.
Dann ist das VPN auch richtig eingerichtet.
"Rückkanal fehlt" ist deine Umschreibung, dass du den Anrufer oder Angerufenen nicht hören kannst? Falls dem so ist, hat es mit dem VPN nur indirekt zu tun.
 

Whoopie

Aktives Mitglied
Mitglied seit
19 Okt 2004
Beiträge
841
Punkte für Reaktionen
6
Punkte
18
 

RipperFox

Neuer User
Mitglied seit
23 Jul 2006
Beiträge
8
Punkte für Reaktionen
0
Punkte
1
Wie KunterBunter schon richtig schrieb: Wenn alles funktioniert bis auf VoIP dann liegt es logischerweise vermutlich NUR an den VoIP-Einstellungen. Evtl. mal STUN beim SIP Clieht am Handy deaktivieren?
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
233,963
Beiträge
2,040,737
Mitglieder
353,174
Neuestes Mitglied
Adun