.titleBar { margin-bottom: 5px!important; }

Registration from 'dexi <sip:dexi@xxx.x.xx.xxx>' faile

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von jHedron, 3 Aug. 2005.

  1. jHedron

    jHedron Neuer User

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich bekomme folgende (und durch google und diesem Forum nicht zu lösende) Meldung:

    Ich versuche mit Xlite auf meinen frisch aufgesetzen Asterisk server zu connecten. :( (Asterisk startet FEHLERLOS!)

    Ich möchte NICHT via einem SIP-Provider RAUS oder REIN!!!

    Hier meine SIP.CONF

    Code:
    [general]
    ;----------- general setup
    port = 5060
    bindaddr = 0.0.0.0
    tos = none
    ;----------- codecs setup
    disallow = all
    allow = alaw
    allow = ulaw
    ;----------- other options
    localnet = xxx.x.xx.0/255.255.255.0
    context = default
    srvlookup = yes
    nat = no
    ;----------- register to peers
    
    ;********************* Users ***********************
    [dexi]
    username = dexi
    accountcode = dexi
    host = dynamic
    secret = dexi
    context = default
    fromuser = dexi
    login = dexi
    type = user
    
    Oder muss ich irgendwo noch was ändern?

    Bin recht neu in dem Bereich und hoffe, dass ihr mir helfen könnt. 8)

    OS: Suse 9.3
    Asterisk: Das aktuellste...

    Gruß

    jHedron
     
  2. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Lass mal 'fromuser' und 'login' weg und setzte 'type=friend'.
     
  3. jHedron

    jHedron Neuer User

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi Maik,

    hab's versucht. Nüscht!!! :(

    Muss ich in der Extensions.conf was drehen? (am [default])

    Muss ich in Xlite einen Outbound-Proxy angeben?

    jHedron
     
  4. Kenny

    Kenny Neuer User

    Registriert seit:
    14 Juli 2005
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Tübingen
    Hallo
    Ich hatte genau das selbe Problem
    zeig mal deine extensions.conf
     
  5. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    Befindet sich Xlite im eigenen LAN oder WAN?

    Falls letzteres benötigst du natürlich noch ein nat=yes nebst type=friend.
     
  6. jHedron

    jHedron Neuer User

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Befindet sich im gleichen LAN.

    Hier die extensions.conf

    Code:
    ;***************** General options *****************
    [general]
    static=yes
    writeprotect=yes
    ;******************* Globals values ******************
    [globals]
    IAXINFO => guest
    TRUNKMSD => 1
    CONSOLE => Console/dsp
    TRUNK => Zap/g2
    .
    . /* hier die Standard-Contexte die original drin waren...
    .
    
    [default]
    exten => dexi,1,Dial(SIP/${EXTEN})
    
    
    Den Inhalt in default hab ich mal reingeschrieben. ;)

    jHedron
     
  7. Kenny

    Kenny Neuer User

    Registriert seit:
    14 Juli 2005
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Tübingen
    Deine Default muss so aussehen
    exten => _X.,1,SetCallerId,xxxxxxxxx
    exten => _0.,1,Dial(SIP/${EXTEN}@sipgate,60)
    exten => _0.,2,Congestion
    exten => _0.,102,Hangup

    Gruß
    Kenny
     
  8. jHedron

    jHedron Neuer User

    Registriert seit:
    3 Aug. 2005
    Beiträge:
    5
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    also mit der alten default hat's jetzt doch funktioniert!

    Es lag wohl doch an "nat=yes"!!!

    was macht denn die neue default?

    Gruß

    jHedron
     
  9. Kenny

    Kenny Neuer User

    Registriert seit:
    14 Juli 2005
    Beiträge:
    55
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Tübingen
    Eigentlich nicht viel mehr.
    aber wenn es ja geht dann behalte die besser alte.

    Gruß
    Kenny