.titleBar { margin-bottom: 5px!important; }

Root password nach MOD benötigt - kein Zugriff mehr möglich

Dieses Thema im Forum "FRITZ!Box Fon als ATA" wurde erstellt von icetiger4, 30 Jan. 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. icetiger4

    icetiger4 Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich wollte meine Fritz FON WLAN Box an einem Linuxrouter (IPCop) betreiben. Ich habe die aktuelle Firmeware 08.03.29 eingespielt. Die MODs habe ich nach den Anweisungen im Forum mit dem temporaeren Telnet-Zugang ohne Probleme ausgeführt. Ich wurde dabei nach keinem Passwort gefragt. Die Werte wurden korrekt in /var/flash/config.cfg eingetragen.

    Nach dem reboot der BOX kann ich diese über die voreingestellte IP-Adresse erreichen und administrieren. Auch der LED-Patch (8,2>/var/led) arbeitet richtig da Power nicht mehr blinkt und ständig an ist. Telnetd (/usr/sbin/telnetd &) ist auch aktiviert und kann über Netzt erreicht werden. Aber genau hier beginnt mein Problem. Beim Telnetlogin gebe ich root an und es wird nach einem Passwort gefragt, das ich nicht kenne. Auch wenn ich keinen Username (z.B.) root angebe, komme ich nicht in das System. Ich habe auch schon über das noch erreichbare WEB-Interface ein Passwort gesetzt. Auch damit klappt es nicht. Da ich mich nicht mehr über Telnet in die BOX einloggen kann, habe ich nun ein Problem :-(

    Kennt jemand dafür eine Lösung ? Wurde von AVM mit der neuen FW 08.03.29 ein Passwort gesetzt ?
    Gruss
    Bernd
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Das Passwort ist disabled, wenn du nicht's in die Debug.cfg geschrieben hast.

    MfG Oliver
     
  3. icetiger4

    icetiger4 Neuer User

    Registriert seit:
    27 Jan. 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Folgendes habe ich bereits in die debug.cfg geschrieben. Dabei konnte ich noch mit root "ohne password" auf die box zugreifen.

    /usr/sbin/telnetd &
    route add default gw 192.168.80.1
    voipd -R
    echo 8,2>/var/led

    Ich habe es auch schon mit dem upload von haveniceimage und den Passwörtern hackme und fritzbox versucht. Immer wieder das gleiche, es wird keines Passwörter für root akzeptiert.

    Gruss
    Bernd
     
  4. haveaniceday

    haveaniceday Aktives Mitglied

    Registriert seit:
    14 Okt. 2004
    Beiträge:
    1,305
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Icetiger4,

    versuch mal den Download aus:
    http://www.ip-phone-forum.de/forum/viewtopic.php?p=72670#72670

    - setzt die Debug.cfg zurück
    - telnet hat das gleiche Passwort wie dein Webinterface.

    Bei dir ist zwar "/usr/sbin/telnetd &" gestartet.
    Die original Box hat allerding durch "*" im Passwortfeld das Login "disabled".
    Es gibt nur die Chance /etc/passwd ( /var/tmp/passwd bzw. shadow ) auch zu ändern oder das Telnet wie in dem o.a. Thread über "/usr/sbin/telnetd -l /sbin/ar7login &" aufzurufen.

    Haveaniceday
     
  5. rr

    rr Neuer User

    Registriert seit:
    6 Okt. 2004
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe das selbe Problem.
    Beim ersten Mal ging telnet (aus starttelnet) ohne, jetzt quält es mich mit einem Pwd.
    Nochmal schrittweise:
    Mit dem Download meinst Du das aktuelle starttelnet.image, nicht wahr?
    Das werfe ich dann über das Webinterface der Box an -->System/Firmwareupdate und starte telnet aus der Befehlszeile des PC ohne vorher den restart der box zu machen:
    und es verlangt: a. einen user --> Welchen?? und b. das password, da könnte ich das vom Webinterface benutzen.

    Grübel......

    rr
     
  6. bigfrog

    bigfrog Neuer User

    Registriert seit:
    30 Jan. 2005
    Beiträge:
    113
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das file aus obigen thread runterladen(nicht das starttelnet.image), hat zwar die endung .tar, trotzdem einfach so wie es ist als update auf die box, danach sollte der telnet wieder ohne passwd klappen, hat zumindest bei mir funktioniert (evtl reboot) wenn du die debug.cfg änderst dann behalt die Zeile mit dem telnet aufruf: "/usr/sbin/telnetd -l /sbin/ar7login &"
    die stellt das mit dem login sicher....
    mfg
    bigfrog
     
  7. rr

    rr Neuer User

    Registriert seit:
    6 Okt. 2004
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Yop,

    das geht.....
    (hatte nicht gesehen, dass man die downloads nur sieht, wenn man eingeloggt ist....)

    rr
     
  8. flatfido

    flatfido Neuer User

    Registriert seit:
    19 Feb. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Super hat geklappt !!
    Habe Fritz!Box ohne Wlan mit Ver. 06.02.29.
    Ich hatte schon fast aufgegeben.
    Vielen Dank
     
Status des Themas:
Es sind keine weiteren Antworten möglich.