route funktioniert nicht wie gewollt

myvoip

Neuer User
Mitglied seit
10 Apr 2006
Beiträge
27
Punkte für Reaktionen
0
Punkte
0
die aufgabe:

die fritzbox soll mit einer vm innerhalb von vmware kommunizieren.
vmware hat hierfür das netz 192.68.88.* benutzt.
die kommunikation von meinem windows mit der vm per 192.168.88.* funkioniert ohne probleme. sollte auch gehen, wenn die vm und windows auf der gleichen hardware laufen.


so hab ich es gemacht:

die fritzbox kann das lokale netz 192.168.88.* offensichtlich nicht kennen.
also habe ich folgendes route kommando gesetzt:
route add 192.168.88.0 gw 192.168.178.23

so sieht die sache dann aus:

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.180.1 * 255.255.255.255 UH 2 0 0 dsl
192.168.180.2 * 255.255.255.255 UH 2 0 0 dsl
192.168.88.0 192.168.178.23 255.255.255.255 UGH 0 0 0 lan
192.168.178.0 * 255.255.255.0 U 0 0 0 lan
default * 0.0.0.0 U 2 0 0 dsl



sollte jetzt nicht die fritzbox alles an 192.168.88.* an meinen windows rechner schicken?

die fritzbox macht dies aber nicht, und routet via den dsl port ins internet, wo die route dann relativ schnell wieder zu ende ist, weil dort bekanntlich 192.168... sinnvoller weise nicht geroutet wird.



was mache ich falsch? :confused:


und schon mal danke! :)
 

doc456

IPPF-Urgestein
Mitglied seit
27 Apr 2006
Beiträge
15,683
Punkte für Reaktionen
5
Punkte
38
Hallo,

na so wie es aussieht, hast du die Mask vergessen und es läuft auf Broadcast (4x255) und der wird ins Netz geroutet. ;)
 
G

gandalf94305

Guest
myvoip schrieb:
192.168.88.0 192.168.178.23 255.255.255.255 UGH 0 0 0 lan
@doc456, fast die richtige Erklärung ;-)

Wie man hier sieht, ist die Netzmaske für den Eintrag nicht 255.255.255.0, d.h. das Subnetz 192.168.88.0/24, sondern der Host 192.168.88.0 (Maske 255.255.255.255). Also gibt mal eine Netzmaske beim "route" Kommando mit an.
Code:
ip route add 192.168.88.0/24 via 192.168.178.23
--gandalf.
 

myvoip

Neuer User
Mitglied seit
10 Apr 2006
Beiträge
27
Punkte für Reaktionen
0
Punkte
0
Vielen Dank für die Hilfe.

Leider geht's immer noch nicht wie gewollt.

von der fritz box
ping 192.168.88.1 geht
ping 192.168.88.133 geht nicht


von meinem pc
ping 192.168.88.133 geht


aus der vm ist ein traceroute, ping,telnet, etc. zur fritzbox möglich.

umgekehrt leider nicht. :confused:
 
G

gandalf94305

Guest
Wenn ich mich recht entsinne, muss man in VMWare das Interface entsprechend freigeben, damit man wirklich von extern darauf zugreifen kann. Ist das erfolgt? Ist denn sicher, daß die VM auf ping überhaupt antwortet? ;-)

Es könnte auch ein Problem damit sein, daß IP-Forwarding in Windows (nicht der VMWare-Instanz, sondern dem Host-Betriebssystem) nicht aktiviert ist und damit das Routing überhaupt nicht stattfindet.

--gandalf.
 

Zurzeit aktive Besucher

3CX

Statistik des Forums

Themen
234,972
Beiträge
2,054,026
Mitglieder
355,350
Neuestes Mitglied
it-vader