.titleBar { margin-bottom: 5px!important; }

Seltsames Problem mit Asterisk's Wait(n)

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von bboksa, 13 Sep. 2005.

  1. bboksa

    bboksa Neuer User

    Registriert seit:
    13 Sep. 2005
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Zusammen,

    ich habe ein seltsames Problem mit Asterisk im Zusammenhang mit dem "Wait"-Befehl:

    Folgender Ausschnitt findet sich in meiner extensions.conf:

    Code:
    [4929xxx]
    exten => s,1,SetLanguage(de)
    exten => s,2,Wait(9)
    exten => s,3,Wait(9)
    exten => s,4,Wait(9)
    exten => s,5,Answer
    exten => s,6,VoiceMail(u1)
    exten => s,7,Goto(boksa,#,1)
    
    [2790xxx]
    exten => s,1,SetLanguage(de)
    exten => s,2,Wait(27)
    exten => s,3,Answer
    exten => s,4,VoiceMail(u1)
    exten => s,5,Goto(boksa,#,1)
    Problem ist: Wait(27) scheint Asterisk nicht verarbeiten zu können. Folgende Ausschnitte machen das Problem deutlich:

    Ein Anruf auf 4929xxx

    Code:
        -- Executing Goto("CAPI[contr1/30]/0", "4929xxx|s|1") in new stack
        -- Goto (4929xxx,s,1)
        -- started pbx on channel (callgroup=0)!
        -- Executing SetLanguage("CAPI[contr1/30]/0", "de") in new stack
        -- Executing Wait("CAPI[contr1/30]/0", "9") in new stack
        -- Executing Wait("CAPI[contr1/30]/0", "9") in new stack
        -- Executing Wait("CAPI[contr1/30]/0", "9") in new stack
        -- Executing Answer("CAPI[contr1/30]/0", "") in new stack
    Ein Anruf auf 2790xxx

    Code:
        -- Executing Goto("CAPI[contr1/31]/1", "2790xxx|s|1") in new stack
        -- Goto (2790xxx,s,1)
        -- Executing SetLanguage("CAPI[contr1/31]/1", "de") in new stack
        -- Executing Wait("CAPI[contr1/31]/1", "27") in new stack
        -- started pbx on channel (callgroup=0)!
      == Spawn extension (2790xxx, s, 2) exited non-zero on 'CAPI[contr1/31]/1'
    Die letzte Zeile erscheint, wenn ich nach weit mehr als 27 Sekunden auflege.

    Wodran kann das liegen? Ich bin für jeden Input dankbar!

    Das ganze ist übrigends Asterisk 1.0.7-BRIstuffed-0.2.0-RC7k auf Debian Sarge.

    Viele Grüße und vielen Dank vorab,

    Benjamin