.titleBar { margin-bottom: 5px!important; }

Seltsames Registrierungsproblem SPA-1001 nach IP-Wechsel

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von dettmar, 23 Sep. 2005.

  1. dettmar

    dettmar Neuer User

    Registriert seit:
    19 Juli 2005
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Ich habe hier ein sehr seltsames Problem mit dem SPA-1001 hinter einem DrayTek-Router. Port 5060 (und natürlich die RTP-Ports) wird auf den SPA durchgereicht. Zunächst läuft alles problemlos. Hier die Registrierung:

    Sep 22 07:51:30 000E08BBE7A1 [5060]STUN trying 0
    Sep 22 07:51:30 000E08BBE7A1 [5060]STUN trying 1
    Sep 22 07:51:30 000E08BBE7A1 [0]REG: STUN a010150->509093d6, 5060->5060
    Sep 22 07:51:30 000E08BBE7A1 RSE_DEBUG: reference domain:sipsnip.com
    Sep 22 07:51:30 000E08BBE7A1 [0:5060]->82.165.39.16:5060
    Sep 22 07:51:30 000E08BBE7A1 [0:5060]->82.165.39.16:5060
    Sep 22 07:51:30 000E08BBE7A1 REGISTER sip:sipsnip.com SIP/2.0
    Via: SIP/2.0/UDP 80.144.147.214:5060;branch=z9hG4bK-5d44fa3d
    From: Ruth u. Timo Dettmar <sip:dettmar@sipsnip.com>;tag=ae0339ef95264a6o0
    To: Ruth u. Timo Dettmar <sip:dettmar@sipsnip.com>
    Call-ID: 5b8cd97e-cfaaf846@10.1.1.80
    CSeq: 1 REGISTER
    Max-Forwards: 70
    Contact: Ruth u. Timo Dettmar <sip:dettmar@80.144.147.214:5060>;expires=60
    User-Agent: Sipura/SPA1001-3.1.5(SE)
    Content-Length: 0
    Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
    Supported: x-sipura

    Das Problem tritt nach einer Neueinwahl des Routers auf (z.B. nach der nächtlichen 24-Stunden-Zwangstrennung). Der SPA versucht nun, sich beim Provider zu registrieren, benutzt dabei aber nun seltsamerweise Port 40388 (scheinbar nicht zufällig, jeden Tag derselbe!). Vom Provider kommt noch nicht einmal eine Antwort und so schlägt die Registrierung natürlich fehl... Hier der Syslog:

    Sep 22 07:47:07 000E08BBE7A1 [5060]STUN trying 0
    Sep 22 07:47:07 000E08BBE7A1 [5060]STUN trying 1
    Sep 22 07:47:07 000E08BBE7A1 [0]REG: STUN a010150->5090a054, 5060->40388
    Sep 22 07:47:07 000E08BBE7A1 RSE_DEBUG: reference domain:sipsnip.com
    Sep 22 07:47:07 000E08BBE7A1 [0:5060]->82.165.39.16:5060
    Sep 22 07:47:07 000E08BBE7A1 [0:5060]->82.165.39.16:5060
    Sep 22 07:47:07 000E08BBE7A1 REGISTER sip:sipsnip.com SIP/2.0
    Via: SIP/2.0/UDP 80.144.160.84:40388;branch=z9hG4bK-743359b5
    From: Ruth u. Timo Dettmar <sip:dettmar@sipsnip.com>;tag=a1a85ee6ebf2f1aeo0
    To: Ruth u. Timo Dettmar <sip:dettmar@sipsnip.com>
    Call-ID: dc54adc6-8fa7f04e@10.1.1.80
    CSeq: 20 REGISTER
    Max-Forwards: 70
    Contact: Ruth u. Timo Dettmar <sip:dettmar@80.144.160.84:40388>;expires=60
    User-Agent: Sipura/SPA1001-3.1.5(SE)
    Content-Length: 0
    Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER
    Supported: x-sipura

    Der einzige Unterschied ist Port 40388 statt 5060. Aber warum? Und vor allem: Was nun?

    Danke für's Mitüberlegen!
    Timo Dettmar
     
  2. ralph.sprenger

    ralph.sprenger Mitglied

    Registriert seit:
    18 Apr. 2005
    Beiträge:
    309
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Das war bei mir auch schon so, allerdings habe ich dann im Sipura den STUN-Server mit Port eingetragen, bei mir stun.1und1.de:3478 und diesen Port im Router dann auf die statische Sipura-IP gesetzt. Ab da ging es dann ohne Probleme.