.titleBar { margin-bottom: 5px!important; }

Sipgate und Traffic auf der Leitung

Dieses Thema im Forum "FRITZ!Box Fon: Telefonie" wurde erstellt von realriot, 16 Feb. 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    Moin,

    ich habe folgendes Problem.
    Ich lasse ein P2P Programm im Hintergrund laufen (so wie emule).
    Mit Nikotel gibt es dabei keine Probleme. die Fritzbox schraubt bei einem VOIP Gespräch das outgoing für das P2P runter so dass für VOIP mehr freiraum bleibt. Somit habe ich eine glasklare Verbindung.

    Das ganze macht die Fritzbox jedoch NICHT bei Sipgate.

    Warum? Wir sind im Chat auf die Idee gekommen, daß es u.U. mit den Parametern für den Trafficshaper zu tun haben kann.
    Welche Ports / Protokolle nutzt Sipgate denn anders als Nikotel?

    Vielleicht weiss ja jemand mehr...

    Grüße

    Sascha
     
  2. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Hi.
    Ich habe mal wild getcpdumpt, und dabei ist mir was aufgefallen...
    1. Was priorisiert diese Regel eigentlich?
    Code:
     name = "fon-rtp";
     filter = "udp[8] = 0x80 or udp port 5060
     priority = 2;
     limiters = "default-out";
    2. Die Box hat forwardrules für
    dsliface
    Code:
     "udp 0.0.0.0:7078 0.0.0.0:7078",
     "udp 0.0.0.0:7079 0.0.0.0:7079",
     "udp 0.0.0.0:7080 0.0.0.0:7080",
     "udp 0.0.0.0:7081 0.0.0.0:7081",
    voipiface
    Code:
       "udp 0.0.0.0:7078 0.0.0.0:7078",
       "udp 0.0.0.0:7079 0.0.0.0:7079",
       "udp 0.0.0.0:7080 0.0.0.0:7080",
       "udp 0.0.0.0:7081 0.0.0.0:7081";
    3. Über 1und1 telefoniert: User Datagram Protocol, Src Port: 7078 (7078), Dst Port: 11868 (11868)
    Über sipgate telefoniert: User Datagram Protocol, Src Port: 7082 (7082), Dst Port: 11868 (11868)

    MfG Oliver
     
  3. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    werde das nachher mal checken. gebe dann sofort laut von mir obs funktioniert hat oder nich;)

    Edit 18:29 Uhr:

    hat leider keinen erfolg gebracht...

    Bitte von Christoph: "Edit"-Funktion nutzen, wenn noch was nachgetragen werden soll.
     
  4. olistudent

    olistudent IPPF-Urgestein

    Registriert seit:
    19 Okt. 2004
    Beiträge:
    14,756
    Zustimmungen:
    2
    Punkte für Erfolge:
    0
    Beruf:
    Softwareentwickler
    Ort:
    Kaiserslautern
    Nach weiteren Tests:
    Seltsamerweise ist der Source Port bei sipgate Gesprächen jetzt auch 7078 und nicht mehr 7082.
    Ich habe den Esel laufen mit vollem Upload (16kb/s).
    Bei einem Telefonat mit dem dus.net Echo Test kann ich keine Probleme feststellen.
    Die Qualität ändert sich auch nicht, wenn ich den Esel während des Telefonats beende.
    Testweise habe ich das Traffic Shaping deaktiviert:
    Erneuter Anruf beim Echo-Test. Das Echo braucht 2sec länger als vorher bis ich es wieder höre. Die Worte sind zerstückelt und unvollständig...

    Schlussfolgerung: Irgendwie greift das TrafficShaping bei realriot für Sipgate nicht. Wieso auch immer...
    Einen STUN hast du nicht eingetragen?

    MfG Oliver
     
  5. addy75

    addy75 Neuer User

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe selbiges Problem. Die Leitung gibt 64Kb her, eMule läuft mit 40Kb Up. Bei Telefonieren nimmt nur der Download um ca. 15Kb ab, der Upload bleibt unberührt. Stelle ich den Muli auf 20Kb up geht es so einiger Maßen. Denke mal an der Bandbreite kann es nicht liegen. Ist wieder mal Sipgate...
    Das Problem tritt aber auch bei anderen Uploads auf, also nicht Programm-bezogen oder auf die Verbindungen des Mulis...
     
  6. enrik

    enrik Neuer User

    Registriert seit:
    26 Okt. 2004
    Beiträge:
    127
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ziemlich sicher UDP-Pakete, die im 9. byte (1. byte payload) ein 0x80 stehen haben. Das ist ein ziemlich grober Match auf "alle RTP Pakete Version 2 ohne weitere Besonderheiten". Und natürlich port 5060 (SIP).

    Gruß,
    Enrik
     
  7. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    Es wird einfach nicht der Upload traffic gemindert beim VOIP-Telefonat. Warum das der Fall ist kann ich mir nicht erklären. Bei einem Gespräch über Nikotel funktioniert das einwandfrei.

    Über andere Anbieter kann ich hierbei noch nichts sagen...
     
  8. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    Diese Infos habe ich mir vom Sipgate support geholt...
    Fällt denn 5004 als RTP-Port in irgendeine Shaping-Rule? ´
    Vielleicht mal manuell irgendwo nachpflegen?

    Grüße

    Sascha
     
  9. addy75

    addy75 Neuer User

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Wenn man nun einfach mal den Port hinter die 5060 einfügt, kann es das dann schon gewesen sein ?

    Was für Ports nutzt Nikotel ? Damit man einen Vergleich hat ?


    /EDIT

    So habe einfach mal in der ac7.cfg hinter dem Eintrag die 5004 eingefügt

    name = "fon-rtp";
    filter = "udp[8] = 0x80 or udp port 5060 or udp port 5004
    priority = 2;
    limiters = "default-out";

    und es ist m.E. besser geworden. Man kann nun ENDLICH telefonieren. Kann aber noch besser werden ;)
    BTW Das Knack-Problem hatte ich leider auch mit SipSnip...

    Qualität von schlecht nach gut

    Sipgate, SipSnip, SipSnip (mit Eintrag) ,Sipgate(mit dem Eintrag), Sipgate (mit Eintrag und den "DSL-Light-Codec"), SipSnip (Mit Eintrag und "DSL-Light Codec"))


    Könnte das mal jemand nachtesten ? FW ist noch die FW23
     
  10. addy75

    addy75 Neuer User

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Kommando zurück.... Seltsamerweise ist wieder schlechter geworden....

    Ich will endlich günstig telefonieren
     
  11. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    anscheinend matcht die regel oben nicht auf sipgate.
    frage ist: warum!

    kann da nicht noch jmd. weiterhelfen?
     
  12. Gag_Halfrunt

    Gag_Halfrunt Neuer User

    Registriert seit:
    19 Jan. 2005
    Beiträge:
    91
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hilft zwar nicht weiter: Aber mit der neuen Version .37 auch keine Veränderung.
     
  13. addy75

    addy75 Neuer User

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    43
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Mit SipSnip ist's das selbe in grün...

    Wie schaut's aus, kann man nicth die Regel so ändern, dass der Box-Telefon-Anschluß generell priorisiert wird oder einfach alle Paktete, die im Header die Kennzeichnung für ein VoIP - Paket haben ( wenn's das gibt ?)
     
  14. KiRKman

    KiRKman Aktives Mitglied

    Registriert seit:
    27 Okt. 2004
    Beiträge:
    1,077
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Wollte nur kurz vermelden, daß ich das Problem auch schon seit jeher habe. Sipgate habe ich das bereits im November letzten Jahres gemeldet, bis heute keine Reaktion. Mit Sipsnip besteht dasselbe Problem. Gar keine Probleme habe ich mit Nikotel und GMX.

    Für mich steht seit langem fest, daß man die FRITZ!Box nicht mit Sipgate verwenden kann. Warum das Traffic Shaping bei Sipgate aber nicht funktioniert, weiß ich nicht. Ich habe mich, seit ich bei Nikotel bin, auch nicht mehr damit beschäftigt.

    Witzig ist, daß ich meine Box bei Sipgate bekommen habe. Dazu bekam ich auch einen Sipgate-Account, 5 EUR Guthaben und den ersten Monat Sipgate-1000 gratis! Zu dumm, daß ich es nie benutzen konnte ;) Das Guthaben habe ich immer noch fast vollständig, die ersten 1000 Minuten verstrichen damals ungenutzt. Stattdessen habe ich jetzt die Nikotel Flatrate...
     
  15. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    naja, man kann sipgate schon nutzen. nur leider nichts grosses uppen nebenbei ;)
     
  16. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    ich habe die regel einfach mal deaktiviert und geschaut ob die überhaupt auch bei nikotel gesprächen verwendet wird :)

    aber ja, wird sie. nur anscheinend hat JEDE veränderung KEINEN einfluss auf gespräche über sipgate...

    habe die regel selbst mal verändert auf:
    filter = "udp"

    weil ich denke dass er dann generell UDP packete priorisiert.... NADA, nichts, niente... nichtmal das hilft.

    ich verstehs net...
     
  17. KiRKman

    KiRKman Aktives Mitglied

    Registriert seit:
    27 Okt. 2004
    Beiträge:
    1,077
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Nee, also bei mir geht wirklich gar nichts nebenher. Ich habe T-DSL 2000 Standard, aber sobald ich auch nur im FlashFXP einen auf 2 Kilobyte/Sekunde limitierten (!!) Upload anstelle, is alles bei Sipgate sofort im Eimer. D.h. ich habe von knapp 24 Kilobytes/Sekunde nur 2 Kilobytes/Sekunde ausgenutzt, aber trotzdem bei Sipgate nur Gehacke. Selbst wenn ich G729 verwende... Das muß irgendwas Anderes sein, was da hakt...
     
  18. KiRKman

    KiRKman Aktives Mitglied

    Registriert seit:
    27 Okt. 2004
    Beiträge:
    1,077
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ich lese gerade von dem Deaktivieren der Regel bei Nikotel. Dazu mal eine generelle Frage meinerseits: hast Du die Regel selber eingetragen? In meiner ar7.cfg findet sich nämlich gar nichts dergleichen. Ich habe die FRITZ!Box Fon mit der 06.03.37. In dieser Sektion der ar7.cfg habe ich auch nie etwas geändert.

    Ich poste mal meinen Teil der ar7.cfg, so wie sie standardmäßig in meiner Box erscheint!
    Code:
                            shaperconnection {
                                    enabled = yes;
                                    targets = "";
                                    name = "Fritz!Box";
                                    limiters {
                                            name = "default-out";
                                            bps_limit {
                                                    limit_total = 100;
                                                    limit_p0 = 0;
                                                    limit_p1 = 95;
                                                    limit_p2 = 95;
                                                    limit_p3 = 0;
                                            }
                                            pps_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            min_priority = 0;
                                            max_priority = 2;
                                            grouping_by_source_ip = no;
                                            grouping_by_dest_ip = no;
                                            grouping_by_source_port = no;
                                            grouping_by_dest_port = no;
                                            dynamic_balancing = no;
                                            bps_child_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            pps_child_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            shapeOutgoingOnIncomingCounters = no;
                                    } {
                                            name = "default-in";
                                            bps_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            pps_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            min_priority = 0;
                                            max_priority = 0;
                                            grouping_by_source_ip = no;
                                            grouping_by_dest_ip = no;
                                            grouping_by_source_port = no;
                                            grouping_by_dest_port = no;
                                            dynamic_balancing = no;
                                            bps_child_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            pps_child_limit {
                                                    limit_total = 0;
                                                    limit_p0 = 0;
                                                    limit_p1 = 0;
                                                    limit_p2 = 0;
                                                    limit_p3 = 0;
                                            }
                                            shapeOutgoingOnIncomingCounters = no;
                                    }
                                    out_rules {
                                            name = "download-tcp-ack";
                                            filter = "tcp and len <= 64";
                                            priority = 2;
                                            limiters = "default-out";
                                    } {
                                            name = "dns";
                                            filter = "udp port 53";
                                            priority = 1;
                                            limiters = "default-out";
                                    } {
                                            name = "voip";
                                            filter = "(udp port 7078 or port 7079 or port 7080 or port 7081 or port 5060)";
                                            priority = 2;
                                            limiters = "default-out";
                                    } {
                                            name = "http-requests";
                                            filter = "(tcp dst port 80 or dst port 8080 or dst port 3128) and (len <= 800)";
                                            priority = 1;
                                            limiters = "default-out";
                                    } {
                                            name = "pri-out";
                                            filter = "icmp";
                                            priority = 1;
                                            limiters = "default-out";
                                    } {
                                            name = "default";
                                            filter = "";
                                            priority = 0;
                                            limiters = "default-out";
                                    }
                                    in_rules {
                                            name = "default";
                                            filter = "";
                                            priority = 0;
                                            limiters = "default-in";
                                    }
                                    demasquerade = no;
                            }
                    }
    Wie Ihr seht, kann ich maximal eine Priorität von 2 erreichen. Für VoIP gibt es bei mir auch nur eine Rule, und die heißt "voip"...
    Code:
    { 
                                            name = "voip"; 
                                            filter = "(udp port 7078 or port 7079 or port 7080 or port 7081 or port 5060)"; 
                                            priority = 2; 
                                            limiters = "default-out"; 
                                    }
    Naja, scheint ja sowieso keinen Unterschied zu machen...
     
  19. realriot

    realriot Neuer User

    Registriert seit:
    23 Nov. 2004
    Beiträge:
    156
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Bremen
    ne ich habe generell die regel fürs shaping bei VOIP geredet.
    eine "VOIP" rule habe ich irgendwie nicht... ?!?

    ich schau mal nach ;)
     
  20. TWELVE

    TWELVE Aktives Mitglied

    Registriert seit:
    3 Okt. 2004
    Beiträge:
    940
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das hat damit nicht allzuviel zu tun, es reicht wenn Pakete verzögert werden in der Warteschlange ( z.B. weil das TrafficShaping sie nicht vorläßt), dann gibt es Aussetzer.Bandbreite ist das eine Ding, aber
    dies bedeutet nicht, das ein bestimmtes Paket sofort abgeschickt wird.
     
Status des Themas:
Es sind keine weiteren Antworten möglich.