.titleBar { margin-bottom: 5px!important; }

Sipura 3000 hinter Bintec X1200 - Kein Durchkommen?

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von reinerp, 13 Sep. 2004.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. reinerp

    reinerp Neuer User

    Registriert seit:
    13 Sep. 2004
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe heute den Sipura 3000 erhalten, da ich die FritzBox Fon von AVM nicht hinter meinem Bintec X1200 Router zusammen mit VoIP nutzen kann. Der X1200 unterstützt leider nur VoIP über H.323 - also abgeschaltet.

    In der NAT-Tabelle des Routers die incoming ports 5060, 5061 und 16384-16482 freigeschaltet. Habs mit und ohne NAT-Einstellungen (STUN) in der Sipura-Konfiguration versucht. Eine Verbindung / Freiton kommt nicht zustande. (Das Debug-Log habe ich angehängt). Ebenso meine Konfigurationen unter SIP und LINE1 als PDF-Dateien. Das Debug-Log des Bintec-Routers läßt auch nur erkennen, daß er eine Verbindung vom ATA zum sip.1und1.de zwecks DNS-Auflösung durchläßt.

    Na ja, die ganze Angelegenheit hatte ich mir eigentlich etwas einfacher vorgestellt. Von den vielen Einstellmöglichkeiten im Web-Dialog bin ich total erschlagen.

    Habt Ihr den ein oder anderen Tip, bevor ich das Thema VoIP erst mal wieder an den Nagel hänge?!
    :roll:[shadow=red]
     

    Anhänge:

  2. reinerp

    reinerp Neuer User

    Registriert seit:
    13 Sep. 2004
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    habe das Problem erstmal selbst gelöst. Rauswählen ins Festnetz kommt schon mal an. Was war die Ursache?

    im admin/advanced unter 'Regional' 'Miscellaneous' für 'Caller ID Method:' "ETSI-DTMF' aktiviert.

    Dann die Debug-Meldungen des Bintec X1200 belauscht, festgestellt, daß der Sipura vom Port 56094 ausgehend über NAT Port 33349-33335 Verbindung zum sip.1und1.de aufnimmt, habe in den NAT-Einstellungen des Routers die udp-Ports 33344-33342 für 'Requested from Outside' auf den Port 56094 der Sipura geforwarded. Und siehe da, die Verbindung kommt zustande. Muß noch beobachten, ob ich tatsächlich die ganze port range erwischt habe. Ob diese port range anstelle der Port-Freigaben von 16384-16482 anzugeben ist und spezifisch für den Bintec X1200 ist, müssten andere mal rückmelden.

    Also weiter in der Konfiguration ...
    Gruß Reiner Pietrzak :)
     
  3. exim

    exim Admin a.D.

    Registriert seit:
    27 Apr. 2004
    Beiträge:
    1,013
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hmm, ist aber eigenartig. Normalerweise sollte der X1200 die von innen kommenden Geschichten (und die dürften eigntlich nur von 16384-16482 kommen) weitrleiten. Stateful Inspection hast Du abgeschalten? Welche OS-Version auf dem BinTec?

    Ich setze heute oder morgen Nachmittag mal einen SPA-2000 hinter einen X1200 zum testen ...
     
  4. reinerp

    reinerp Neuer User

    Registriert seit:
    13 Sep. 2004
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Also, das mit dem forwarden der ports 33344-33442 (sorry, hatte mich oben verschrieben) war offenbar doch nicht notwendig. Ich hab das zurückgenommen und komme trotzdem raus. Ob wer reinkommt werden ich heute abend testen können.

    Nein, Stateful Inspection ist mit den Standardeinstellungen der Firmware-Version 6.3 Rev. 4 Patch 15 konfiguriert. Da habe ich nichts zusätzlich definiert.

    Es scheint nur die Tonwahleinstellung 'ETSI-DTMF' gewesen zu sein (Stand default-mäßig auf 'Bellcore (N.Amer,China)'. Obwohls definitiv nach nur dieser Änderung noch nicht lief, jetzt geht's aber.

    Und den reboot des Sipura, wie nach Einstellungsänderungen in einem anderen thread empfohlen hatte ich auch durchgeführt, bevor ich einen neuen Verbindungsversuch gestartet hatte.

    Definitiv startet der Sipura 3000 die DNS-Abfrage intern über den Port 56094 per NAT dann auf Port 33xxx geforwarded und offenbar jetzt auch ohne Öffnen der Ports für incoming traffic ordentlich aufgelöst??? - ich kriege ja jetzt Verbindung, d.h. der STUN funktioniert offenbar so wie er soll.

    edit: der interne Port für DNS-Abfragen ändert sich offenbar nach jedem reboot, augenblicklich z.B. 20118, nach mehrfachen reboots ging wieder gar nichts mehr, dann plötzlich gehts wieder (Kann es sein, daß die Funktion des stun eine ganze Weile braucht, bis das durchgeschaltet ist und ich nach reboots nur zu ungeduldig war??)

    Danke, die Testergebnisse würden mich als gründlichen Menschen natürlich trotzdem interessieren.
     
  5. exim

    exim Admin a.D.

    Registriert seit:
    27 Apr. 2004
    Beiträge:
    1,013
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hatte leider nur sehr kurz Zeit, den SPA-2k hinter einen X1200 zu setzen und ich kann den X1200 leider auch nicht mal einfach so außer Gefecht nehmen denn der läuft u.a. als VPN-Gateway. Auf der Kiste läuft auch noch die 6.3Rev4P15. Habe mit Nikotel getestet. Abgehend kein Problem. Ankommend Portforwarding 5060 und 14384-16482 UDP auf den SPA. Stateful inspection ist *nicht* standardmässig aktiviert - der Menüpunkt ist zwar da, aber da sollte nix drinnenstehen. Wenn es so aussieht wie auf dem Bild im Attachment (nur sichtbar wenn angemeldet), also keine Filter definiert, ist Stateful Inspection deaktiviert.

    Was mich wundert ist, dass der SPA ziemlich lange mit dem STUN herummurkst. Erstelle bitte nochmals ein Debug-Log, jedoch mit "SIP Debug Option: full" unter Line 1, so daß auch die SIP-Nachrichten aufgezeichnet werden. Genaueres zum Syslog hier: http://www.ip-phone-forum.de/forum/viewtopic.php?t=537


    Ob der STUN funktioniert oder nicht erkennst Du daran, ob der SPA die korrekte externe IP im Info-Tab anzeigt oder nicht. Eventuell mal die Seite des SPA neu laden, es kann ein paar Sekunden dauern bis da eine IP-Adresse erscheint. Vergleich mit http://www.whatismyip.com/
    Die DNS-Anfragen kommen i.d.R. von unprivilegierten Ports zum Ziel 53. Und die müssen funktionieren, auch ohne explizite NAT-Konfiguration. Andere Möglichkeit: Nimm den X1200 als DNS-Proxy, also im SPA den X1200 als DNS-Server eintragen, sofern Du nicht noch einen internen "echten" DNS laufen hast. Die DNS-Proxy-Funktion am X1200 ist weitreichend konfigurierbar und funktioniert problemlos.
     

    Anhänge:

  6. reinerp

    reinerp Neuer User

    Registriert seit:
    13 Sep. 2004
    Beiträge:
    4
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Private IP statt der externen IP bei Registrierung

    Vielen Dank für die Anregungen.

    exim: Was mich wundert ist, dass der SPA ziemlich lange mit dem STUN herummurkst.

    Ja, das ist auch mein Eindruck. Hab den Syslog-Mitschnitt angehängt.

    Beim Initialisieren nach dem reboot scheint STUN nicht schnell genug die nötige Information zu liefern. Beim ersten Registrierungsversuch wird offenbar statt der externen IP die private IP übergeben und damit schlägt die Registrierung fehl.

    Ich warte jetzt mal den Registrierungstimeout von ca. 20 min ab, obs beim zweiten Versuch klappt. Kann man den timeout bis zum ersten Registrierungsversuch nach reboot (Anzahl Stun reuquests o.ä.) vielleicht irgendwo konfigurieren, wenns tatsächlich daran liegen sollte?

    edit: Ja, nach Ablauf des timeouts bis zur nächsten Registrierung war die Registrierung erfolgreich! Heißt das, nach jedem reboot bzw. Wechsel der externen IP 20 min. warten?

    edit: Nein, hab die Einstellung bereits unter 'SIP' im avanced admin-Modus gefunden. Wenn ich das 'Reg Retry Long Intvl:' auf 60 setze, handle ich mir damit evtl. an anderer Stelle Probleme ein (z.B. dauernde Verbindungsversuche, traffic, ...)?

    edit: offenbar hat auch die Einstellung der 'Caller ID Method:' keinen Einfluß auf Erfolg oder Mißerfolg der Registrierung!
     

    Anhänge:

  7. exim

    exim Admin a.D.

    Registriert seit:
    27 Apr. 2004
    Beiträge:
    1,013
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Habe mal fix drübergeschaut, die richtige Zeit habe ich erst heute Nacht *g*. Nur auf die Schnelle: Deine Konfig für SIP und Line 1 sieht auf den ersten Blick i.O. aus. Aber Dein PSTN-Zugang scheint nicht zu wollen. Welcher Wert steht im Info-Tab unter "Line Voltage" und welcher Wert steht im PSTN-Line-TAB unten links unter "Line-In-Use Voltage"? Rest später ... ;)
     
  8. exim

    exim Admin a.D.

    Registriert seit:
    27 Apr. 2004
    Beiträge:
    1,013
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, Nachschlag:
    Da die VoIP-Verbindung nicht korrekt funktioniert (keine Reg.) versucht der SPA einen Fallback auf die PSTN-Leitung ([0:5060]->127.0.0.1:5061 INVITE sip:fallback@127.0.0.1:5061), welche jedoch auch nicht funktioniert ([0:5060]<<127.0.0.1:5061 SIP/2.0 503 Service Unavailable - das kommt wenn die PSTN-Leitung nicht als solche erkannt wurde).

    In den Notify-Messages des SPA (NAT keepalive) steht die korrekte externe IP (NOTIFY sip:sip.1und1.de SIP/2.0 - Via: SIP/2.0/UDP 80.134.20.33 - also muß der SPA ja schonmal irgendwie (STUN?) an die externe IP gekommen sein. Die Registrierung nach einem Reboot in Deinem Log erfolgt jedoch mit lokaler IP (SIP/2.0 479 Please don't use private IP addresses - Via: SIP/2.0/UDP 192.168.125.228). Es sieht so aus als ob der SPA in dem Moment der Registrierung die externe IP noch nicht erkannt hat. Die Frage ist nur - wieso!?

    Aber versuche zunächst einmal, die PSTN-Leitung hinzubekommen. Bitte beantworte mal die oben gestellte Frage nach der Volt-Anzeige ...
     
  9. rotzloeffel

    rotzloeffel Neuer User

    Registriert seit:
    12 Okt. 2004
    Beiträge:
    7
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Portforwarding am X1200 ??

    Exim hat oben mal geschrieben, das Portforwarding am X1200 einzustellen sei, weis jemand wie?
     
  10. Netview

    Netview IPPF-Promi

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    3,366
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Beruf:
    Dipl.-Inf.
    Ort:
    Westerwald
    so geht's:

    BINTEC-Xnnnn Setup Tool BinTec Communications AG
    [IP][NAT][EDIT]..[EDIT]: NAT - sessions from OUTSIDE (Provider) Xnnnn
    _______________________________________________________________________________


    Service user defined
    Protocol udp

    Remote Address
    Remote Mask


    External Address
    External Mask
    External Port specify range Port 5060 to Port 5061

    Internal Address spa-2000/3000 (ip)
    Internal Mask 255.255.255.255
    Internal Port any

    SAVE CANCEL
    _______________________________________________________________________________
    Use <Space> to select

    BINTEC-Xnnnn Setup Tool BinTec Communications AG
    [IP][NAT][EDIT]..[EDIT]: NAT - sessions from OUTSIDE (Provider) Xnnnn
    _______________________________________________________________________________


    Service user defined
    Protocol udp

    Remote Address
    Remote Mask


    External Address
    External Mask
    External Port specify range Port 16384 to Port 16482

    Internal Address spa-2000/3000 (ip)
    Internal Mask 255.255.255.255
    Internal Port any

    SAVE CANCEL
    _______________________________________________________________________________
    Use <Space> to select
     
  11. suarez

    suarez Neuer User

    Registriert seit:
    28 Dez. 2004
    Beiträge:
    90
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi,

    hatte die fehler auch nachdem ich ihn hinter einem x1200 laufen liess.
    das neue firmwareupdate löste das problem.

    nat hatte ich schon drin, die ports sind ja immer die gleichen bei 1und1.
    na gut, dann kann ich ja schon mal das qos pdf laden.........
    :)

    cya
    suarez
     
Status des Themas:
Es sind keine weiteren Antworten möglich.