.titleBar { margin-bottom: 5px!important; }

Skinny Konfiguration

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von *DAU, 17 Okt. 2005.

  1. *DAU

    *DAU Neuer User

    Registriert seit:
    12 Juni 2005
    Beiträge:
    35
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    mein Apache-Webserver stellt für mein Cisco 7960 das Directory und verschiedene Services bereit. Seit ich auf die Skinny-Firmware 7.2(2) mit anschließendem Factory-Reset umgestiegen bin sendet das Telefon ungültige Requests an den Webserver. Der Apache antwortet darauf einfach nur mit einer bad-request message statt mit der passenden XML-Datei.

    Hier ein Auszug aus dem fehlerhaften Request:

    Code:
    Accept-Charset:
    ...
    ...
    ...
    x-CiscoIPPhoneModelName: CP-7960
    x-CiscoIPPhoneSDKVersion: 4.0.1
    x-CiscoIPPhoneDisplay: 133,65,2,G
    
    Die Hex-Werte zwischen "Accept-Charset:" und "x-CiscoIPPhone..." sind: 20 0a 01 01 02 0a 01 01 02 0a 01 01 01 0d 0a. Ich vermute dass es am Factory-Reset und nicht am Firmware-Update liegt. Auf meinem TFTP-Server liegt nur die SEP<MAC>.cnf.XML. Wie konfiguriere ich mein Cisco-Telefon so dass die Anfragen wieder standardkonform sind :?:

    SEP<MAC>.cnf.XML:
    Code:
    <device>
    <devicePool>
     <callManagerGroup>
      <members>
       <member  priority="0">
        <callManager>
         <ports>
          <ethernetPhonePort>2000</ethernetPhonePort>
         </ports>
         <processNodeName>10.1.1.2</processNodeName>
        </callManager>
       </member>
      </members>
     </callManagerGroup>
    </devicePool>
    <versionStamp>{Jan 01 2002 00:00:00}</versionStamp>
    <loadInformation></loadInformation>
    <userLocale>
     <name>English_United_States</name>
     <langCode>en</langCode>
    </userLocale>
    <networkLocale>United_States</networkLocale>
    <idleTimeout>0</idleTimeout>
    <authenticationURL></authenticationURL>
    <directoryURL>http://10.1.1.1/directory.xml</directoryURL>
    <idleURL></idleURL>
    <informationURL></informationURL>
    <messagesURL></messagesURL>
    <proxyServerURL></proxyServerURL>
    <servicesURL>http://10.1.1.1/index.xml</servicesURL>
    </device>
    
    Gruß
    *DAU
     
  2. *DAU

    *DAU Neuer User

    Registriert seit:
    12 Juni 2005
    Beiträge:
    35
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich habe gerade noch einmal einen Factory-Reset gemacht und siehe da, der Request sieht nun folgendermaßen aus:

    Code:
    GET /index.xml?name=SEP00036B72499A&locale=...
    
    Die Punkte stellen undefinierbare Zeichen dar. Kann mir jemand sagen wie ich das Locale einstelle? ich habe die SEP<MAC>.cnf.XML einfach von http://voip-info.org/wiki/view/SCCP-HOWTO2 übernommen. Vielleicht fehlt mir eine Datei die ab dieser Firmware-Version vorhanden sein muss.

    Gruß
    *DAU
     
  3. *DAU

    *DAU Neuer User

    Registriert seit:
    12 Juni 2005
    Beiträge:
    35
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, für alle die vielleicht mal ein ähnliches Problem haben: Bei mir lag es an der SEP<MAC>.cnf.XML :!: