[SOT] Frage zum TCPMP Player & NAS

carlos

Mitglied
Mitglied seit
30 Nov 2004
Beiträge
213
Punkte für Reaktionen
0
Punkte
16
Auf dem NAS ein NSLU2 mit Unslung 6.8 Beta.
Gruß

Carlos
 

Meatwad

Aktives Mitglied
Mitglied seit
1 Sep 2006
Beiträge
1,587
Punkte für Reaktionen
0
Punkte
0
NAS machen viele probleme, da die datenrate einfach eingeschränkt ist. probier mal die platte über usb anzuschließen
 

withoutfield

Neuer User
Mitglied seit
28 Nov 2006
Beiträge
73
Punkte für Reaktionen
0
Punkte
0
Update:
Seit Version 3.0.5 ist mein MP3 Abspielproblem beseitigt!
Wenn ich nun über den Fileexplorer einen Track aus einem Ordner abspiele, spielt der neue eingebaute Player automatisch den nächsten Track im Ordner ab.
Klasse, endlich klappt das *freu*
pEtEr
 

sunnymagic

Neuer User
Mitglied seit
26 Dez 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
TCPMP und streaming von Lan HD

Hallo,

ich bin neu hier im Forum und hätte gleich ein paar Fragen

Habe den SOT (super Arbeit) installiert. Ich binn voll zufrieden damit. Leider kann ich von meinem NAS keine Divx Filme streamen - Mpeg funktioniert. Wie ich gelesen habe binn ich nicht der einzige mit diesem Problem.
Giebt es da schon eine lösung?

Meine Tests ergaben folgendes:
Mpeg streamen SOT vom Freigabe Ordner auf PC - geht
Mpeg streamen SOT vom NAS - geht
Divx streamen SOT vom Freigabe Ordner auf PC - geht
Divx streamen SOT vom NAS - geht net :(
Divx streamen PC vom NAS - geht

Da ich alles per LAN verbunden habe kann ich Wireless Probs ausschließen.
So wie ich das sehe liegt es wohl am Player TCPMP, da sonst alles funzt?

Hat jemand ne Idee :confused:

sunnymagic
 

withoutfield

Neuer User
Mitglied seit
28 Nov 2006
Beiträge
73
Punkte für Reaktionen
0
Punkte
0
Hallo sunnymmagic,
leider gibt es, zumindest soweit ich weiß, noch keine Lösung um Divx oder Xvid Filme von einem "70 Euro NAS" zu streamen, da die Übertragungsgeschwindigkeit eines solch güntigen NAS mit maximal 3,5 MBit/s wohl zu niedrig ist. Zwar werden 100MBit/s versprochen, aber die Hardware und Treiber können das nicht.
Da der TCPMP Player in dieser Form auch nicht weiterentwickelt wird sehe ich mit diesem Player auch keine Lösungsmöglichkeit.
Wie du aber in diesem Thread nachlesen kannst hatte ich auch ein Problem mit mp3 Playslisten, das seit der SOT VS3.0.5 aber gelöst ist.
Darum denke ich, daß es nur eine Frage der Zeit ist, bis z.B. Neelix einen eigenen Player programiert hat der das abspielen dieser Filme ermöglicht.
Also einfach dranbleiben, dieses Board ist meiner Meinung nach eine super kreative Community und Neelix ein erstklassiger Programmierer. *schleim* :)
pEtEr
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
Also ich denke nicht, dass es an der Geschwindigkeit des NAS liegt. Ich kann mit meinem Laptop von meinem NAS (Icybox NAS-900) per WLAN wunderbar streamen - selbst bei geringer Signalstärke und nur 1 MBit/s reicht es um die DivX-Files von onlinetvrecorder.com zu streamen. Wenn ich über die SOT von NAS Videos abspiele funktioniert das auch mit großen MPEG-Files wunderbar nur bei DivX streikt er. Ich denke eher das liegt an dem TCPMP-Player.
 

sunnymagic

Neuer User
Mitglied seit
26 Dez 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
@y3000
Ich bin auch deiner Meinung, meine "Versuche" haben gezeigt, dass Streaming vom NAS auch mit Divx möglich ist. Nur TCPMP macht da Probs. Ich habe auch mit neuer Firmware des NAS (Funtec NetDisc) experimentiert, da in einem anderen Forum von ähnlichen Probs geschrieben wurde (mit anderen Playern), brachte aber alles nichts.

@withoutfield
Danke für die schnelle Antwort, ich denke aber es liegt am "Protokoll" oder so - kenne mich da nicht aus (evtl. Header?) - aber wie ich beobachtet habe kann ich vom NAS auch Mpeg Dateien nicht vorspulen, was aber von einem freigegebenen Ordner auf dem PC geht. Ausserdem kann ich beim Stramen vom PC im TCPMP Player über Benchmark und Medieninfo auch die File Größe der gestreamten Datei sehen, was am NAS nicht geht. So als wären die Infos der Datei nicht vorhanden?
Na mal sehn - vieleicht findet jemand eine Lösung
so long
sunnymagic
 

withoutfield

Neuer User
Mitglied seit
28 Nov 2006
Beiträge
73
Punkte für Reaktionen
0
Punkte
0
Hallo y3000 und sunnymagic,
ihr habt natürlich Recht, auf dem PC vom NAS gestreamt funktioniert ein Divx-Film ohne Probleme. Dann liegt es wohl eher am TCPMP.
Wie aber schon geschrieben bin ich mir sicher, daß irgendwer oder irgendeine Software das Problem früher oder später lösen wird.
Ich habe übrigens ein "NoName" NAS, vergleichbar mit der IcyBox. Soweit ich weiß arbeiten die alle mit der gleichen Hardware und Treibern. Nur das Gehäuse wird individuell gestaltet. Welche Treiberversionen habt ihr denn? Ich muss meine nachreichen, bin z.Z. nicht zuhause.
Bleiben wir also am Ball,
pEtEr
 

sunnymagic

Neuer User
Mitglied seit
26 Dez 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
Also ich benutze im moment NAS-BASIC45 mit LOADER 69. Die meisten der NAS haben den selben Chipsatz. Es unterscheidet sich wohl wirklich nur das Gehäuse. Die Firmware konnte wohl ab NAS-BASIC41, Loader 67 Dateien größer als 4 GB unterstützen. Wie ich das rausgelesen habe machen die das mit einem Trick, der die Großen Dateien in mehrere kleine unterteilt aber nach "außen" als eine ganze Datei verkauft. Vieleicht ist ja das unser Prob. Suche noch eine Firmware, die älter ist (glaube 36 oder so?):noidea:

Gruß sunnymagic
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
Also meine Icy Box NAS-900 hat die folgende Firmware NAS-BASIC43, LOADER 067. Ich habe nirgends auf www.icybox.de eine andere Firmware gefunden - gibt es für diese Box was neueres?
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
Ich hätte da noch eine Frage. Und zwar möchte ich das Verzeichnis welches ich auf dem NAS freigegeben habe mit einem Passwort schützen aber dann kann die STB die Verbindung nich herstellen.

Zur Zeit habe ich keinen Passwortschutz und folgenden Befehl in der startup.cmd:
net use * \\icybox\thomsonbox /user: /password:

Wenn ich ein Verzeichnis am PC freigebe:
net use * \\icybox\thomsonbox /user:yyy /password:123

Wenn ich auf der NAS einen Passwortschutz einrichte habe ich es schon mit folgenden Befehlen ohne Erfolg versucht - wo liegt mein Fehler?
net use * \\icybox\thomsonbox /user: /password:123
net use * \\icybox\thomsonbox 123
net use * \\icybox\thomsonbox /password:123

Das Problem ist, dass ich nicht weiß was ich bei user eingeben muss...
 

NEELIXThomas

SOT-Team
Mitglied seit
31 Mrz 2006
Beiträge
2,150
Punkte für Reaktionen
0
Punkte
0
ich rate jetzt wirklich ins blaue, probiere mal "root"

hat Dein NAS ein Webinterface?
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
@NEELIXThomas:
Ich werde das mit root morgen mal versuchen. Wenn ich unter Windows eine Verbindung mit der Icy Box herstelle gibt er mir als User immer Gast vor. Wenn ich mich dann über die STB mit der Icy Box als Gast verbinden möchte klappt das nicht. Muss ich unbedingt einen User angeben? Unter XP geht das ja auch mit net use z: \\icybox\thomsonbox xyz123?! Mein NAS hat auch ein Webinterface aber dort kann ich nur Ordner erstellen und diese mit einem Passwort versehen. User-Namen kann ich nicht vergeben.

In einem anderen Beitrag habe ich schonmal gefragt, ob es eine Möglichkeit gibt Audiodateien mit dem neuen SOT-Audiplayer vorzuspulen. Hat leider keiner geantwortet (ist wohl untergegangen), deshalb frage ich an dieser Stelle nochmal. Ich höre nämlich gern Hörbücher und mit dem TCPMP-Player hatte ich die Möglichkeit relativ schnell an die Stelle vorzuspringen an der ich beim letzten Mal aufgehört hatte. Ist das auch mit den neuen Player möglich?
 

NEELIXThomas

SOT-Team
Mitglied seit
31 Mrz 2006
Beiträge
2,150
Punkte für Reaktionen
0
Punkte
0
das Spulen habe ich noch nicht eingebaut, steht aber schon auf der todo-liste

bezüglich Gast, probiere mal die Groß kleinschreibung zu ändern, vielleicht hilfts ja (ich glaube zwar selbst nicht daran, aber einen Versuch ist es allemal wert)
 

sunnymagic

Neuer User
Mitglied seit
26 Dez 2006
Beiträge
5
Punkte für Reaktionen
0
Punkte
0
Hallo,

die Firmware zu den NAS giebt es hier http://www.lanserver.co.uk.tt/
bei den meisten NAS ist der Standardname "admin" ebenso wie das passwort, wobei man das PW ändern kann und den Namen nicht :(

Gruß sunnymagic
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
Das mit dem Spulen bei Audio-Files klappt einwandfrei - einfach super!

Das Verbinden mit einem passwortgeschützten Verzeichnis auf meinem NAS klappt nicht. Ich habe jetzt mal folgendes versucht:

net.exe use test1 \\icybox\thomsonbox /user: /password:
net.exe use test2 \\icybox\thomsonbox /user:user /password:xyz
net.exe use test3 \\icybox\thomsonbox /user:Gast /password:xyz
net.exe use test4 \\icybox\thomsonbox /user:icybox\Gast /password:xyz
net.exe use test5 \\icybox\thomsonbox /user:Gast /password:xyz
net.exe use test6 \\icybox\thomsonbox /user:admin /password:xyz
net.exe use test7 \\icybox\thomsonbox /user:root /password:xyz
net.exe use test8 \\icybox\thomsonbox /user: /password:xyz
net.exe use test9 \\icybox\thomsonbox xyz
net.exe use test10 \\icybox\thomsonbox /user:ThomsonBox /password:xyz
net.exe use test11 \\icybox\thomsonbox /user:thomsonbox /password:xyz

Kann mir jemand mit einem ähnlich NAS wie der Icy Box NAS-900 sagen wie sein Eintrag in der Startup.cmd lautet?!
 

stbuser

Neuer User
Mitglied seit
19 Nov 2006
Beiträge
46
Punkte für Reaktionen
0
Punkte
0
Ich bin im Besitz eines Raidsonic IB-NAS2000 und habe keinerlei Probleme mit der Transferrate, da die Box bis 8 MB/s (nichtMBit/s)kann.

Mit unten folgendem Eintrag in der start.cmd klappt die Verbindung einwandfrei.
Hast du auch dem Share auf deinem NAS deinen Benutzer zugewiesen?
net.exe use * \\icybox\filme /user:benutzername /password:passwort
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
@stbuser: Ich kann bei meiner NAS keine Benutzer zuweisen , sondern nur einzelnen Verzeichnissen Passwörter zuweisen. Funktioniert bei der NAS-2000 eigentlich das Abspielen von DivX-Files über die STB/TCPMP?

@NEELIXThomas: Ich habe festgestellt, dass meine MP3-Files über den SOT-Player übersteuert abgespielt werden. Über TCPMP stimmt die Lautstärkeneinstellung. Kannst Du in einer der nächsten Versionen einen Lautstärkeregler für den Player einbauen, den man über die FB steuern kann?
 

y3000

Neuer User
Mitglied seit
31 Okt 2006
Beiträge
42
Punkte für Reaktionen
0
Punkte
0
Ich kopiers mal rüber ...
 
Erhalten Sie 3CX für 1 Jahr kostenlos!

Gehostet, in Ihrer privaten Cloud oder on-Premise! Ganz ohne Haken. Geben Sie Ihren Namen und Ihre E-Mail an und los geht´s:

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.
oder via