.titleBar { margin-bottom: 5px!important; }

SPA-3000 mit Linksys-Router und Sipath/Siproxd an Sipgate

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von t47, 14 Juni 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. t47

    t47 Neuer User

    Registriert seit:
    31 Mai 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo,

    ich weiß nicht so recht, wohin meine Frage gehört; ich stelle sie einfach mal hier rein:
    Meine Konfiguration ist so wie im Betreff genannt: SPA-3000, Linksys WRT54G mit OpenWRT und Sipath (oder auch Siproxd, ich habe beides versucht) und als VOIP-Anbieter Sipgate (neben web.de).
    Die Schwierigkeit ist folgende: Sobald ich im Sipura als Outbound-Proxy meine Router-Adresse eingebe (egal ob mit Sipath oder Siproxd), bekomme ich bei Sipgate die stereotype Fehlermeldung "es ist ein Fehler..blabla..". Dies gilt nur für kostenpflichtige Anrufe ins Festnetz; 0800-Nummern funktionieren einwandfrei und ich kann auch über meine Sipgate-Nummer aus dem Festnetz angerufen werden und der Testanruf auf der Sipgate-Nr. 10000 geht auch ohne Schwierigkeiten.
    Kostenpflichtige Anrufe bei Web.de funktionieren problemlos.
    Entferne ich den Eintrag für den Outbound-Proxy bei Line1 (das ist der Sipgate-Account), kann ich kostenpflichtige Anrufe machen. Die Audio-Qualität ist dann aber nach ca. 1 Sekunde unter aller Sau, es rattert fürchterlich, absolut unbrauchbar.
    Das Ganze hört sich natürlich nach einem NAT/Port-Forwarding-Problem an, nur frage ich mich dann, warum es
    a) bei kostenlosen Gesprächen über Sipgate gut funktioniert (mit Outbound-Proxy)
    b) bei Web.de sowieso ohne Probleme geht
    Also, ich bin einigermaßen ratlos.
    Hat jemand einen Hinweis für mich?

    Gruß
    Walter
     
  2. TinTin

    TinTin Aktives Mitglied

    Registriert seit:
    6 Mai 2004
    Beiträge:
    1,864
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hi,

    habe zwar im Moment sipgate nicht als Provider in meinem Sipura, aber wenn ich mich recht erinnere gehörte in "outbound proxy" entweder sipgate.de oder proxy.de.sipgate.net.

    Andere wichtige Parameter unter Line1 (oder PSTN Line):

    Nat Mapping Enable: Yes
    Nat Keep Alive Enable: Yes

    unter SIP Karteireiter:

    Alle NAT Support Parameters auf Yes, bis auf die beiden STUN Einträge, die auf No.

    Dann darauf achten, dass die beiden SIP Ports (default UDP 5060 und 5061) sowie UDP 16384 bis 16482 per portforwarding vom Router auf die interne Netzwerk-IP des Sipura weitergeleitet werden.

    Gruß,
    Tin
     
  3. t47

    t47 Neuer User

    Registriert seit:
    31 Mai 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für die Anwort, Tin, aber sie trifft leider nicht die Problematik.
    Wenn ich Sipath oder Siproxd benutze, dann sind das ja gerade *lokale* SIP-Proxies, die unter anderem den Zweck haben, das ganze NAT-Geraffel in den Einstellungen des UA zu vermeiden.
    Die Verbindung mit Sipgate klappt übrigens - bei eingetragenem Sipgate-Proxy - ganz ohne NAT-Mapping oder VIA-Einträge; das liegt womöglich daran, daß der Linksys-Router symmetrisches NAT macht. Es reicht also einfaches Port-Forwarding.
    Nichtsdestotrotz frage ich mich weiter, worin der technische Unterschied bei Sipgate zwischen kostenlosen und kostenpflichtigen Verbindungen besteht, weil ich natürlich lieber mit einem lokalen Proxy arbeiten würde, auch wegen der größeren Flexibilität (z.B. routen von lokalen VOIP-VOIP-Verbindungen usw.)

    Viele Grüße
    Walter
     
  4. CaptainCrunch

    CaptainCrunch Neuer User

    Registriert seit:
    8 Apr. 2005
    Beiträge:
    169
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hast du STUN deaktiviert, wenn du den lokalen Proxy nutzt?
     
  5. t47

    t47 Neuer User

    Registriert seit:
    31 Mai 2005
    Beiträge:
    15
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  6. zoo

    zoo Aktives Mitglied

    Registriert seit:
    9 Juni 2005
    Beiträge:
    869
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    hallo t47,

    bei mir läuft siproxd problemlos mit meinem SPA-1001.

    In /etc/init.d/S45firewall habe ich die Ports aufgemacht:
    iptables -t nat -A prerouting_rule -i $WAN -p udp --dport 7070:7079 -j ACCEPT
    iptables -A input_rule -i $WAN -p udp --dport 7070:7079 -j ACCEPT

    Diese Ports verwendet der siproxd.

    Und dann im Sipura einstellen:
    Use Outbound Proxy: Yes
    Outbound Proxy: Router-IP

    das sollte reichen und funktionieren.


    Wenn du magst, maile mir ruhig mal deine Config und wir vergleichen mal.



    zoo
     
Status des Themas:
Es sind keine weiteren Antworten möglich.