.titleBar { margin-bottom: 5px!important; }

SPA läuft jetzt, aber 90% Packets lost

Dieses Thema im Forum "Linksys (VoIP)" wurde erstellt von Boergi, 13 Okt. 2005.

Status des Themas:
Es sind keine weiteren Antworten möglich.
  1. Boergi

    Boergi Neuer User

    Registriert seit:
    6 Mai 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So, ich habe sie inzwischen doch zum Laufen gebracht (wenn man das so nennen kann).


    Noch schnell ne Übersicht dann zu meiner Frage...


    Ich habe in Deutschland ein Sipura SPA-841 Telefon an einem T-Sinus 154 Basic W-LAN DSL Router hängen, verbunden mit Sipgate. (DSL Provider Congster). Der Dialplan ist so konfiguriert dass automatisch wenn man den Hörer abhebt die Rufnummer meiner SPA-3000 gewählt wird, diese

    steht in Tschechien an einem Netgear DG632B, ist auch bei sipgate eingeloggt, der DSL Provider ist die tschechische Telekom, so, heb ich nun in Deutschland ab hör ich nur ab und zu ein paar Brocken Rauschen oder nach 20 sekunden wenn ich ein paar tasten drücke komisches Piepsen, die Info Seite des SPA-3000 zeigt viele verlorene Pakete an, weiss nicht ob das normal ist:

    Hook State: On Line Voltage: 22 (V)
    Loop Current: 0.0 (mA) Registration State: Registered
    Last Registration At: 1/3/2003 11:15:40 Next Registration In: 200 s
    Last Called VoIP Number: Last Called PSTN Number:
    Last VoIP Caller: Last PSTN Caller: ,
    Last PSTN Disconnect Reason: VoIP Call Ended PSTN Activity Timer: 30000 (ms)
    Mapped SIP Port: Call Type:
    VoIP State: Connected PSTN State: Idle
    VoIP Tone: Outside Dial PSTN Tone:
    VoIP Peer Name: Anna Buettner PSTN Peer Name:
    VoIP Peer Number: 6262193 PSTN Peer Number:
    VoIP Call Encoder: G726-16 VoIP Call Decoder: G726-16
    VoIP Call FAX: No VoIP Call Remote Hold: No
    VoIP Call Duration: 00:00:07 VoIP Call Packets Sent: 388
    VoIP Call Packets Recv: 199 VoIP Call Bytes Sent: 15520
    VoIP Call Bytes Recv: 7960 VoIP Call Decode Latency: 60 ms
    VoIP Call Jitter: 3 ms VoIP Call Round Trip Delay: 0 ms
    VoIP Call Packets Lost: 170 VoIP Call Packet Error: 0
    VoIP Call Mapped RTP Port: 17468 >> 0


    Von 199 empfangenen sind 170 verloren gegangen, denke das ist zuviel, hab den kleinsten Codec gewählt und beide Geräte hängen ja an einem DSL Anschluss an dem sonst nichts betrieben wird.

    Ein Ping Test von Tschechien nach Deutschland lieferte folgenden Wert:

    Antwort von 84.181.130.174: Bytes=32 Zeit=131ms TTL=53
    Antwort von 84.181.130.174: Bytes=32 Zeit=123ms TTL=53
    Antwort von 84.181.130.174: Bytes=32 Zeit=111ms TTL=53
    Antwort von 84.181.130.174: Bytes=32 Zeit=108ms TTL=53

    Die Verbindung läuft über 13 Hops, sind das schon zuviele?
    Ich hatte ein ähnliches Problem schonmal, da hab ich dann irgendwas in den EInstellungen edr SPA-3000 geändert und schon war's weg
     
  2. Robinson

    Robinson Aktives Mitglied

    Registriert seit:
    24 März 2004
    Beiträge:
    1,751
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Wismar
    Setze mal den Jitter (LineX->Network Jitter Level) hoch, meinetwegen erstmal "extremely high". Zum Testen solltest Du dann auch Jitter Buffer Adjustment: auf disabled stellen.

    Die Rechnung mit den Paketen geht übrigens anders: der SPA3000 hat selbst 388 gesendet, 199 rechtzeitig und 170 zu spät empfangen. Damit hat das SPA841 insgesamt 369 Pakete geschickt. Mit erhöhung des Jitter-Buffers wird länger gewartet, bis die Daten in Sprachsignale umgesetzt werden. Somit kommen Pakete, die im Netz vielleicht länger brauchen (z.B. hier 170), doch noch rechtzeitig an. Allerdings erhöht sich auch die Latenzzeit, also die Zeit die vergeht zwischen Deinem Sprechen und dem Hören des Angerufenen.

    PS.: Der kleinste Codec ist übrigens G723.
     
  3. Boergi

    Boergi Neuer User

    Registriert seit:
    6 Mai 2005
    Beiträge:
    24
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Es läuft jetzt, habe den Router nochmal gewechselt, war wohl ein Port Problem, hab nun fast perfekte Sprachqualität, nur 2 Sachen, ich hab ein kleines Rauschen in der Leitung und am VoIP Telefon hört man sich ganz leise doppelt, kann man das irgendwie wegbekommen?

    danke
     
  4. Robinson

    Robinson Aktives Mitglied

    Registriert seit:
    24 März 2004
    Beiträge:
    1,751
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Wismar
    Oder so :)

    - "kleines Rauschen": ist Comfort noise und gewollt, um das Gefühl einer "stehenden Leitung" zu vermitteln. Zu dem Thema gibt es schon einige Threads im Forum.
    - "ganz leise doppelt": ist zwar nicht gewollt, aber gerade auf langen Strecken nicht unbedingt unnormal. Wenn Du Glück hast, stellen sich die automatischen Filter (echo cancelation) in den nächsten Gesprächen noch besser ein. Eine andere Möglichkeit besteht in der Anbindung SPA3000-Telefon/Anlage - einfach mal mit den Einstellungen Regional -> Miscellaneous (ganz unten) -> FXS Port Impedance spielen.
     
  5. Carli

    Carli Mitglied

    Registriert seit:
    19 Mai 2005
    Beiträge:
    454
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    @boergi

    Die Übertragungszeiten sind grundsätzlich länger als beim echten Festnetz, weshalb ein Echo eigentlich da sein muss. Es wird nur von den Geräten so gut wie möglich herausgefiltert.
    Ein trivialer Anhaltspunkt: Wenn Du Dich doppelt hörst ist meistens auch das Telefon Deines Gesprächspartners zu laut eingestellt, weshalb die Schallwellen durch den Hörer ins Mikro und zu Dir zurück kommen. Wenn Dein Gesprächspartner sich doppelt hört ist meist Dein Telefon zu laut oder Dein Mikro zu empfindlich eingestellt.
    Da hilft nur probieren und ganz wirst Du es nur schwer wegbekommen.

    Gruß
    C
     
Status des Themas:
Es sind keine weiteren Antworten möglich.