.titleBar { margin-bottom: 5px!important; }

SpanDSP kompilieren schlägt fehl tiffiop.h // Debian 3.1

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von chefkoch-2002, 3 Aug. 2005.

  1. chefkoch-2002

    chefkoch-2002 Neuer User

    Registriert seit:
    13 Juli 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo Leute,

    nach dem nun endlich mein Asterisk vernünftig läuft, habe ich ein erneutes Problem. Ich komme gerade auf die Idee Faxe empfangen zu wollen ;-)

    Ich habemit das Paket SpanDSP von einem alternativen Mirror gezogen, da opencall.org down ist. Die Bezeichnung des Paketes spandsp-0.0.1k.tar.gz.

    Nach dem configure will ich ein make ausführen und das schlägt fehl, da er die Datei tiffiop.h nicht finden kann. Ich habe mit aptitude install libtiff-dev die Version 3.7.5 installiert glaube ich. Die Datei scheint aber nicht enthalten zu sein.

    Ich habe im Internet schon mal gesucht und konnte keine Lösung finden. Deshalb ergeben sich zwei Fragen:

    1. Ist das das aktuelle Paket von SpanDSP
    2. Wie löse ich das Problem beim ausführen des make

    Vielen Dank im Voraus

    Chefkoch
     
  2. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    1.Nein ist es nicht!
    2. Nimm eine Aktuelle Version!
    (Siehe Link in Signatur)
     
  3. chefkoch-2002

    chefkoch-2002 Neuer User

    Registriert seit:
    13 Juli 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Danke für die schnelle Antwort. Das habe ich mir schon gedacht. Die Seite ist nicht erreichbar und Dein Link funktioniert auch nicht, dass ist der Grund warum ich poste.

    Wäre klasse, wenn Du mir das tar per mail schicken könntest. eine PN Habe ich Dir bereits geschickt.

    Danke

    der Chefkoch
     
  4. Hupe

    Hupe Aktives Mitglied

    Registriert seit:
    8 Apr. 2004
    Beiträge:
    2,586
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Nichts gegen Dich, aber ich verschicke grundsätzlich nichts per email an Leute, die ich nicht (richtig) kenne!
    Aber ich könnte das File hier reinsetzen!
    Spandsp 0.0.2pre18 mit passender app_txfax.c und app_rxfax.c habe ich auchnoch gefunden. Allerdings nichtmehr das original-Patchfile. Ich habe nur mein gepatchtes Makefile, welches wohl eher nicht zu deinem Asterisk 1.0.9 samt Bristuff passt, da ich ja die Head-Version nutze.
     
  5. chefkoch-2002

    chefkoch-2002 Neuer User

    Registriert seit:
    13 Juli 2005
    Beiträge:
    22
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich habe es jetzt geschafft. Eigentlich schon länger, aber ich wollte diesen Post abschließen. Außerdem schickt er mir die Faxe jetzt als PDF an eine Mail Adresse :D
     
  6. astrakid

    astrakid Neuer User

    Registriert seit:
    24 Apr. 2011
    Beiträge:
    86
    Zustimmungen:
    0
    Punkte für Erfolge:
    6
    hi,
    ich stehe vor einem ähnlichen problem. ich will ebenfalls faxe empfangen können. da mir dazu die spandsp-komponenten fehlen, versuche ich seit tagen, die entsprechenden dateien zu crosscompilen.
    hab mir in einer VM ein ubuntu 10.04 aufgesetzt und mir als erstes die folgenden sourcen heruntergeladen:
    - tomatousb (betriebssystem auf meinem soho-router, wo asterisk bisher läuft)
    - spandsp 0.0.6pre18
    - asterisk

    so weit so gut. nun weiß ich nicht so ganz genau, wie ich spandsp und asterisk miteinander verbinde... asterisk zu kompilieren schlägt jedenfalls beim "make" fehl, mit folgender meldung:

    /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libc.a(libc-lowlevellock.o):(.text+0x30): first defined here
    collect2: ld returned 1 exit status
    make[1]: *** [asterisk] Fehler 1
    make: *** [main] Fehler 2

    leider weiß ich gar niocht, wo ich nun suchen soll. hat einer einen heißen tipp?

    gruß,
    astrakid