.titleBar { margin-bottom: 5px!important; }

txfax() Funktion bei spandsp --> wie ??

Dieses Thema im Forum "Asterisk Allgemein" wurde erstellt von atn.voip, 7 Jan. 2006.

  1. atn.voip

    atn.voip Neuer User

    Registriert seit:
    12 Okt. 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Grüß Gott!
    Ich habe mich nun durch (glaube ich) durch Tausende Seiten und auch durch dieses Forum geschlagen.
    Aber ich hab immer noch ein Verständnis-Problem.

    Wie schicke ich ein Fax mit txfax() an eine bestimmte Nummer?
    (rxfax is ja soviel leichter zu verstehen)

    Würde mich über Erklärungen, Beispiele, etc. sehr freuen.
     
  2. chaos2000

    chaos2000 Aktives Mitglied

    Registriert seit:
    22 Aug. 2004
    Beiträge:
    2,028
    Zustimmungen:
    0
    Punkte für Erfolge:
    36
    Ort:
    LE
    Hallo atn.voip,

    das ist eigendlich gar nicht so komplizert ;)
    Als erstes solltest du die eine tiff-File deines Faxes erzeugen.

    Bsp:
    Code:
    /usr/bin/gs -q -sDEVICE=tiffg3 -sPAPERSIZE=a4 -r204x196 -dNOPAUSE -sOutputFile=/var/spool/asterisk/outgoing/fax.tif — /location/of/fax/document/fax.pdf' 
    
    Dannach erstellst du ein call-File mit folgendem Inhalt:
    Code:
    
    Channel: Zap/g1/NUMMER
    SetVar: LOCALHEADERINFO=Companyname
    SetVar: LOCALSTATIONID=FAXNUMMER
    
    
    Application: txfax
    Data: /var/spool/asterisk/outgoing/fax.tif
    
    und kopierst es dann nach /var/spool/asterisk/outgoing/


    QUELLE: http://lists.digium.com/pipermail/asterisk-users/2003-October/025094.html
     
  3. Hias-online

    Hias-online Neuer User

    Registriert seit:
    16 Nov. 2005
    Beiträge:
    124
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    hi,

    habe callfile wie oben erstellt:
    Cli sagt folgendes
    Code:
    *CLI>     -- Attempting call on Zap/1/140094 for application txfax(/mnt/x.tif) (Retry 1)
        -- Requested transfer capability: 0x00 - SPEECH
        -- Channel 0/1, span 1 got hangup, cause 42
    Jan  7 20:15:47 WARNING[2286]: cdr.c:548 ast_cdr_disposition: Cause not handled
        -- Hungup 'Zap/1-1'
    Jan  7 20:15:47 NOTICE[2286]: pbx_spool.c:270 attempt_thread: Call failed to go through, reason 8
    
    
     
  4. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
  5. atn.voip

    atn.voip Neuer User

    Registriert seit:
    12 Okt. 2005
    Beiträge:
    20
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    So ich habe mich seit einiger Zeit nicht gemeldet, da ich keine Zeit für * hatte.

    Habe nun die geposteten Anweisungen befolgt.
    Ich habe nun ein kleines Problem mit email2fax:

    Habe nun getestet mit dem Befehl:
    cat mail.eml | sudo –u asteriskuser email2fax –-debug

    aber es wirft einen Fehler bei:
    FAXNUMBERS=`echo $NEWNUM | sed -e "s/ /, /g"`

    Es wirft einen Fehler bei "s".

    Was könnte man da machen?

    PS.: Ich verwende die Linux-Distribution Debian
    und Asterisk 1.0.10
     
  6. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    mir welchem Programm hast Du die eml datei erstellt?

    Was sagt das Logfile /var/log/asterisk/faxlog ?

    Gruß Sven
     
  7. JoergStueger

    JoergStueger Neuer User

    Registriert seit:
    25 Jan. 2006
    Beiträge:
    73
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen!

    Ich hab ein ähnliches Problem ...

    Mail erstellt mit Thunderbird/windows
    cat 027.eml | email2fax --debug

    gibt mir ein
    0
    No recipient addresses found in header

    zurück ....

    Hm .... in Subject würde ne passende Nummer stehen.

    Vielleicht weiß ja jemand Rat ....

    LG
    Joerg
     
  8. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    eml Datei öffnen und mit Unix Zeilenumbruchsformat abspeichern.


    Gruß Sven
     
  9. JoergStueger

    JoergStueger Neuer User

    Registriert seit:
    25 Jan. 2006
    Beiträge:
    73
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo!

    Ich habs mit nano geöffnet und wieder gespeichert .... reicht das nicht?

    LG
    Joerg
     
  10. konabi

    konabi Mitglied

    Registriert seit:
    11 Apr. 2005
    Beiträge:
    424
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ich kann Dir mal eine eml Datei mit pdf Anhang senden mit der es geht.
    So daß wir dieses Problem ausschließen können.
    Wenn Du willst, gib einfach mal deine Email Adresse durch.

    Gruß Sven