Typhoon (TAS106H-C) - Asuscom/Askey 675

Klingelding

Neuer User
Mitglied seit
6 Sep 2004
Beiträge
45
Punkte für Reaktionen
0
Punkte
6
Hallo Forum,

meine HFC-Karte, eine Typhoon ISDN QUick Com 128 PCI (TAS106H-C) gibt sich in den Logs als eine Asuscom/Askey 675 Karte aus.
Im Forum habe ich schon gelesen, dass man was in der Datei zaphfc.c aendern muss. Leider finde ich den Beitrag nicht, was genau man aendern muss.
An einer anderen Stelle steht, dass es bei den neuen Versionen von bri-stuff nicht mehr notwendig ist. Danach sieht es bei mir aber wohl nicht aus. :(

Verwende Fedora Core 1 mit bri-stuff Version RC4a

/var/log/messages meldet:
Code:
kernel: Zapata Telephony Interface Registered on major 196
kernel: PCI: Enabling device 00:12.0 (0000 -> 0003)
testpc kernel: PCI: Found IRQ 5 for device 00:12.0
testpc kernel: zaphfc: Asuscom/Askey 675 configured at mem 0xd08db000 fifo 0xc3828000(0x3828000) IRQ 5
 HZ 100
kernel: zaphfc: Card 0 configured for NT mode
testpc kernel: zaphfc: 1 hfc-pci card(s) in this box.
testpc kernel: Registered tone zone 3 (Netherlands)
testpc kernel: Registered tone zone 3 (Netherlands)

bei lspci sieht es so aus:
Code:
00:12.0 Network controller: Asustek Computer, Inc. ISDNLink P-IN100-ST-D (rev 02)
 
Hast du damit irgendwelche Probleme?
Oder warum willst du es ändern?

Ich hab (vermutlich) die gleiche Karte und nutze Fedora Core 2...
 
Seit der zaphfc-Version in bri-stuff 0.1.0-RCx (also auch bei Dir) ist keine Modifikation mehr an zaphfc.c noetig. Die Karten werden jetzt automatisch erkannt. Vorher musste man dem Treiber die richtige PCI-Kennung auf den Weg geben, damit er die Karte erkannt hat.

Die Bezeichnung, mit der der Treiber die Karte erkennt ist vollkommen schnurz (ein rein kosmetisches Problem). Wichtig ist nur, DASS er eine erkennt - dann spricht er die Karte auch richtig an, es erfolgt keine modellspezifische Unterscheidung. Von daher: Entwarnung. :)
 
schakal2k schrieb:
Hast du damit irgendwelche Probleme?
Mein Problem ist, dass das daran angeschlossene ISDN-Telefon nicht funktioniert.
Asterisk meldet immer Teilnehmer nicht verfuegbar (oder aehnlich)
Wenn es funktionieren wuerde, duerfte sich die Karte auch gerne als Asuscom ausgeben.

Da ich einen Verkabelungsfehler eigentlich ausschiesse (Mit Durchgangspruefer uerberprueft). Und ich in den Logs auch nichts anstoessiges bis auf eben den Kartennamen stosse, halte ich dies fuer den Fehler.

Unter FC2 wird die Karte auch als Asuscom erkannt. Nur da lief es mit dem kompilieren des 2.6 Kernels b.z.w. mit dem Laden der Module nicht so richtig gut (Invalid Module Format).
 
Klingelding schrieb:
schakal2k schrieb:
Hast du damit irgendwelche Probleme?
Mein Problem ist, dass das daran angeschlossene ISDN-Telefon nicht funktioniert.
Asterisk meldet immer Teilnehmer nicht verfuegbar (oder aehnlich)
Wenn es funktionieren wuerde, duerfte sich die Karte auch gerne als Asuscom ausgeben.

Da ich einen Verkabelungsfehler eigentlich ausschiesse (Mit Durchgangspruefer uerberprueft). Und ich in den Logs auch nichts anstoessiges bis auf eben den Kartennamen stosse, halte ich dies fuer den Fehler.

Unter FC2 wird die Karte auch als Asuscom erkannt. Nur da lief es mit dem kompilieren des 2.6 Kernels b.z.w. mit dem Laden der Module nicht so richtig gut (Invalid Module Format).

Das mit dem Invalid Module Format hatte ich auch.

Was passiert denn, wenn du den Hörer abnimmst?
Ggf. mal mit "asterisk -vvvvvgc" starten und dann "bri debug span 1"

Dann sollte da eine Meldung stehen.

Des weiteren bitte mal deine "/var/log/messages" nach "hisax" durchsuchen. Wenn das noch läuft, dann gibts Probleme.

Mir hat auch folgender Beitrag geholfen:
http://www.ip-phone-forum.de/forum/viewtopic.php?t=2620

Wenn du noch weitere Probleme hast, helfe ich dir gern.
 
Danke fuer eure Hilfe. Es funktioniet jetzt. :D
Nun kann es an die weiteren einstellungen etc. gehen.

Die Bezeichnung, mit der der Treiber die Karte erkennt ist vollkommen schnurz (ein rein kosmetisches Problem). Wichtig ist nur, DASS er eine erkennt - dann spricht er die Karte auch richtig an, es erfolgt keine modellspezifische Unterscheidung. Von daher: Entwarnung.

Da ist mein Gewissen ja jetzt beruhigt.

Des weiteren bitte mal deine "/var/log/messages" nach "hisax" durchsuchen. Wenn das noch läuft, dann gibts Probleme.
Von hisax habe ich noch Meldungen gefunden. Die jeweils letzte Meldung war immer, dass hisax entladen wird. Habe aber nun trotzdem hisax ganz entfernt.

Danke fuer den Link. Auf die Beitraege bin ich vorher noch gar nicht aufmerksam geworden. Dachte eigentlich, dass ich das ganze Forum durchsucht ung durchblaettert haette.

Letztendlich lag es wohl doch "nur" an einem defekten Kabel. Hatte anscheinend nicht von Ende zu Ende, sondern nur den Teil, wo die Kabel am NTBA angeklemmt werden bis zum Ende gemessen.
Man kann wohl nie die Kabel oft genug kontrollieren.... So hab ich "ein wenig" kompilieren geuebt ;)

Danke nochmal! Das ganze ist schon ne tolle Sache!
 
Sag mal, wie hast du die Hisax-Treiber ganz entfernt?

Bei mir werden sie im moment nur entladen...
 
Sag mal, wie hast du die Hisax-Treiber ganz entfernt?

Vielleicht nicht die einfachste Loesung aber zumindest eine die Funktioniert.

Karte ausgebaut, kudzu die nicht mehr vorhandene Hardware entfernen lassen, kudzu beim booten nicht mehr automatisch starten lassen (chkconfig kudzu off), alternativ beim naechsten starten mit eingebauter Karte kudzu die Karte einfach nicht mehr einrichten lassen.
 
Klingelding schrieb:
...

Karte ausgebaut, kudzu die nicht mehr vorhandene Hardware entfernen lassen, kudzu beim booten nicht mehr automatisch starten lassen (chkconfig kudzu off), alternativ beim naechsten starten mit eingebauter Karte kudzu die Karte einfach nicht mehr einrichten lassen.

Ich hatte die Karte mal umgesteckt und beim nächsten Start von kudzu hab ich kudzu die Karte auch nicht einrichten lassen. Aber trotzdem läd und entläd er die Treiber...

Naja, solangs funktioniert...
 

Statistik des Forums

Themen
245,186
Beiträge
2,225,933
Mitglieder
372,046
Neuestes Mitglied
LiniXXus
Holen Sie sich 3CX - völlig kostenlos!
Verbinden Sie Ihr Team und Ihre Kunden Telefonie Livechat Videokonferenzen

Gehostet oder selbst-verwaltet. Für bis zu 10 Nutzer dauerhaft kostenlos. Keine Kreditkartendetails erforderlich. Ohne Risiko testen.

3CX
Für diese E-Mail-Adresse besteht bereits ein 3CX-Konto. Sie werden zum Kundenportal weitergeleitet, wo Sie sich anmelden oder Ihr Passwort zurücksetzen können, falls Sie dieses vergessen haben.