.titleBar { margin-bottom: 5px!important; }

Unable to create channel of type 'Zap' Fehler.

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von Alarith, 22 Sep. 2005.

  1. Alarith

    Alarith Neuer User

    Registriert seit:
    22 Sep. 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo zusammen,

    ich mache gerade meine ersten Schritte mit * (also totaler newbie).

    Ich habe sie jetzt soweit, dass ich intern mit meinen Sip Telefonen telefonieren kann.

    Jetzt möchte ich gerne nach aussen telefonieren, und zwar via ISDN.

    In der * stecken 2 HFC Karten. Eine (die erste) hängt an einem NTBA.

    Wenn ich jetzt versuche rauszuwählen, kommt folgenden Fehlermeldung im Log:

    Unable to create channel of type 'Zap'

    Ich könnte hier Hilfe gebrauchen ich komme einfach nicht weiter.

    Hier mal die Configs die ich benutze, bitte sagen wenn man noch mehr braucht:

    zaptel.conf

    defaultzone=nl
    loadzone = nl
    # von Christian
    span=1,1,3,ccs,ami
    bchan=1-2
    dchan=3
    span=2,1,3,ccs,ami
    bchan=4-5
    dchan=6

    zapata.conf

    [channels]
    ;-----------------------------------------------------------------------------
    ;TE-Karte fuer Anschluss an NTBA/ISDN-Telefonnetz
    ;-----------------------------------------------------------------------------
    switchtype = euroisdn
    signalling = bri_cpe_ptmp
    pridialplan = local
    prilocaldialplan = local
    echocancel = yes
    echocancelwhenbridged=no
    echotraining=no
    usecallerid = yes
    overlapdial = no
    immediate = no
    group = 1
    context = pstn
    ;usecallingpres=yes
    ;nationalprefix = 0
    ;internationalprefix = 00
    channel => 1-2


    extensions.conf (nur ein Teil)

    [pstn]
    exten => _0.,1,Dial(Zap/g1/${EXTEN:1},60)
    exten => _0.,2,Congestion
    exten => _0.,3,Busy
    exten => _0.,4,Hangup
    exten => _X.,1,Dial(SIP/christian,60,tr)
    exten => _X.,2,Hangup

    ztcfg -vv

    Zaptel Configuration
    ======================

    SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)
    SPAN 2: CCS/ AMI Build-out: 399-533 feet (DSX-1)

    Channel map:

    Channel 01: Individual Clear channel (Default) (Slaves: 01)
    Channel 02: Individual Clear channel (Default) (Slaves: 02)
    Channel 03: D-channel (Default) (Slaves: 03)
    Channel 04: Individual Clear channel (Default) (Slaves: 04)
    Channel 05: Individual Clear channel (Default) (Slaves: 05)
    Channel 06: D-channel (Default) (Slaves: 06)

    6 channels configured.

    zap show channels
    Chan Extension Context Language MusicOnHold
    pseudo pstn
    1 pstn
    2 pstn


    Hat jemand eine Idee, was ich falsch mache ?

    Danke

    Ala
     
  2. kombjuder

    kombjuder IPPF-Promi

    Registriert seit:
    2 Nov. 2004
    Beiträge:
    3,086
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Ort:
    Weil am Rhein
    Was richtig falsches sehe ich nicht.
    Was mir auffiel:
    In der zapata.conf ist nur eine Karte definiert.

    Das macht evtl. auch nicht was du willst:
    Alles was mit Null beginnt über Zap raus und die führende Null wird abgeschnitten. Du wählst also eine Null für's Amt vor.


    Mein Vorschlag:
    Steck mal deine ISDN-Netzleitung in die andere Karte. Was 1ist und was 2 ist öffter vollkommen unklar.
     
  3. Alarith

    Alarith Neuer User

    Registriert seit:
    22 Sep. 2005
    Beiträge:
    9
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Hallo nochmal,

    also ich habe versucht das Kabel in die anderen Dose zu stecken, hat nichts gebracht. Dann habe ich etwas an den Config gespielt und die Krise bekommen, da die Fehlermeldung weg ging, wenn ich versucht habe
    auf einer Karte im NT Modus (laut zapata.conf) zu wählen (bri_net_ptmp).
    Karte hängt allerdings direkt an einem NTBA, also bringt mir das nix.
    Ein Kollege hat dann einen Hinweis gefunden, dass man die ztcfg nur einmal ausführen darf, nachdem die Module geladen werden. Jetzt ist
    die Fehlermeldung endlich weg. Und ich kann von aussen meine Sip Telefone anrufen. Nur wenn ich jetzt von innen versuche rauszuwählen,
    kommt:

    Executing Dial("SIP/christian-eeaf", "Zap/g1/XXXXXXX/|60") in new stack
    Urgent handler
    Urgent handler
    Urgent handler
    -- Requested transfer capability: 0x00 - SPEECH
    Urgent handler
    -- Called g1/XXXXXXXX/
    Urgent handler
    -- Channel 0/1, span 1 got hangup
    Urgent handler
    Sep 23 18:29:12 WARNING[4804]: app_dial.c:426 wait_for_answer: Unable to forward voice
    -- Hungup 'Zap/1-1'
    == No one is available to answer at this time
    -- Executing Congestion("SIP/christian-eeaf", "") in new stack
    Urgent handler
    Urgent handler
    Urgent handler


    Hat jemand eine Idee was jetzt falsch läuft, bin ja ganz nahe dran :)

    Cya

    Ala