undefined Symbols beim übersetzen

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
Hallo!

Seit geraumer Zeit versuche ist Asterisk zum laufen zu bringen und stolpere über eine Falle nach derselben. Nun bin ich soweit, dass ich nicht weiter weiß:

Beim übersetzen von bristuff-0.3.0-PRE-1d/zaphfc Gibt es leider folgende Ausgaben:

[email protected]:/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc# make
make -C /usr/src/linux-2.6 SUBDIRS=/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc ZAP=-I/home/arthur/bristuff-0.3.0-PRE-1d/zaptel-1.2.1 modules
make[1]: Gehe in Verzeichnis »/usr/src/linux-source-2.6.12«
Building modules, stage 2.
MODPOST
*** Warning: "zt_register" [/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc/zaphfc.ko] undefined!
*** Warning: "zt_transmit" [/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc/zaphfc.ko] undefined!
*** Warning: "zt_receive" [/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc/zaphfc.ko] undefined!
*** Warning: "zt_ec_chunk" [/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc/zaphfc.ko] undefined!
*** Warning: "zt_unregister" [/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc/zaphfc.ko] undefined!
make[1]: Verlasse Verzeichnis »/usr/src/linux-source-2.6.12«


Nach anfänglichem, gekonntem ignorieren bin ich nun soweit das ganze doch etwas ernster zu nehmen. Schlieslich für das wohl zu folgendem Problem:
[email protected]:/home/arthur/bristuff-0.3.0-PRE-1d/zaphfc# modprobe zaphfc modes=1
WARNING: Error inserting zaptel (/lib/modules/2.6.12-9-386/misc/zaptel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting zaphfc (/lib/modules/2.6.12-9-386/extra/zaphfc.ko): Unknown symbol in module, or unknown parameter (see dmesg)


welches dann mit dmesg aufgeschlüsselt die Warnungen von vorher in einem anderen Licht erscheinen lässt:
[4296774.674000] zaptel: disagrees about version of symbol create_proc_entry
[4296774.674000] zaptel: Unknown symbol create_proc_entry
[4296774.675000] zaptel: disagrees about version of symbol proc_mkdir
[4296774.675000] zaptel: Unknown symbol proc_mkdir
[4296774.676000] zaptel: disagrees about version of symbol remove_proc_entry
[4296774.676000] zaptel: Unknown symbol remove_proc_entry
[4296774.681000] zaphfc: Unknown symbol zt_receive
[4296774.682000] zaphfc: Unknown symbol zt_ec_chunk
[4296774.682000] zaphfc: Unknown symbol zt_transmit
[4296774.683000] zaphfc: Unknown symbol zt_unregister
[4296774.684000] zaphfc: Unknown symbol zt_register


Anscheinend gibt es auch beim übersetzen anderer bristuff Teile kleinere Probleme ...
Aber das ist nun erstmal zweitrangig ... Was mache ich hier falsch?

Ich habe auch den Beitrag http://www.ip-phone-forum.de/showthread.php?p=395638#post395638 gelesen, gehe aber grundsätzlich nach der Anleitung unter http://www.pro-linux.de/work/asterisk/asterisk-1.html vor ...

Was mache ich denn falsch??? Wäre super wenn sich einer erbarmen könnte und mir einen kleinen Tip gibt.

thx Arthur Dent
 

VOIPdani

Mitglied
Mitglied seit
8 Aug 2005
Beiträge
432
Punkte für Reaktionen
0
Punkte
0
Hallo!

Die meiner Meinung nach beste Anleitung zum Thema "Wie installiere ich Asterisk richtig" findest du unter http://www.asterisk.li/asterisk120.htm

Versuch mal diese Anleitung Schritt für Schritt abzuarbeiten, dann müsste es eigentlich klappen!

lg Dani
 

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
Danke & Weitere Infos

Hallo VOIPdani!

vielen dank erstmal für diese Info. Ich hätte allerdings am liebsten eine Anleitung für Ubuntu mit 2.6er Kernel.

Hier sei vielleicht noch erwähnt, dass ich Ubuntu 5.10, eine HFC-S Karte sowie eine Fritz!Card USB installiert habe. Das System habe ich irgendwie gerade zerschossen und werde wohl mal wieder neu installieren dürfen ...

Danke schonmal für weitere Hilfe!

thx Arthur Dent
 

wrrdlbrrmpft

Mitglied
Mitglied seit
17 Jul 2004
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Arthur Dent schrieb:
Ich hätte allerdings am liebsten eine Anleitung für Ubuntu mit 2.6er Kernel.
Da du selber kompilierst, ist das Ubuntu-Label wohl ziemlich Wurscht. Ich kann mit den Warnungen auch nichts anfangen. Aber ein paar Ideen, wonach man gucken könnte:
- Benutzt du den selben Compiler, mit dem der Kernel übersetzt wurde? (dmesg gibt hier Auskunft)
- Bist du genau so vorgegangen, wie in INSTALL beschrieben?
- Sind die richtigen und konfigurierten Kernelquellen an der richtigen Stelle? (siehe INSTALL)

Wünsche viel Erfolg und ausreichend Geduld!
Benno
 

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
Frage

Hallo wrrdlbrrmpft,

vielleicht steh ich ja gerade auf der Leitung. Aber was meinst Du denn genau mit 'wie in INSTALL beschrieben' :noidea: ?
Welches INSTALL?

Danke uns schönen Abend!

Arthur Dent
 

wrrdlbrrmpft

Mitglied
Mitglied seit
17 Jul 2004
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Arthur Dent schrieb:
Ich meine die Datei bristuff-0.3.0-PRE-1d/INSTALL. Ich weiß jetzt nicht, in wie weit du mit Linux vertraut bist. Du kannst die Datei z. B. mit folgendem Befehl lesen:

less INSTALL

Der Befehl muss natürlich im Verzeichnis
bristuff-0.3.0-PRE-1d
eingegeben werden. Du kannst natürlich auch jeden anderen Pager oder ASCII-Editor verwenden.

Viele Grüße!
Benno
 

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
danke für die info

Hallo Benno,

vielen Dank für den Tip mit INSTALL. Ich muss gestehen, dass ich das noch gar nicht gesehen hatte.

Ein Unix Neuling bin ich auch tatsächlich. Habe aber einiges in den letzten Tagen dazu gelernt. Was so eine Asterisk Installation alles mit sich bringt ;-). Das Problem habe ich aber immernoch. Ich werde nun erstmal einige Dinge aussortieren und mich dann nochmal melden.

Bye, Arthur Dent
 

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
gcc downgraden

Hallo Benno,

ich habe nach einigem Neuinstallieren und imemr noch denselben Problemen mal versucht herauszufinden, mit welchem Compiler der Kernel übersetzt ist. Es handelt sich um die Version 3.4! Standardmäßig wird bei Ubuntu 5.10 allerdings die gcc Version 4.0 beigepackt. Nun hatte ich mir überlegt einfach
aptitude remove gcc-4.0
einzugeben und mittels
aptitude install gcc-3.4
die alte Version zu installieren. Irgendwie klappt das aber nicht so recht. Er sagt zwar danach es sei alles installiert, kennt aber das Kommando cc bzw. gcc nicht mehr... Was mache ich denn nun schon wieder falsch? Rufe ich explizit gcc-3.4 auf, so startet der Compiler. Allerdings ist das so nicht in den Makefiles hinterlegt... :confused:

Eine kleine Hilfe wäre nochmal super!

thx Arthur Dent
 

wrrdlbrrmpft

Mitglied
Mitglied seit
17 Jul 2004
Beiträge
263
Punkte für Reaktionen
0
Punkte
0
Arthur Dent schrieb:
Rufe ich explizit gcc-3.4 auf, so startet der Compiler. Allerdings ist das so nicht in den Makefiles hinterlegt... :confused:
Habe gerade keine bristuff-sourcen griffbereit. Deshalb weiß ich nicht, ob das hier geht. Evtl. hilft schon ein

export CC=gcc-3.4

vor dem Aufruf von install.sh.

Wenn nicht, bevor man lange sucht, kannst du das hier mal versuchen, auch wenn sich dem einen oder anderen jetzt die Zehennägel aufrollen:

mkdir /tmp/bin
ln -s /usr/bin/gcc-3.4 /tmp/bin/gcc
export PATH=/tmp/bin/:$PATH

Der erste Befehl legt das Verzeichnis bin unter /tmp an. Der zweite setzt einen symbolischen Link.
Das setzt voraus, dass gcc-3.4 unter /usr/bin liegt. Ansonsten musst du die Zeile anpassen.
Das dritte Kommando sorgt dafür, dass das Verzeichnis an erster Stelle in deiner PATH-Variablen auftaucht.
Dann mal versuchen, ob es sich so installieren lässt. Anschließend kann man mit einem

rm -rf /tmp/bin

die temporär angelegten Dateien wieder löschen.

Viel Erfolg!
Benno
 

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
nix geht

Hallo Benno,

auch wenn ich Dich schon wieder belästige ... Aber irgendwie klappt das auch nicht. Der Befehl gcc wird nun erkannt und der Befehl cc fehlt noch immer - natürlich, muß ja auch...

Hier die Fehlermeldung:
make: cc: Kommando nicht gefunden

Anscheinend nimmt das 'make' Kommando immer cc her?

Ich glaub, dass wird nix mehr in diesem Leben ...

Thx

Arthur dent
 

cibi

Mitglied
Mitglied seit
6 Apr 2005
Beiträge
561
Punkte für Reaktionen
0
Punkte
0
Ich benutze gcc 3.3.5 (Debian,s. Signatur).
Dort kommen auch die Warnungen, Probleme hatte ich aber bisher nicht.

Die vermissten Funktionen sind im Modul Zaptel, welche beim Kompilieren über Zaptel.h eingebunden werden, nur der Linker (?) beschwert sich anschließend.

Zaptel (/lib/modules/2.6.12-9-386/misc/zaptel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting zaphfc (/lib/modules/2.6.12-9-386/extra/zaphfc.ko)
[/QUTOE]

Hier wird einmal Versucht das Zaptelmodul aus dem misc Verzeichnis zu laden und das Zaphfcmodul aus extra, was etwas merkwürdig ist,da normalerwiese (s. Makefile) alles in /lib/modules/<version>/misc installiert wird, und manchmal eine andere/falsche zaptel.ko in ../extra vorhanden ist.

Lösche bzw. verschiebe mal die Module, und installier Zaptel nochmal neu und anschließend am Besten Zaphfc übersetzten und installieren.
 

Arthur Dent

Neuer User
Mitglied seit
3 Jan 2006
Beiträge
14
Punkte für Reaktionen
0
Punkte
0
scheint zu funktionieren

Hallo Ihr fleißigen Helfer!

Nach dem Tip von cibi funktioniert nun zumindest das
modprobe zaphfc modes=1
Kommando. Das ist schonmal ein riesen Erfolg ...
Nun habe ich mir allerdings zwischenzeitlich selber eine Falle gebaut. Da der bristuff Kram nicht funktionieren wollte bin ich zwischenzeitlich auf misdn umgestiegen. Es scheint ein mehr oder minder fataler Fehler zu sein. Wenn ich Asterisk nun starten möchte, kommt folgende Fehlermeldung:
[chan_misdn.so] => (Channel driver for mISDN Support (Bri/Pri))
Jan 5 14:30:58 ERROR[14991]: chan_misdn.c:3467 load_module: Unable to initialize mISDN
Jan 5 14:30:58 WARNING[14991]: loader.c:414 __load_resource: chan_misdn.so: load_module failed, returning -1
Jan 5 14:30:58 WARNING[14991]: loader.c:554 load_modules: Loading module chan_misdn.so failed!

Dazu sage ich nur: Die Geister die ich rief, werd ich nun nicht los ... :mad:

Hat dazu jemand eine tolle Idee? Ich habe auch schon unter /etc/asterisk in allen .conf Dateien nach misdn gesucht und nichts tolles gefunden. Wie bringe ich ihm denn nun bei, dass er den misdn welcher noch immer nicht funktioniert auch nicht mehr verwendet?

Vielen Dank schonmal im voraus und auch im nachhinein an all die fleißigen Helfer!

Wenn das irgendwann mal läuft werde ich eine Anleitung für Ubuntu 5.10 verfassen und allen zur Verfügung stellen. Wahrscheinlich ists dann sowieso bei jedem wieder anders. Eins sei aber schon jetzt gesagt: Das bei Ubuntu 5.10 trotz einem Kernel welcher mit gcc-3.4 kompiliert wurde, standardmäßig der gcc-4.0 installiert wird ist nicht der Weisheit letzter Schluß ...

bis denn

Arthur Dent
 

3CX PBX - GRATIS
Linux / Win / Cloud

Statistik des Forums

Themen
234,443
Beiträge
2,046,636
Mitglieder
354,203
Neuestes Mitglied
vogls2