.titleBar { margin-bottom: 5px!important; }

Unerwarteter Fehler und kein Ende

Dieses Thema im Forum "IP-TV" wurde erstellt von luggi, 6 Feb. 2007.

  1. luggi

    luggi Neuer User

    Registriert seit:
    12 Aug. 2004
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hallo,

    ich habe den SOTClient eigentlich seit den ersten Versionen laufen, aber seit einigen Versionen kommt jeweils beim Starten folgender Fehler, sodass ich auf die jeweils ältere Version zurückgreifen muss:

    SOTClient.exe
    MissingMethodException

    Datei- oder Assemblyname
    'OpenNETCF.Windows.Forms, Version (etc.pp.)' bzw. eine Abhängigkeit davon wurde nicht gefunden.

    Ich hab in mein Windows-Verzeichnis geschaut, und sowohl GAC_OpenNETCF.Windows.Forms_v2_0_0_0_cneutral_1.dll als auch GAC_System.Windows.Forms_v2_0_0_0_cneutral_1.dll sind da.

    Ich hab's sowohl von der Freigabe (SAMBA auf nem Debian-Rechner) als auch von einem USB-Stick probiert, und auch nochmal frisch aus dem aktuellen Download das gesamte Dateisystem entpackt. Auch die PKFClient.exe ist auf dem neuesten Stand - ich komm einfach nicht mehr weiter - hat hier jemand eine Idee?

    Vielen dank,


    Lukas
     
  2. Meatwad

    Meatwad Aktives Mitglied

    Registriert seit:
    1 Sep. 2006
    Beiträge:
    1,587
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    sicher, dass du alle dateien auf dem netzwerkpfad/usb-stick hast? kopier nochmal alle dateien aus dem verzeichnis "windows" rüber. (also von der zip in den netzwerkordner)
     
  3. luggi

    luggi Neuer User

    Registriert seit:
    12 Aug. 2004
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    *räusper*

    Entwarnung: Ich habe jetzt nochmal die PKFClient.exe (zum xten Mal) auf der Box überschrieben und eben geht's.

    Ein Problem ist jetzt allerdings wieder aufgetaucht: die SOT.ini wird scheinbar bei jedem Start mit der mitgelieferten "überschrieben", sodass ich momentan keine Änderungen in die SOT.ini schreiben kann...
     
  4. Hans Mayer

    Hans Mayer Mitglied

    Registriert seit:
    6 Jan. 2007
    Beiträge:
    256
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    > Ein Problem ist jetzt allerdings wieder aufgetaucht: die SOT.ini wird
    > scheinbar bei jedem Start mit der mitgelieferten "überschrieben", sodass ich
    > momentan keine Änderungen in die SOT.ini schreiben kann...

    dazu muss man mal wieder sagen rtfm.

    les nochmal die releasnotes durch, bzw da ist nach dem ersten starten des sot in der ini ein eintrag namens "styles=0", den muss man auf 1 setzen.

    mfg
    hans
     
  5. luggi

    luggi Neuer User

    Registriert seit:
    12 Aug. 2004
    Beiträge:
    12
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Asche über mein Haupt...

    Ich hatte mir die Release Notes gestern zwar noch angeguckt, aber offenbar mit BVK - Brett vor Kopf. Auf jeden Fall vielen Dank Euch beiden für die schnelle Hilfe (auch wenn das Problem offenbar vor dem Fernseher saß..)

    grüße,

    lukas