.titleBar { margin-bottom: 5px!important; }

Unknown signalling method 'bri_net' Fehler...

Dieses Thema im Forum "Asterisk ISDN mit Bristuff (hfc, zaptel)" wurde erstellt von ceicke, 11 Juli 2005.

  1. ceicke

    ceicke Neuer User

    Registriert seit:
    7 Juli 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Ingenieur
    Ort:
    Hamburg
    Hallo,

    nach einem Tag rumprobieren habe ich es geschafft den zapata treiber zu kompilieren :)
    Ich benutze eine Karte welche den NT Modus unterstützt, wenn ich /proc/zaptel/1 auslese dann sehe ich auch das sie korrekt initialisiert ist, soweit bin ich ganz happy.
    Nun habe folgendes in /etc/asterisk/zapata.conf eingetragen:

    Code:
    [channels]
    switchtype=euroisdn
    signalling=bri_net
    pridialplan=local
    echocancel=yes
    immediate=no
    overlapdial=yes
    group=1
    context=default
    channel=>1-2
    
    leider bekomme ich den folgenden Fehler wenn ich asterisk starte:

    Code:
    Jul 11 16:46:09 ERROR[28204]: chan_zap.c:10218 setup_zap: Unknown signalling method 'bri_net'
    Jul 11 16:46:09 ERROR[28204]: chan_zap.c:9847 setup_zap: Signalling must be specified before any channels are.
    
    Natürlich resultiert der zweite Fehler aus dem Ersten. Meine Fragen sind nun natürlich 1. wie kann ich das beheben/was mache ich falsch und 2. was ist denn eigentlich genau dieses signalling?

    Vielen Dank für eure Hilfe!
    Christoph
     
  2. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Das liest sich jetzt so als haettest du versucht, die offiziellen Asterisk- und Zapata-Sourcen zu verwenden. Du brauchst aber auf jeden Fall die bristuff-patches von junghanns.net
     
  3. ceicke

    ceicke Neuer User

    Registriert seit:
    7 Juli 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Ingenieur
    Ort:
    Hamburg
    Ja, das habe ich gemacht da die Sachen von junghanns.net nicht mit dem realtime mysql Konfigurationszeugs zusammengearbeitet haben...
    ok, dann werde ich mal wieder die Sachen von Junghanns nehmen.
     
  4. ceicke

    ceicke Neuer User

    Registriert seit:
    7 Juli 2005
    Beiträge:
    65
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    Beruf:
    IT-Ingenieur
    Ort:
    Hamburg
    tja, nun funktioniert die Geschichte von junghanns.net, aber leider kann ich jetzt das res_config_mysql nicht mehr kompilieren und ein schon kompiliertes Modul scheitert bei der Initialisierung kläglich und der ganze Laden stürzt mit der folgenden Fehlermeldung ab:

    Code:
    undefined symbol: ast_config_load
    
    habt ihr noch eine Idee? Ich bin auf die Konfiguration von MySQL angewiesen und komme nicht drumherum...

    Danke,
    Christoph
     
  5. Maik

    Maik Gesperrt

    Registriert seit:
    1 Apr. 2004
    Beiträge:
    1,778
    Zustimmungen:
    0
    Punkte für Erfolge:
    0
    res_config_mysql laeuft glaube ich nur mit der CVS-Version von Asterisk. Es gibt eine Bristuff-Version, die auf der CVS-Version aufbaut (0.2.0-RC8f-CVS). Kannst es ja mal damit probieren. Ansonsten wirst du wohl entweder auf MySQL verzichten muessen oder eine Karte kaufen muessen, die mit einem anderen channel-Treiber funktioniert.
     
  6. simpel

    simpel Neuer User

    Registriert seit:
    8 Sep. 2004
    Beiträge:
    104
    Zustimmungen:
    0
    Punkte für Erfolge:
    16
    Ort:
    Viersen Dülken
    Wenn die Karte im NT-Modus, d.h. man möchte gern ein ISDN-Telefon anschließen, muß es lauten:

    signalling = bri_net_ptmp

    wenn die Karte im TE-Modus (in Richtung ISDN-Netz) laufen soll, dann sollte dort:

    signalling = bri_cpe_ptmp stehen.

    ptmp steht für "Point to Multipoint).

    Gruß

    Simpel